]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- require gcc 5.0 (uses C++14)
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_without  glade   # Glade catalog
4 %bcond_with     gtk4    # GTK+ 4 based library [doesn't build with 3.90]
5
6 Summary:        VTE terminal widget library
7 Summary(pl.UTF-8):      Biblioteka z kontrolką terminala VTE
8 Name:           vte
9 Version:        0.54.2
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vte/0.54/%{name}-%{version}.tar.xz
14 # Source0-md5:  054a8a46b9de9078f81931311cf27a68
15 Patch0:         %{name}-wordsep.patch
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  gdk-pixbuf2-devel
20 BuildRequires:  gettext-devel
21 %{?with_glade:BuildRequires:    glade-devel >= 3}
22 BuildRequires:  glib2-devel >= 1:2.40.0
23 BuildRequires:  gnutls-devel >= 3.2.7
24 BuildRequires:  gobject-introspection-devel >= 0.10.0
25 BuildRequires:  gperf
26 BuildRequires:  gtk+3-devel >= 3.8.0
27 %{?with_gtk4:BuildRequires:     gtk+4-devel >= 3.89}
28 BuildRequires:  gtk-doc >= 1.13
29 BuildRequires:  gtk-doc-automake >= 1.13
30 BuildRequires:  intltool >= 0.40.0
31 BuildRequires:  libstdc++-devel >= 6:5.0
32 BuildRequires:  libtool >= 2:2.2
33 BuildRequires:  libxml2-progs >= 2
34 BuildRequires:  ncurses-devel
35 BuildRequires:  pango-devel >= 1:1.22.0
36 BuildRequires:  pcre2-8-devel >= 10.21
37 BuildRequires:  pkgconfig
38 BuildRequires:  rpmbuild(macros) >= 1.592
39 BuildRequires:  tar >= 1:1.22
40 # for test application
41 #BuildRequires: vala >= 2:0.24
42 BuildRequires:  xz
43 BuildRequires:  zlib-devel
44 Requires:       glib2 >= 1:2.40.0
45 Requires:       gnutls >= 3.2.7
46 Requires:       gtk+3 >= 3.8.0
47 Requires:       pango >= 1:1.22.0
48 Obsoletes:      vte-common < 0.42.0
49 # sr@Latn vs. sr@latin
50 Conflicts:      glibc-misc < 6:2.7
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 The vte package contains a terminal widget for GTK+ 3.x. It's used by
55 gnome-terminal among other programs.
56
57 %description -l pl.UTF-8
58 Ten pakiet zawiera kontrolkę terminala dla GTK+ 3.x. Jest używany
59 przez gnome-terminal oraz inne programy.
60
61 %package common
62 Summary:        Common files for vte and vte0
63 Summary(pl.UTF-8):      Pliki wspólne dla vte i vte0
64 Group:          X11/Libraries
65 Requires(pre):  utempter
66
67 %description common
68 Common files for GTK+ 3 based vte and GTK+ 2 based vte0.
69
70 %description common -l pl.UTF-8
71 Pliki wspólne dla vte opartego na GTK+ 3 oraz vte0 opartego na GTK+ 2.
72
73 %package devel
74 Summary:        Header files for VTE for GTK+ 3
75 Summary(pl.UTF-8):      Pliki nagłówkowe VTE dla GTK+ 3
76 Group:          X11/Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       glib2-devel >= 1:2.40.0
79 Requires:       gnutls-devel >= 3.2.7
80 Requires:       gtk+3-devel >= 3.8.0
81 Requires:       ncurses-devel
82 Requires:       pango-devel >= 1:1.22.0
83 Requires:       pcre2-8-devel >= 10.21
84 Requires:       zlib-devel
85 Conflicts:      gnome-libs-devel < 1.4.1.2
86
87 %description devel
88 This package contains header files for GTK+ 3 based vte library.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe potrzebne do kompilowania programów używających
92 biblioteki vte opartej na GTK+ 3.
93
94 %package static
95 Summary:        Static VTE library for GTK+ 3
96 Summary(pl.UTF-8):      Statyczna biblioteka VTE dla GTK+ 3
97 Group:          X11/Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99 Conflicts:      gnome-libs-static < 1.4.1.2
100
101 %description static
102 Static version of VTE library for GTK+ 3.
103
104 %description static -l pl.UTF-8
105 Statyczna wersja biblioteki VTE dla GTK+ 3.
106
107 %package glade
108 Summary:        VTE catalog file for Glade
109 Summary(pl.UTF-8):      Plik katalogu VTE dla Glade
110 Group:          X11/Development/Libraries
111 Requires:       %{name}-devel = %{version}-%{release}
112 Requires:       glade >= 3
113
114 %description glade
115 VTE catalog file for Glade.
116
117 %description glade -l pl.UTF-8
118 Plik katalogu VTE dla Glade.
119
120 %package -n vala-vte
121 Summary:        Vala API for VTE library
122 Summary(pl.UTF-8):      API języka Vala dla biblioteki VTE
123 Group:          Development/Libraries
124 Requires:       %{name}-devel = %{version}-%{release}
125 Requires:       vala >= 2:0.24
126 %if "%{_rpmversion}" >= "5"
127 BuildArch:      noarch
128 %endif
129
130 %description -n vala-vte
131 Vala API for VTE library.
132
133 %description -n vala-vte -l pl.UTF-8
134 API języka Vala dla biblioteki VTE.
135
136 %package apidocs
137 Summary:        VTE API documentation (GTK+ 3 version)
138 Summary(pl.UTF-8):      Dokumentacja API VTE (wersja dla GTK+ 3)
139 Group:          Documentation
140 Requires:       gtk-doc-common
141 %if "%{_rpmversion}" >= "5"
142 BuildArch:      noarch
143 %endif
144
145 %description apidocs
146 VTE API documentation (GTK+ 3 version).
147
148 %description apidocs -l pl.UTF-8
149 Dokumentacja API VTE (wersja dla GTK+ 3).
150
151 %prep
152 %setup -q
153 %patch0 -p1
154
155 %build
156 %{__gtkdocize}
157 %{__glib_gettextize}
158 %{__intltoolize}
159 %{__libtoolize}
160 %{__aclocal}
161 %{__autoheader}
162 %{__automake}
163 %{__autoconf}
164 install -d build-gtk3
165 cd build-gtk3
166 ../%configure \
167         --disable-silent-rules \
168         %{?with_glade:--enable-glade-catalogue} \
169         --enable-gtk-doc \
170         --enable-introspection \
171         --with-html-dir=%{_gtkdocdir}
172 %{__make}
173 cd ..
174
175 %if %{with gtk4}
176 install -d build-gtk4
177 cd build-gtk4
178 # note: "3.902468" is a result of configure.ac bug (unquoted brackets)
179 ../%configure \
180         --disable-silent-rules \
181         --enable-gtk-doc \
182         --enable-introspection \
183         --with-gtk=3.902468 \
184         --with-html-dir=%{_gtkdocdir}
185 %{__make}
186 %endif
187
188 %install
189 rm -rf $RPM_BUILD_ROOT
190
191 %if %{with gtk4}
192 %{__make} -C build-gtk4 install \
193         DESTDIR=$RPM_BUILD_ROOT
194 %endif
195
196 %{__make} -C build-gtk3 install \
197         DESTDIR=$RPM_BUILD_ROOT
198
199 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
200
201 %find_lang %{name}-2.91
202
203 %clean
204 rm -rf $RPM_BUILD_ROOT
205
206 %post   -p /sbin/ldconfig
207 %postun -p /sbin/ldconfig
208
209 %files -f vte-2.91.lang
210 %defattr(644,root,root,755)
211 %doc AUTHORS ChangeLog NEWS
212 %attr(755,root,root) %{_bindir}/vte-2.91
213 %attr(755,root,root) %{_libdir}/libvte-2.91.so.*.*.*
214 %attr(755,root,root) %ghost %{_libdir}/libvte-2.91.so.0
215 %{_libdir}/girepository-1.0/Vte-2.91.typelib
216 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/vte.sh
217
218 %files devel
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/libvte-2.91.so
221 %{_includedir}/vte-2.91
222 %{_pkgconfigdir}/vte-2.91.pc
223 %{_datadir}/gir-1.0/Vte-2.91.gir
224
225 %files static
226 %defattr(644,root,root,755)
227 %{_libdir}/libvte-2.91.a
228
229 %if %{with glade}
230 %files glade
231 %defattr(644,root,root,755)
232 %{_datadir}/glade/catalogs/vte-2.91.xml
233 %{_datadir}/glade/pixmaps/hicolor/16x16/actions/widget-vte-terminal.png
234 %{_datadir}/glade/pixmaps/hicolor/22x22/actions/widget-vte-terminal.png
235 %endif
236
237 %files -n vala-vte
238 %defattr(644,root,root,755)
239 %{_datadir}/vala/vapi/vte-2.91.vapi
240
241 %files apidocs
242 %defattr(644,root,root,755)
243 %{_gtkdocdir}/vte-2.91
This page took 0.061612 seconds and 4 git commands to generate.