]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- C++ now, BR: libstdc++-devel
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_without  glade   # Glade catalog
4 #
5 Summary:        VTE terminal widget library
6 Summary(pl.UTF-8):      Biblioteka z kontrolką terminala VTE
7 Name:           vte
8 Version:        0.42.0
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vte/0.42/%{name}-%{version}.tar.xz
13 # Source0-md5:  6dd98fd69b66508dcc2707bcdbdab93c
14 BuildRequires:  autoconf >= 2.63
15 BuildRequires:  automake >= 1:1.9
16 BuildRequires:  docbook-dtd412-xml
17 BuildRequires:  gettext-devel
18 %{?with_glade:BuildRequires:    glade-devel >= 3}
19 BuildRequires:  glib2-devel >= 1:2.40.0
20 BuildRequires:  gnutls-devel >= 3.2.7
21 BuildRequires:  gobject-introspection-devel >= 0.10.0
22 BuildRequires:  gtk+3-devel >= 3.8.0
23 BuildRequires:  gtk-doc >= 1.13
24 BuildRequires:  gtk-doc-automake >= 1.13
25 BuildRequires:  intltool >= 0.40.0
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool >= 2:2.2
28 BuildRequires:  libxml2-progs >= 2
29 BuildRequires:  ncurses-devel
30 BuildRequires:  pango-devel >= 1:1.22.0
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.592
33 BuildRequires:  tar >= 1:1.22
34 #BuildRequires: vala >= 2:0.18
35 BuildRequires:  xz
36 BuildRequires:  zlib-devel
37 Requires:       glib2 >= 1:2.40.0
38 Requires:       gnutls >= 3.2.7
39 Requires:       gtk+3 >= 3.8.0
40 Requires:       pango >= 1:1.22.0
41 Obsoletes:      vte-common < 0.42.0
42 # sr@Latn vs. sr@latin
43 Conflicts:      glibc-misc < 6:2.7
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 The vte package contains a terminal widget for GTK+ 3.x. It's used by
48 gnome-terminal among other programs.
49
50 %description -l pl.UTF-8
51 Ten pakiet zawiera kontrolkę terminala dla GTK+ 3.x. Jest używany
52 przez gnome-terminal oraz inne programy.
53
54 %package common
55 Summary:        Common files for vte and vte0
56 Summary(pl.UTF-8):      Pliki wspólne dla vte i vte0
57 Group:          X11/Libraries
58 Requires(pre):  utempter
59
60 %description common
61 Common files for GTK+ 3 based vte and GTK+ 2 based vte0.
62
63 %description common -l pl.UTF-8
64 Pliki wspólne dla vte opartego na GTK+ 3 oraz vte0 opartego na GTK+ 2.
65
66 %package devel
67 Summary:        Header files for VTE for GTK+ 3
68 Summary(pl.UTF-8):      Pliki nagłówkowe VTE dla GTK+ 3
69 Group:          X11/Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       glib2-devel >= 1:2.40.0
72 Requires:       gnutls-devel >= 3.2.7
73 Requires:       gtk+3-devel >= 3.8.0
74 Requires:       ncurses-devel
75 Requires:       pango-devel >= 1:1.22.0
76 Requires:       zlib-devel
77 Conflicts:      gnome-libs-devel < 1.4.1.2
78
79 %description devel
80 This package contains header files for GTK+ 3 based vte library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe potrzebne do kompilowania programów używających
84 biblioteki vte opartej na GTK+ 3.
85
86 %package static
87 Summary:        Static VTE library for GTK+ 3
88 Summary(pl.UTF-8):      Statyczna biblioteka VTE dla GTK+ 3
89 Group:          X11/Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91 Conflicts:      gnome-libs-static < 1.4.1.2
92
93 %description static
94 Static version of VTE library for GTK+ 3.
95
96 %description static -l pl.UTF-8
97 Statyczna wersja biblioteki VTE dla GTK+ 3.
98
99 %package glade
100 Summary:        VTE catalog file for Glade
101 Summary(pl.UTF-8):      Plik katalogu VTE dla Glade
102 Group:          X11/Development/Libraries
103 Requires:       %{name}-devel = %{version}-%{release}
104 Requires:       glade >= 3
105
106 %description glade
107 VTE catalog file for Glade.
108
109 %description glade -l pl.UTF-8
110 Plik katalogu VTE dla Glade.
111
112 %package -n vala-vte
113 Summary:        Vala API for VTE library
114 Summary(pl.UTF-8):      API języka Vala dla biblioteki VTE
115 Group:          Development/Libraries
116 Requires:       %{name}-devel = %{version}-%{release}
117 Requires:       vala >= 2:0.18
118
119 %description -n vala-vte
120 Vala API for VTE library.
121
122 %description -n vala-vte -l pl.UTF-8
123 API języka Vala dla biblioteki VTE.
124
125 %package apidocs
126 Summary:        VTE API documentation (GTK+ 3 version)
127 Summary(pl.UTF-8):      Dokumentacja API VTE (wersja dla GTK+ 3)
128 Group:          Documentation
129 Requires:       gtk-doc-common
130 %if "%{_rpmversion}" >= "5"
131 BuildArch:      noarch
132 %endif
133
134 %description apidocs
135 VTE API documentation (GTK+ 3 version).
136
137 %description apidocs -l pl.UTF-8
138 Dokumentacja API VTE (wersja dla GTK+ 3).
139
140 %prep
141 %setup -q
142
143 %build
144 %{__gtkdocize}
145 %{__glib_gettextize}
146 %{__intltoolize}
147 %{__libtoolize}
148 %{__aclocal}
149 %{__autoheader}
150 %{__automake}
151 %{__autoconf}
152 %configure \
153         --disable-silent-rules \
154         %{?with_glade:--enable-glade-catalogue} \
155         --enable-gtk-doc \
156         --enable-introspection \
157         --with-html-dir=%{_gtkdocdir}
158 %{__make}
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162
163 %{__make} install \
164         DESTDIR=$RPM_BUILD_ROOT
165
166 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
167
168 %find_lang %{name}-2.91
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %files -f vte-2.91.lang
177 %defattr(644,root,root,755)
178 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
179 %attr(755,root,root) %{_bindir}/vte-2.91
180 %attr(755,root,root) %{_libdir}/libvte-2.91.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libvte-2.91.so.0
182 %{_libdir}/girepository-1.0/Vte-2.91.typelib
183 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/vte.sh
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libvte-2.91.so
188 %{_includedir}/vte-2.91
189 %{_pkgconfigdir}/vte-2.91.pc
190 %{_datadir}/gir-1.0/Vte-2.91.gir
191
192 %files static
193 %defattr(644,root,root,755)
194 %{_libdir}/libvte-2.91.a
195
196 %if %{with glade}
197 %files glade
198 %defattr(644,root,root,755)
199 %{_datadir}/glade/catalogs/vte-2.91.xml
200 %{_datadir}/glade/pixmaps/hicolor/16x16/actions/widget-vte-terminal.png
201 %{_datadir}/glade/pixmaps/hicolor/22x22/actions/widget-vte-terminal.png
202 %endif
203
204 %files -n vala-vte
205 %defattr(644,root,root,755)
206 %{_datadir}/vala/vapi/vte-2.91.vapi
207
208 %files apidocs
209 %defattr(644,root,root,755)
210 %{_gtkdocdir}/vte-2.91
This page took 0.038221 seconds and 4 git commands to generate.