]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- don't search for obsolete zvt
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_with     glx # build for glX support
4 #
5 Summary:        VTE terminal widget library
6 Summary(pl):    Biblioteka z kontrolk± terminala VTE
7 Name:           vte
8 Version:        0.11.11
9 Release:        6
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.11/%{name}-%{version}.tar.bz2
13 # Source0-md5:  4d7a3674df5b8be7f1adffa981c1fc3d
14 Patch0:         %{name}-keys.patch
15 Patch1:         %{name}-localenames.patch
16 Patch2:         %{name}-atktextselection.patch
17 Patch3:         %{name}-types-include.patch
18 Patch4:         %{name}-performance.patch
19 %{?with_glx:BuildRequires:      OpenGL-devel}
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  glib2-devel >= 2.2.0
23 BuildRequires:  gtk+2-devel >= 2.2.0
24 BuildRequires:  gtk-doc
25 BuildRequires:  libart_lgpl-devel >= 2.3.10
26 BuildRequires:  libtool
27 BuildRequires:  libzvt
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  python-pygtk-devel >= 1.99.13
30 BuildRequires:  xft-devel >= 2.1.2
31 Requires(pre):  utempter
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The vte package contains a terminal widget for GTK+. It's used by
36 gnome-terminal among other programs.
37
38 %description -l pl
39 Ten pakiet zawiera kontrolkê terminala dla GTK+. Jest u¿ywany przez
40 gnome-terminal oraz inne programy.
41
42 %package devel
43 Summary:        Headers for VTE
44 Summary(pl):    Pliki nag³ówkowe VTE
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       glib2-devel >= 2.2.0
48 Requires:       gtk+2-devel >= 2.2.0
49 Requires:       libart_lgpl-devel >= 2.3.10
50 Requires:       OpenGL-devel
51 Conflicts:      gnome-libs-devel < 1.4.1.2
52
53 %description devel
54 The vte package contains a terminal widget for GTK+. It's used by
55 gnome-terminal among other programs.
56
57 You should install the vte-devel package if you would like to
58 compile applications that use the vte terminal widget. You do not need
59 to install vte-devel if you just want to use precompiled
60 applications.
61
62 %description devel -l pl
63 Pliki nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych
64 vte.
65
66 %package static
67 Summary:        Static VTE library
68 Summary(pl):    Statyczna biblioteka VTE
69 Group:          X11/Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71 Conflicts:      gnome-libs-static < 1.4.1.2
72
73 %description static
74 Static version of VTE libraries.
75
76 %description static -l pl
77 Statyczna wersja bibliotek VTE.
78
79 %package -n python-vte
80 Summary:        Python VTE module
81 Summary(pl):    Modu³ VTE dla pythona
82 Group:          Libraries
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       python-pygtk-gtk >= 1.99.13
85
86 %description -n python-vte
87 Python VTE library.
88
89 %description -n python-vte -l pl
90 Biblioteka VTE dla pythona.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p0
98 %patch4 -p0
99
100 mv -f po/{no,nb}.po
101
102 %build
103 glib-gettextize --copy --force
104 %{__libtoolize}
105 %{__aclocal}
106 %{__autoheader}
107 %{__automake}
108 %{__autoconf}
109 CFLAGS="-I/usr/include/ncurses"
110 %configure \
111         --with-xft2 \
112         --with-pangox \
113         %{?with_glx:--with-glX} \
114         --with-default-emulation=xterm \
115         --enable-gtk-doc \
116         --with-html-dir=%{_gtkdocdir}
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/*.{la,a}
126
127 %find_lang vte
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files -f vte.lang
136 %defattr(644,root,root,755)
137 %doc NEWS README AUTHORS
138 %attr(755,root,root) %{_bindir}/vte
139 %attr(755,root,root) %{_libdir}/lib*.so.*.*
140 %dir %{_libdir}/vte
141 %attr(755,root,root) %{_libdir}/vte/*
142 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
143 %{_datadir}/vte
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %{_libdir}/lib*.la
149 %{_includedir}/*
150 %{_pkgconfigdir}/*
151 %{_gtkdocdir}/*
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/lib*.a
156
157 %files -n python-vte
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{py_sitedir}/gtk-2.0/*.so
This page took 0.057452 seconds and 3 git commands to generate.