]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- disable keys.patch - causes gnome-terminal breakage, rel.2
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_with     glx # build for GLX support
4 #
5 Summary:        VTE terminal widget library
6 Summary(pl):    Biblioteka z kontrolk± terminala VTE
7 Name:           vte
8 Version:        0.13.4
9 Release:        2
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/vte/0.13/%{name}-%{version}.tar.bz2
13 # Source0-md5:  6b963ce0b5999d83b382089ef94d2874
14 Patch0:         %{name}-keys.patch
15 %{?with_glx:BuildRequires:      OpenGL-devel}
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gettext-devel
19 BuildRequires:  glib2-devel >= 1:2.12.1
20 BuildRequires:  gtk+2-devel >= 2:2.10.1
21 BuildRequires:  gtk-doc
22 BuildRequires:  libart_lgpl-devel >= 2.3.10
23 BuildRequires:  libtool
24 BuildRequires:  ncurses-devel
25 BuildRequires:  pkgconfig
26 BuildRequires:  python-pygtk-devel >= 2:2.9.3
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.197
29 Requires(pre):  utempter
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         no_build_with_as_needed 1
33
34 %description
35 The vte package contains a terminal widget for GTK+. It's used by
36 gnome-terminal among other programs.
37
38 %description -l pl
39 Ten pakiet zawiera kontrolkê terminala dla GTK+. Jest u¿ywany przez
40 gnome-terminal oraz inne programy.
41
42 %package devel
43 Summary:        Headers for VTE
44 Summary(pl):    Pliki nag³ówkowe VTE
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 %{?with_glx:Requires:   OpenGL-devel}
48 Requires:       glib2-devel >= 1:2.12.1
49 Requires:       gtk+2-devel >= 2:2.10.1
50 Requires:       libart_lgpl-devel >= 2.3.10
51 Requires:       ncurses-devel
52 Conflicts:      gnome-libs-devel < 1.4.1.2
53
54 %description devel
55 The vte package contains a terminal widget for GTK+. It's used by
56 gnome-terminal among other programs.
57
58 You should install the vte-devel package if you would like to
59 compile applications that use the vte terminal widget. You do not need
60 to install vte-devel if you just want to use precompiled
61 applications.
62
63 %description devel -l pl
64 Pliki nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych
65 vte.
66
67 %package static
68 Summary:        Static VTE library
69 Summary(pl):    Statyczna biblioteka VTE
70 Group:          X11/Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72 Conflicts:      gnome-libs-static < 1.4.1.2
73
74 %description static
75 Static version of VTE libraries.
76
77 %description static -l pl
78 Statyczna wersja bibliotek VTE.
79
80 %package -n python-vte
81 Summary:        Python VTE module
82 Summary(pl):    Modu³ VTE dla pythona
83 Group:          Libraries
84 %pyrequires_eq  python-libs
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       python-pygtk-gtk >= 2:2.9.3
87
88 %description -n python-vte
89 Python VTE library.
90
91 %description -n python-vte -l pl
92 Biblioteka VTE dla pythona.
93
94 %prep
95 %setup -q
96 # disabled: breaks other apps
97 #%patch0 -p1
98
99 %build
100 %{__intltoolize}
101 %{__libtoolize}
102 %{__aclocal}
103 %{__autoheader}
104 %{__automake}
105 %{__autoconf}
106 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
107 %configure \
108         --with-xft2 \
109         --with-pangox \
110         %{?with_glx:--with-glX} \
111         --with-default-emulation=xterm \
112         --enable-gtk-doc \
113         --with-html-dir=%{_gtkdocdir}
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/*.{la,a}
123 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/ug
124
125 %find_lang vte
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files -f vte.lang
134 %defattr(644,root,root,755)
135 %doc NEWS README AUTHORS
136 %attr(755,root,root) %{_bindir}/vte
137 %attr(755,root,root) %{_libdir}/lib*.so.*.*
138 %dir %{_libdir}/vte
139 %attr(755,root,root) %{_libdir}/vte/*
140 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
141 %{_datadir}/vte
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/lib*.so
146 %{_libdir}/lib*.la
147 %{_includedir}/*
148 %{_pkgconfigdir}/*
149 %{_gtkdocdir}/*
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/lib*.a
154
155 %files -n python-vte
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{py_sitedir}/gtk-2.0/*.so
This page took 0.078458 seconds and 3 git commands to generate.