]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- removed bogus macros
[packages/vte.git] / vte.spec
1 # TODO:
2 # - fix gtk-doc location
3
4 %include        /usr/lib/rpm/macros.python
5
6 Summary:        VTE terminal widget library
7 Summary(pl):    Biblioteka z widgetem terminala VTE
8 Name:           vte
9 Version:        0.10.4
10 Release:        0.1
11 License:        LGPL
12 Group:          X11/Libraries
13 Source0:        ftp://ftp.gnome.org/pub/gnome/sources/%{name}/0.10/%{name}-%{version}.tar.bz2
14 Patch0:         %{name}-Xft2.patch
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  glib2-devel >= 2.0.7
18 BuildRequires:  gtk+2-devel >= 2.0.9
19 BuildRequires:  libart_lgpl-devel >= 2.3.10
20 BuildRequires:  libtool
21 BuildRequires:  python-pygtk-devel >= 1.99.13
22 Requires(pre):  utempter
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _prefix         /usr/X11R6
26 %define         _mandir         %{_prefix}/man
27
28 %description
29 The vte package contains a terminal widget for GTK+. It's used by
30 gnome-terminal among other programs.
31
32 %description -l pl
33 Ten pakiet zawiera widget terminala dla GTK+. Jest u¿ywany przez
34 gnome-terminal oraz inne programy.
35
36 %package devel
37 Summary:        Headers for vte
38 Summary(pl):    Pliki nag³ówkowe vte
39 Group:          X11/Development/Libraries
40 Requires:       %{name} = %{version}
41 Requires:       glib2-devel >= %{glib2_version}
42 Requires:       gtk+2-devel >= %{gtk2_version}
43 Requires:       libart_lgpl-devel >= %{libart_lgpl_version}
44 Conflicts:      gnome-libs-devel < 1.4.1.2
45
46 %description devel
47 The vte package contains a terminal widget for GTK+. It's used by
48 gnome-terminal among other programs.
49
50 You should install the vte-devel package if you would like to
51 compile applications that use the vte terminal widget. You do not need
52 to install vte-devel if you just want to use precompiled
53 applications.
54
55 %description devel -l pl
56 Pliki nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych
57 vte.
58
59 %package static
60 Summary:        Static vte library
61 Summary(pl):    Statyczna biblioteka vte
62 Group:          X11/Development/Libraries
63 Requires:       %{name}-devel = %{version}
64 Conflicts:      gnome-libs-static < 1.4.1.2
65
66 %description static
67 Static version of vte libraries.
68
69 %description static -l pl
70 Statyczna wersja bibliotek vte.
71
72 %package -n python-vte
73 Summary:        Python vte library
74 Summary(pl):    Biblioteka vte dla pythona
75 Group:          Libraries
76 Requires:       %{name} = %{version}
77
78 %description -n python-vte
79 Python vte library.
80
81 %description -n python-vte -l pl
82 Biblioteka vte dla pythona.
83
84 %prep
85 %setup  -q
86 %patch0 -p1
87
88 %build
89 #rm -f missing
90 #%{__libtoolize}
91 #%{__aclocal} -I %{_aclocaldir}/gnome2-macros
92 #%{__autoconf}
93 #%{__automake}
94 %configure
95 %{__make} pythonsiteexecdir=%{py_sitedir}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT \
102         pkgconfigdir=%{_pkgconfigdir} \
103         pythonsiteexecdir=%{py_sitedir}
104
105 %find_lang vte
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files -f vte.lang
114 %defattr(644,root,root,755)
115 %doc NEWS README AUTHORS
116 %attr(755,root,root) %{_bindir}/vte
117 %attr(755,root,root) %{_libdir}/lib*.so.*.*
118 %dir %{_libdir}/vte
119 %attr(755,root,root) %{_libdir}/vte/*
120 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/lib*.so
125 %attr(755,root,root) %{_libdir}/lib*.la
126 %{_includedir}/*
127 %{_pkgconfigdir}/*
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/lib*.a
132
133 %files -n python-vte
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.087103 seconds and 3 git commands to generate.