]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- bug TODO added
[packages/vte.git] / vte.spec
1 #
2 # TODO:
3 # - watch https://bugs.launchpad.net/ubuntu/+source/vte/+bug/91985
4 #   for news regarding the lack of transparency. The patches there
5 #   apply, but don't work
6 #
7 # Conditional build:
8 %bcond_with     glx     # drawing using GLX
9 #
10 Summary:        VTE terminal widget library
11 Summary(pl.UTF-8):      Biblioteka z kontrolką terminala VTE
12 Name:           vte
13 Version:        0.16.0
14 Release:        1.0.1
15 License:        LGPL
16 Group:          X11/Libraries
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/vte/0.16/%{name}-%{version}.tar.bz2
18 # Source0-md5:  6b85967ba75ed574d0e5782697fbc79f
19 Patch0:         %{name}-keys.patch
20 Patch1:         %{name}-link.patch
21 Patch2:         %{name}-transparency.patch
22 %{?with_glx:BuildRequires:      OpenGL-GLU-devel}
23 %{?with_glx:BuildRequires:      OpenGL-GLX-devel}
24 BuildRequires:  autoconf >= 2.59-9
25 BuildRequires:  automake >= 1:1.6
26 BuildRequires:  gettext-devel
27 BuildRequires:  gtk+2-devel >= 2:2.10.9
28 BuildRequires:  gtk-doc >= 1.8
29 BuildRequires:  gtk-doc-automake
30 BuildRequires:  intltool >= 0.35.5
31 BuildRequires:  libtool
32 BuildRequires:  ncurses-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  python-pygtk-devel >= 2:2.10.4
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.197
37 Requires(pre):  utempter
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 The vte package contains a terminal widget for GTK+. It's used by
42 gnome-terminal among other programs.
43
44 %description -l pl.UTF-8
45 Ten pakiet zawiera kontrolkę terminala dla GTK+. Jest używany przez
46 gnome-terminal oraz inne programy.
47
48 %package devel
49 Summary:        Headers for VTE
50 Summary(pl.UTF-8):      Pliki nagłówkowe VTE
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 %{?with_glx:Requires:   OpenGL-GLU-devel}
54 Requires:       gtk+2-devel >= 2:2.10.9
55 Requires:       ncurses-devel
56 Conflicts:      gnome-libs-devel < 1.4.1.2
57
58 %description devel
59 The vte package contains a terminal widget for GTK+. It's used by
60 gnome-terminal among other programs.
61
62 You should install the vte-devel package if you would like to compile
63 applications that use the vte terminal widget. You do not need to
64 install vte-devel if you just want to use precompiled applications.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe potrzebne do kompilowania programów używających vte.
68
69 %package static
70 Summary:        Static VTE library
71 Summary(pl.UTF-8):      Statyczna biblioteka VTE
72 Group:          X11/Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74 Conflicts:      gnome-libs-static < 1.4.1.2
75
76 %description static
77 Static version of VTE libraries.
78
79 %description static -l pl.UTF-8
80 Statyczna wersja bibliotek VTE.
81
82 %package -n python-vte
83 Summary:        Python VTE module
84 Summary(pl.UTF-8):      Moduł VTE dla pythona
85 Group:          Libraries
86 %pyrequires_eq  python-libs
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       python-pygtk-gtk >= 2:2.10.4
89
90 %description -n python-vte
91 Python VTE library.
92
93 %description -n python-vte -l pl.UTF-8
94 Biblioteka VTE dla pythona.
95
96 %package apidocs
97 Summary:        VTE API documentation
98 Summary(pl.UTF-8):      Dokumentacja API VTE
99 Group:          Documentation
100 Requires:       gtk-doc-common
101
102 %description apidocs
103 VTE API documentation.
104
105 %description apidocs -l pl.UTF-8
106 Dokumentacja API VTE.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %patch1 -p1
112 %patch2 -p1
113
114 %build
115 %{__glib_gettextize}
116 %{__intltoolize}
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoheader}
120 %{__automake}
121 %{__autoconf}
122 cd gnome-pty-helper
123 %{__libtoolize}
124 %{__aclocal}
125 %{__autoheader}
126 %{__automake}
127 %{__autoconf}
128 cd ..
129 %configure \
130         --enable-gtk-doc \
131         --with-default-emulation=xterm \
132         %{?with_glx:--with-glX} \
133         --with-html-dir=%{_gtkdocdir} \
134         --with-pangox \
135         --with-xft2
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/*.{la,a}
146
147 %find_lang vte
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files -f vte.lang
156 %defattr(644,root,root,755)
157 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
158 %attr(755,root,root) %{_bindir}/vte
159 %attr(755,root,root) %{_libdir}/libvte.so.*.*.*
160 %dir %{_libdir}/vte
161 %attr(755,root,root) %{_libdir}/vte/*
162 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
163 %{_datadir}/vte
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libvte.so
168 %{_libdir}/libvte.la
169 %{_includedir}/vte
170 %{_pkgconfigdir}/vte.pc
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libvte.a
175
176 %files apidocs
177 %defattr(644,root,root,755)
178 %{_gtkdocdir}/vte
179
180 %files -n python-vte
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{py_sitedir}/gtk-2.0/vtemodule.so
This page took 0.057628 seconds and 3 git commands to generate.