]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- R: ncurses-devel in -devel
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_with     glx # build for GLX support
4 #
5 Summary:        VTE terminal widget library
6 Summary(pl):    Biblioteka z kontrolk± terminala VTE
7 Name:           vte
8 Version:        0.11.13
9 Release:        1
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/vte/0.11/%{name}-%{version}.tar.bz2
13 # Source0-md5:  5eb73c7de433fb6e53ac4378df9d23b5
14 Patch0:         %{name}-keys.patch
15 Patch1:         %{name}-atktextselection.patch
16 Patch2:         %{name}-nozvt.patch
17 %{?with_glx:BuildRequires:      OpenGL-devel}
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  gettext-devel
21 BuildRequires:  glib2-devel >= 2.2.0
22 BuildRequires:  gtk+2-devel >= 2:2.2.0
23 BuildRequires:  gtk-doc
24 BuildRequires:  libart_lgpl-devel >= 2.3.10
25 BuildRequires:  libtool
26 BuildRequires:  ncurses-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  python
29 BuildRequires:  python-pygtk-devel >= 1.99.13
30 BuildRequires:  rpmbuild(macros) >= 1.197
31 BuildRequires:  xft-devel >= 2.1.2
32 Requires(pre):  utempter
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The vte package contains a terminal widget for GTK+. It's used by
37 gnome-terminal among other programs.
38
39 %description -l pl
40 Ten pakiet zawiera kontrolkê terminala dla GTK+. Jest u¿ywany przez
41 gnome-terminal oraz inne programy.
42
43 %package devel
44 Summary:        Headers for VTE
45 Summary(pl):    Pliki nag³ówkowe VTE
46 Group:          X11/Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       OpenGL-devel
49 Requires:       glib2-devel >= 2.2.0
50 Requires:       gtk+2-devel >= 2.2.0
51 Requires:       libart_lgpl-devel >= 2.3.10
52 Requires:       ncurses-devel
53 Conflicts:      gnome-libs-devel < 1.4.1.2
54
55 %description devel
56 The vte package contains a terminal widget for GTK+. It's used by
57 gnome-terminal among other programs.
58
59 You should install the vte-devel package if you would like to
60 compile applications that use the vte terminal widget. You do not need
61 to install vte-devel if you just want to use precompiled
62 applications.
63
64 %description devel -l pl
65 Pliki nag³ówkowe potrzebne do kompilowania programów u¿ywaj±cych
66 vte.
67
68 %package static
69 Summary:        Static VTE library
70 Summary(pl):    Statyczna biblioteka VTE
71 Group:          X11/Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73 Conflicts:      gnome-libs-static < 1.4.1.2
74
75 %description static
76 Static version of VTE libraries.
77
78 %description static -l pl
79 Statyczna wersja bibliotek VTE.
80
81 %package -n python-vte
82 Summary:        Python VTE module
83 Summary(pl):    Modu³ VTE dla pythona
84 Group:          Libraries
85 %pyrequires_eq  python-libs
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       python-pygtk-gtk >= 1.99.13
88
89 %description -n python-vte
90 Python VTE library.
91
92 %description -n python-vte -l pl
93 Biblioteka VTE dla pythona.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100
101 %build
102 %{__glib_gettextize}
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoheader}
106 %{__automake}
107 %{__autoconf}
108 CFLAGS="-I/usr/include/ncurses"
109 %configure \
110         --with-xft2 \
111         --with-pangox \
112         %{?with_glx:--with-glX} \
113         --with-default-emulation=xterm \
114         --enable-gtk-doc \
115         --with-html-dir=%{_gtkdocdir}
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/*.{la,a}
125 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
126
127 %find_lang vte
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files -f vte.lang
136 %defattr(644,root,root,755)
137 %doc NEWS README AUTHORS
138 %attr(755,root,root) %{_bindir}/vte
139 %attr(755,root,root) %{_libdir}/lib*.so.*.*
140 %dir %{_libdir}/vte
141 %attr(755,root,root) %{_libdir}/vte/*
142 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
143 %{_datadir}/vte
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %{_libdir}/lib*.la
149 %{_includedir}/*
150 %{_pkgconfigdir}/*
151 %{_gtkdocdir}/*
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/lib*.a
156
157 %files -n python-vte
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{py_sitedir}/gtk-2.0/*.so
This page took 0.036613 seconds and 3 git commands to generate.