]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- use _gidocdir for apidocs
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  glade   # Glade catalog
5 %bcond_without  gtk4    # GTK+ 4 based library
6 %bcond_without  systemd # systemd
7
8 Summary:        VTE terminal widget library
9 Summary(pl.UTF-8):      Biblioteka z kontrolką terminala VTE
10 Name:           vte
11 Version:        0.74.0
12 Release:        1
13 # some files have LGPL v2.1+ signature, but some LGPL v3+
14 License:        LGPL v3+ (library), GPL v3+ (app)
15 Group:          X11/Libraries
16 Source0:        https://download.gnome.org/sources/vte/0.74/%{name}-%{version}.tar.xz
17 # Source0-md5:  ab2df0e0c0f197eb16eb4894bf8d2826
18 Patch0:         %{name}-wordsep.patch
19 URL:            https://wiki.gnome.org/Apps/Terminal/VTE
20 BuildRequires:  cairo-gobject-devel
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  fribidi-devel >= 1.0.0
23 # C11
24 BuildRequires:  gcc >= 6:4.7
25 BuildRequires:  gdk-pixbuf2-devel
26 BuildRequires:  gettext-tools
27 BuildRequires:  glib2-devel >= 1:2.52.0
28 BuildRequires:  gnutls-devel >= 3.2.7
29 BuildRequires:  gobject-introspection-devel >= 0.10.0
30 BuildRequires:  gperf
31 BuildRequires:  gtk+3-devel >= 3.24.0
32 %{?with_gtk4:BuildRequires:     gtk4-devel >= 4.0.1}
33 %{?with_apidocs:BuildRequires:  gi-docgen}
34 BuildRequires:  intltool >= 0.40.0
35 BuildRequires:  libicu-devel >= 4.8
36 # C++20 support (-std=gnu++2a, char8_t)
37 BuildRequires:  libstdc++-devel >= 6:9.0
38 BuildRequires:  libxml2-progs >= 2
39 BuildRequires:  meson >= 0.60.0
40 BuildRequires:  ninja >= 1.5
41 BuildRequires:  pango-devel >= 1:1.22.0
42 BuildRequires:  pcre2-8-devel >= 10.21
43 BuildRequires:  pkgconfig
44 BuildRequires:  rpm-build >= 4.6
45 BuildRequires:  rpmbuild(macros) >= 2.029
46 %{?with_systemd:BuildRequires:  systemd-devel >= 1:220}
47 BuildRequires:  tar >= 1:1.22
48 BuildRequires:  vala >= 2:0.24
49 BuildRequires:  xz
50 BuildRequires:  zlib-devel
51 Requires:       fribidi >= 1.0.0
52 Requires:       glib2 >= 1:2.52.0
53 Requires:       gnutls >= 3.2.7
54 Requires:       gtk+3 >= 3.24.0
55 Requires:       libicu >= 4.8
56 Requires:       pango >= 1:1.22.0
57 %{?with_systemd:Requires:       systemd-libs >= 1:220}
58 Obsoletes:      vte-common < 0.42.0
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 The vte package contains a terminal widget for GTK+ 3.x. It's used by
63 gnome-terminal among other programs.
64
65 %description -l pl.UTF-8
66 Ten pakiet zawiera kontrolkę terminala dla GTK+ 3.x. Jest używany
67 przez gnome-terminal oraz inne programy.
68
69 %package devel
70 Summary:        Header files for VTE for GTK+ 3
71 Summary(pl.UTF-8):      Pliki nagłówkowe VTE dla GTK+ 3
72 License:        LGPL v3+
73 Group:          X11/Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       glib2-devel >= 1:2.52.0
76 Requires:       gtk+3-devel >= 3.24.0
77 Requires:       pango-devel >= 1:1.22.0
78 Conflicts:      gnome-libs-devel < 1.4.1.2
79
80 %description devel
81 This package contains header files for GTK+ 3 based vte library.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe potrzebne do kompilowania programów używających
85 biblioteki vte opartej na GTK+ 3.
86
87 %package glade
88 Summary:        VTE catalog file for Glade
89 Summary(pl.UTF-8):      Plik katalogu VTE dla Glade
90 Group:          X11/Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92 Requires:       glade >= 3
93
94 %description glade
95 VTE catalog file for Glade.
96
97 %description glade -l pl.UTF-8
98 Plik katalogu VTE dla Glade.
99
100 %package -n vala-vte
101 Summary:        Vala API for VTE library
102 Summary(pl.UTF-8):      API języka Vala dla biblioteki VTE
103 License:        LGPL v3+
104 Group:          Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106 Requires:       vala >= 2:0.24
107 BuildArch:      noarch
108
109 %description -n vala-vte
110 Vala API for VTE library.
111
112 %description -n vala-vte -l pl.UTF-8
113 API języka Vala dla biblioteki VTE.
114
115 %package apidocs
116 Summary:        VTE API documentation (GTK+ 3 version)
117 Summary(pl.UTF-8):      Dokumentacja API VTE (wersja dla GTK+ 3)
118 Group:          Documentation
119 BuildArch:      noarch
120
121 %description apidocs
122 VTE API documentation (GTK+ 3 version).
123
124 %description apidocs -l pl.UTF-8
125 Dokumentacja API VTE (wersja dla GTK+ 3).
126
127 %package gtk4
128 Summary:        VTE terminal widget library (GTK 4 version)
129 Summary(pl.UTF-8):      Biblioteka z kontrolką terminala VTE (wersja dla GTK 4)
130 Group:          Libraries
131 Requires:       fribidi >= 1.0.0
132 Requires:       glib2 >= 1:2.52.0
133 Requires:       gnutls >= 3.2.7
134 Requires:       gtk4 >= 4.0.1
135 Requires:       libicu >= 4.8
136 Requires:       pango >= 1:1.22.0
137 %{?with_systemd:Requires:       systemd-libs >= 1:220}
138 # for common files
139 Suggests:       %{name} = %{version}-%{release}
140
141 %description gtk4
142 The vte package contains a terminal widget for GTK 4.x. It's used by
143 gnome-terminal among other programs.
144
145 %description gtk4 -l pl.UTF-8
146 Ten pakiet zawiera kontrolkę terminala dla GTK 4. Jest używany przez
147 gnome-terminal oraz inne programy.
148
149 %package gtk4-devel
150 Summary:        Header files for VTE for GTK 4
151 Summary(pl.UTF-8):      Pliki nagłówkowe VTE dla GTK 4
152 License:        LGPL v3+
153 Group:          X11/Development/Libraries
154 Requires:       %{name}-gtk4 = %{version}-%{release}
155 Requires:       glib2-devel >= 1:2.52.0
156 Requires:       gtk4-devel >= 4.0.1
157 Requires:       pango-devel >= 1:1.22.0
158
159 %description gtk4-devel
160 This package contains header files for GTK 4 based vte library.
161
162 %description gtk4-devel -l pl.UTF-8
163 Pliki nagłówkowe potrzebne do kompilowania programów używających
164 biblioteki vte opartej na GTK 4.
165
166 %package -n vala-vte-gtk4
167 Summary:        Vala API for VTE library (GTK 4 version)
168 Summary(pl.UTF-8):      API języka Vala dla biblioteki VTE (wersja dla GTK 4)
169 License:        LGPL v3+
170 Group:          Development/Libraries
171 Requires:       %{name}-gtk4-devel = %{version}-%{release}
172 Requires:       vala >= 2:0.24
173 BuildArch:      noarch
174
175 %description -n vala-vte-gtk4
176 Vala API for VTE library (GTK 4 version).
177
178 %description -n vala-vte-gtk4 -l pl.UTF-8
179 API języka Vala dla biblioteki VTE (wersja dla GTK 4).
180
181 %package gtk4-apidocs
182 Summary:        VTE API documentation (GTK 4 version)
183 Summary(pl.UTF-8):      Dokumentacja API VTE (wersja dla GTK 4)
184 Group:          Documentation
185 BuildArch:      noarch
186
187 %description gtk4-apidocs
188 VTE API documentation (GTK 4 version).
189
190 %description gtk4-apidocs -l pl.UTF-8
191 Dokumentacja API VTE (wersja dla GTK 4).
192
193 %prep
194 %setup -q
195 %patch0 -p1
196
197 # it seems 9.0 with -std=gnu++2a is sufficient for 0.68.x (-std=gnu++20 option was added in 10.0)
198 %{__sed} -i -e '/cxx_req_std/ s/gnu++20/gnu++2a/; /gxx_req_version/ s/10\.0/9.0/' meson.build
199 # ...except for single test, which wants consteval and constinit
200 %{__sed} -i -e 's/consteval //;s/constinit //' src/pastify-test.cc
201
202 %build
203 %meson build \
204         %{?with_apidocs:-Ddocs=true} \
205         %{!?with_glade:-Dglade=false} \
206         -Dgtk3=true \
207         -Dgtk4=%{__true_false gtk4} \
208         %{!?with_systemd:-D_systemd=false} \
209
210 %ninja_build -C build
211
212 %install
213 rm -rf $RPM_BUILD_ROOT
214
215 %ninja_install -C build
216
217 %if %{with apidocs}
218 # FIXME: where to package gi-docgen generated docs?
219 install -d $RPM_BUILD_ROOT%{_gidocdir}
220 %{__mv} $RPM_BUILD_ROOT%{_docdir}/vte-2.91* $RPM_BUILD_ROOT%{_gidocdir}
221 %endif
222
223 %find_lang %{name}-2.91
224
225 %clean
226 rm -rf $RPM_BUILD_ROOT
227
228 %post   -p /sbin/ldconfig
229 %postun -p /sbin/ldconfig
230
231 %post   gtk4 -p /sbin/ldconfig
232 %postun gtk4 -p /sbin/ldconfig
233
234 %files -f vte-2.91.lang
235 %defattr(644,root,root,755)
236 %doc AUTHORS ChangeLog README.md
237 %attr(755,root,root) %{_bindir}/vte-2.91
238 # gtk-version neutral, move to common?
239 %attr(755,root,root) %{_libexecdir}/vte-urlencode-cwd
240 %attr(755,root,root) %{_libdir}/libvte-2.91.so.*.*.*
241 %attr(755,root,root) %ghost %{_libdir}/libvte-2.91.so.0
242 %{_libdir}/girepository-1.0/Vte-2.91.typelib
243 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/vte.csh
244 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/vte.sh
245 %if %{with systemd}
246 %dir %{systemduserunitdir}/vte-spawn-.scope.d
247 %{systemduserunitdir}/vte-spawn-.scope.d/defaults.conf
248 %endif
249
250 %files devel
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_libdir}/libvte-2.91.so
253 %{_includedir}/vte-2.91
254 %{_pkgconfigdir}/vte-2.91.pc
255 %{_datadir}/gir-1.0/Vte-2.91.gir
256
257 %if %{with glade}
258 %files glade
259 %defattr(644,root,root,755)
260 %{_datadir}/glade/catalogs/vte-2.91.xml
261 %{_datadir}/glade/pixmaps/hicolor/*x*/actions/widget-vte-terminal.png
262 %endif
263
264 %files -n vala-vte
265 %defattr(644,root,root,755)
266 %{_datadir}/vala/vapi/vte-2.91.deps
267 %{_datadir}/vala/vapi/vte-2.91.vapi
268
269 %if %{with apidocs}
270 %files apidocs
271 %defattr(644,root,root,755)
272 %{_gidocdir}/vte-2.91
273 %endif
274
275 %if %{with gtk4}
276 %files gtk4
277 %defattr(644,root,root,755)
278 %attr(755,root,root) %{_bindir}/vte-2.91-gtk4
279 %attr(755,root,root) %{_libdir}/libvte-2.91-gtk4.so.0
280 %{_libdir}/girepository-1.0/Vte-3.91.typelib
281
282 %files gtk4-devel
283 %defattr(644,root,root,755)
284 %attr(755,root,root) %{_libdir}/libvte-2.91-gtk4.so
285 %{_includedir}/vte-2.91-gtk4
286 %{_pkgconfigdir}/vte-2.91-gtk4.pc
287 %{_datadir}/gir-1.0/Vte-3.91.gir
288
289 %files -n vala-vte-gtk4
290 %defattr(644,root,root,755)
291 %{_datadir}/vala/vapi/vte-2.91-gtk4.deps
292 %{_datadir}/vala/vapi/vte-2.91-gtk4.vapi
293
294 %if %{with apidocs}
295 %files gtk4-apidocs
296 %defattr(644,root,root,755)
297 %{_gidocdir}/vte-2.91-gtk4
298 %endif
299 %endif
This page took 0.058585 seconds and 3 git commands to generate.