]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
376cdc3625d3df948cf96d9c8515596d241f0d0d
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_with     glx     # drawing using GLX
4 #
5 Summary:        VTE terminal widget library
6 Summary(pl.UTF-8):      Biblioteka z kontrolką terminala VTE
7 Name:           vte
8 Version:        0.17.4
9 Release:        2
10 License:        LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vte/0.17/%{name}-%{version}.tar.bz2
13 # Source0-md5:  ec6cb2668db7146eae7cfc48af98f3ed
14 # http://bugzilla.gnome.org/show_bug.cgi?id=552096
15 Patch0:         %{name}-link.patch
16 %{?with_glx:BuildRequires:      OpenGL-GLU-devel}
17 %{?with_glx:BuildRequires:      OpenGL-GLX-devel}
18 BuildRequires:  autoconf >= 2.59-9
19 BuildRequires:  automake >= 1:1.9
20 BuildRequires:  gettext-devel
21 BuildRequires:  gtk+2-devel >= 2:2.14.0
22 BuildRequires:  gtk-doc >= 1.8
23 BuildRequires:  gtk-doc-automake
24 BuildRequires:  intltool >= 0.40.0
25 BuildRequires:  libtool
26 BuildRequires:  ncurses-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-pygtk-devel >= 2:2.12.0
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.197
31 Requires(pre):  utempter
32 # sr@Latn vs. sr@latin
33 Conflicts:      glibc-misc < 6:2.7
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The vte package contains a terminal widget for GTK+. It's used by
38 gnome-terminal among other programs.
39
40 %description -l pl.UTF-8
41 Ten pakiet zawiera kontrolkę terminala dla GTK+. Jest używany przez
42 gnome-terminal oraz inne programy.
43
44 %package devel
45 Summary:        Headers for VTE
46 Summary(pl.UTF-8):      Pliki nagłówkowe VTE
47 Group:          X11/Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 %{?with_glx:Requires:   OpenGL-GLU-devel}
50 Requires:       gtk+2-devel >= 2:2.14.0
51 Requires:       ncurses-devel
52 Conflicts:      gnome-libs-devel < 1.4.1.2
53
54 %description devel
55 The vte package contains a terminal widget for GTK+. It's used by
56 gnome-terminal among other programs.
57
58 You should install the vte-devel package if you would like to compile
59 applications that use the vte terminal widget. You do not need to
60 install vte-devel if you just want to use precompiled applications.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe potrzebne do kompilowania programów używających vte.
64
65 %package static
66 Summary:        Static VTE library
67 Summary(pl.UTF-8):      Statyczna biblioteka VTE
68 Group:          X11/Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70 Conflicts:      gnome-libs-static < 1.4.1.2
71
72 %description static
73 Static version of VTE libraries.
74
75 %description static -l pl.UTF-8
76 Statyczna wersja bibliotek VTE.
77
78 %package -n python-vte
79 Summary:        Python VTE module
80 Summary(pl.UTF-8):      Moduł VTE dla pythona
81 Group:          Libraries
82 %pyrequires_eq  python-libs
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       python-pygtk-gtk >= 2:2.12.0
85
86 %description -n python-vte
87 Python VTE library.
88
89 %description -n python-vte -l pl.UTF-8
90 Biblioteka VTE dla pythona.
91
92 %package apidocs
93 Summary:        VTE API documentation
94 Summary(pl.UTF-8):      Dokumentacja API VTE
95 Group:          Documentation
96 Requires:       gtk-doc-common
97
98 %description apidocs
99 VTE API documentation.
100
101 %description apidocs -l pl.UTF-8
102 Dokumentacja API VTE.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107
108 %build
109 %{__glib_gettextize}
110 %{__intltoolize}
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoheader}
114 %{__automake}
115 %{__autoconf}
116 cd gnome-pty-helper
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoheader}
120 %{__automake}
121 %{__autoconf}
122 cd ..
123 %configure \
124         --enable-gtk-doc \
125         --with-default-emulation=xterm \
126         %{?with_glx:--with-glX} \
127         --with-html-dir=%{_gtkdocdir} \
128         --with-pangox \
129         --with-xft2
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/*.{la,a}
140
141 %find_lang %{name}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files -f vte.lang
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
152 %attr(755,root,root) %{_bindir}/vte
153 %attr(755,root,root) %{_libdir}/libvte.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libvte.so.9
155 %dir %{_libdir}/vte
156 %attr(755,root,root) %{_libdir}/vte/*
157 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
158 %{_datadir}/vte
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libvte.so
163 %{_libdir}/libvte.la
164 %{_includedir}/vte
165 %{_pkgconfigdir}/vte.pc
166
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/libvte.a
170
171 %files apidocs
172 %defattr(644,root,root,755)
173 %{_gtkdocdir}/vte
174
175 %files -n python-vte
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{py_sitedir}/gtk-2.0/vtemodule.so
This page took 0.067472 seconds and 3 git commands to generate.