]> git.pld-linux.org Git - packages/vte.git/blob - vte.spec
- updated to 0.16.9
[packages/vte.git] / vte.spec
1 #
2 # Conditional build:
3 %bcond_with     glx     # drawing using GLX
4 #
5 Summary:        VTE terminal widget library
6 Summary(pl.UTF-8):      Biblioteka z kontrolką terminala VTE
7 Name:           vte
8 Version:        0.16.9
9 Release:        1
10 License:        LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vte/0.16/%{name}-%{version}.tar.bz2
13 # Source0-md5:  a42c893a01e3d9818789be373e529422
14 Patch0:         %{name}-keys.patch
15 Patch1:         %{name}-link.patch
16 %{?with_glx:BuildRequires:      OpenGL-GLU-devel}
17 %{?with_glx:BuildRequires:      OpenGL-GLX-devel}
18 BuildRequires:  autoconf >= 2.59-9
19 BuildRequires:  automake >= 1:1.6
20 BuildRequires:  gettext-devel
21 BuildRequires:  gtk+2-devel >= 2:2.12.0
22 BuildRequires:  gtk-doc >= 1.8
23 BuildRequires:  gtk-doc-automake
24 BuildRequires:  intltool >= 0.36.2
25 BuildRequires:  libtool
26 BuildRequires:  ncurses-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-pygtk-devel >= 2:2.12.0
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.197
31 Requires(pre):  utempter
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The vte package contains a terminal widget for GTK+. It's used by
36 gnome-terminal among other programs.
37
38 %description -l pl.UTF-8
39 Ten pakiet zawiera kontrolkę terminala dla GTK+. Jest używany przez
40 gnome-terminal oraz inne programy.
41
42 %package devel
43 Summary:        Headers for VTE
44 Summary(pl.UTF-8):      Pliki nagłówkowe VTE
45 Group:          X11/Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 %{?with_glx:Requires:   OpenGL-GLU-devel}
48 Requires:       gtk+2-devel >= 2:2.12.0
49 Requires:       ncurses-devel
50 Conflicts:      gnome-libs-devel < 1.4.1.2
51
52 %description devel
53 The vte package contains a terminal widget for GTK+. It's used by
54 gnome-terminal among other programs.
55
56 You should install the vte-devel package if you would like to compile
57 applications that use the vte terminal widget. You do not need to
58 install vte-devel if you just want to use precompiled applications.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe potrzebne do kompilowania programów używających vte.
62
63 %package static
64 Summary:        Static VTE library
65 Summary(pl.UTF-8):      Statyczna biblioteka VTE
66 Group:          X11/Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68 Conflicts:      gnome-libs-static < 1.4.1.2
69
70 %description static
71 Static version of VTE libraries.
72
73 %description static -l pl.UTF-8
74 Statyczna wersja bibliotek VTE.
75
76 %package -n python-vte
77 Summary:        Python VTE module
78 Summary(pl.UTF-8):      Moduł VTE dla pythona
79 Group:          Libraries
80 %pyrequires_eq  python-libs
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       python-pygtk-gtk >= 2:2.12.0
83
84 %description -n python-vte
85 Python VTE library.
86
87 %description -n python-vte -l pl.UTF-8
88 Biblioteka VTE dla pythona.
89
90 %package apidocs
91 Summary:        VTE API documentation
92 Summary(pl.UTF-8):      Dokumentacja API VTE
93 Group:          Documentation
94 Requires:       gtk-doc-common
95
96 %description apidocs
97 VTE API documentation.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API VTE.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106
107 %build
108 %{__glib_gettextize}
109 %{__intltoolize}
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoheader}
113 %{__automake}
114 %{__autoconf}
115 cd gnome-pty-helper
116 %{__libtoolize}
117 %{__aclocal}
118 %{__autoheader}
119 %{__automake}
120 %{__autoconf}
121 cd ..
122 %configure \
123         --enable-gtk-doc \
124         --with-default-emulation=xterm \
125         %{?with_glx:--with-glX} \
126         --with-html-dir=%{_gtkdocdir} \
127         --with-pangox \
128         --with-xft2
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/*.{la,a}
139
140 %find_lang vte
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f vte.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
151 %attr(755,root,root) %{_bindir}/vte
152 %attr(755,root,root) %{_libdir}/libvte.so.*.*.*
153 %dir %{_libdir}/vte
154 %attr(755,root,root) %{_libdir}/vte/*
155 %attr(2755,root,utmp) %{_libdir}/gnome-pty-helper
156 %{_datadir}/vte
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libvte.so
161 %{_libdir}/libvte.la
162 %{_includedir}/vte
163 %{_pkgconfigdir}/vte.pc
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libvte.a
168
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/vte
172
173 %files -n python-vte
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{py_sitedir}/gtk-2.0/vtemodule.so
This page took 0.069768 seconds and 3 git commands to generate.