]> git.pld-linux.org Git - packages/volume_key.git/blob - volume_key.spec
af2dd0da1ac8b2854d1f5010b1f6fd4394f25f65
[packages/volume_key.git] / volume_key.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x binding
4 %bcond_without  python3 # CPython 3.x binding
5
6 Summary:        An utility for manipulating storage encryption keys and passphrases
7 Summary(pl.UTF-8):      Narzędzie do operacji na kluczach i hasłach do szyfrowania dysków
8 Name:           volume_key
9 Version:        0.3.12
10 Release:        2
11 License:        GPL v2
12 Group:          Applications/System
13 Source0:        https://releases.pagure.org/volume_key/%{name}-%{version}.tar.xz
14 # Source0-md5:  200591290173c3ea71528411838f9080
15 URL:            https://pagure.io/volume_key/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake
18 BuildRequires:  cryptsetup-devel
19 BuildRequires:  gettext-tools >= 0.18.2
20 BuildRequires:  glib2-devel >= 2.0
21 BuildRequires:  gpgme-devel
22 BuildRequires:  libblkid-devel
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  nss-devel
25 BuildRequires:  pkgconfig
26 %{?with_python2:BuildRequires:  python-devel >= 1:2.4}
27 %{?with_python3:BuildRequires:  python3-devel >= 1:3.5}
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       %{name}-libs = %{version}-%{release}
31 # gpg2 as /usr/bin/gpg
32 Requires:       gnupg2 >= 2.2
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This package provides a command-line tool for manipulating storage
37 volume encryption keys and storing them separately from volumes.
38
39 The main goal of the software is to allow restoring access to an
40 encrypted hard drive if the primary user forgets the passphrase. The
41 encryption key back up can also be useful for extracting data after a
42 hardware or software failure that corrupts the header of the encrypted
43 volume, or to access the company data after an employee leaves
44 abruptly.
45
46 %description -l pl.UTF-8
47 Ten pakiet zawiera narzędzie linii poleceń do operacji na kluczach do
48 szyfrowania wolumenów dyskowych oraz przechowywania ich poza
49 wolumenami.
50
51 Głównym celem tego oprogramowania jest umożliwienie przywracania
52 dostępu do szyfrowanych dysków twardych w sytuacji, kiedy użytkownik
53 zapomni hasła. Kopia zapasowa klucza szyfrującego może być przydatna
54 także do wydobywania danych po awarii sprzętu lub oprogramowania,
55 wiążącej się z uszkodzeniem nagłówka zaszyfrowanego wolumenu, albo
56 dostępu do danych firmowych po nagłym odejściu pracownika.
57
58 %package libs
59 Summary:        A library for manipulating storage encryption keys and passphrases
60 Summary(pl.UTF-8):      Biblioteka do operacji na kluczach i hasłach do szyfrowania dysków
61 Group:          Libraries
62
63 %description libs
64 This package provides libvolume_key, a library for manipulating
65 storage volume encryption keys and storing them separately from
66 volumes.
67
68 %description libs -l pl.UTF-8
69 Ten pakiet zawiera bibliotekę libvolume_key, służącą do operacji na
70 kluczach do szyfrowania wolumenów dyskowych oraz przechowywania ich
71 poza wolumenami.
72
73 %package devel
74 Summary:        Header files for volume_key library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki volume_key
76 Group:          Development/Libraries
77 Requires:       %{name}-libs = %{version}-%{release}
78
79 %description devel
80 Header files for volume_key library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki volume_key.
84
85 %package -n python-%{name}
86 Summary:        Python 2 bindings for volume_key library
87 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki volume_key
88 Group:          Libraries
89 Requires:       %{name}-libs = %{version}-%{release}
90
91 %description -n python-%{name}
92 This package provides Python 2 bindings for libvolume_key, a library
93 for manipulating storage volume encryption keys and storing them
94 separately from volumes.
95
96 %description -n python-%{name} -l pl.UTF-8
97 Ten pakiet zawiera wiązania Pythona 2 do biblioteki libvolume_key,
98 służącej do operacji na kluczach do szyfrowania wolumenów dyskowych
99 oraz przechowywania ich poza wolumenami.
100
101 %package -n python3-%{name}
102 Summary:        Python 3 bindings for volume_key library
103 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki volume_key
104 Group:          Libraries
105 Requires:       %{name}-libs = %{version}-%{release}
106
107 %description -n python3-%{name}
108 This package provides Python 3 bindings for libvolume_key, a library
109 for manipulating storage volume encryption keys and storing them
110 separately from volumes.
111
112 %description -n python3-%{name} -l pl.UTF-8
113 Ten pakiet zawiera wiązania Pythona 3 do biblioteki libvolume_key,
114 służącej do operacji na kluczach do szyfrowania wolumenów dyskowych
115 oraz przechowywania ich poza wolumenami.
116
117 %prep
118 %setup -q
119
120 %build
121 %{__libtoolize}
122 %{__aclocal} -I m4
123 %{__autoconf}
124 %{__autoheader}
125 %{__automake}
126 %configure \
127         GPG=/usr/bin/gpg \
128         %{!?with_python2:--without-python} \
129         %{!?with_python3:--without-python3}
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 %if %{with python2}
139 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
140 %py_postclean
141 %endif
142
143 %if %{with python3}
144 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/*.la
145 %endif
146
147 %find_lang %{name}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   libs -p /sbin/ldconfig
153 %postun libs -p /sbin/ldconfig
154
155 %files -f %{name}.lang
156 %defattr(644,root,root,755)
157 %doc AUTHORS ChangeLog NEWS README
158 %attr(755,root,root) %{_bindir}/volume_key
159 %{_mandir}/man8/volume_key.8*
160
161 %files libs
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libvolume_key.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libvolume_key.so.1
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libvolume_key.so
169 # TODO: drop when .pc file is introduced
170 %{_libdir}/libvolume_key.la
171 %{_includedir}/volume_key
172
173 %if %{with python2}
174 %files -n python-%{name}
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{py_sitedir}/_volume_key.so
177 %{py_sitedir}/volume_key.py[co]
178 %endif
179
180 %if %{with python3}
181 %files -n python3-%{name}
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{py3_sitedir}/_volume_key.so
184 %{py3_sitedir}/volume_key.py
185 %{py3_sitedir}/__pycache__/volume_key.cpython-*.py[co]
186 %endif
This page took 0.062348 seconds and 3 git commands to generate.