]> git.pld-linux.org Git - packages/vlc.git/blob - vlc.spec
- wx.patch is useless
[packages/vlc.git] / vlc.spec
1 #
2 # TODO:
3 # - check the altivec patch
4 # - add proper package descriptions/translations
5 # - bcondize this damn spec! (it should be automated too)
6 # - go through the configure --help and add all options with proper
7 #   reqs and bconds
8 # - flac plugin doesn't work with mono files
9 #
10 # Conditional build:
11 %bcond_without  aalib   # build without aalib support
12 %bcond_without  caca    # build without caca support
13 %bcond_without  dv      # build without dv support
14 %bcond_without  lirc    # build without lirc support
15 %bcond_without  x264    # build without x264 support
16 %bcond_without  alsa    # don't build alsa plugin
17 %bcond_without  arts    # don't build arts plugin
18 %bcond_without  ggi     # don't build ggi plugin
19 %bcond_without  live    # build without live.com support
20 %bcond_without  speex   # don't build speex plugin
21 %bcond_with     mozilla # build mozilla plugin
22 %bcond_with     slp     # build with slp, broken
23 %bcond_with     svgalib # build with svgalib video_output
24 %bcond_with     hal     # build with hal support
25 #
26 Summary:        VLC - a multimedia player and stream server
27 Summary(pl.UTF-8):      VLC - odtwarzacz multimedialny oraz serwer strumieni
28 Name:           vlc
29 Version:        0.8.6f
30 Release:        1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 # use the bz2 src, its a 4mb difference
34 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
35 # Source0-md5:  c3aded2583fcdb9f4c71d3fc3601b73b
36 Source1:        %{name}.desktop
37 Patch0:         %{name}-altivec.patch
38 Patch1:         %{name}-buildflags.patch
39 Patch2:         %{name}-defaultfont.patch
40 Patch3:         %{name}-live.patch
41 Patch4:         %{name}-pic-mmx.patch
42 Patch5:         %{name}-real_codecs_path.patch
43 Patch6:         %{name}-osdmenu_path.patch
44 URL:            http://www.videolan.org/vlc/
45 BuildRequires:  OpenGL-devel
46 BuildRequires:  SDL_image-devel >= 1.2
47 BuildRequires:  a52dec-libs-devel
48 %{?with_aalib:BuildRequires:    aalib-devel}
49 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9}
50 %{?with_arts:BuildRequires:     artsc-devel}
51 BuildRequires:  autoconf
52 BuildRequires:  automake
53 BuildRequires:  esound-devel
54 BuildRequires:  faad2-devel >= 2.5
55 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080131.1
56 BuildRequires:  flac-devel >= 1.1.3
57 BuildRequires:  fribidi-devel
58 BuildRequires:  gettext-devel
59 %{?with_hal:BuildRequires:      hal-devel >= 0.2.97}
60 %{?with_dv:BuildRequires:       libavc1394-devel}
61 %{?with_caca:BuildRequires:     libcaca-devel}
62 BuildRequires:  libcddb-devel
63 BuildRequires:  libcdio-devel
64 BuildRequires:  libdts-devel
65 %{?with_dv:BuildRequires:       libdv-devel}
66 BuildRequires:  libdvbpsi-devel
67 BuildRequires:  libdvdcss-devel
68 BuildRequires:  libdvdnav-devel
69 BuildRequires:  libdvdread-devel
70 BuildRequires:  libebml-devel >= 0.7.6
71 %{?with_ggi:BuildRequires:      libggi-devel}
72 BuildRequires:  libid3tag-devel
73 BuildRequires:  libmad-devel
74 BuildRequires:  libmatroska-devel >= 0.7.5
75 BuildRequires:  libmodplug-devel
76 BuildRequires:  libmpcdec-devel >= 1.2.1
77 BuildRequires:  libogg-devel
78 BuildRequires:  libpng-devel
79 %{?with_dv:BuildRequires:       libraw1394-devel}
80 BuildRequires:  libsmbclient-devel
81 BuildRequires:  libtheora-devel
82 BuildRequires:  libtool
83 BuildRequires:  libvorbis-devel
84 %{?with_x264:BuildRequires:     libx264-devel}
85 BuildRequires:  libxml2-devel
86 %{?with_lirc:BuildRequires:     lirc-devel}
87 %{?with_live:BuildRequires:     live >= 2005.03.11}
88 %{?with_mozilla:BuildRequires:  mozilla-devel}
89 BuildRequires:  mpeg2dec-devel >= 0.3.2
90 BuildRequires:  ncurses-devel
91 %{?with_slp:BuildRequires:      openslp-devel}
92 BuildRequires:  pkgconfig
93 %{?with_speex:BuildRequires:    speex-devel > 1:1.1.0}
94 %{?with_svgalib:BuildRequires:  svgalib-devel}
95 BuildRequires:  vcdimager-devel
96 BuildRequires:  wxGTK2-unicode-devel >= 2.6.2-2
97 BuildRequires:  xosd-devel
98 BuildRequires:  xvid-devel
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %description
102 VLC (initially VideoLAN Client) is a multimedia player for various
103 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
104 as well as DVDs, VCDs, and various streaming protocols. It can also be
105 used as a server to stream in unicast or multicast in IPv4 or IPv6 on
106 a high-bandwidth network.
107
108 %description -l pl.UTF-8
109 VLC (wcześniej znany pod nazwą VideoLAN Client) jest odtwarzaczem
110 multimedialnym dla wielu formatów wideo i dźwięku (MPEG-1, MPEG-2,
111 MPEG-4, DivX, MP3, Ogg, ...), płyt DVD, VCD oraz różnych protokołów
112 strumieniowych. Może być wykorzystany jako serwer do wysyłania
113 strumieni unicast lub multicast w protokołach IPv4 lub IPv6 w
114 wysokoprzepustowych sieciach.
115
116 %package devel
117 Summary:        VLC header files
118 Summary(pl.UTF-8):      Pliki nagłówkowe VLC
119 Group:          X11/Development/Libraries
120 Requires:       %{name} = %{version}-%{release}
121
122 %description devel
123 VLC header files.
124
125 %description devel -l pl.UTF-8
126 Pliki nagłówkowe VLC.
127
128 %package static
129 Summary:        VLC static libraries
130 Summary(pl.UTF-8):      Biblioteki statyczne VLC
131 Group:          X11/Development/Libraries
132 Requires:       %{name}-devel = %{version}-%{release}
133
134 %description static
135 VLC static libraries.
136
137 %description static -l pl.UTF-8
138 Biblioteki statyczne VLC.
139
140 %package X11
141 Summary:        VLC - X11 output plugin
142 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia X11
143 Group:          X11/Applications/Multimedia
144 Requires:       %{name} = %{version}-%{release}
145 Obsoletes:      vlc-gnome
146 Obsoletes:      vlc-gtk
147
148 %description X11
149 X11 output plugin for VLC. Contains GUI image/icon resources.
150
151 %description X11 -l pl.UTF-8
152 Wtyczka wyjścia X11 dla klienta VLC. Zawiera zasoby interfejsu GUI
153 (obrazy/ikony).
154
155 %package GGI
156 Summary:        VLC - GGI output plugin
157 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia GGI
158 Group:          X11/Applications/Multimedia
159 Requires:       %{name} = %{version}-%{release}
160
161 %description GGI
162 GGI output plugin for VLC.
163
164 %description GGI -l pl.UTF-8
165 Wtyczka wyjścia GGI dla klienta VLC.
166
167 %package fb
168 Summary:        VLC - fb output plugin
169 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia fb
170 Group:          X11/Applications/Multimedia
171 Requires:       %{name} = %{version}-%{release}
172
173 %description fb
174 fb output plugin for VLC.
175
176 %description fb -l pl.UTF-8
177 Wtyczka wyjścia fb dla klienta VLC.
178
179 %package SDL
180 Summary:        VLC - SDL output plugin
181 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia SDL
182 Group:          X11/Applications/Multimedia
183 Requires:       %{name} = %{version}-%{release}
184
185 %description SDL
186 SDL output plugin for VLC.
187
188 %description SDL -l pl.UTF-8
189 Wtyczka wyjścia SDL dla klienta VLC.
190
191 %package esd
192 Summary:        VLC - EsounD audio output plugin
193 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia dźwięku EsounD
194 Group:          X11/Applications/Multimedia
195 Requires:       %{name} = %{version}-%{release}
196
197 %description esd
198 EsounD audio output plugin for VLC.
199
200 %description esd -l pl.UTF-8
201 Wtyczka wyjścia dźwięku EsounD dla klienta VLC.
202
203 %package alsa
204 Summary:        VLC - ALSA audio output plugin
205 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia dźwięku ALSA
206 Group:          X11/Applications/Multimedia
207 Requires:       %{name} = %{version}-%{release}
208
209 %description alsa
210 ALSA audio output plugin for VLC.
211
212 %description alsa -l pl.UTF-8
213 Wtyczka wyjścia dźwięku ALSA dla klienta VLC.
214
215 %prep
216 %setup -q
217 ## %patch0 -p1
218 %patch1 -p0
219 %patch2 -p1
220 %patch3 -p1
221 %patch4 -p1
222 %patch5 -p1
223 %patch6 -p1
224
225 %build
226 cp -f /usr/share/automake/config.* .
227 %{__gettextize}
228 %{__aclocal} -I m4
229 %{__autoconf}
230 %configure \
231 %ifarch ppc
232         --disable-altivec \
233 %endif
234         --%{?with_aalib:en}%{!?with_aalib:dis}able-aa \
235         %{?with_alsa:--enable-alsa} \
236         %{?with_arts:--enable-arts} \
237         %{!?with_arts:--disable-arts} \
238         --%{?with_caca:en}%{!?with_caca:dis}able-caca \
239         --enable-dsp \
240         --enable-dummy \
241         --%{?with_dv:en}%{!?with_dv:dis}able-dv \
242         --enable-dvb \
243         --enable-dvbpsi \
244         --with-dvdcss \
245         --enable-dvdnav \
246         --enable-dvdread \
247         --enable-esd \
248         --enable-faad \
249         --enable-fb \
250         --enable-freetype \
251         --enable-fribidi \
252         --enable-ffmpeg \
253         --enable-flac \
254         --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
255         %{!?with_speex:--disable-speex} \
256         --disable-glide \
257         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
258         --enable-mad \
259         --enable-mga \
260         %{?with_mozilla:--enable-mozilla } \
261         %{?with_live:--enable-live555 } \
262         %{!?with_live:--disable-live555 } \
263         --with-live555-tree=%{_libdir}/liveMedia \
264         --enable-ncurses \
265         --enable-pvr \
266         --enable-real \
267         --enable-realrtsp \
268         --enable-sdl \
269         --with-sdl=/usr \
270         --enable-skins2 \
271         %{?with_slp:--enable-slp} \
272         %{!?with_slp:--disable-slp} \
273         --enable-smb \
274         %{?with_svgalib:--enable-svgalib} \
275         --enable-tarkin \
276         --enable-theora \
277         --enable-tremor \
278         --enable-v4l\
279         --enable-x11 \
280         %{!?with_x264:--disable-x264} \
281         --enable-xosd \
282         --enable-xvid \
283         --enable-oss \
284         --disable-testsuite \
285         --disable-macosx \
286         --with-wx-config=wx-gtk2-unicode-config \
287         %{!?with_hal:--disable-hal} \
288         --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
289
290 # echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
291 %{__make}
292
293 %install
294 rm -rf $RPM_BUILD_ROOT
295 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
296
297 %{__make} install \
298         DESTDIR=$RPM_BUILD_ROOT
299
300 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
301 install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
302
303 %if "%{_lib}" != "lib"
304 install -d $RPM_BUILD_ROOT%{_prefix}/lib
305 ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
306 %endif
307
308 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/co
309
310 %find_lang %{name}
311
312 %clean
313 rm -rf $RPM_BUILD_ROOT
314
315 %files -f %{name}.lang
316 %defattr(644,root,root,755)
317 %doc AUTHORS MAINTAINERS NEWS README THANKS
318 %doc doc/bugreport-howto.txt doc/intf-cdda.txt
319 %doc doc/intf-vcd.txt doc/translations.txt
320 %attr(755,root,root) %{_bindir}/vlc
321 %if "%{_lib}" != "lib"
322 %{_prefix}/lib/vlc
323 %endif
324 %dir %{_libdir}/vlc
325 %dir %{_libdir}/vlc/gui
326 %dir %{_libdir}/vlc/visualization
327 %attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
328 %attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
329 %attr(755,root,root) %{_libdir}/vlc/mux
330 %attr(755,root,root) %{_libdir}/vlc/misc
331 %attr(755,root,root) %{_libdir}/vlc/control
332 %attr(755,root,root) %{_libdir}/vlc/access_output
333 %attr(755,root,root) %{_libdir}/vlc/codec
334 %attr(755,root,root) %{_libdir}/vlc/demux
335 %attr(755,root,root) %{_libdir}/vlc/access
336 %exclude %{_libdir}/vlc/access/libscreen_plugin.so
337 %attr(755,root,root) %{_libdir}/vlc/video_chroma
338 %attr(755,root,root) %{_libdir}/vlc/audio_mixer
339 %attr(755,root,root) %{_libdir}/vlc/video_filter
340 %dir %{_libdir}/vlc/video_output
341 %attr(755,root,root) %{_libdir}/vlc/stream_out
342 %attr(755,root,root) %{_libdir}/vlc/audio_filter
343 %attr(755,root,root) %{_libdir}/vlc/packetizer
344 %attr(755,root,root) %{_libdir}/vlc/access_filter
345 %attr(755,root,root) %{_libdir}/vlc/services_discovery
346 %dir %{_libdir}/vlc/audio_output
347 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
348 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
349 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
350 %attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
351 %dir %{_datadir}/%{name}
352 %{_datadir}/%{name}/http
353 %{_datadir}/%{name}/osdmenu
354 %{_mandir}/man1/vlc.1*
355
356 %files devel
357 %defattr(644,root,root,755)
358 %attr(755,root,root) %{_bindir}/vlc-config
359 %dir %{_includedir}/%{name}
360 %{_includedir}/%{name}/*
361
362 %files static
363 %defattr(644,root,root,755)
364 %{_libdir}/libvlc.a
365 %{_libdir}/%{name}/*.a
366
367 %files X11
368 %defattr(644,root,root,755)
369 %attr(755,root,root) %{_bindir}/svlc
370 %attr(755,root,root) %{_bindir}/wxvlc
371 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
372 %attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
373 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
374 %attr(755,root,root) %{_libdir}/vlc/video_output
375 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
376 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
377 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
378 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
379 %{_datadir}/%{name}/skins2
380 %{_datadir}/%{name}/vlc*.xpm
381 %{_datadir}/%{name}/pda*.xpm
382 %{_datadir}/%{name}/vlc*.png
383 %{_datadir}/%{name}/vlc*.ico
384 %{_desktopdir}/*.desktop
385
386 %if %{with ggi}
387 %files GGI
388 %defattr(644,root,root,755)
389 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
390 %endif
391
392 %files SDL
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
395 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
396
397 %files fb
398 %defattr(644,root,root,755)
399 %attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
400
401 %files esd
402 %defattr(644,root,root,755)
403 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
404
405 %if %{with alsa}
406 %files alsa
407 %defattr(644,root,root,755)
408 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
409 %endif
This page took 0.101048 seconds and 4 git commands to generate.