]> git.pld-linux.org Git - packages/vlc.git/blob - vlc.spec
- gcc-hack fixed properly
[packages/vlc.git] / vlc.spec
1 #
2 # TODO:
3 # - check the altivec patch
4 # - add proper package descriptions/translations
5 # - bcondize this damn spec! (it should be automated too)
6 # - go through the configure --help and add all options with proper
7 #   reqs and bconds
8 #
9 # Conditional build:
10 %bcond_without  aa      # build without aalib support
11 %bcond_without  caca    # build without caca support
12 %bcond_without  dv      # build without dv support
13 %bcond_without  lirc    # build without lirc support
14 %bcond_without  x264    # build without x264 support
15 %bcond_without  alsa    # don't build alsa plugin
16 %bcond_without  arts    # don't build arts plugin
17 %bcond_without  ggi     # don't build ggi plugin
18 %bcond_without  live    # build without live.com support
19 %bcond_without  speex   # don't build speex plugin
20 %bcond_with     mozilla # build mozilla plugin
21 %bcond_with     slp     # build with slp, broken
22 %bcond_with     svgalib # build with svgalib video_output
23 %bcond_with     hal     # build with hal support
24 #
25 Summary:        VLC - a multimedia player and stream server
26 Summary(pl):    VLC - odtwarzacz multimedialny oraz serwer strumieni
27 Name:           vlc
28 Version:        0.8.6
29 Release:        2
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 # use the bz2 src, its a 4mb difference
33 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
34 # Source0-md5:  77a275f3408c4c9feae451d4eae47f89
35 Source1:        %{name}.desktop
36 Patch0:         %{name}-altivec.patch
37 Patch1:         %{name}-buildflags.patch
38 Patch2:         %{name}-defaultfont.patch
39 Patch3:         %{name}-live.patch
40 Patch4:         %{name}-pic-mmx.patch
41 Patch5:         %{name}-real_codecs_path.patch
42 Patch6:         %{name}-osdmenu_path.patch
43 URL:            http://www.videolan.org/vlc/
44 BuildRequires:  OpenGL-devel
45 BuildRequires:  SDL_image-devel >= 1.2
46 BuildRequires:  a52dec-libs-devel
47 %{?with_aa:BuildRequires:       aalib-devel}
48 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9}
49 %{?with_arts:BuildRequires:     artsc-devel}
50 BuildRequires:  autoconf
51 BuildRequires:  automake
52 BuildRequires:  esound-devel
53 BuildRequires:  faad2-devel >= 2.5
54 BuildRequires:  ffmpeg-devel >= 0.4.9
55 BuildRequires:  flac-devel
56 BuildRequires:  fribidi-devel
57 BuildRequires:  gettext-devel
58 %{?with_hal:BuildRequires:      hal-devel >= 0.2.97}
59 %{?with_dv:BuildRequires:       libavc1394-devel}
60 %{?with_caca:BuildRequires:     libcaca-devel}
61 BuildRequires:  libcddb-devel
62 BuildRequires:  libcdio-devel
63 BuildRequires:  libdts-devel
64 %{?with_dv:BuildRequires:       libdv-devel}
65 BuildRequires:  libdvbpsi-devel
66 BuildRequires:  libdvdcss-devel
67 BuildRequires:  libdvdnav-devel
68 BuildRequires:  libdvdread-devel
69 BuildRequires:  libebml-devel >= 0.7.6
70 %{?with_ggi:BuildRequires:      libggi-devel}
71 BuildRequires:  libid3tag-devel
72 BuildRequires:  libmad-devel
73 BuildRequires:  libmatroska-devel >= 0.7.5
74 BuildRequires:  libmodplug-devel
75 BuildRequires:  libogg-devel
76 BuildRequires:  libpng-devel
77 %{?with_dv:BuildRequires:       libraw1394-devel}
78 BuildRequires:  libsmbclient-devel
79 BuildRequires:  libtheora-devel
80 BuildRequires:  libtool
81 BuildRequires:  libvorbis-devel
82 %{?with_x264:BuildRequires:     libx264-devel}
83 BuildRequires:  libxml2-devel
84 %{?with_lirc:BuildRequires:     lirc-devel}
85 %{?with_live:BuildRequires:     live >= 2005.03.11}
86 %{?with_mozilla:BuildRequires:  mozilla-devel}
87 BuildRequires:  mpeg2dec-devel >= 0.3.2
88 BuildRequires:  ncurses-devel
89 %{?with_slp:BuildRequires:      openslp-devel}
90 BuildRequires:  pkgconfig
91 %{?with_speex:BuildRequires:    speex-devel > 1:1.1.0}
92 %{?with_svgalib:BuildRequires:  svgalib-devel}
93 BuildRequires:  vcdimager-devel
94 BuildRequires:  wxGTK2-unicode-devel >= 2.6.2-2
95 BuildRequires:  xosd-devel
96 BuildRequires:  xvid-devel
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %description
100 VLC (initially VideoLAN Client) is a multimedia player for various
101 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
102 as well as DVDs, VCDs, and various streaming protocols. It can also be
103 used as a server to stream in unicast or multicast in IPv4 or IPv6 on
104 a high-bandwidth network.
105
106 %description -l pl
107 VLC (wcze¶niej znany pod nazw± VideoLAN Client) jest odtwarzaczem
108 multimedialnym dla wielu formatów wideo i d¼wiêku (MPEG-1, MPEG-2,
109 MPEG-4, DivX, MP3, Ogg, ...), p³yt DVD, VCD oraz ró¿nych protoko³ów
110 strumieniowych. Mo¿e byæ wykorzystany jako serwer do wysy³ania
111 strumieni unicast lub multicast w protoko³ach IPv4 lub IPv6 w
112 wysokoprzepustowych sieciach.
113
114 %package devel
115 Summary:        VLC header files
116 Summary(pl):    Pliki nag³ówkowe VLC
117 Group:          X11/Development/Libraries
118 Requires:       %{name} = %{version}-%{release}
119
120 %description devel
121 VLC header files.
122
123 %description devel -l pl
124 Pliki nag³ówkowe VLC.
125
126 %package static
127 Summary:        VLC static libraries
128 Summary(pl):    Biblioteki statyczne VLC
129 Group:          X11/Development/Libraries
130 Requires:       %{name}-devel = %{version}-%{release}
131
132 %description static
133 VLC static libraries.
134
135 %description static -l pl
136 Biblioteki statyczne VLC.
137
138 %package X11
139 Summary:        VLC - X11 output plugin
140 Summary(pl):    Klient VLC - wtyczka wyj¶cia X11
141 Group:          X11/Applications/Multimedia
142 Requires:       %{name} = %{version}-%{release}
143 Obsoletes:      vlc-gnome
144 Obsoletes:      vlc-gtk
145
146 %description X11
147 X11 output plugin for VLC. Contains GUI image/icon resources.
148
149 %description X11 -l pl
150 Wtyczka wyj¶cia X11 dla klienta VLC. Zawiera zasoby interfejsu GUI
151 (obrazy/ikony).
152
153 %package GGI
154 Summary:        VLC - GGI output plugin
155 Summary(pl):    Klient VLC - wtyczka wyj¶cia GGI
156 Group:          X11/Applications/Multimedia
157 Requires:       %{name} = %{version}-%{release}
158
159 %description GGI
160 GGI output plugin for VLC.
161
162 %description GGI -l pl
163 Wtyczka wyj¶cia GGI dla klienta VLC.
164
165 %package fb
166 Summary:        VLC - fb output plugin
167 Summary(pl):    Klient VLC - wtyczka wyj¶cia fb
168 Group:          X11/Applications/Multimedia
169 Requires:       %{name} = %{version}-%{release}
170
171 %description fb
172 fb output plugin for VLC.
173
174 %description fb -l pl
175 Wtyczka wyj¶cia fb dla klienta VLC.
176
177 %package SDL
178 Summary:        VLC - SDL output plugin
179 Summary(pl):    Klient VLC - wtyczka wyj¶cia SDL
180 Group:          X11/Applications/Multimedia
181 Requires:       %{name} = %{version}-%{release}
182
183 %description SDL
184 SDL output plugin for VLC.
185
186 %description SDL -l pl
187 Wtyczka wyj¶cia SDL dla klienta VLC.
188
189 %package esd
190 Summary:        VLC - EsounD audio output plugin
191 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku EsounD
192 Group:          X11/Applications/Multimedia
193 Requires:       %{name} = %{version}-%{release}
194
195 %description esd
196 EsounD audio output plugin for VLC.
197
198 %description esd -l pl
199 Wtyczka wyj¶cia d¼wiêku EsounD dla klienta VLC.
200
201 %package alsa
202 Summary:        VLC - ALSA audio output plugin
203 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku ALSA
204 Group:          X11/Applications/Multimedia
205 Requires:       %{name} = %{version}-%{release}
206
207 %description alsa
208 ALSA audio output plugin for VLC.
209
210 %description alsa -l pl
211 Wtyczka wyj¶cia d¼wiêku ALSA dla klienta VLC.
212
213 %prep
214 %setup -q
215 ## %patch0 -p1
216 %patch1 -p0
217 %patch2 -p1
218 %patch3 -p1
219 %patch4 -p1
220 %patch5 -p1
221 %patch6 -p1
222
223 %build
224 cp -f /usr/share/automake/config.* .
225 %{__gettextize}
226 %{__aclocal} -I m4
227 %{__autoconf}
228 CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
229 %configure \
230 %ifarch ppc
231         --disable-altivec \
232 %endif
233         --%{?with_aa:en}%{!?with_aa:dis}able-aa \
234         %{?with_alsa:--enable-alsa} \
235         %{?with_arts:--enable-arts} \
236         %{!?with_arts:--disable-arts} \
237         --%{?with_caca:en}%{!?with_caca:dis}able-caca \
238         --enable-dsp \
239         --enable-dummy \
240         --%{?with_dv:en}%{!?with_dv:dis}able-dv \
241         --enable-dvb \
242         --enable-dvbpsi \
243         --with-dvdcss \
244         --enable-dvdnav \
245         --enable-dvdread \
246         --enable-esd \
247         --enable-faad \
248         --enable-fb \
249         --enable-freetype \
250         --enable-fribidi \
251         --enable-ffmpeg \
252         --enable-flac \
253         --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
254         %{!?with_speex:--disable-speex} \
255         --disable-glide \
256         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
257         --enable-mad \
258         --enable-mga \
259         %{?with_mozilla:--enable-mozilla } \
260         %{?with_live:--enable-live555 } \
261         %{!?with_live:--disable-live555 } \
262         --with-live555-tree=%{_libdir}/liveMedia \
263         --enable-ncurses \
264         --enable-pvr \
265         --enable-real \
266         --enable-realrtsp \
267         --enable-sdl \
268         --with-sdl=/usr \
269         --enable-skins2 \
270         %{?with_slp:--enable-slp} \
271         %{!?with_slp:--disable-slp} \
272         --enable-smb \
273         %{?with_svgalib:--enable-svgalib} \
274         --enable-tarkin \
275         --enable-theora \
276         --enable-tremor \
277         --enable-v4l\
278         --enable-x11 \
279         %{!?with_x264:--disable-x264} \
280         --enable-xosd \
281         --enable-xvid \
282         --enable-oss \
283         --disable-testsuite \
284         --with-wx-config=wx-gtk2-unicode-config \
285         %{!?with_hal:--disable-hal} \
286         --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
287
288 # echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
289 %{__make}
290
291 %install
292 rm -rf $RPM_BUILD_ROOT
293 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
294
295 %{__make} install \
296         DESTDIR=$RPM_BUILD_ROOT
297
298 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
299 install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
300
301 %if "%{_lib}" != "lib"
302 install -d $RPM_BUILD_ROOT%{_prefix}/lib
303 ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
304 %endif
305
306 %find_lang %{name}
307
308 %clean
309 rm -rf $RPM_BUILD_ROOT
310
311 %files -f %{name}.lang
312 %defattr(644,root,root,755)
313 %doc AUTHORS MAINTAINERS NEWS README THANKS
314 %doc doc/bugreport-howto.txt doc/intf-cdda.txt
315 %doc doc/intf-vcd.txt doc/translations.txt
316 %attr(755,root,root) %{_bindir}/vlc
317 %if "%{_lib}" != "lib"
318 %{_prefix}/lib/vlc
319 %endif
320 %dir %{_libdir}/vlc
321 %dir %{_libdir}/vlc/gui
322 %dir %{_libdir}/vlc/visualization
323 %attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
324 %attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
325 %attr(755,root,root) %{_libdir}/vlc/mux
326 %attr(755,root,root) %{_libdir}/vlc/misc
327 %attr(755,root,root) %{_libdir}/vlc/control
328 %attr(755,root,root) %{_libdir}/vlc/access_output
329 %attr(755,root,root) %{_libdir}/vlc/codec
330 %attr(755,root,root) %{_libdir}/vlc/demux
331 %attr(755,root,root) %{_libdir}/vlc/access
332 %exclude %{_libdir}/vlc/access/libscreen_plugin.so
333 %attr(755,root,root) %{_libdir}/vlc/video_chroma
334 %attr(755,root,root) %{_libdir}/vlc/audio_mixer
335 %attr(755,root,root) %{_libdir}/vlc/video_filter
336 %dir %{_libdir}/vlc/video_output
337 %attr(755,root,root) %{_libdir}/vlc/stream_out
338 %attr(755,root,root) %{_libdir}/vlc/audio_filter
339 %attr(755,root,root) %{_libdir}/vlc/packetizer
340 %attr(755,root,root) %{_libdir}/vlc/access_filter
341 %attr(755,root,root) %{_libdir}/vlc/services_discovery
342 %dir %{_libdir}/vlc/audio_output
343 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
344 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
345 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
346 %attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
347 %dir %{_datadir}/%{name}
348 %{_datadir}/%{name}/http
349 %{_datadir}/%{name}/osdmenu
350 %{_mandir}/man1/vlc.1*
351
352 %files devel
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_bindir}/vlc-config
355 %dir %{_includedir}/%{name}
356 %{_includedir}/%{name}/*
357
358 %files static
359 %defattr(644,root,root,755)
360 %{_libdir}/libvlc.a
361 %{_libdir}/%{name}/*.a
362
363 %files X11
364 %defattr(644,root,root,755)
365 %attr(755,root,root) %{_bindir}/svlc
366 %attr(755,root,root) %{_bindir}/wxvlc
367 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
368 %attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
369 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
370 %attr(755,root,root) %{_libdir}/vlc/video_output
371 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
372 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
373 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
374 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
375 %{_datadir}/%{name}/skins2
376 %{_datadir}/%{name}/vlc*.xpm
377 %{_datadir}/%{name}/pda*.xpm
378 %{_datadir}/%{name}/vlc*.png
379 %{_datadir}/%{name}/vlc*.ico
380 %{_desktopdir}/*.desktop
381
382 %if %{with ggi}
383 %files GGI
384 %defattr(644,root,root,755)
385 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
386 %endif
387
388 %files SDL
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
391 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
392
393 %files fb
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
396
397 %files esd
398 %defattr(644,root,root,755)
399 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
400
401 %if %{with alsa}
402 %files alsa
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
405 %endif
This page took 0.070883 seconds and 4 git commands to generate.