]> git.pld-linux.org Git - packages/vlc.git/blob - vlc.spec
- BR: libmpcdec-devel
[packages/vlc.git] / vlc.spec
1 #
2 # TODO:
3 # - check the altivec patch
4 # - add proper package descriptions/translations
5 # - bcondize this damn spec! (it should be automated too)
6 # - go through the configure --help and add all options with proper
7 #   reqs and bconds
8 #
9 # Conditional build:
10 %bcond_without  aa      # build without aalib support
11 %bcond_without  caca    # build without caca support
12 %bcond_without  dv      # build without dv support
13 %bcond_without  lirc    # build without lirc support
14 %bcond_without  x264    # build without x264 support
15 %bcond_without  alsa    # don't build alsa plugin
16 %bcond_without  arts    # don't build arts plugin
17 %bcond_without  ggi     # don't build ggi plugin
18 %bcond_without  live    # build without live.com support
19 %bcond_without  speex   # don't build speex plugin
20 %bcond_with     mozilla # build mozilla plugin
21 %bcond_with     slp     # build with slp, broken
22 %bcond_with     svgalib # build with svgalib video_output
23 %bcond_with     hal     # build with hal support
24 #
25 Summary:        VLC - a multimedia player and stream server
26 Summary(pl):    VLC - odtwarzacz multimedialny oraz serwer strumieni
27 Name:           vlc
28 Version:        0.8.6
29 Release:        2
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 # use the bz2 src, its a 4mb difference
33 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
34 # Source0-md5:  77a275f3408c4c9feae451d4eae47f89
35 Source1:        %{name}.desktop
36 Patch0:         %{name}-altivec.patch
37 Patch1:         %{name}-buildflags.patch
38 Patch2:         %{name}-defaultfont.patch
39 Patch3:         %{name}-live.patch
40 Patch4:         %{name}-pic-mmx.patch
41 Patch5:         %{name}-real_codecs_path.patch
42 Patch6:         %{name}-osdmenu_path.patch
43 URL:            http://www.videolan.org/vlc/
44 BuildRequires:  OpenGL-devel
45 BuildRequires:  SDL_image-devel >= 1.2
46 BuildRequires:  a52dec-libs-devel
47 %{?with_aa:BuildRequires:       aalib-devel}
48 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9}
49 %{?with_arts:BuildRequires:     artsc-devel}
50 BuildRequires:  autoconf
51 BuildRequires:  automake
52 BuildRequires:  esound-devel
53 BuildRequires:  faad2-devel >= 2.5
54 BuildRequires:  ffmpeg-devel >= 0.4.9
55 BuildRequires:  flac-devel
56 BuildRequires:  fribidi-devel
57 BuildRequires:  gettext-devel
58 %{?with_hal:BuildRequires:      hal-devel >= 0.2.97}
59 %{?with_dv:BuildRequires:       libavc1394-devel}
60 %{?with_caca:BuildRequires:     libcaca-devel}
61 BuildRequires:  libcddb-devel
62 BuildRequires:  libcdio-devel
63 BuildRequires:  libdts-devel
64 %{?with_dv:BuildRequires:       libdv-devel}
65 BuildRequires:  libdvbpsi-devel
66 BuildRequires:  libdvdcss-devel
67 BuildRequires:  libdvdnav-devel
68 BuildRequires:  libdvdread-devel
69 BuildRequires:  libebml-devel >= 0.7.6
70 %{?with_ggi:BuildRequires:      libggi-devel}
71 BuildRequires:  libid3tag-devel
72 BuildRequires:  libmad-devel
73 BuildRequires:  libmatroska-devel >= 0.7.5
74 BuildRequires:  libmodplug-devel
75 BuildRequires:  libmpcdec-devel >= 1.2.1
76 BuildRequires:  libogg-devel
77 BuildRequires:  libpng-devel
78 %{?with_dv:BuildRequires:       libraw1394-devel}
79 BuildRequires:  libsmbclient-devel
80 BuildRequires:  libtheora-devel
81 BuildRequires:  libtool
82 BuildRequires:  libvorbis-devel
83 %{?with_x264:BuildRequires:     libx264-devel}
84 BuildRequires:  libxml2-devel
85 %{?with_lirc:BuildRequires:     lirc-devel}
86 %{?with_live:BuildRequires:     live >= 2005.03.11}
87 %{?with_mozilla:BuildRequires:  mozilla-devel}
88 BuildRequires:  mpeg2dec-devel >= 0.3.2
89 BuildRequires:  ncurses-devel
90 %{?with_slp:BuildRequires:      openslp-devel}
91 BuildRequires:  pkgconfig
92 %{?with_speex:BuildRequires:    speex-devel > 1:1.1.0}
93 %{?with_svgalib:BuildRequires:  svgalib-devel}
94 BuildRequires:  vcdimager-devel
95 BuildRequires:  wxGTK2-unicode-devel >= 2.6.2-2
96 BuildRequires:  xosd-devel
97 BuildRequires:  xvid-devel
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %description
101 VLC (initially VideoLAN Client) is a multimedia player for various
102 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
103 as well as DVDs, VCDs, and various streaming protocols. It can also be
104 used as a server to stream in unicast or multicast in IPv4 or IPv6 on
105 a high-bandwidth network.
106
107 %description -l pl
108 VLC (wcze¶niej znany pod nazw± VideoLAN Client) jest odtwarzaczem
109 multimedialnym dla wielu formatów wideo i d¼wiêku (MPEG-1, MPEG-2,
110 MPEG-4, DivX, MP3, Ogg, ...), p³yt DVD, VCD oraz ró¿nych protoko³ów
111 strumieniowych. Mo¿e byæ wykorzystany jako serwer do wysy³ania
112 strumieni unicast lub multicast w protoko³ach IPv4 lub IPv6 w
113 wysokoprzepustowych sieciach.
114
115 %package devel
116 Summary:        VLC header files
117 Summary(pl):    Pliki nag³ówkowe VLC
118 Group:          X11/Development/Libraries
119 Requires:       %{name} = %{version}-%{release}
120
121 %description devel
122 VLC header files.
123
124 %description devel -l pl
125 Pliki nag³ówkowe VLC.
126
127 %package static
128 Summary:        VLC static libraries
129 Summary(pl):    Biblioteki statyczne VLC
130 Group:          X11/Development/Libraries
131 Requires:       %{name}-devel = %{version}-%{release}
132
133 %description static
134 VLC static libraries.
135
136 %description static -l pl
137 Biblioteki statyczne VLC.
138
139 %package X11
140 Summary:        VLC - X11 output plugin
141 Summary(pl):    Klient VLC - wtyczka wyj¶cia X11
142 Group:          X11/Applications/Multimedia
143 Requires:       %{name} = %{version}-%{release}
144 Obsoletes:      vlc-gnome
145 Obsoletes:      vlc-gtk
146
147 %description X11
148 X11 output plugin for VLC. Contains GUI image/icon resources.
149
150 %description X11 -l pl
151 Wtyczka wyj¶cia X11 dla klienta VLC. Zawiera zasoby interfejsu GUI
152 (obrazy/ikony).
153
154 %package GGI
155 Summary:        VLC - GGI output plugin
156 Summary(pl):    Klient VLC - wtyczka wyj¶cia GGI
157 Group:          X11/Applications/Multimedia
158 Requires:       %{name} = %{version}-%{release}
159
160 %description GGI
161 GGI output plugin for VLC.
162
163 %description GGI -l pl
164 Wtyczka wyj¶cia GGI dla klienta VLC.
165
166 %package fb
167 Summary:        VLC - fb output plugin
168 Summary(pl):    Klient VLC - wtyczka wyj¶cia fb
169 Group:          X11/Applications/Multimedia
170 Requires:       %{name} = %{version}-%{release}
171
172 %description fb
173 fb output plugin for VLC.
174
175 %description fb -l pl
176 Wtyczka wyj¶cia fb dla klienta VLC.
177
178 %package SDL
179 Summary:        VLC - SDL output plugin
180 Summary(pl):    Klient VLC - wtyczka wyj¶cia SDL
181 Group:          X11/Applications/Multimedia
182 Requires:       %{name} = %{version}-%{release}
183
184 %description SDL
185 SDL output plugin for VLC.
186
187 %description SDL -l pl
188 Wtyczka wyj¶cia SDL dla klienta VLC.
189
190 %package esd
191 Summary:        VLC - EsounD audio output plugin
192 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku EsounD
193 Group:          X11/Applications/Multimedia
194 Requires:       %{name} = %{version}-%{release}
195
196 %description esd
197 EsounD audio output plugin for VLC.
198
199 %description esd -l pl
200 Wtyczka wyj¶cia d¼wiêku EsounD dla klienta VLC.
201
202 %package alsa
203 Summary:        VLC - ALSA audio output plugin
204 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku ALSA
205 Group:          X11/Applications/Multimedia
206 Requires:       %{name} = %{version}-%{release}
207
208 %description alsa
209 ALSA audio output plugin for VLC.
210
211 %description alsa -l pl
212 Wtyczka wyj¶cia d¼wiêku ALSA dla klienta VLC.
213
214 %prep
215 %setup -q
216 ## %patch0 -p1
217 %patch1 -p0
218 %patch2 -p1
219 %patch3 -p1
220 %patch4 -p1
221 %patch5 -p1
222 %patch6 -p1
223
224 %build
225 cp -f /usr/share/automake/config.* .
226 %{__gettextize}
227 %{__aclocal} -I m4
228 %{__autoconf}
229 CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
230 %configure \
231 %ifarch ppc
232         --disable-altivec \
233 %endif
234         --%{?with_aa:en}%{!?with_aa:dis}able-aa \
235         %{?with_alsa:--enable-alsa} \
236         %{?with_arts:--enable-arts} \
237         %{!?with_arts:--disable-arts} \
238         --%{?with_caca:en}%{!?with_caca:dis}able-caca \
239         --enable-dsp \
240         --enable-dummy \
241         --%{?with_dv:en}%{!?with_dv:dis}able-dv \
242         --enable-dvb \
243         --enable-dvbpsi \
244         --with-dvdcss \
245         --enable-dvdnav \
246         --enable-dvdread \
247         --enable-esd \
248         --enable-faad \
249         --enable-fb \
250         --enable-freetype \
251         --enable-fribidi \
252         --enable-ffmpeg \
253         --enable-flac \
254         --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
255         %{!?with_speex:--disable-speex} \
256         --disable-glide \
257         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
258         --enable-mad \
259         --enable-mga \
260         %{?with_mozilla:--enable-mozilla } \
261         %{?with_live:--enable-live555 } \
262         %{!?with_live:--disable-live555 } \
263         --with-live555-tree=%{_libdir}/liveMedia \
264         --enable-ncurses \
265         --enable-pvr \
266         --enable-real \
267         --enable-realrtsp \
268         --enable-sdl \
269         --with-sdl=/usr \
270         --enable-skins2 \
271         %{?with_slp:--enable-slp} \
272         %{!?with_slp:--disable-slp} \
273         --enable-smb \
274         %{?with_svgalib:--enable-svgalib} \
275         --enable-tarkin \
276         --enable-theora \
277         --enable-tremor \
278         --enable-v4l\
279         --enable-x11 \
280         %{!?with_x264:--disable-x264} \
281         --enable-xosd \
282         --enable-xvid \
283         --enable-oss \
284         --disable-testsuite \
285         --with-wx-config=wx-gtk2-unicode-config \
286         %{!?with_hal:--disable-hal} \
287         --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
288
289 # echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
290 %{__make}
291
292 %install
293 rm -rf $RPM_BUILD_ROOT
294 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
295
296 %{__make} install \
297         DESTDIR=$RPM_BUILD_ROOT
298
299 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
300 install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
301
302 %if "%{_lib}" != "lib"
303 install -d $RPM_BUILD_ROOT%{_prefix}/lib
304 ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
305 %endif
306
307 %find_lang %{name}
308
309 %clean
310 rm -rf $RPM_BUILD_ROOT
311
312 %files -f %{name}.lang
313 %defattr(644,root,root,755)
314 %doc AUTHORS MAINTAINERS NEWS README THANKS
315 %doc doc/bugreport-howto.txt doc/intf-cdda.txt
316 %doc doc/intf-vcd.txt doc/translations.txt
317 %attr(755,root,root) %{_bindir}/vlc
318 %if "%{_lib}" != "lib"
319 %{_prefix}/lib/vlc
320 %endif
321 %dir %{_libdir}/vlc
322 %dir %{_libdir}/vlc/gui
323 %dir %{_libdir}/vlc/visualization
324 %attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
325 %attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
326 %attr(755,root,root) %{_libdir}/vlc/mux
327 %attr(755,root,root) %{_libdir}/vlc/misc
328 %attr(755,root,root) %{_libdir}/vlc/control
329 %attr(755,root,root) %{_libdir}/vlc/access_output
330 %attr(755,root,root) %{_libdir}/vlc/codec
331 %attr(755,root,root) %{_libdir}/vlc/demux
332 %attr(755,root,root) %{_libdir}/vlc/access
333 %exclude %{_libdir}/vlc/access/libscreen_plugin.so
334 %attr(755,root,root) %{_libdir}/vlc/video_chroma
335 %attr(755,root,root) %{_libdir}/vlc/audio_mixer
336 %attr(755,root,root) %{_libdir}/vlc/video_filter
337 %dir %{_libdir}/vlc/video_output
338 %attr(755,root,root) %{_libdir}/vlc/stream_out
339 %attr(755,root,root) %{_libdir}/vlc/audio_filter
340 %attr(755,root,root) %{_libdir}/vlc/packetizer
341 %attr(755,root,root) %{_libdir}/vlc/access_filter
342 %attr(755,root,root) %{_libdir}/vlc/services_discovery
343 %dir %{_libdir}/vlc/audio_output
344 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
345 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
346 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
347 %attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
348 %dir %{_datadir}/%{name}
349 %{_datadir}/%{name}/http
350 %{_datadir}/%{name}/osdmenu
351 %{_mandir}/man1/vlc.1*
352
353 %files devel
354 %defattr(644,root,root,755)
355 %attr(755,root,root) %{_bindir}/vlc-config
356 %dir %{_includedir}/%{name}
357 %{_includedir}/%{name}/*
358
359 %files static
360 %defattr(644,root,root,755)
361 %{_libdir}/libvlc.a
362 %{_libdir}/%{name}/*.a
363
364 %files X11
365 %defattr(644,root,root,755)
366 %attr(755,root,root) %{_bindir}/svlc
367 %attr(755,root,root) %{_bindir}/wxvlc
368 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
369 %attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
370 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
371 %attr(755,root,root) %{_libdir}/vlc/video_output
372 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
373 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
374 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
375 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
376 %{_datadir}/%{name}/skins2
377 %{_datadir}/%{name}/vlc*.xpm
378 %{_datadir}/%{name}/pda*.xpm
379 %{_datadir}/%{name}/vlc*.png
380 %{_datadir}/%{name}/vlc*.ico
381 %{_desktopdir}/*.desktop
382
383 %if %{with ggi}
384 %files GGI
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
387 %endif
388
389 %files SDL
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
392 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
393
394 %files fb
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
397
398 %files esd
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
401
402 %if %{with alsa}
403 %files alsa
404 %defattr(644,root,root,755)
405 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
406 %endif
This page took 0.137731 seconds and 4 git commands to generate.