]> git.pld-linux.org Git - packages/vlc.git/blob - vlc.spec
- BR: libx264-devel (with bcond)
[packages/vlc.git] / vlc.spec
1 #
2 # TODO:
3 # - check the altivec patch 
4 # - add proper package descriptions/translations
5 # - bcondize this damn spec! (it should be automated too)
6 # - go through the configure --help and add all options with proper
7 #   reqs and bconds
8 # Conditional build:
9 %bcond_without  aa
10 %bcond_without  caca
11 %bcond_without  dv
12 %bcond_without  lirc
13 %bcond_without  x264
14 %bcond_without  alsa    # don't build alsa plugin
15 %bcond_without  arts    # don't build arts plugin
16 %bcond_without  ggi     # don't build ggi plugin
17 %bcond_without  live    # build without live.com support
18 %bcond_without  speex   # don't build speex plugin
19 %bcond_with     mozilla # build mozilla plugin
20 %bcond_with     slp     # build with slp, broken
21 %bcond_with     svgalib # build with svgalib video_output
22 %bcond_with     hal     # build with hal support
23 #
24 Summary:        VLC - a multimedia player and stream server
25 Summary(pl):    VLC - odtwarzacz multimedialny oraz serwer strumieni
26 Name:           vlc
27 Version:        0.8.5
28 Release:        0.1
29 License:        GPL
30 Group:          X11/Applications/Multimedia
31 # use the bz2 src, its a 4mb difference
32 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
33 # Source0-md5:  16bb5bf87ed94879a8eb7b0ff9b4f16f
34 Source1:        %{name}.desktop
35 Patch0:         %{name}-altivec.patch
36 Patch1:         %{name}-buildflags.patch
37 Patch2:         %{name}-defaultfont.patch
38 Patch3:         %{name}-live.patch
39 Patch4:         %{name}-pic-mmx.patch
40 Patch5:         %{name}-matroska-shared.patch
41 Patch6:         %{name}-real_codecs_path.patch
42 URL:            http://www.videolan.org/vlc/
43 BuildRequires:  OpenGL-devel
44 BuildRequires:  SDL_image-devel >= 1.2
45 BuildRequires:  a52dec-libs-devel
46 %{?with_aa:BuildRequires:       aalib-devel}
47 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9}
48 %{?with_arts:BuildRequires:     artsc-devel}
49 BuildRequires:  autoconf
50 BuildRequires:  automake
51 BuildRequires:  esound-devel
52 BuildRequires:  faad2-devel
53 BuildRequires:  ffmpeg-devel >= 0.4.9
54 BuildRequires:  flac-devel
55 BuildRequires:  fribidi-devel
56 BuildRequires:  gettext-devel
57 %{?with_hal:BuildRequires:      hal-devel >= 0.2.97}
58 %{?with_dv:BuildRequires:       libavc1394-devel}
59 %{?with_caca:BuildRequires:     libcaca-devel}
60 BuildRequires:  libcdio-devel
61 BuildRequires:  libcddb-devel
62 BuildRequires:  libdts-devel
63 %{?with_dv:BuildRequires:       libdv-devel}
64 BuildRequires:  libdvbpsi-devel
65 BuildRequires:  libdvdnav-devel
66 BuildRequires:  libdvdread-devel
67 BuildRequires:  libdvdcss-devel
68 BuildRequires:  libebml-devel >= 0.7.6
69 %{?with_ggi:BuildRequires:      libggi-devel}
70 BuildRequires:  libid3tag-devel
71 BuildRequires:  libmad-devel
72 BuildRequires:  libmatroska-devel >= 0.7.5
73 BuildRequires:  libmodplug-devel
74 BuildRequires:  libogg-devel
75 BuildRequires:  libpng-devel
76 %{?with_dv:BuildRequires:       libraw1394-devel}
77 BuildRequires:  libsmbclient-devel
78 BuildRequires:  libtheora-devel
79 BuildRequires:  libtool
80 BuildRequires:  libvorbis-devel
81 %{?with_x264:BuildRequires:     libx264-devel}
82 BuildRequires:  libxml2-devel
83 %{?with_lirc:BuildRequires:     lirc-devel}
84 %{?with_live:BuildRequires:     live >= 2005.03.11}
85 BuildRequires:  mpeg2dec-devel >= 0.3.2
86 %{?with_mozilla:BuildRequires:  mozilla-devel}
87 BuildRequires:  ncurses-devel
88 %{?with_slp:BuildRequires:      openslp-devel}
89 BuildRequires:  pkgconfig
90 %{?with_speex:BuildRequires:    speex-devel > 1:1.1.0}
91 %{?with_svgalib:BuildRequires:  svgalib-devel}
92 BuildRequires:  vcdimager-devel
93 BuildRequires:  wxGTK2-unicode-devel >= 2.6.2-2
94 BuildRequires:  xosd-devel
95 BuildRequires:  xvid-devel
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %description
99 VLC (initially VideoLAN Client) is a multimedia player for various 
100 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
101 as well as DVDs, VCDs, and various streaming protocols. It can also 
102 be used as a server to stream in unicast or multicast in IPv4 
103 or IPv6 on a high-bandwidth network.
104
105 %description -l pl
106 VLC (wcze¶niej znany pod nazw± VideoLAN Client) jest odtwarzaczem 
107 multimedialnym dla wielu formatów wideo i d¼wiêku (MPEG-1, MPEG-2, 
108 MPEG-4, DivX, MP3, Ogg, ...), p³yt DVD, VCD oraz ró¿nych protoko³ów 
109 strumieniowych. Mo¿e byæ wykorzystany jako serwer do wysy³ania 
110 strumieni unicast lub multicast w protoko³ach IPv4 lub IPv6 
111 w wysokoprzepustowych sieciach.
112
113 %package devel
114 Summary:        VLC header files
115 Summary(pl):    Pliki nag³ówkowe VLC
116 Group:          X11/Development/Libraries
117 Requires:       %{name} = %{version}-%{release}
118
119 %description devel
120 VLC header files.
121
122 %description devel -l pl
123 Pliki nag³ówkowe VLC.
124
125 %package static
126 Summary:        VLC static libraries
127 Summary(pl):    Biblioteki statyczne VLC
128 Group:          X11/Development/Libraries
129 Requires:       %{name}-devel = %{version}-%{release}
130
131 %description static
132 VLC static libraries.
133
134 %description static -l pl
135 Biblioteki statyczne VLC.
136
137 %package X11
138 Summary:        VLC - X11 output plugin
139 Summary(pl):    Klient VLC - wtyczka wyj¶cia X11
140 Group:          X11/Applications/Multimedia
141 Requires:       %{name} = %{version}-%{release}
142 Obsoletes:      vlc-gnome
143 Obsoletes:      vlc-gtk
144
145 %description X11
146 X11 output plugin for VLC. Contains GUI image/icon resources.
147
148 %description X11 -l pl
149 Wtyczka wyj¶cia X11 dla klienta VLC. Zawiera zasoby interfejsu 
150 GUI (obrazy/ikony).
151
152 %package GGI
153 Summary:        VLC - GGI output plugin
154 Summary(pl):    Klient VLC - wtyczka wyj¶cia GGI
155 Group:          X11/Applications/Multimedia
156 Requires:       %{name} = %{version}-%{release}
157
158 %description GGI
159 GGI output plugin for VLC.
160
161 %description GGI -l pl
162 Wtyczka wyj¶cia GGI dla klienta VLC.
163
164 %package fb
165 Summary:        VLC - fb output plugin
166 Summary(pl):    Klient VLC - wtyczka wyj¶cia fb
167 Group:          X11/Applications/Multimedia
168 Requires:       %{name} = %{version}-%{release}
169
170 %description fb
171 fb output plugin for VLC.
172
173 %description fb -l pl
174 Wtyczka wyj¶cia fb dla klienta VLC.
175
176 %package SDL
177 Summary:        VLC - SDL output plugin
178 Summary(pl):    Klient VLC - wtyczka wyj¶cia SDL
179 Group:          X11/Applications/Multimedia
180 Requires:       %{name} = %{version}-%{release}
181
182 %description SDL
183 SDL output plugin for VLC.
184
185 %description SDL -l pl
186 Wtyczka wyj¶cia SDL dla klienta VLC.
187
188 %package esd
189 Summary:        VLC - EsounD audio output plugin
190 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku EsounD
191 Group:          X11/Applications/Multimedia
192 Requires:       %{name} = %{version}-%{release}
193
194 %description esd
195 EsounD audio output plugin for VLC.
196
197 %description esd -l pl
198 Wtyczka wyj¶cia d¼wiêku EsounD dla klienta VLC.
199
200 %package alsa
201 Summary:        VLC - ALSA audio output plugin
202 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku ALSA
203 Group:          X11/Applications/Multimedia
204 Requires:       %{name} = %{version}-%{release}
205
206 %description alsa
207 ALSA audio output plugin for VLC.
208
209 %description alsa -l pl
210 Wtyczka wyj¶cia d¼wiêku ALSA dla klienta VLC.
211
212 %prep
213 %setup -q
214 ## %patch0 -p1
215 %patch1 -p0
216 %patch2 -p1
217 %patch3 -p1
218 %patch4 -p1
219 %patch5 -p1
220 %patch6 -p1
221
222 %build
223 cp -f /usr/share/automake/config.* .
224 %{__gettextize}
225 %{__aclocal} -I m4
226 %{__autoconf}
227 CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
228 %configure \
229 %ifarch ppc
230         --disable-altivec \
231 %endif
232         --%{?with_aa:en}%{!?with_aa:dis}able-aa \
233         %{?with_alsa:--enable-alsa} \
234         %{?with_arts:--enable-arts} \
235         %{!?with_arts:--disable-arts} \
236         --%{?with_caca:en}%{!?with_caca:dis}able-caca \
237         --enable-dsp \
238         --enable-dummy \
239         --%{?with_dv:en}%{!?with_dv:dis}able-dv \
240         --enable-dvb \
241         --enable-dvbpsi \
242         --with-dvdcss \
243         --enable-dvdnav \
244         --enable-dvdread \
245         --enable-esd \
246         --enable-faad \
247         --enable-fb \
248         --enable-freetype \
249         --enable-fribidi \
250         --enable-ffmpeg \
251         --enable-flac \
252         --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
253         %{?with_ggi:--with-ggi} \
254         %{!?with_speex:--disable-speex} \
255         --disable-glide \
256         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
257         --enable-mad \
258         --enable-mga \
259         %{?with_mozilla:--enable-mozilla } \
260         %{?with_live:--enable-livedotcom } \
261         %{!?with_live:--disable-livedotcom } \
262         --with-livedotcom-tree=%{_libdir}/liveMedia \
263         --enable-ncurses \
264         --enable-pvr \
265         --enable-real \
266         --enable-realrtsp \
267         --enable-sdl \
268         --with-sdl=/usr \
269         --enable-skins2 \
270         %{?with_slp:--enable-slp} \
271         %{!?with_slp:--disable-slp} \
272         --enable-smb \
273         %{?with_svgalib:--enable-svgalib} \
274         --enable-tarkin \
275         --enable-theora \
276         --enable-tremor \
277         --enable-v4l\
278         --enable-x11 \
279         %{!?with_x264:--disable-x264} \
280         --enable-xosd \
281         --enable-xvid \
282         --enable-oss \
283         --disable-testsuite \
284         --with-wx-config=wx-gtk2-unicode-config \
285         %{!?with_hal:--disable-hal} \
286         --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
287
288 # echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
289 %{__make}
290
291 %install
292 rm -rf $RPM_BUILD_ROOT
293 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
294
295 %{__make} install \
296         DESTDIR=$RPM_BUILD_ROOT
297
298 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
299 install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
300
301 %if "%{_lib}" != "lib"
302 install -d $RPM_BUILD_ROOT%{_prefix}/lib
303 ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
304 %endif
305
306 %find_lang %{name}
307
308 %clean
309 rm -rf $RPM_BUILD_ROOT
310
311 %files -f %{name}.lang
312 %defattr(644,root,root,755)
313 %doc AUTHORS MAINTAINERS NEWS README THANKS
314 %doc doc/bugreport-howto.txt doc/intf-cdda.txt
315 %doc doc/intf-vcd.txt doc/translations.txt
316 %attr(755,root,root) %{_bindir}/vlc
317 %if "%{_lib}" != "lib"
318 %{_prefix}/lib/vlc
319 %endif
320 %dir %{_libdir}/vlc
321 %dir %{_libdir}/vlc/gui
322 %dir %{_libdir}/vlc/visualization
323 %attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
324 %attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
325 %attr(755,root,root) %{_libdir}/vlc/mux
326 %attr(755,root,root) %{_libdir}/vlc/misc
327 %attr(755,root,root) %{_libdir}/vlc/control
328 %attr(755,root,root) %{_libdir}/vlc/access_output
329 %attr(755,root,root) %{_libdir}/vlc/codec
330 %attr(755,root,root) %{_libdir}/vlc/demux
331 %attr(755,root,root) %{_libdir}/vlc/access
332 %exclude %{_libdir}/vlc/access/libscreen_plugin.so
333 %attr(755,root,root) %{_libdir}/vlc/video_chroma
334 %attr(755,root,root) %{_libdir}/vlc/audio_mixer
335 %attr(755,root,root) %{_libdir}/vlc/video_filter
336 %dir %{_libdir}/vlc/video_output
337 %attr(755,root,root) %{_libdir}/vlc/stream_out
338 %attr(755,root,root) %{_libdir}/vlc/audio_filter
339 %attr(755,root,root) %{_libdir}/vlc/packetizer
340 %attr(755,root,root) %{_libdir}/vlc/access_filter
341 %attr(755,root,root) %{_libdir}/vlc/services_discovery
342 %dir %{_libdir}/vlc/audio_output
343 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
344 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
345 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
346 %attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
347 %dir %{_datadir}/%{name}
348 %{_datadir}/%{name}/http
349 %{_datadir}/%{name}/osdmenu
350 %{_mandir}/man1/vlc.1*
351
352 %files devel
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_bindir}/vlc-config
355 %dir %{_includedir}/%{name}
356 %{_includedir}/%{name}/*
357
358 %files static
359 %defattr(644,root,root,755)
360 %{_libdir}/libvlc.a
361 %{_libdir}/%{name}/*.a
362
363 %files X11
364 %defattr(644,root,root,755)
365 %attr(755,root,root) %{_bindir}/svlc
366 %attr(755,root,root) %{_bindir}/wxvlc
367 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
368 %attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
369 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
370 %attr(755,root,root) %{_libdir}/vlc/video_output
371 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
372 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
373 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
374 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
375 %{_datadir}/%{name}/skins2
376 %{_datadir}/%{name}/vlc*.xpm
377 %{_datadir}/%{name}/pda*.xpm
378 %{_datadir}/%{name}/vlc*.png
379 %{_datadir}/%{name}/vlc*.ico
380 %{_desktopdir}/*
381
382 %if %{with ggi}
383 %files GGI
384 %defattr(644,root,root,755)
385 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
386 %endif 
387
388 %files SDL
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
391 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
392
393 %files fb
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
396
397 %files esd
398 %defattr(644,root,root,755)
399 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
400
401 %if %{with alsa}
402 %files alsa
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
405 %endif
This page took 0.079382 seconds and 4 git commands to generate.