]> git.pld-linux.org Git - packages/vlc.git/blob - vlc.spec
- updated to 0.8.5 final - (partial) merged from DEVEL
[packages/vlc.git] / vlc.spec
1 #
2 # TODO:
3 # - check the altivec patch 
4 # - add proper package descriptions/translations
5 # - bcondize this damn spec! (it should be automated too)
6 # - go through the configure --help and add all options with proper
7 #   reqs and bconds
8 # Conditional build:
9 %bcond_without  aa
10 %bcond_without  caca
11 %bcond_without  dv
12 %bcond_without  lirc
13 %bcond_without  alsa    # don't build alsa plugin
14 %bcond_without  arts    # don't build arts plugin
15 %bcond_without  ggi     # don't build ggi plugin
16 %bcond_without  live    # build without live.com support
17 %bcond_without  speex   # don't build speex plugin
18 %bcond_with     mozilla # build mozilla plugin
19 %bcond_with     slp     # build with slp, broken
20 %bcond_with     svgalib # build with svgalib video_output
21 %bcond_with     hal     # build with hal support
22 #
23 Summary:        VLC - a multimedia player and stream server
24 Summary(pl):    VLC - odtwarzacz multimedialny oraz serwer strumieni
25 Name:           vlc
26 Version:        0.8.5
27 Release:        0.1
28 License:        GPL
29 Group:          X11/Applications/Multimedia
30 # use the bz2 src, its a 4mb difference
31 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
32 # Source0-md5:  16bb5bf87ed94879a8eb7b0ff9b4f16f
33 Source1:        %{name}.desktop
34 Patch0:         %{name}-altivec.patch
35 Patch1:         %{name}-buildflags.patch
36 Patch2:         %{name}-defaultfont.patch
37 Patch3:         %{name}-live.patch
38 Patch4:         %{name}-pic-mmx.patch
39 Patch5:         %{name}-matroska-shared.patch
40 Patch6:         %{name}-real_codecs_path.patch
41 URL:            http://www.videolan.org/vlc/
42 BuildRequires:  OpenGL-devel
43 BuildRequires:  SDL_image-devel >= 1.2
44 BuildRequires:  a52dec-libs-devel
45 %{?with_aa:BuildRequires:       aalib-devel}
46 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9}
47 %{?with_arts:BuildRequires:     artsc-devel}
48 BuildRequires:  autoconf
49 BuildRequires:  automake
50 BuildRequires:  esound-devel
51 BuildRequires:  faad2-devel
52 BuildRequires:  ffmpeg-devel >= 0.4.9
53 BuildRequires:  flac-devel
54 BuildRequires:  fribidi-devel
55 BuildRequires:  gettext-devel
56 %{?with_hal:BuildRequires:      hal-devel >= 0.2.97}
57 %{?with_caca:BuildRequires:     libcaca-devel}
58 BuildRequires:  libcdio-devel
59 BuildRequires:  libcddb-devel
60 BuildRequires:  libdts-devel
61 %{?with_dv:BuildRequires:       libdv-devel}
62 BuildRequires:  libdvbpsi-devel
63 BuildRequires:  libdvdnav-devel
64 BuildRequires:  libdvdread-devel
65 BuildRequires:  libdvdcss-devel
66 BuildRequires:  libebml-devel >= 0.7.6
67 %{?with_ggi:BuildRequires:      libggi-devel}
68 BuildRequires:  libid3tag-devel
69 BuildRequires:  libmad-devel
70 BuildRequires:  libmatroska-devel >= 0.7.5
71 BuildRequires:  libmodplug-devel
72 BuildRequires:  libogg-devel
73 BuildRequires:  libpng-devel
74 BuildRequires:  libsmbclient-devel
75 BuildRequires:  libtheora-devel
76 BuildRequires:  libvorbis-devel
77 BuildRequires:  libxml2-devel
78 %{?with_lirc:BuildRequires:     lirc-devel}
79 %{?with_live:BuildRequires:     live >= 2005.03.11}
80 BuildRequires:  mpeg2dec-devel >= 0.3.2
81 %{?with_mozilla:BuildRequires:  mozilla-devel}
82 BuildRequires:  ncurses-devel
83 %{?with_slp:BuildRequires:      openslp-devel}
84 BuildRequires:  pkgconfig
85 %{?with_speex:BuildRequires:    speex-devel > 1:1.1.0}
86 %{?with_svgalib:BuildRequires:  svgalib-devel}
87 BuildRequires:  vcdimager-devel
88 BuildRequires:  wxGTK2-unicode-devel >= 2.5.5
89 BuildRequires:  xosd-devel
90 BuildRequires:  xvid-devel
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %description
94 VLC (initially VideoLAN Client) is a multimedia player for various 
95 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
96 as well as DVDs, VCDs, and various streaming protocols. It can also 
97 be used as a server to stream in unicast or multicast in IPv4 
98 or IPv6 on a high-bandwidth network.
99
100 %description -l pl
101 VLC (wcze¶niej znany pod nazw± VideoLAN Client) jest odtwarzaczem 
102 multimedialnym dla wielu formatów wideo i d¼wiêku (MPEG-1, MPEG-2, 
103 MPEG-4, DivX, MP3, Ogg, ...), p³yt DVD, VCD oraz ró¿nych protoko³ów 
104 strumieniowych. Mo¿e byæ wykorzystany jako serwer do wysy³ania 
105 strumieni unicast lub multicast w protoko³ach IPv4 lub IPv6 
106 w wysokoprzepustowych sieciach.
107
108 %package devel
109 Summary:        VLC header files
110 Summary(pl):    Pliki nag³ówkowe VLC
111 Group:          X11/Development/Libraries
112 Requires:       %{name} = %{version}-%{release}
113
114 %description devel
115 VLC header files.
116
117 %description devel -l pl
118 Pliki nag³ówkowe VLC.
119
120 %package static
121 Summary:        VLC static libraries
122 Summary(pl):    Biblioteki statyczne VLC
123 Group:          X11/Development/Libraries
124 Requires:       %{name}-devel = %{version}-%{release}
125
126 %description static
127 VLC static libraries.
128
129 %description static -l pl
130 Biblioteki statyczne VLC.
131
132 %package X11
133 Summary:        VLC - X11 output plugin
134 Summary(pl):    Klient VLC - wtyczka wyj¶cia X11
135 Group:          X11/Applications/Multimedia
136 Requires:       %{name} = %{version}-%{release}
137 Obsoletes:      vlc-gnome
138 Obsoletes:      vlc-gtk
139
140 %description X11
141 X11 output plugin for VLC. Contains GUI image/icon resources.
142
143 %description X11 -l pl
144 Wtyczka wyj¶cia X11 dla klienta VLC. Zawiera zasoby interfejsu 
145 GUI (obrazy/ikony).
146
147 %package GGI
148 Summary:        VLC - GGI output plugin
149 Summary(pl):    Klient VLC - wtyczka wyj¶cia GGI
150 Group:          X11/Applications/Multimedia
151 Requires:       %{name} = %{version}-%{release}
152
153 %description GGI
154 GGI output plugin for VLC.
155
156 %description GGI -l pl
157 Wtyczka wyj¶cia GGI dla klienta VLC.
158
159 %package fb
160 Summary:        VLC - fb output plugin
161 Summary(pl):    Klient VLC - wtyczka wyj¶cia fb
162 Group:          X11/Applications/Multimedia
163 Requires:       %{name} = %{version}-%{release}
164
165 %description fb
166 fb output plugin for VLC.
167
168 %description fb -l pl
169 Wtyczka wyj¶cia fb dla klienta VLC.
170
171 %package SDL
172 Summary:        VLC - SDL output plugin
173 Summary(pl):    Klient VLC - wtyczka wyj¶cia SDL
174 Group:          X11/Applications/Multimedia
175 Requires:       %{name} = %{version}-%{release}
176
177 %description SDL
178 SDL output plugin for VLC.
179
180 %description SDL -l pl
181 Wtyczka wyj¶cia SDL dla klienta VLC.
182
183 %package esd
184 Summary:        VLC - EsounD audio output plugin
185 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku EsounD
186 Group:          X11/Applications/Multimedia
187 Requires:       %{name} = %{version}-%{release}
188
189 %description esd
190 EsounD audio output plugin for VLC.
191
192 %description esd -l pl
193 Wtyczka wyj¶cia d¼wiêku EsounD dla klienta VLC.
194
195 %package alsa
196 Summary:        VLC - ALSA audio output plugin
197 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku ALSA
198 Group:          X11/Applications/Multimedia
199 Requires:       %{name} = %{version}-%{release}
200
201 %description alsa
202 ALSA audio output plugin for VLC.
203
204 %description alsa -l pl
205 Wtyczka wyj¶cia d¼wiêku ALSA dla klienta VLC.
206
207 %prep
208 %setup -q
209 ## %patch0 -p1
210 %patch1 -p0
211 %patch2 -p1
212 %patch3 -p1
213 %patch4 -p1
214 %patch5 -p1
215 %patch6 -p1
216
217 %build
218 cp -f /usr/share/automake/config.* .
219 %{__gettextize}
220 %{__aclocal} -I m4
221 %{__autoconf}
222 CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
223 %configure \
224 %ifarch ppc
225         --disable-altivec \
226 %endif
227         --%{?with_aa:en}%{!?with_aa:dis}able-aa \
228         %{?with_alsa:--enable-alsa} \
229         %{?with_arts:--enable-arts} \
230         %{!?with_arts:--disable-arts} \
231         --%{?with_caca:en}%{!?with_caca:dis}able-caca \
232         --enable-dsp \
233         --enable-dummy \
234         --%{?with_dv:en}%{!?with_dv:dis}able-dv \
235         --enable-dvb \
236         --enable-dvbpsi \
237         --with-dvdcss \
238         --enable-dvdnav \
239         --enable-dvdread \
240         --enable-esd \
241         --enable-faad \
242         --enable-fb \
243         --enable-freetype \
244         --enable-fribidi \
245         --enable-ffmpeg \
246         --enable-flac \
247         --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
248         %{?with_ggi:--with-ggi} \
249         %{!?with_speex:--disable-speex} \
250         --disable-glide \
251         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
252         --enable-mad \
253         --enable-mga \
254         %{?with_mozilla:--enable-mozilla } \
255         %{?with_live:--enable-livedotcom } \
256         %{!?with_live:--disable-livedotcom } \
257         --with-livedotcom-tree=%{_libdir}/liveMedia \
258         --enable-ncurses \
259         --enable-pvr \
260         --enable-real \
261         --enable-realrtsp \
262         --enable-sdl \
263         --with-sdl=/usr \
264         --enable-skins2 \
265         %{?with_slp:--enable-slp} \
266         %{!?with_slp:--disable-slp} \
267         --enable-smb \
268         %{?with_svgalib:--enable-svgalib} \
269         --enable-tarkin \
270         --enable-theora \
271         --enable-tremor \
272         --enable-v4l\
273         --enable-x11 \
274         --enable-xosd \
275         --enable-xvid \
276         --enable-oss \
277         --disable-testsuite \
278         --with-wx-config=wx-gtk2-unicode-config \
279         %{!?with_hal:--disable-hal} \
280         --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
281
282 # echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
283 %{__make}
284
285 %install
286 rm -rf $RPM_BUILD_ROOT
287 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
288
289 %{__make} install \
290         DESTDIR=$RPM_BUILD_ROOT
291
292 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
293 install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
294
295 %if "%{_lib}" != "lib"
296 install -d $RPM_BUILD_ROOT%{_prefix}/lib
297 ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
298 %endif
299
300 %find_lang %{name}
301
302 %clean
303 rm -rf $RPM_BUILD_ROOT
304
305 %files -f %{name}.lang
306 %defattr(644,root,root,755)
307 %doc AUTHORS MAINTAINERS NEWS README THANKS
308 %doc doc/bugreport-howto.txt doc/intf-cdda.txt
309 %doc doc/intf-vcd.txt doc/translations.txt
310 %attr(755,root,root) %{_bindir}/vlc
311 %if "%{_lib}" != "lib"
312 %{_prefix}/lib/vlc
313 %endif
314 %dir %{_libdir}/vlc
315 %dir %{_libdir}/vlc/gui
316 %dir %{_libdir}/vlc/visualization
317 %attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
318 %attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
319 %attr(755,root,root) %{_libdir}/vlc/mux
320 %attr(755,root,root) %{_libdir}/vlc/misc
321 %attr(755,root,root) %{_libdir}/vlc/control
322 %attr(755,root,root) %{_libdir}/vlc/access_output
323 %attr(755,root,root) %{_libdir}/vlc/codec
324 %attr(755,root,root) %{_libdir}/vlc/demux
325 %attr(755,root,root) %{_libdir}/vlc/access
326 %exclude %{_libdir}/vlc/access/libscreen_plugin.so
327 %attr(755,root,root) %{_libdir}/vlc/video_chroma
328 %attr(755,root,root) %{_libdir}/vlc/audio_mixer
329 %attr(755,root,root) %{_libdir}/vlc/video_filter
330 %dir %{_libdir}/vlc/video_output
331 %attr(755,root,root) %{_libdir}/vlc/stream_out
332 %attr(755,root,root) %{_libdir}/vlc/audio_filter
333 %attr(755,root,root) %{_libdir}/vlc/packetizer
334 %attr(755,root,root) %{_libdir}/vlc/access_filter
335 %attr(755,root,root) %{_libdir}/vlc/services_discovery
336 %dir %{_libdir}/vlc/audio_output
337 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
338 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
339 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
340 %attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
341 %dir %{_datadir}/%{name}
342 %{_datadir}/%{name}/http
343 %{_datadir}/%{name}/osdmenu
344 %{_mandir}/man1/vlc.1*
345
346 %files devel
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_bindir}/vlc-config
349 %dir %{_includedir}/%{name}
350 %{_includedir}/%{name}/*
351
352 %files static
353 %defattr(644,root,root,755)
354 %{_libdir}/libvlc.a
355 %{_libdir}/%{name}/*.a
356
357 %files X11
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_bindir}/svlc
360 %attr(755,root,root) %{_bindir}/wxvlc
361 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
362 %attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
363 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
364 %attr(755,root,root) %{_libdir}/vlc/video_output
365 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
366 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
367 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
368 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
369 %{_datadir}/%{name}/skins2
370 %{_datadir}/%{name}/vlc*.xpm
371 %{_datadir}/%{name}/pda*.xpm
372 %{_datadir}/%{name}/vlc*.png
373 %{_datadir}/%{name}/vlc*.ico
374 %{_desktopdir}/*
375
376 %if %{with ggi}
377 %files GGI
378 %defattr(644,root,root,755)
379 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
380 %endif 
381
382 %files SDL
383 %defattr(644,root,root,755)
384 %attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
385 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
386
387 %files fb
388 %defattr(644,root,root,755)
389 %attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
390
391 %files esd
392 %defattr(644,root,root,755)
393 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
394
395 %if %{with alsa}
396 %files alsa
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
399 %endif
This page took 0.067472 seconds and 4 git commands to generate.