]> git.pld-linux.org Git - packages/vlc.git/blob - vlc.spec
- BR: freetype-devel
[packages/vlc.git] / vlc.spec
1 #
2 # TODO:
3 # - check the altivec patch
4 # - add proper package descriptions/translations
5 # - bcondize this damn spec! (it should be automated too)
6 # - go through the configure --help and add all options with proper
7 #   reqs and bconds
8 # - flac plugin doesn't work with mono files
9 #
10 # Conditional build:
11 %bcond_without  aalib   # build without aalib support
12 %bcond_without  caca    # build without caca support
13 %bcond_without  dv      # build without dv support
14 %bcond_without  lirc    # build without lirc support
15 %bcond_without  x264    # build without x264 support
16 %bcond_without  alsa    # don't build alsa plugin
17 %bcond_without  arts    # don't build arts plugin
18 %bcond_without  ggi     # don't build ggi plugin
19 %bcond_without  live    # build without live.com support
20 %bcond_without  speex   # don't build speex plugin
21 %bcond_with     mozilla # build mozilla plugin
22 %bcond_with     slp     # build with slp, broken
23 %bcond_with     svgalib # build with svgalib video_output
24 %bcond_with     hal     # build with hal support
25 #
26 Summary:        VLC - a multimedia player and stream server
27 Summary(pl.UTF-8):      VLC - odtwarzacz multimedialny oraz serwer strumieni
28 Name:           vlc
29 Version:        0.8.6f
30 Release:        1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 # use the bz2 src, its a 4mb difference
34 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
35 # Source0-md5:  c3aded2583fcdb9f4c71d3fc3601b73b
36 Source1:        %{name}.desktop
37 Patch0:         %{name}-altivec.patch
38 Patch1:         %{name}-buildflags.patch
39 Patch2:         %{name}-defaultfont.patch
40 Patch3:         %{name}-live.patch
41 Patch4:         %{name}-pic-mmx.patch
42 Patch5:         %{name}-real_codecs_path.patch
43 Patch6:         %{name}-osdmenu_path.patch
44 URL:            http://www.videolan.org/vlc/
45 BuildRequires:  OpenGL-devel
46 BuildRequires:  SDL_image-devel >= 1.2
47 BuildRequires:  a52dec-libs-devel
48 %{?with_aalib:BuildRequires:    aalib-devel}
49 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9}
50 %{?with_arts:BuildRequires:     artsc-devel}
51 BuildRequires:  autoconf
52 BuildRequires:  automake
53 BuildRequires:  esound-devel
54 BuildRequires:  faad2-devel >= 2.5
55 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080131.1
56 BuildRequires:  flac-devel >= 1.1.3
57 BuildRequires:  freetype-devel
58 BuildRequires:  fribidi-devel
59 BuildRequires:  gettext-devel
60 %{?with_hal:BuildRequires:      hal-devel >= 0.2.97}
61 %{?with_dv:BuildRequires:       libavc1394-devel}
62 %{?with_caca:BuildRequires:     libcaca-devel}
63 BuildRequires:  libcddb-devel
64 BuildRequires:  libcdio-devel
65 BuildRequires:  libdts-devel
66 %{?with_dv:BuildRequires:       libdv-devel}
67 BuildRequires:  libdvbpsi-devel
68 BuildRequires:  libdvdcss-devel
69 BuildRequires:  libdvdnav-devel
70 BuildRequires:  libdvdread-devel
71 BuildRequires:  libebml-devel >= 0.7.6
72 %{?with_ggi:BuildRequires:      libggi-devel}
73 BuildRequires:  libid3tag-devel
74 BuildRequires:  libmad-devel
75 BuildRequires:  libmatroska-devel >= 0.7.5
76 BuildRequires:  libmodplug-devel
77 BuildRequires:  libmpcdec-devel >= 1.2.1
78 BuildRequires:  libogg-devel
79 BuildRequires:  libpng-devel
80 %{?with_dv:BuildRequires:       libraw1394-devel}
81 BuildRequires:  libsmbclient-devel
82 BuildRequires:  libtheora-devel
83 BuildRequires:  libtool
84 BuildRequires:  libvorbis-devel
85 %{?with_x264:BuildRequires:     libx264-devel}
86 BuildRequires:  libxml2-devel
87 %{?with_lirc:BuildRequires:     lirc-devel}
88 %{?with_live:BuildRequires:     live >= 2005.03.11}
89 %{?with_mozilla:BuildRequires:  mozilla-devel}
90 BuildRequires:  mpeg2dec-devel >= 0.3.2
91 BuildRequires:  ncurses-devel
92 %{?with_slp:BuildRequires:      openslp-devel}
93 BuildRequires:  pkgconfig
94 %{?with_speex:BuildRequires:    speex-devel > 1:1.1.0}
95 %{?with_svgalib:BuildRequires:  svgalib-devel}
96 BuildRequires:  vcdimager-devel
97 BuildRequires:  wxGTK2-unicode-devel >= 2.6.2-2
98 BuildRequires:  xosd-devel
99 BuildRequires:  xvid-devel
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %description
103 VLC (initially VideoLAN Client) is a multimedia player for various
104 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
105 as well as DVDs, VCDs, and various streaming protocols. It can also be
106 used as a server to stream in unicast or multicast in IPv4 or IPv6 on
107 a high-bandwidth network.
108
109 %description -l pl.UTF-8
110 VLC (wcześniej znany pod nazwą VideoLAN Client) jest odtwarzaczem
111 multimedialnym dla wielu formatów wideo i dźwięku (MPEG-1, MPEG-2,
112 MPEG-4, DivX, MP3, Ogg, ...), płyt DVD, VCD oraz różnych protokołów
113 strumieniowych. Może być wykorzystany jako serwer do wysyłania
114 strumieni unicast lub multicast w protokołach IPv4 lub IPv6 w
115 wysokoprzepustowych sieciach.
116
117 %package devel
118 Summary:        VLC header files
119 Summary(pl.UTF-8):      Pliki nagłówkowe VLC
120 Group:          X11/Development/Libraries
121 Requires:       %{name} = %{version}-%{release}
122
123 %description devel
124 VLC header files.
125
126 %description devel -l pl.UTF-8
127 Pliki nagłówkowe VLC.
128
129 %package static
130 Summary:        VLC static libraries
131 Summary(pl.UTF-8):      Biblioteki statyczne VLC
132 Group:          X11/Development/Libraries
133 Requires:       %{name}-devel = %{version}-%{release}
134
135 %description static
136 VLC static libraries.
137
138 %description static -l pl.UTF-8
139 Biblioteki statyczne VLC.
140
141 %package X11
142 Summary:        VLC - X11 output plugin
143 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia X11
144 Group:          X11/Applications/Multimedia
145 Requires:       %{name} = %{version}-%{release}
146 Obsoletes:      vlc-gnome
147 Obsoletes:      vlc-gtk
148
149 %description X11
150 X11 output plugin for VLC. Contains GUI image/icon resources.
151
152 %description X11 -l pl.UTF-8
153 Wtyczka wyjścia X11 dla klienta VLC. Zawiera zasoby interfejsu GUI
154 (obrazy/ikony).
155
156 %package GGI
157 Summary:        VLC - GGI output plugin
158 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia GGI
159 Group:          X11/Applications/Multimedia
160 Requires:       %{name} = %{version}-%{release}
161
162 %description GGI
163 GGI output plugin for VLC.
164
165 %description GGI -l pl.UTF-8
166 Wtyczka wyjścia GGI dla klienta VLC.
167
168 %package fb
169 Summary:        VLC - fb output plugin
170 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia fb
171 Group:          X11/Applications/Multimedia
172 Requires:       %{name} = %{version}-%{release}
173
174 %description fb
175 fb output plugin for VLC.
176
177 %description fb -l pl.UTF-8
178 Wtyczka wyjścia fb dla klienta VLC.
179
180 %package SDL
181 Summary:        VLC - SDL output plugin
182 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia SDL
183 Group:          X11/Applications/Multimedia
184 Requires:       %{name} = %{version}-%{release}
185
186 %description SDL
187 SDL output plugin for VLC.
188
189 %description SDL -l pl.UTF-8
190 Wtyczka wyjścia SDL dla klienta VLC.
191
192 %package esd
193 Summary:        VLC - EsounD audio output plugin
194 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia dźwięku EsounD
195 Group:          X11/Applications/Multimedia
196 Requires:       %{name} = %{version}-%{release}
197
198 %description esd
199 EsounD audio output plugin for VLC.
200
201 %description esd -l pl.UTF-8
202 Wtyczka wyjścia dźwięku EsounD dla klienta VLC.
203
204 %package alsa
205 Summary:        VLC - ALSA audio output plugin
206 Summary(pl.UTF-8):      Klient VLC - wtyczka wyjścia dźwięku ALSA
207 Group:          X11/Applications/Multimedia
208 Requires:       %{name} = %{version}-%{release}
209
210 %description alsa
211 ALSA audio output plugin for VLC.
212
213 %description alsa -l pl.UTF-8
214 Wtyczka wyjścia dźwięku ALSA dla klienta VLC.
215
216 %prep
217 %setup -q
218 ## %patch0 -p1
219 %patch1 -p0
220 %patch2 -p1
221 %patch3 -p1
222 %patch4 -p1
223 %patch5 -p1
224 %patch6 -p1
225
226 %build
227 cp -f /usr/share/automake/config.* .
228 %{__gettextize}
229 %{__aclocal} -I m4
230 %{__autoconf}
231 %configure \
232 %ifarch ppc
233         --disable-altivec \
234 %endif
235         --%{?with_aalib:en}%{!?with_aalib:dis}able-aa \
236         %{?with_alsa:--enable-alsa} \
237         %{?with_arts:--enable-arts} \
238         %{!?with_arts:--disable-arts} \
239         --%{?with_caca:en}%{!?with_caca:dis}able-caca \
240         --enable-dsp \
241         --enable-dummy \
242         --%{?with_dv:en}%{!?with_dv:dis}able-dv \
243         --enable-dvb \
244         --enable-dvbpsi \
245         --with-dvdcss \
246         --enable-dvdnav \
247         --enable-dvdread \
248         --enable-esd \
249         --enable-faad \
250         --enable-fb \
251         --enable-freetype \
252         --enable-fribidi \
253         --enable-ffmpeg \
254         --enable-flac \
255         --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
256         %{!?with_speex:--disable-speex} \
257         --disable-glide \
258         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
259         --enable-mad \
260         --enable-mga \
261         %{?with_mozilla:--enable-mozilla } \
262         %{?with_live:--enable-live555 } \
263         %{!?with_live:--disable-live555 } \
264         --with-live555-tree=%{_libdir}/liveMedia \
265         --enable-ncurses \
266         --enable-pvr \
267         --enable-real \
268         --enable-realrtsp \
269         --enable-sdl \
270         --with-sdl=/usr \
271         --enable-skins2 \
272         %{?with_slp:--enable-slp} \
273         %{!?with_slp:--disable-slp} \
274         --enable-smb \
275         %{?with_svgalib:--enable-svgalib} \
276         --enable-tarkin \
277         --enable-theora \
278         --enable-tremor \
279         --enable-v4l\
280         --enable-x11 \
281         %{!?with_x264:--disable-x264} \
282         --enable-xosd \
283         --enable-xvid \
284         --enable-oss \
285         --disable-testsuite \
286         --disable-macosx \
287         --with-wx-config=wx-gtk2-unicode-config \
288         %{!?with_hal:--disable-hal} \
289         --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
290
291 # echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
292 %{__make}
293
294 %install
295 rm -rf $RPM_BUILD_ROOT
296 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
297
298 %{__make} install \
299         DESTDIR=$RPM_BUILD_ROOT
300
301 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
302 install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
303
304 %if "%{_lib}" != "lib"
305 install -d $RPM_BUILD_ROOT%{_prefix}/lib
306 ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
307 %endif
308
309 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/co
310
311 %find_lang %{name}
312
313 %clean
314 rm -rf $RPM_BUILD_ROOT
315
316 %files -f %{name}.lang
317 %defattr(644,root,root,755)
318 %doc AUTHORS MAINTAINERS NEWS README THANKS
319 %doc doc/bugreport-howto.txt doc/intf-cdda.txt
320 %doc doc/intf-vcd.txt doc/translations.txt
321 %attr(755,root,root) %{_bindir}/vlc
322 %if "%{_lib}" != "lib"
323 %{_prefix}/lib/vlc
324 %endif
325 %dir %{_libdir}/vlc
326 %dir %{_libdir}/vlc/gui
327 %dir %{_libdir}/vlc/visualization
328 %attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
329 %attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
330 %attr(755,root,root) %{_libdir}/vlc/mux
331 %attr(755,root,root) %{_libdir}/vlc/misc
332 %attr(755,root,root) %{_libdir}/vlc/control
333 %attr(755,root,root) %{_libdir}/vlc/access_output
334 %attr(755,root,root) %{_libdir}/vlc/codec
335 %attr(755,root,root) %{_libdir}/vlc/demux
336 %attr(755,root,root) %{_libdir}/vlc/access
337 %exclude %{_libdir}/vlc/access/libscreen_plugin.so
338 %attr(755,root,root) %{_libdir}/vlc/video_chroma
339 %attr(755,root,root) %{_libdir}/vlc/audio_mixer
340 %attr(755,root,root) %{_libdir}/vlc/video_filter
341 %dir %{_libdir}/vlc/video_output
342 %attr(755,root,root) %{_libdir}/vlc/stream_out
343 %attr(755,root,root) %{_libdir}/vlc/audio_filter
344 %attr(755,root,root) %{_libdir}/vlc/packetizer
345 %attr(755,root,root) %{_libdir}/vlc/access_filter
346 %attr(755,root,root) %{_libdir}/vlc/services_discovery
347 %dir %{_libdir}/vlc/audio_output
348 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
349 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
350 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
351 %attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
352 %dir %{_datadir}/%{name}
353 %{_datadir}/%{name}/http
354 %{_datadir}/%{name}/osdmenu
355 %{_mandir}/man1/vlc.1*
356
357 %files devel
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_bindir}/vlc-config
360 %dir %{_includedir}/%{name}
361 %{_includedir}/%{name}/*
362
363 %files static
364 %defattr(644,root,root,755)
365 %{_libdir}/libvlc.a
366 %{_libdir}/%{name}/*.a
367
368 %files X11
369 %defattr(644,root,root,755)
370 %attr(755,root,root) %{_bindir}/svlc
371 %attr(755,root,root) %{_bindir}/wxvlc
372 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
373 %attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
374 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
375 %attr(755,root,root) %{_libdir}/vlc/video_output
376 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
377 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
378 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
379 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
380 %{_datadir}/%{name}/skins2
381 %{_datadir}/%{name}/vlc*.xpm
382 %{_datadir}/%{name}/pda*.xpm
383 %{_datadir}/%{name}/vlc*.png
384 %{_datadir}/%{name}/vlc*.ico
385 %{_desktopdir}/*.desktop
386
387 %if %{with ggi}
388 %files GGI
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
391 %endif
392
393 %files SDL
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
396 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
397
398 %files fb
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
401
402 %files esd
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
405
406 %if %{with alsa}
407 %files alsa
408 %defattr(644,root,root,755)
409 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
410 %endif
This page took 0.111977 seconds and 4 git commands to generate.