]> git.pld-linux.org Git - packages/vlc.git/blob - vlc.spec
- some bcond descs
[packages/vlc.git] / vlc.spec
1 #
2 # TODO:
3 # - check the altivec patch 
4 # - add proper package descriptions/translations
5 # - bcondize this damn spec! (it should be automated too)
6 # - go through the configure --help and add all options with proper
7 #   reqs and bconds
8 #
9 # Conditional build:
10 %bcond_without  aa      # build without aalib support
11 %bcond_without  caca    # build without caca support
12 %bcond_without  dv      # build without dv support
13 %bcond_without  lirc    # build without lirc support
14 %bcond_without  x264    # build without x264 support
15 %bcond_without  alsa    # don't build alsa plugin
16 %bcond_without  arts    # don't build arts plugin
17 %bcond_without  ggi     # don't build ggi plugin
18 %bcond_without  live    # build without live.com support
19 %bcond_without  speex   # don't build speex plugin
20 %bcond_with     mozilla # build mozilla plugin
21 %bcond_with     slp     # build with slp, broken
22 %bcond_with     svgalib # build with svgalib video_output
23 %bcond_with     hal     # build with hal support
24 #
25 Summary:        VLC - a multimedia player and stream server
26 Summary(pl):    VLC - odtwarzacz multimedialny oraz serwer strumieni
27 Name:           vlc
28 Version:        0.8.5
29 Release:        0.1
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 # use the bz2 src, its a 4mb difference
33 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
34 # Source0-md5:  16bb5bf87ed94879a8eb7b0ff9b4f16f
35 Source1:        %{name}.desktop
36 Patch0:         %{name}-altivec.patch
37 Patch1:         %{name}-buildflags.patch
38 Patch2:         %{name}-defaultfont.patch
39 Patch3:         %{name}-live.patch
40 Patch4:         %{name}-pic-mmx.patch
41 Patch5:         %{name}-matroska-shared.patch
42 Patch6:         %{name}-real_codecs_path.patch
43 Patch7:         %{name}-osdmenu_path.patch
44 URL:            http://www.videolan.org/vlc/
45 BuildRequires:  OpenGL-devel
46 BuildRequires:  SDL_image-devel >= 1.2
47 BuildRequires:  a52dec-libs-devel
48 %{?with_aa:BuildRequires:       aalib-devel}
49 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9}
50 %{?with_arts:BuildRequires:     artsc-devel}
51 BuildRequires:  autoconf
52 BuildRequires:  automake
53 BuildRequires:  esound-devel
54 BuildRequires:  faad2-devel
55 BuildRequires:  ffmpeg-devel >= 0.4.9
56 BuildRequires:  flac-devel
57 BuildRequires:  fribidi-devel
58 BuildRequires:  gettext-devel
59 %{?with_hal:BuildRequires:      hal-devel >= 0.2.97}
60 %{?with_dv:BuildRequires:       libavc1394-devel}
61 %{?with_caca:BuildRequires:     libcaca-devel}
62 BuildRequires:  libcdio-devel
63 BuildRequires:  libcddb-devel
64 BuildRequires:  libdts-devel
65 %{?with_dv:BuildRequires:       libdv-devel}
66 BuildRequires:  libdvbpsi-devel
67 BuildRequires:  libdvdnav-devel
68 BuildRequires:  libdvdread-devel
69 BuildRequires:  libdvdcss-devel
70 BuildRequires:  libebml-devel >= 0.7.6
71 %{?with_ggi:BuildRequires:      libggi-devel}
72 BuildRequires:  libid3tag-devel
73 BuildRequires:  libmad-devel
74 BuildRequires:  libmatroska-devel >= 0.7.5
75 BuildRequires:  libmodplug-devel
76 BuildRequires:  libogg-devel
77 BuildRequires:  libpng-devel
78 %{?with_dv:BuildRequires:       libraw1394-devel}
79 BuildRequires:  libsmbclient-devel
80 BuildRequires:  libtheora-devel
81 BuildRequires:  libtool
82 BuildRequires:  libvorbis-devel
83 %{?with_x264:BuildRequires:     libx264-devel}
84 BuildRequires:  libxml2-devel
85 %{?with_lirc:BuildRequires:     lirc-devel}
86 %{?with_live:BuildRequires:     live >= 2005.03.11}
87 BuildRequires:  mpeg2dec-devel >= 0.3.2
88 %{?with_mozilla:BuildRequires:  mozilla-devel}
89 BuildRequires:  ncurses-devel
90 %{?with_slp:BuildRequires:      openslp-devel}
91 BuildRequires:  pkgconfig
92 %{?with_speex:BuildRequires:    speex-devel > 1:1.1.0}
93 %{?with_svgalib:BuildRequires:  svgalib-devel}
94 BuildRequires:  vcdimager-devel
95 BuildRequires:  wxGTK2-unicode-devel >= 2.6.2-2
96 BuildRequires:  xosd-devel
97 BuildRequires:  xvid-devel
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %description
101 VLC (initially VideoLAN Client) is a multimedia player for various 
102 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
103 as well as DVDs, VCDs, and various streaming protocols. It can also 
104 be used as a server to stream in unicast or multicast in IPv4 
105 or IPv6 on a high-bandwidth network.
106
107 %description -l pl
108 VLC (wcze¶niej znany pod nazw± VideoLAN Client) jest odtwarzaczem 
109 multimedialnym dla wielu formatów wideo i d¼wiêku (MPEG-1, MPEG-2, 
110 MPEG-4, DivX, MP3, Ogg, ...), p³yt DVD, VCD oraz ró¿nych protoko³ów 
111 strumieniowych. Mo¿e byæ wykorzystany jako serwer do wysy³ania 
112 strumieni unicast lub multicast w protoko³ach IPv4 lub IPv6 
113 w wysokoprzepustowych sieciach.
114
115 %package devel
116 Summary:        VLC header files
117 Summary(pl):    Pliki nag³ówkowe VLC
118 Group:          X11/Development/Libraries
119 Requires:       %{name} = %{version}-%{release}
120
121 %description devel
122 VLC header files.
123
124 %description devel -l pl
125 Pliki nag³ówkowe VLC.
126
127 %package static
128 Summary:        VLC static libraries
129 Summary(pl):    Biblioteki statyczne VLC
130 Group:          X11/Development/Libraries
131 Requires:       %{name}-devel = %{version}-%{release}
132
133 %description static
134 VLC static libraries.
135
136 %description static -l pl
137 Biblioteki statyczne VLC.
138
139 %package X11
140 Summary:        VLC - X11 output plugin
141 Summary(pl):    Klient VLC - wtyczka wyj¶cia X11
142 Group:          X11/Applications/Multimedia
143 Requires:       %{name} = %{version}-%{release}
144 Obsoletes:      vlc-gnome
145 Obsoletes:      vlc-gtk
146
147 %description X11
148 X11 output plugin for VLC. Contains GUI image/icon resources.
149
150 %description X11 -l pl
151 Wtyczka wyj¶cia X11 dla klienta VLC. Zawiera zasoby interfejsu 
152 GUI (obrazy/ikony).
153
154 %package GGI
155 Summary:        VLC - GGI output plugin
156 Summary(pl):    Klient VLC - wtyczka wyj¶cia GGI
157 Group:          X11/Applications/Multimedia
158 Requires:       %{name} = %{version}-%{release}
159
160 %description GGI
161 GGI output plugin for VLC.
162
163 %description GGI -l pl
164 Wtyczka wyj¶cia GGI dla klienta VLC.
165
166 %package fb
167 Summary:        VLC - fb output plugin
168 Summary(pl):    Klient VLC - wtyczka wyj¶cia fb
169 Group:          X11/Applications/Multimedia
170 Requires:       %{name} = %{version}-%{release}
171
172 %description fb
173 fb output plugin for VLC.
174
175 %description fb -l pl
176 Wtyczka wyj¶cia fb dla klienta VLC.
177
178 %package SDL
179 Summary:        VLC - SDL output plugin
180 Summary(pl):    Klient VLC - wtyczka wyj¶cia SDL
181 Group:          X11/Applications/Multimedia
182 Requires:       %{name} = %{version}-%{release}
183
184 %description SDL
185 SDL output plugin for VLC.
186
187 %description SDL -l pl
188 Wtyczka wyj¶cia SDL dla klienta VLC.
189
190 %package esd
191 Summary:        VLC - EsounD audio output plugin
192 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku EsounD
193 Group:          X11/Applications/Multimedia
194 Requires:       %{name} = %{version}-%{release}
195
196 %description esd
197 EsounD audio output plugin for VLC.
198
199 %description esd -l pl
200 Wtyczka wyj¶cia d¼wiêku EsounD dla klienta VLC.
201
202 %package alsa
203 Summary:        VLC - ALSA audio output plugin
204 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku ALSA
205 Group:          X11/Applications/Multimedia
206 Requires:       %{name} = %{version}-%{release}
207
208 %description alsa
209 ALSA audio output plugin for VLC.
210
211 %description alsa -l pl
212 Wtyczka wyj¶cia d¼wiêku ALSA dla klienta VLC.
213
214 %prep
215 %setup -q
216 ## %patch0 -p1
217 %patch1 -p0
218 %patch2 -p1
219 %patch3 -p1
220 %patch4 -p1
221 %patch5 -p1
222 %patch6 -p1
223 %patch7 -p1
224
225 %build
226 cp -f /usr/share/automake/config.* .
227 %{__gettextize}
228 %{__aclocal} -I m4
229 %{__autoconf}
230 CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
231 %configure \
232 %ifarch ppc
233         --disable-altivec \
234 %endif
235         --%{?with_aa:en}%{!?with_aa:dis}able-aa \
236         %{?with_alsa:--enable-alsa} \
237         %{?with_arts:--enable-arts} \
238         %{!?with_arts:--disable-arts} \
239         --%{?with_caca:en}%{!?with_caca:dis}able-caca \
240         --enable-dsp \
241         --enable-dummy \
242         --%{?with_dv:en}%{!?with_dv:dis}able-dv \
243         --enable-dvb \
244         --enable-dvbpsi \
245         --with-dvdcss \
246         --enable-dvdnav \
247         --enable-dvdread \
248         --enable-esd \
249         --enable-faad \
250         --enable-fb \
251         --enable-freetype \
252         --enable-fribidi \
253         --enable-ffmpeg \
254         --enable-flac \
255         --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
256         %{?with_ggi:--with-ggi} \
257         %{!?with_speex:--disable-speex} \
258         --disable-glide \
259         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
260         --enable-mad \
261         --enable-mga \
262         %{?with_mozilla:--enable-mozilla } \
263         %{?with_live:--enable-livedotcom } \
264         %{!?with_live:--disable-livedotcom } \
265         --with-livedotcom-tree=%{_libdir}/liveMedia \
266         --enable-ncurses \
267         --enable-pvr \
268         --enable-real \
269         --enable-realrtsp \
270         --enable-sdl \
271         --with-sdl=/usr \
272         --enable-skins2 \
273         %{?with_slp:--enable-slp} \
274         %{!?with_slp:--disable-slp} \
275         --enable-smb \
276         %{?with_svgalib:--enable-svgalib} \
277         --enable-tarkin \
278         --enable-theora \
279         --enable-tremor \
280         --enable-v4l\
281         --enable-x11 \
282         %{!?with_x264:--disable-x264} \
283         --enable-xosd \
284         --enable-xvid \
285         --enable-oss \
286         --disable-testsuite \
287         --with-wx-config=wx-gtk2-unicode-config \
288         %{!?with_hal:--disable-hal} \
289         --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
290
291 # echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
292 %{__make}
293
294 %install
295 rm -rf $RPM_BUILD_ROOT
296 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
297
298 %{__make} install \
299         DESTDIR=$RPM_BUILD_ROOT
300
301 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
302 install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
303
304 %if "%{_lib}" != "lib"
305 install -d $RPM_BUILD_ROOT%{_prefix}/lib
306 ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
307 %endif
308
309 %find_lang %{name}
310
311 %clean
312 rm -rf $RPM_BUILD_ROOT
313
314 %files -f %{name}.lang
315 %defattr(644,root,root,755)
316 %doc AUTHORS MAINTAINERS NEWS README THANKS
317 %doc doc/bugreport-howto.txt doc/intf-cdda.txt
318 %doc doc/intf-vcd.txt doc/translations.txt
319 %attr(755,root,root) %{_bindir}/vlc
320 %if "%{_lib}" != "lib"
321 %{_prefix}/lib/vlc
322 %endif
323 %dir %{_libdir}/vlc
324 %dir %{_libdir}/vlc/gui
325 %dir %{_libdir}/vlc/visualization
326 %attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
327 %attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
328 %attr(755,root,root) %{_libdir}/vlc/mux
329 %attr(755,root,root) %{_libdir}/vlc/misc
330 %attr(755,root,root) %{_libdir}/vlc/control
331 %attr(755,root,root) %{_libdir}/vlc/access_output
332 %attr(755,root,root) %{_libdir}/vlc/codec
333 %attr(755,root,root) %{_libdir}/vlc/demux
334 %attr(755,root,root) %{_libdir}/vlc/access
335 %exclude %{_libdir}/vlc/access/libscreen_plugin.so
336 %attr(755,root,root) %{_libdir}/vlc/video_chroma
337 %attr(755,root,root) %{_libdir}/vlc/audio_mixer
338 %attr(755,root,root) %{_libdir}/vlc/video_filter
339 %dir %{_libdir}/vlc/video_output
340 %attr(755,root,root) %{_libdir}/vlc/stream_out
341 %attr(755,root,root) %{_libdir}/vlc/audio_filter
342 %attr(755,root,root) %{_libdir}/vlc/packetizer
343 %attr(755,root,root) %{_libdir}/vlc/access_filter
344 %attr(755,root,root) %{_libdir}/vlc/services_discovery
345 %dir %{_libdir}/vlc/audio_output
346 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
347 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
348 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
349 %attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
350 %dir %{_datadir}/%{name}
351 %{_datadir}/%{name}/http
352 %{_datadir}/%{name}/osdmenu
353 %{_mandir}/man1/vlc.1*
354
355 %files devel
356 %defattr(644,root,root,755)
357 %attr(755,root,root) %{_bindir}/vlc-config
358 %dir %{_includedir}/%{name}
359 %{_includedir}/%{name}/*
360
361 %files static
362 %defattr(644,root,root,755)
363 %{_libdir}/libvlc.a
364 %{_libdir}/%{name}/*.a
365
366 %files X11
367 %defattr(644,root,root,755)
368 %attr(755,root,root) %{_bindir}/svlc
369 %attr(755,root,root) %{_bindir}/wxvlc
370 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
371 %attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
372 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
373 %attr(755,root,root) %{_libdir}/vlc/video_output
374 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
375 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
376 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
377 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
378 %{_datadir}/%{name}/skins2
379 %{_datadir}/%{name}/vlc*.xpm
380 %{_datadir}/%{name}/pda*.xpm
381 %{_datadir}/%{name}/vlc*.png
382 %{_datadir}/%{name}/vlc*.ico
383 %{_desktopdir}/*
384
385 %if %{with ggi}
386 %files GGI
387 %defattr(644,root,root,755)
388 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
389 %endif 
390
391 %files SDL
392 %defattr(644,root,root,755)
393 %attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
394 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
395
396 %files fb
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
399
400 %files esd
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
403
404 %if %{with alsa}
405 %files alsa
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
408 %endif
This page took 0.0539 seconds and 4 git commands to generate.