]> git.pld-linux.org Git - packages/vlc.git/blob - vlc.spec
- BR wxGTK2-unicode-devel proper version
[packages/vlc.git] / vlc.spec
1 #
2 # TODO:
3 # - check the altivec patch 
4 # - add proper package descriptions/translations
5 # - bcondize this damn spec! (it should be automated too)
6 # - go through the configure --help and add all options with proper
7 #   reqs and bconds
8 # Conditional build:
9 %bcond_without  aa
10 %bcond_without  caca
11 %bcond_without  dv
12 %bcond_without  lirc
13 %bcond_without  alsa    # don't build alsa plugin
14 %bcond_without  arts    # don't build arts plugin
15 %bcond_without  ggi     # don't build ggi plugin
16 %bcond_without  live    # build without live.com support
17 %bcond_without  speex   # don't build speex plugin
18 %bcond_with     mozilla # build mozilla plugin
19 %bcond_with     slp     # build with slp, broken
20 %bcond_with     svgalib # build with svgalib video_output
21 %bcond_with     hal     # build with hal support
22 #
23 Summary:        VLC - a multimedia player and stream server
24 Summary(pl):    VLC - odtwarzacz multimedialny oraz serwer strumieni
25 Name:           vlc
26 Version:        0.8.5
27 Release:        0.1
28 License:        GPL
29 Group:          X11/Applications/Multimedia
30 # use the bz2 src, its a 4mb difference
31 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
32 # Source0-md5:  16bb5bf87ed94879a8eb7b0ff9b4f16f
33 Source1:        %{name}.desktop
34 Patch0:         %{name}-altivec.patch
35 Patch1:         %{name}-buildflags.patch
36 Patch2:         %{name}-defaultfont.patch
37 Patch3:         %{name}-live.patch
38 Patch4:         %{name}-pic-mmx.patch
39 Patch5:         %{name}-matroska-shared.patch
40 Patch6:         %{name}-real_codecs_path.patch
41 URL:            http://www.videolan.org/vlc/
42 BuildRequires:  OpenGL-devel
43 BuildRequires:  SDL_image-devel >= 1.2
44 BuildRequires:  a52dec-libs-devel
45 %{?with_aa:BuildRequires:       aalib-devel}
46 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9}
47 %{?with_arts:BuildRequires:     artsc-devel}
48 BuildRequires:  autoconf
49 BuildRequires:  automake
50 BuildRequires:  esound-devel
51 BuildRequires:  faad2-devel
52 BuildRequires:  ffmpeg-devel >= 0.4.9
53 BuildRequires:  flac-devel
54 BuildRequires:  fribidi-devel
55 BuildRequires:  gettext-devel
56 %{?with_hal:BuildRequires:      hal-devel >= 0.2.97}
57 %{?with_dv:BuildRequires:       libavc1394-devel}
58 %{?with_caca:BuildRequires:     libcaca-devel}
59 BuildRequires:  libcdio-devel
60 BuildRequires:  libcddb-devel
61 BuildRequires:  libdts-devel
62 %{?with_dv:BuildRequires:       libdv-devel}
63 BuildRequires:  libdvbpsi-devel
64 BuildRequires:  libdvdnav-devel
65 BuildRequires:  libdvdread-devel
66 BuildRequires:  libdvdcss-devel
67 BuildRequires:  libebml-devel >= 0.7.6
68 %{?with_ggi:BuildRequires:      libggi-devel}
69 BuildRequires:  libid3tag-devel
70 BuildRequires:  libmad-devel
71 BuildRequires:  libmatroska-devel >= 0.7.5
72 BuildRequires:  libmodplug-devel
73 BuildRequires:  libogg-devel
74 BuildRequires:  libpng-devel
75 %{?with_dv:BuildRequires:       libraw1394-devel}
76 BuildRequires:  libsmbclient-devel
77 BuildRequires:  libtheora-devel
78 BuildRequires:  libtool
79 BuildRequires:  libvorbis-devel
80 BuildRequires:  libxml2-devel
81 %{?with_lirc:BuildRequires:     lirc-devel}
82 %{?with_live:BuildRequires:     live >= 2005.03.11}
83 BuildRequires:  mpeg2dec-devel >= 0.3.2
84 %{?with_mozilla:BuildRequires:  mozilla-devel}
85 BuildRequires:  ncurses-devel
86 %{?with_slp:BuildRequires:      openslp-devel}
87 BuildRequires:  pkgconfig
88 %{?with_speex:BuildRequires:    speex-devel > 1:1.1.0}
89 %{?with_svgalib:BuildRequires:  svgalib-devel}
90 BuildRequires:  vcdimager-devel
91 BuildRequires:  wxGTK2-unicode-devel >= 2.6.2-2
92 BuildRequires:  xosd-devel
93 BuildRequires:  xvid-devel
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %description
97 VLC (initially VideoLAN Client) is a multimedia player for various 
98 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
99 as well as DVDs, VCDs, and various streaming protocols. It can also 
100 be used as a server to stream in unicast or multicast in IPv4 
101 or IPv6 on a high-bandwidth network.
102
103 %description -l pl
104 VLC (wcze¶niej znany pod nazw± VideoLAN Client) jest odtwarzaczem 
105 multimedialnym dla wielu formatów wideo i d¼wiêku (MPEG-1, MPEG-2, 
106 MPEG-4, DivX, MP3, Ogg, ...), p³yt DVD, VCD oraz ró¿nych protoko³ów 
107 strumieniowych. Mo¿e byæ wykorzystany jako serwer do wysy³ania 
108 strumieni unicast lub multicast w protoko³ach IPv4 lub IPv6 
109 w wysokoprzepustowych sieciach.
110
111 %package devel
112 Summary:        VLC header files
113 Summary(pl):    Pliki nag³ówkowe VLC
114 Group:          X11/Development/Libraries
115 Requires:       %{name} = %{version}-%{release}
116
117 %description devel
118 VLC header files.
119
120 %description devel -l pl
121 Pliki nag³ówkowe VLC.
122
123 %package static
124 Summary:        VLC static libraries
125 Summary(pl):    Biblioteki statyczne VLC
126 Group:          X11/Development/Libraries
127 Requires:       %{name}-devel = %{version}-%{release}
128
129 %description static
130 VLC static libraries.
131
132 %description static -l pl
133 Biblioteki statyczne VLC.
134
135 %package X11
136 Summary:        VLC - X11 output plugin
137 Summary(pl):    Klient VLC - wtyczka wyj¶cia X11
138 Group:          X11/Applications/Multimedia
139 Requires:       %{name} = %{version}-%{release}
140 Obsoletes:      vlc-gnome
141 Obsoletes:      vlc-gtk
142
143 %description X11
144 X11 output plugin for VLC. Contains GUI image/icon resources.
145
146 %description X11 -l pl
147 Wtyczka wyj¶cia X11 dla klienta VLC. Zawiera zasoby interfejsu 
148 GUI (obrazy/ikony).
149
150 %package GGI
151 Summary:        VLC - GGI output plugin
152 Summary(pl):    Klient VLC - wtyczka wyj¶cia GGI
153 Group:          X11/Applications/Multimedia
154 Requires:       %{name} = %{version}-%{release}
155
156 %description GGI
157 GGI output plugin for VLC.
158
159 %description GGI -l pl
160 Wtyczka wyj¶cia GGI dla klienta VLC.
161
162 %package fb
163 Summary:        VLC - fb output plugin
164 Summary(pl):    Klient VLC - wtyczka wyj¶cia fb
165 Group:          X11/Applications/Multimedia
166 Requires:       %{name} = %{version}-%{release}
167
168 %description fb
169 fb output plugin for VLC.
170
171 %description fb -l pl
172 Wtyczka wyj¶cia fb dla klienta VLC.
173
174 %package SDL
175 Summary:        VLC - SDL output plugin
176 Summary(pl):    Klient VLC - wtyczka wyj¶cia SDL
177 Group:          X11/Applications/Multimedia
178 Requires:       %{name} = %{version}-%{release}
179
180 %description SDL
181 SDL output plugin for VLC.
182
183 %description SDL -l pl
184 Wtyczka wyj¶cia SDL dla klienta VLC.
185
186 %package esd
187 Summary:        VLC - EsounD audio output plugin
188 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku EsounD
189 Group:          X11/Applications/Multimedia
190 Requires:       %{name} = %{version}-%{release}
191
192 %description esd
193 EsounD audio output plugin for VLC.
194
195 %description esd -l pl
196 Wtyczka wyj¶cia d¼wiêku EsounD dla klienta VLC.
197
198 %package alsa
199 Summary:        VLC - ALSA audio output plugin
200 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku ALSA
201 Group:          X11/Applications/Multimedia
202 Requires:       %{name} = %{version}-%{release}
203
204 %description alsa
205 ALSA audio output plugin for VLC.
206
207 %description alsa -l pl
208 Wtyczka wyj¶cia d¼wiêku ALSA dla klienta VLC.
209
210 %prep
211 %setup -q
212 ## %patch0 -p1
213 %patch1 -p0
214 %patch2 -p1
215 %patch3 -p1
216 %patch4 -p1
217 %patch5 -p1
218 %patch6 -p1
219
220 %build
221 cp -f /usr/share/automake/config.* .
222 %{__gettextize}
223 %{__aclocal} -I m4
224 %{__autoconf}
225 CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
226 %configure \
227 %ifarch ppc
228         --disable-altivec \
229 %endif
230         --%{?with_aa:en}%{!?with_aa:dis}able-aa \
231         %{?with_alsa:--enable-alsa} \
232         %{?with_arts:--enable-arts} \
233         %{!?with_arts:--disable-arts} \
234         --%{?with_caca:en}%{!?with_caca:dis}able-caca \
235         --enable-dsp \
236         --enable-dummy \
237         --%{?with_dv:en}%{!?with_dv:dis}able-dv \
238         --enable-dvb \
239         --enable-dvbpsi \
240         --with-dvdcss \
241         --enable-dvdnav \
242         --enable-dvdread \
243         --enable-esd \
244         --enable-faad \
245         --enable-fb \
246         --enable-freetype \
247         --enable-fribidi \
248         --enable-ffmpeg \
249         --enable-flac \
250         --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
251         %{?with_ggi:--with-ggi} \
252         %{!?with_speex:--disable-speex} \
253         --disable-glide \
254         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
255         --enable-mad \
256         --enable-mga \
257         %{?with_mozilla:--enable-mozilla } \
258         %{?with_live:--enable-livedotcom } \
259         %{!?with_live:--disable-livedotcom } \
260         --with-livedotcom-tree=%{_libdir}/liveMedia \
261         --enable-ncurses \
262         --enable-pvr \
263         --enable-real \
264         --enable-realrtsp \
265         --enable-sdl \
266         --with-sdl=/usr \
267         --enable-skins2 \
268         %{?with_slp:--enable-slp} \
269         %{!?with_slp:--disable-slp} \
270         --enable-smb \
271         %{?with_svgalib:--enable-svgalib} \
272         --enable-tarkin \
273         --enable-theora \
274         --enable-tremor \
275         --enable-v4l\
276         --enable-x11 \
277         --enable-xosd \
278         --enable-xvid \
279         --enable-oss \
280         --disable-testsuite \
281         --with-wx-config=wx-gtk2-unicode-config \
282         %{!?with_hal:--disable-hal} \
283         --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
284
285 # echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
286 %{__make}
287
288 %install
289 rm -rf $RPM_BUILD_ROOT
290 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
291
292 %{__make} install \
293         DESTDIR=$RPM_BUILD_ROOT
294
295 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
296 install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
297
298 %if "%{_lib}" != "lib"
299 install -d $RPM_BUILD_ROOT%{_prefix}/lib
300 ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
301 %endif
302
303 %find_lang %{name}
304
305 %clean
306 rm -rf $RPM_BUILD_ROOT
307
308 %files -f %{name}.lang
309 %defattr(644,root,root,755)
310 %doc AUTHORS MAINTAINERS NEWS README THANKS
311 %doc doc/bugreport-howto.txt doc/intf-cdda.txt
312 %doc doc/intf-vcd.txt doc/translations.txt
313 %attr(755,root,root) %{_bindir}/vlc
314 %if "%{_lib}" != "lib"
315 %{_prefix}/lib/vlc
316 %endif
317 %dir %{_libdir}/vlc
318 %dir %{_libdir}/vlc/gui
319 %dir %{_libdir}/vlc/visualization
320 %attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
321 %attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
322 %attr(755,root,root) %{_libdir}/vlc/mux
323 %attr(755,root,root) %{_libdir}/vlc/misc
324 %attr(755,root,root) %{_libdir}/vlc/control
325 %attr(755,root,root) %{_libdir}/vlc/access_output
326 %attr(755,root,root) %{_libdir}/vlc/codec
327 %attr(755,root,root) %{_libdir}/vlc/demux
328 %attr(755,root,root) %{_libdir}/vlc/access
329 %exclude %{_libdir}/vlc/access/libscreen_plugin.so
330 %attr(755,root,root) %{_libdir}/vlc/video_chroma
331 %attr(755,root,root) %{_libdir}/vlc/audio_mixer
332 %attr(755,root,root) %{_libdir}/vlc/video_filter
333 %dir %{_libdir}/vlc/video_output
334 %attr(755,root,root) %{_libdir}/vlc/stream_out
335 %attr(755,root,root) %{_libdir}/vlc/audio_filter
336 %attr(755,root,root) %{_libdir}/vlc/packetizer
337 %attr(755,root,root) %{_libdir}/vlc/access_filter
338 %attr(755,root,root) %{_libdir}/vlc/services_discovery
339 %dir %{_libdir}/vlc/audio_output
340 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
341 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
342 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
343 %attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
344 %dir %{_datadir}/%{name}
345 %{_datadir}/%{name}/http
346 %{_datadir}/%{name}/osdmenu
347 %{_mandir}/man1/vlc.1*
348
349 %files devel
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_bindir}/vlc-config
352 %dir %{_includedir}/%{name}
353 %{_includedir}/%{name}/*
354
355 %files static
356 %defattr(644,root,root,755)
357 %{_libdir}/libvlc.a
358 %{_libdir}/%{name}/*.a
359
360 %files X11
361 %defattr(644,root,root,755)
362 %attr(755,root,root) %{_bindir}/svlc
363 %attr(755,root,root) %{_bindir}/wxvlc
364 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
365 %attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
366 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
367 %attr(755,root,root) %{_libdir}/vlc/video_output
368 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
369 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
370 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
371 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
372 %{_datadir}/%{name}/skins2
373 %{_datadir}/%{name}/vlc*.xpm
374 %{_datadir}/%{name}/pda*.xpm
375 %{_datadir}/%{name}/vlc*.png
376 %{_datadir}/%{name}/vlc*.ico
377 %{_desktopdir}/*
378
379 %if %{with ggi}
380 %files GGI
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
383 %endif 
384
385 %files SDL
386 %defattr(644,root,root,755)
387 %attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
388 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
389
390 %files fb
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
393
394 %files esd
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
397
398 %if %{with alsa}
399 %files alsa
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
402 %endif
This page took 0.05297 seconds and 4 git commands to generate.