]> git.pld-linux.org Git - packages/vlc.git/blob - vlc.spec
ba2147b9f03eb267375c4e2b6e54780d786651bd
[packages/vlc.git] / vlc.spec
1 #
2 # TODO:
3 # - check the altivec patch
4 # - add proper package descriptions/translations
5 # - bcondize this damn spec! (it should be automated too)
6 # - go through the configure --help and add all options with proper
7 #   reqs and bconds
8 #
9 # Conditional build:
10 %bcond_without  aa      # build without aalib support
11 %bcond_without  caca    # build without caca support
12 %bcond_without  dv      # build without dv support
13 %bcond_without  lirc    # build without lirc support
14 %bcond_without  x264    # build without x264 support
15 %bcond_without  alsa    # don't build alsa plugin
16 %bcond_without  arts    # don't build arts plugin
17 %bcond_without  ggi     # don't build ggi plugin
18 %bcond_without  live    # build without live.com support
19 %bcond_without  speex   # don't build speex plugin
20 %bcond_with     mozilla # build mozilla plugin
21 %bcond_with     slp     # build with slp, broken
22 %bcond_with     svgalib # build with svgalib video_output
23 %bcond_with     hal     # build with hal support
24 #
25 Summary:        VLC - a multimedia player and stream server
26 Summary(pl):    VLC - odtwarzacz multimedialny oraz serwer strumieni
27 Name:           vlc
28 Version:        0.8.6
29 Release:        4
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 # use the bz2 src, its a 4mb difference
33 Source0:        http://download.videolan.org/pub/videolan/vlc/%{version}/%{name}-%{version}.tar.bz2
34 # Source0-md5:  77a275f3408c4c9feae451d4eae47f89
35 Source1:        %{name}.desktop
36 Patch0:         %{name}-altivec.patch
37 Patch1:         %{name}-buildflags.patch
38 Patch2:         %{name}-defaultfont.patch
39 Patch3:         %{name}-live.patch
40 Patch4:         %{name}-pic-mmx.patch
41 Patch5:         %{name}-real_codecs_path.patch
42 Patch6:         %{name}-osdmenu_path.patch
43 Patch7:         %{name}-wx.patch
44 URL:            http://www.videolan.org/vlc/
45 BuildRequires:  OpenGL-devel
46 BuildRequires:  SDL_image-devel >= 1.2
47 BuildRequires:  a52dec-libs-devel
48 %{?with_aa:BuildRequires:       aalib-devel}
49 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9}
50 %{?with_arts:BuildRequires:     artsc-devel}
51 BuildRequires:  autoconf
52 BuildRequires:  automake
53 BuildRequires:  esound-devel
54 BuildRequires:  faad2-devel >= 2.5
55 BuildRequires:  ffmpeg-devel >= 0.4.9
56 BuildRequires:  flac-devel
57 BuildRequires:  fribidi-devel
58 BuildRequires:  gettext-devel
59 %{?with_hal:BuildRequires:      hal-devel >= 0.2.97}
60 %{?with_dv:BuildRequires:       libavc1394-devel}
61 %{?with_caca:BuildRequires:     libcaca-devel}
62 BuildRequires:  libcddb-devel
63 BuildRequires:  libcdio-devel
64 BuildRequires:  libdts-devel
65 %{?with_dv:BuildRequires:       libdv-devel}
66 BuildRequires:  libdvbpsi-devel
67 BuildRequires:  libdvdcss-devel
68 BuildRequires:  libdvdnav-devel
69 BuildRequires:  libdvdread-devel
70 BuildRequires:  libebml-devel >= 0.7.6
71 %{?with_ggi:BuildRequires:      libggi-devel}
72 BuildRequires:  libid3tag-devel
73 BuildRequires:  libmad-devel
74 BuildRequires:  libmatroska-devel >= 0.7.5
75 BuildRequires:  libmodplug-devel
76 BuildRequires:  libmpcdec-devel >= 1.2.1
77 BuildRequires:  libogg-devel
78 BuildRequires:  libpng-devel
79 %{?with_dv:BuildRequires:       libraw1394-devel}
80 BuildRequires:  libsmbclient-devel
81 BuildRequires:  libtheora-devel
82 BuildRequires:  libtool
83 BuildRequires:  libvorbis-devel
84 %{?with_x264:BuildRequires:     libx264-devel}
85 BuildRequires:  libxml2-devel
86 %{?with_lirc:BuildRequires:     lirc-devel}
87 %{?with_live:BuildRequires:     live >= 2005.03.11}
88 %{?with_mozilla:BuildRequires:  mozilla-devel}
89 BuildRequires:  mpeg2dec-devel >= 0.3.2
90 BuildRequires:  ncurses-devel
91 %{?with_slp:BuildRequires:      openslp-devel}
92 BuildRequires:  pkgconfig
93 %{?with_speex:BuildRequires:    speex-devel > 1:1.1.0}
94 %{?with_svgalib:BuildRequires:  svgalib-devel}
95 BuildRequires:  vcdimager-devel
96 BuildRequires:  wxGTK2-unicode-devel >= 2.6.2-2
97 BuildRequires:  xosd-devel
98 BuildRequires:  xvid-devel
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %description
102 VLC (initially VideoLAN Client) is a multimedia player for various
103 audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, Ogg, ...)
104 as well as DVDs, VCDs, and various streaming protocols. It can also be
105 used as a server to stream in unicast or multicast in IPv4 or IPv6 on
106 a high-bandwidth network.
107
108 %description -l pl
109 VLC (wcze¶niej znany pod nazw± VideoLAN Client) jest odtwarzaczem
110 multimedialnym dla wielu formatów wideo i d¼wiêku (MPEG-1, MPEG-2,
111 MPEG-4, DivX, MP3, Ogg, ...), p³yt DVD, VCD oraz ró¿nych protoko³ów
112 strumieniowych. Mo¿e byæ wykorzystany jako serwer do wysy³ania
113 strumieni unicast lub multicast w protoko³ach IPv4 lub IPv6 w
114 wysokoprzepustowych sieciach.
115
116 %package devel
117 Summary:        VLC header files
118 Summary(pl):    Pliki nag³ówkowe VLC
119 Group:          X11/Development/Libraries
120 Requires:       %{name} = %{version}-%{release}
121
122 %description devel
123 VLC header files.
124
125 %description devel -l pl
126 Pliki nag³ówkowe VLC.
127
128 %package static
129 Summary:        VLC static libraries
130 Summary(pl):    Biblioteki statyczne VLC
131 Group:          X11/Development/Libraries
132 Requires:       %{name}-devel = %{version}-%{release}
133
134 %description static
135 VLC static libraries.
136
137 %description static -l pl
138 Biblioteki statyczne VLC.
139
140 %package X11
141 Summary:        VLC - X11 output plugin
142 Summary(pl):    Klient VLC - wtyczka wyj¶cia X11
143 Group:          X11/Applications/Multimedia
144 Requires:       %{name} = %{version}-%{release}
145 Obsoletes:      vlc-gnome
146 Obsoletes:      vlc-gtk
147
148 %description X11
149 X11 output plugin for VLC. Contains GUI image/icon resources.
150
151 %description X11 -l pl
152 Wtyczka wyj¶cia X11 dla klienta VLC. Zawiera zasoby interfejsu GUI
153 (obrazy/ikony).
154
155 %package GGI
156 Summary:        VLC - GGI output plugin
157 Summary(pl):    Klient VLC - wtyczka wyj¶cia GGI
158 Group:          X11/Applications/Multimedia
159 Requires:       %{name} = %{version}-%{release}
160
161 %description GGI
162 GGI output plugin for VLC.
163
164 %description GGI -l pl
165 Wtyczka wyj¶cia GGI dla klienta VLC.
166
167 %package fb
168 Summary:        VLC - fb output plugin
169 Summary(pl):    Klient VLC - wtyczka wyj¶cia fb
170 Group:          X11/Applications/Multimedia
171 Requires:       %{name} = %{version}-%{release}
172
173 %description fb
174 fb output plugin for VLC.
175
176 %description fb -l pl
177 Wtyczka wyj¶cia fb dla klienta VLC.
178
179 %package SDL
180 Summary:        VLC - SDL output plugin
181 Summary(pl):    Klient VLC - wtyczka wyj¶cia SDL
182 Group:          X11/Applications/Multimedia
183 Requires:       %{name} = %{version}-%{release}
184
185 %description SDL
186 SDL output plugin for VLC.
187
188 %description SDL -l pl
189 Wtyczka wyj¶cia SDL dla klienta VLC.
190
191 %package esd
192 Summary:        VLC - EsounD audio output plugin
193 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku EsounD
194 Group:          X11/Applications/Multimedia
195 Requires:       %{name} = %{version}-%{release}
196
197 %description esd
198 EsounD audio output plugin for VLC.
199
200 %description esd -l pl
201 Wtyczka wyj¶cia d¼wiêku EsounD dla klienta VLC.
202
203 %package alsa
204 Summary:        VLC - ALSA audio output plugin
205 Summary(pl):    Klient VLC - wtyczka wyj¶cia d¼wiêku ALSA
206 Group:          X11/Applications/Multimedia
207 Requires:       %{name} = %{version}-%{release}
208
209 %description alsa
210 ALSA audio output plugin for VLC.
211
212 %description alsa -l pl
213 Wtyczka wyj¶cia d¼wiêku ALSA dla klienta VLC.
214
215 %prep
216 %setup -q
217 ## %patch0 -p1
218 %patch1 -p0
219 %patch2 -p1
220 %patch3 -p1
221 %patch4 -p1
222 %patch5 -p1
223 %patch6 -p1
224 %patch7 -p1
225
226 %build
227 cp -f /usr/share/automake/config.* .
228 %{__gettextize}
229 %{__aclocal} -I m4
230 %{__autoconf}
231 CFLAGS="%{rpmcflags} -DALSA_PCM_OLD_HW_PARAMS_API"
232 %configure \
233 %ifarch ppc
234         --disable-altivec \
235 %endif
236         --%{?with_aa:en}%{!?with_aa:dis}able-aa \
237         %{?with_alsa:--enable-alsa} \
238         %{?with_arts:--enable-arts} \
239         %{!?with_arts:--disable-arts} \
240         --%{?with_caca:en}%{!?with_caca:dis}able-caca \
241         --enable-dsp \
242         --enable-dummy \
243         --%{?with_dv:en}%{!?with_dv:dis}able-dv \
244         --enable-dvb \
245         --enable-dvbpsi \
246         --with-dvdcss \
247         --enable-dvdnav \
248         --enable-dvdread \
249         --enable-esd \
250         --enable-faad \
251         --enable-fb \
252         --enable-freetype \
253         --enable-fribidi \
254         --enable-ffmpeg \
255         --enable-flac \
256         --%{?with_ggi:en}%{!?with_ggi:dis}able-ggi \
257         %{!?with_speex:--disable-speex} \
258         --disable-glide \
259         --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
260         --enable-mad \
261         --enable-mga \
262         %{?with_mozilla:--enable-mozilla } \
263         %{?with_live:--enable-live555 } \
264         %{!?with_live:--disable-live555 } \
265         --with-live555-tree=%{_libdir}/liveMedia \
266         --enable-ncurses \
267         --enable-pvr \
268         --enable-real \
269         --enable-realrtsp \
270         --enable-sdl \
271         --with-sdl=/usr \
272         --enable-skins2 \
273         %{?with_slp:--enable-slp} \
274         %{!?with_slp:--disable-slp} \
275         --enable-smb \
276         %{?with_svgalib:--enable-svgalib} \
277         --enable-tarkin \
278         --enable-theora \
279         --enable-tremor \
280         --enable-v4l\
281         --enable-x11 \
282         %{!?with_x264:--disable-x264} \
283         --enable-xosd \
284         --enable-xvid \
285         --enable-oss \
286         --disable-testsuite \
287         --with-wx-config=wx-gtk2-unicode-config \
288         %{!?with_hal:--disable-hal} \
289         --disable-optimizations # we use own RPM_OPT_FLAGS optimalizations
290
291 # echo "CFLAGS += -I/usr/include/ncurses" >> Makefile.opts
292 %{__make}
293
294 %install
295 rm -rf $RPM_BUILD_ROOT
296 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_mandir}/man1}
297
298 %{__make} install \
299         DESTDIR=$RPM_BUILD_ROOT
300
301 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
302 install doc/vlc.1 $RPM_BUILD_ROOT%{_mandir}/man1
303
304 %if "%{_lib}" != "lib"
305 install -d $RPM_BUILD_ROOT%{_prefix}/lib
306 ln -sf %{_libdir}/vlc $RPM_BUILD_ROOT%{_prefix}/lib
307 %endif
308
309 %find_lang %{name}
310
311 %clean
312 rm -rf $RPM_BUILD_ROOT
313
314 %files -f %{name}.lang
315 %defattr(644,root,root,755)
316 %doc AUTHORS MAINTAINERS NEWS README THANKS
317 %doc doc/bugreport-howto.txt doc/intf-cdda.txt
318 %doc doc/intf-vcd.txt doc/translations.txt
319 %attr(755,root,root) %{_bindir}/vlc
320 %if "%{_lib}" != "lib"
321 %{_prefix}/lib/vlc
322 %endif
323 %dir %{_libdir}/vlc
324 %dir %{_libdir}/vlc/gui
325 %dir %{_libdir}/vlc/visualization
326 %attr(755,root,root) %{_libdir}/vlc/gui/libncurses_plugin.so
327 %attr(755,root,root) %{_libdir}/vlc/visualization/libvisual_plugin.so
328 %attr(755,root,root) %{_libdir}/vlc/mux
329 %attr(755,root,root) %{_libdir}/vlc/misc
330 %attr(755,root,root) %{_libdir}/vlc/control
331 %attr(755,root,root) %{_libdir}/vlc/access_output
332 %attr(755,root,root) %{_libdir}/vlc/codec
333 %attr(755,root,root) %{_libdir}/vlc/demux
334 %attr(755,root,root) %{_libdir}/vlc/access
335 %exclude %{_libdir}/vlc/access/libscreen_plugin.so
336 %attr(755,root,root) %{_libdir}/vlc/video_chroma
337 %attr(755,root,root) %{_libdir}/vlc/audio_mixer
338 %attr(755,root,root) %{_libdir}/vlc/video_filter
339 %dir %{_libdir}/vlc/video_output
340 %attr(755,root,root) %{_libdir}/vlc/stream_out
341 %attr(755,root,root) %{_libdir}/vlc/audio_filter
342 %attr(755,root,root) %{_libdir}/vlc/packetizer
343 %attr(755,root,root) %{_libdir}/vlc/access_filter
344 %attr(755,root,root) %{_libdir}/vlc/services_discovery
345 %dir %{_libdir}/vlc/audio_output
346 %exclude %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
347 %{?with_alsa:%exclude %{_libdir}/%{name}/audio_output/libalsa_plugin.so}
348 %exclude %{_libdir}/%{name}/audio_output/libesd_plugin.so
349 %attr(755,root,root) %{_libdir}/vlc/audio_output/*.so
350 %dir %{_datadir}/%{name}
351 %{_datadir}/%{name}/http
352 %{_datadir}/%{name}/osdmenu
353 %{_mandir}/man1/vlc.1*
354
355 %files devel
356 %defattr(644,root,root,755)
357 %attr(755,root,root) %{_bindir}/vlc-config
358 %dir %{_includedir}/%{name}
359 %{_includedir}/%{name}/*
360
361 %files static
362 %defattr(644,root,root,755)
363 %{_libdir}/libvlc.a
364 %{_libdir}/%{name}/*.a
365
366 %files X11
367 %defattr(644,root,root,755)
368 %attr(755,root,root) %{_bindir}/svlc
369 %attr(755,root,root) %{_bindir}/wxvlc
370 %attr(755,root,root) %{_libdir}/vlc/gui/libskins2_plugin.so
371 %attr(755,root,root) %{_libdir}/vlc/gui/libwxwidgets_plugin.so
372 %attr(755,root,root) %{_libdir}/vlc/access/libscreen_plugin.so
373 %attr(755,root,root) %{_libdir}/vlc/video_output
374 %{?with_ggi:%exclude %{_libdir}/%{name}/video_output/libggi_plugin.so}
375 %exclude %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
376 %exclude %{_libdir}/%{name}/video_output/libfb_plugin.so
377 %attr(755,root,root) %{_libdir}/vlc/visualization/libxosd_plugin.so
378 %{_datadir}/%{name}/skins2
379 %{_datadir}/%{name}/vlc*.xpm
380 %{_datadir}/%{name}/pda*.xpm
381 %{_datadir}/%{name}/vlc*.png
382 %{_datadir}/%{name}/vlc*.ico
383 %{_desktopdir}/*.desktop
384
385 %if %{with ggi}
386 %files GGI
387 %defattr(644,root,root,755)
388 %attr(755,root,root) %{_libdir}/%{name}/video_output/libggi_plugin.so
389 %endif
390
391 %files SDL
392 %defattr(644,root,root,755)
393 %attr(755,root,root) %{_libdir}/%{name}/video_output/libvout_sdl_plugin.so
394 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libaout_sdl_plugin.so
395
396 %files fb
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/%{name}/video_output/libfb_plugin.so
399
400 %files esd
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libesd_plugin.so
403
404 %if %{with alsa}
405 %files alsa
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_libdir}/%{name}/audio_output/libalsa_plugin.so
408 %endif
This page took 0.050548 seconds and 2 git commands to generate.