]> git.pld-linux.org Git - packages/virt-viewer.git/blob - virt-viewer.spec
- let it obsolete withdrawn spice-client from spice-space package
[packages/virt-viewer.git] / virt-viewer.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk2    # use GTK+ 2.x instead of GTK+ 3.x
4 %bcond_without  spice   # SPICE support
5 %bcond_without  ovirt   # oVirt support
6 #
7 Summary:        Virtual Machine Viewer
8 Summary(pl.UTF-8):      Przeglądarka maszyny wirtualnej
9 Name:           virt-viewer
10 Version:        2.0
11 Release:        1
12 License:        GPL v2+
13 Group:          X11/Applications/Networking
14 Source0:        https://fedorahosted.org/released/virt-viewer/%{name}-%{version}.tar.gz
15 # Source0-md5:  4b1e9a2029e0dfff741e17bb915f75ec
16 URL:            http://virt-manager.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  gettext-tools >= 0.14.1
20 BuildRequires:  glib2-devel >= 1:2.22.0
21 BuildRequires:  intltool >= 0.35.0
22 %{?with_ovirt:BuildRequires:    libgovirt-devel >= 0.3.2}
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  libvirt-devel >= 0.10.0
25 BuildRequires:  libxml2-devel >= 1:2.6.0
26 BuildRequires:  perl-tools-pod
27 BuildRequires:  rpmbuild(macros) >= 1.596
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  spice-protocol >= 0.10.1
30 %if %{with gtk2}
31 BuildRequires:  gtk+2-devel >= 2:2.18.0
32 BuildRequires:  gtk-vnc-devel >= 0.4.3
33 %{?with_spice:BuildRequires: spice-gtk2-devel >= 0.22}
34 %else
35 BuildRequires:  gtk+3-devel >= 3.0.0
36 BuildRequires:  gtk3-vnc-devel >= 0.4.3
37 %{?with_spice:BuildRequires: spice-gtk-devel >= 0.22}
38 %endif
39 Requires(post,postun):  gtk-update-icon-cache
40 Requires(post,postun):  shared-mime-info
41 Requires:       glib2 >= 1:2.22.0
42 Requires:       hicolor-icon-theme
43 Requires:       libvirt >= 0.10.0
44 Requires:       libxml2 >= 1:2.6.0
45 %if %{with gtk2}
46 Requires:       gtk+2 >= 2:2.18.0
47 Requires:       gtk-vnc >= 0.4.3
48 %{?with_spice:Requires: spice-gtk2 >= 0.22}
49 %else
50 Requires:       gtk+3 >= 3.0.0
51 Requires:       gtk3-vnc >= 0.4.3
52 %{?with_spice:Requires: spice-gtk >= 0.22}
53 %endif
54 %{?with_ovirt:Requires: libgovirt >= 0.3.2}
55 Suggests:       openssh-clients
56 Suggests:       gnome-keyring >= 0.4.9
57 # let it obsolete withdrawn spice client from spice-space package
58 %{?with_spice:Obsoletes:        spice-client}
59 Obsoletes:      virt-viewer-plugin
60 ExclusiveArch:  %{ix86} %{x8664} ia64
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 Virtual Machine Viewer provides a graphical console client for
65 connecting to virtual machines. It uses the GTK-VNC or SPICE-GTK
66 widgets to provide the display, and libvirt for looking up VNC/SPICE
67 server details.
68
69 %description -l pl.UTF-8
70 Virtual Machine Viewer udostępnia klienta graficznej konsoli do
71 łączenia z maszynami wirtualnymi. Wykorzystuje widgety GTK-VNC lub
72 SPICE-GTK do zapewnienia obrazu oraz libvirt do odczytu szczegółów
73 serwera VNC/SPICE.
74
75 %prep
76 %setup -q
77
78 %{__sed} -i -e 's|PWD|shell pwd|g' icons/*/Makefile.am
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --disable-silent-rules \
88         --disable-update-mimedb \
89         %{__with_without spice spice-gtk} \
90         --with-gtk=%{?with_gtk2:2.0}%{!?with_gtk2:3.0} \
91         %{!?with_ovirt:--without-ovirt}
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # empty version of ru,zh_CN,zh_TW
102 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ru_RU
103 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.GB2312
104 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_TW.Big5
105
106 %find_lang %{name}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 %update_icon_cache hicolor
113 %update_mime_database
114
115 %postun
116 %update_icon_cache hicolor
117 %update_mime_database
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog NEWS README
122 %attr(755,root,root) %{_bindir}/virt-viewer
123 %attr(755,root,root) %{_bindir}/remote-viewer
124 %dir %{_datadir}/%{name}
125 %dir %{_datadir}/%{name}/ui
126 %{_datadir}/%{name}/ui/*.xml
127 %{_datadir}/mime/packages/virt-viewer-mime.xml
128 %{_desktopdir}/remote-viewer.desktop
129 %{_iconsdir}/hicolor/*/apps/virt-viewer.png
130 %{_iconsdir}/hicolor/24x24/devices/virt-viewer-usb.png
131 %{_iconsdir}/hicolor/24x24/devices/virt-viewer-usb.svg
132 %{_mandir}/man1/virt-viewer.1*
133 %{_mandir}/man1/remote-viewer.1*
This page took 0.077808 seconds and 4 git commands to generate.