]> git.pld-linux.org Git - packages/virt-viewer.git/blob - virt-viewer.spec
- 0.5.1
[packages/virt-viewer.git] / virt-viewer.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk2
4 %bcond_without  gtk3
5 %bcond_without  spice
6 %bcond_with     plugin
7 #
8 Summary:        Virtual Machine Viewer
9 Name:           virt-viewer
10 Version:        0.5.1
11 Release:        1
12 License:        GPL v2+
13 Group:          X11/Applications/Networking
14 Source0:        http://virt-manager.org/download/sources/virt-viewer/%{name}-%{version}.tar.gz
15 # Source0-md5:  69c82567df00afadfa2f79d3f1eb692d
16 URL:            http://virt-manager.org/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gettext-devel >= 0.14.1
20 BuildRequires:  glib2-devel
21 BuildRequires:  intltool >= 0.35.0
22 %if %{with gtk3}
23 BuildRequires:  gtk+3-devel >= 3.0.0
24 BuildRequires:  gtk3-vnc-devel >= 0.4.3
25 %{?with_spice:BuildRequires: spice-gtk-devel >= 0.9}
26 %endif
27 %if %{with gtk2}
28 BuildRequires:  gtk+2-devel >= 2.12.0
29 BuildRequires:  gtk-vnc-devel >= 0.4.3
30 %{?with_spice:BuildRequires: spice-gtk2-devel >= 0.9}
31 %endif
32 BuildRequires:  libtool
33 BuildRequires:  libvirt-devel >= 0.6.0
34 BuildRequires:  libxml2-devel
35 BuildRequires:  perl-tools-pod
36 BuildRequires:  sed >= 4.0
37 %{?with_plugin:BuildRequires: xulrunner-devel}
38 Requires(post,postun):  gtk-update-icon-cache
39 Requires:       hicolor-icon-theme
40 Suggests:       openssh-clients
41 Suggests:       gnome-keyring >= 0.4.9
42 ExclusiveArch:  %{ix86} x86_64 ia64
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Virtual Machine Viewer provides a graphical console client for
47 connecting to virtual machines. It uses the GTK-VNC or SPICE-GTK
48 widgets to provide the display, and libvirt for looking up VNC/SPICE
49 server details.
50
51 Virtual Machine Viewer provides a graphical console client for
52 connecting to virtual machines. It uses the GTK-VNC or SPICE-GTK
53 widgets to provide the display, and libvirt for looking up VNC/SPICE
54 server details.
55
56 %package plugin
57 Summary:        Mozilla plugin for the gtk-vnc library
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description plugin
62 Virtual Machine Viewer provides a graphical
63 console client for connecting to virtual machines. It uses the GTK-VNC
64 or SPICE-GTK widgets to provide the display, and libvirt for looking
65 up VNC/SPICE server details.
66
67 This package provides a web browser plugin for Mozilla compatible
68 browsers.
69
70 %prep
71 %setup -q
72
73 %{__sed} -i -e 's|PWD|shell pwd|g' icons/*/Makefile.am
74
75 %build
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoconf}
79 %{__automake}
80 %configure \
81         %{__enable_disable plugin} \
82         %{__with_without spice spice-gtk} \
83         %{__with_without gtk2 gtk 2.0} \
84         %{__with_without gtk3 gtk 3.0}
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %find_lang %{name}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 %update_icon_cache hicolor
101
102 %postun
103 %update_icon_cache hicolor
104
105 %files -f %{name}.lang
106 %defattr(644,root,root,755)
107 %doc AUTHORS ChangeLog NEWS README
108 %attr(755,root,root) %{_bindir}/virt-viewer
109 %attr(755,root,root) %{_bindir}/remote-viewer
110 %dir %{_datadir}/%{name}
111 %dir %{_datadir}/%{name}/ui
112 %{_datadir}/%{name}/ui/*.xml
113 %{_iconsdir}/hicolor/*/apps/virt-viewer.png
114 %{_mandir}/man1/virt-viewer.1*
115 %{_mandir}/man1/remote-viewer.1*
116
117 %if %{with plugin}
118 %files plugin
119 %defattr(644,root,root,755)
120 %endif
This page took 0.247324 seconds and 4 git commands to generate.