]> git.pld-linux.org Git - packages/virt-viewer.git/blob - virt-viewer.spec
- up to 9.0
[packages/virt-viewer.git] / virt-viewer.spec
1 #
2 # Conditional build:
3 %bcond_without  spice   # SPICE support
4 %bcond_without  ovirt   # oVirt support
5 #
6 Summary:        Virtual Machine Viewer
7 Summary(pl.UTF-8):      Przeglądarka maszyny wirtualnej
8 Name:           virt-viewer
9 Version:        9.0
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Applications/Networking
13 Source0:        https://virt-manager.org/download/sources/virt-viewer/%{name}-%{version}.tar.gz
14 # Source0-md5:  f90413f321b697405369c6f963ea7a5e
15 URL:            http://virt-manager.org/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake
18 BuildRequires:  gettext-tools >= 0.14.1
19 BuildRequires:  glib2-devel >= 1:2.40.0
20 BuildRequires:  gtk+3-devel >= 3.12
21 BuildRequires:  gtk3-vnc-devel >= 0.4.3
22 BuildRequires:  icoutils
23 BuildRequires:  intltool >= 0.35.0
24 %{?with_ovirt:BuildRequires:    libgovirt-devel >= 0.3.3}
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  libvirt-devel >= 1.2.8
27 BuildRequires:  libvirt-glib-devel >= 0.1.8
28 BuildRequires:  libxml2-devel >= 1:2.6.0
29 BuildRequires:  perl-tools-pod
30 BuildRequires:  pkgconfig
31 %{?with_ovirt:BuildRequires:    rest-devel >= 0.8}
32 BuildRequires:  rpmbuild(macros) >= 1.596
33 BuildRequires:  sed >= 4.0
34 %{?with_spice:BuildRequires:    spice-gtk-devel >= 0.35}
35 BuildRequires:  spice-protocol >= 0.12.7
36 BuildRequires:  vte-devel
37 Requires(post,postun):  gtk-update-icon-cache
38 Requires(post,postun):  shared-mime-info
39 Requires:       glib2 >= 1:2.40.0
40 Requires:       gtk+3 >= 3.12
41 Requires:       gtk3-vnc >= 0.4.3
42 Requires:       hicolor-icon-theme
43 %{?with_ovirt:Requires: libgovirt >= 0.3.3}
44 Requires:       libvirt >= 1.2.8
45 Requires:       libvirt-glib >= 0.1.8
46 Requires:       libxml2 >= 1:2.6.0
47 %{?with_ovirt:Requires: rest >= 0.8}
48 %{?with_spice:Requires: spice-gtk >= 0.35}
49 Suggests:       gnome-keyring >= 0.4.9
50 Suggests:       openssh-clients
51 # let it obsolete withdrawn spice client from spice-space package
52 %{?with_spice:Obsoletes:        spice-client}
53 Obsoletes:      virt-viewer-plugin
54 ExclusiveArch:  %{ix86} %{x8664} ia64
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Virtual Machine Viewer provides a graphical console client for
59 connecting to virtual machines. It uses the GTK-VNC or SPICE-GTK
60 widgets to provide the display, and libvirt for looking up VNC/SPICE
61 server details.
62
63 %description -l pl.UTF-8
64 Virtual Machine Viewer udostępnia klienta graficznej konsoli do
65 łączenia z maszynami wirtualnymi. Wykorzystuje widgety GTK-VNC lub
66 SPICE-GTK do zapewnienia obrazu oraz libvirt do odczytu szczegółów
67 serwera VNC/SPICE.
68
69 %package -n bash-completion-virt-viewer
70 Summary:        bash-completion for virt-viewer command
71 Summary(pl.UTF-8):      bashowe uzupełnianie parametrów polecenia virt-viewer
72 Group:          Applications/Shells
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       bash-completion >= 2.0
75 %if "%{_rpmversion}" >= "5"
76 BuildArch:      noarch
77 %endif
78
79 %description -n bash-completion-virt-viewer
80 Bash-completion for virt-viewer command.
81
82 %description -n bash-completion-virt-viewer -l pl.UTF-8
83 Bashowe uzupełnianie parametrów polecenia virt-viewer.
84
85 %prep
86 %setup -q
87
88 %{__sed} -i -e 's|PWD|shell pwd|g' icons/*/Makefile.am
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         --disable-silent-rules \
98         --disable-update-mimedb \
99         %{__with_without spice spice-gtk} \
100         %{!?with_ovirt:--without-ovirt}
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %find_lang %{name}
111
112 #%clean
113 #rm -rf $RPM_BUILD_ROOT
114
115 %post
116 %update_icon_cache hicolor
117 %update_mime_database
118
119 %postun
120 %update_icon_cache hicolor
121 %update_mime_database
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README.md
126 %attr(755,root,root) %{_bindir}/virt-viewer
127 %attr(755,root,root) %{_bindir}/remote-viewer
128 %{_datadir}/appdata/remote-viewer.appdata.xml
129 %{_datadir}/mime/packages/virt-viewer-mime.xml
130 %{_desktopdir}/remote-viewer.desktop
131 %{_iconsdir}/hicolor/*/apps/virt-viewer.png
132 %{_iconsdir}/hicolor/24x24/devices/virt-viewer-usb.png
133 %{_iconsdir}/hicolor/24x24/devices/virt-viewer-usb.svg
134 %{_mandir}/man1/virt-viewer.1*
135 %{_mandir}/man1/remote-viewer.1*
136
137 %files -n bash-completion-virt-viewer
138 %defattr(644,root,root,755)
139 %{bash_compdir}/virt-viewer
This page took 0.064819 seconds and 4 git commands to generate.