]> git.pld-linux.org Git - packages/virt-viewer.git/blob - virt-viewer.spec
drop EA: (can't see anything arch exclusive)
[packages/virt-viewer.git] / virt-viewer.spec
1 #
2 # Conditional build:
3 %bcond_without  spice   # SPICE support
4 %bcond_without  ovirt   # oVirt support
5 #
6 Summary:        Virtual Machine Viewer
7 Summary(pl.UTF-8):      Przeglądarka maszyny wirtualnej
8 Name:           virt-viewer
9 Version:        11.0
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Applications/Networking
13 Source0:        https://virt-manager.org/download/sources/virt-viewer/%{name}-%{version}.tar.xz
14 # Source0-md5:  06b80228aaf10e614aeb8ffa4814b03a
15 URL:            http://virt-manager.org/
16 BuildRequires:  bash-completion-devel
17 BuildRequires:  cmake
18 BuildRequires:  gettext-tools >= 0.14.1
19 BuildRequires:  glib2-devel >= 1:2.40.0
20 BuildRequires:  gtk+3-devel >= 3.12
21 BuildRequires:  gtk3-vnc-devel >= 0.4.3
22 BuildRequires:  icoutils
23 BuildRequires:  intltool >= 0.35.0
24 %{?with_ovirt:BuildRequires:    libgovirt-devel >= 0.3.7}
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  libvirt-devel >= 1.2.8
27 BuildRequires:  libvirt-glib-devel >= 0.1.8
28 BuildRequires:  libxml2-devel >= 1:2.6.0
29 BuildRequires:  meson
30 BuildRequires:  ninja
31 BuildRequires:  perl-tools-pod
32 BuildRequires:  pkgconfig
33 %{?with_ovirt:BuildRequires:    rest-devel >= 0.8}
34 BuildRequires:  rpmbuild(macros) >= 2.000
35 BuildRequires:  sed >= 4.0
36 %{?with_spice:BuildRequires:    spice-gtk-devel >= 0.35}
37 BuildRequires:  spice-protocol >= 0.12.7
38 BuildRequires:  vte-devel
39 Requires(post,postun):  gtk-update-icon-cache
40 Requires(post,postun):  shared-mime-info
41 Requires:       glib2 >= 1:2.40.0
42 Requires:       gtk+3 >= 3.12
43 Requires:       gtk3-vnc >= 0.4.3
44 Requires:       hicolor-icon-theme
45 %{?with_ovirt:Requires: libgovirt >= 0.3.3}
46 Requires:       libvirt >= 1.2.8
47 Requires:       libvirt-glib >= 0.1.8
48 Requires:       libxml2 >= 1:2.6.0
49 %{?with_ovirt:Requires: rest >= 0.8}
50 %{?with_spice:Requires: spice-gtk >= 0.35}
51 Suggests:       gnome-keyring >= 0.4.9
52 Suggests:       openssh-clients
53 # let it obsolete withdrawn spice client from spice-space package
54 %{?with_spice:Obsoletes:        spice-client}
55 Obsoletes:      virt-viewer-plugin
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Virtual Machine Viewer provides a graphical console client for
60 connecting to virtual machines. It uses the GTK-VNC or SPICE-GTK
61 widgets to provide the display, and libvirt for looking up VNC/SPICE
62 server details.
63
64 %description -l pl.UTF-8
65 Virtual Machine Viewer udostępnia klienta graficznej konsoli do
66 łączenia z maszynami wirtualnymi. Wykorzystuje widgety GTK-VNC lub
67 SPICE-GTK do zapewnienia obrazu oraz libvirt do odczytu szczegółów
68 serwera VNC/SPICE.
69
70 %package -n bash-completion-virt-viewer
71 Summary:        bash-completion for virt-viewer command
72 Summary(pl.UTF-8):      bashowe uzupełnianie parametrów polecenia virt-viewer
73 Group:          Applications/Shells
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       bash-completion >= 2.0
76 BuildArch:      noarch
77
78 %description -n bash-completion-virt-viewer
79 Bash-completion for virt-viewer command.
80
81 %description -n bash-completion-virt-viewer -l pl.UTF-8
82 Bashowe uzupełnianie parametrów polecenia virt-viewer.
83
84 %prep
85 %setup -q
86
87 %build
88 %meson \
89         %{!?with_ovirt:-Dovirt=disabled} \
90         %{?with_ovirt:-Dovirt=enabled} \
91         %{!?with_spice:-Dspice=disabled} \
92         %{?with_spice:-Dspice=enabled} \
93         build
94
95 %ninja_build -C build
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %ninja_install -C build
101
102 %find_lang %{name}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post
108 %update_icon_cache hicolor
109 %update_mime_database
110
111 %postun
112 %update_icon_cache hicolor
113 %update_mime_database
114
115 %files -f %{name}.lang
116 %defattr(644,root,root,755)
117 %doc AUTHORS NEWS README.md
118 %attr(755,root,root) %{_bindir}/virt-viewer
119 %attr(755,root,root) %{_bindir}/remote-viewer
120 %{_datadir}/metainfo/remote-viewer.appdata.xml
121 %{_datadir}/mime/packages/virt-viewer-mime.xml
122 %{_desktopdir}/remote-viewer.desktop
123 %{_iconsdir}/hicolor/*/apps/virt-viewer.png
124 %{_iconsdir}/hicolor/scalable/apps/virt-viewer.svg
125 %{_mandir}/man1/virt-viewer.1*
126 %{_mandir}/man1/remote-viewer.1*
127
128 %files -n bash-completion-virt-viewer
129 %defattr(644,root,root,755)
130 %{bash_compdir}/virt-viewer
This page took 0.512531 seconds and 3 git commands to generate.