]> git.pld-linux.org Git - packages/vips.git/blob - vips.spec
3e9be67dd79c83157895075850c56eb43db4af15
[packages/vips.git] / vips.spec
1 # TODO:
2 # - pdfium>=4200 as an alternative for poppler?
3 #
4 # Conditional build:
5 %bcond_with     libspng         # libspng for PNG read/write support nstead of libpng
6
7 Summary:        A fast image processing library with low memory needs
8 Summary(pl.UTF-8):      Szybka, mająca małe wymagania pamięciowe biblioteka przetwarzania obrazów
9 Name:           vips
10 Version:        8.13.3
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 #Source0Download: https://github.com/libvips/libvips/tags
15 Source0:        https://github.com/libvips/libvips/archive/v%{version}/libvips-%{version}.tar.gz
16 # Source0-md5:  f09f25930aa27ed16e32c5a39aedfd31
17 URL:            https://www.libvips.org/
18 BuildRequires:  ImageMagick-devel >= 1:7.0
19 BuildRequires:  OpenEXR-devel >= 1.2.2
20 BuildRequires:  autoconf >= 2.69
21 BuildRequires:  automake >= 1.6
22 BuildRequires:  bzip2-devel
23 BuildRequires:  cairo-devel >= 1.2
24 BuildRequires:  cfitsio-devel
25 BuildRequires:  cgif-devel >= 0.2.0
26 BuildRequires:  doxygen
27 BuildRequires:  expat-devel >= 1.95
28 BuildRequires:  fftw3-devel >= 3.0.0
29 BuildRequires:  fontconfig-devel
30 BuildRequires:  gettext-tools
31 BuildRequires:  giflib-devel
32 BuildRequires:  glib2-devel >= 1:2.62
33 BuildRequires:  gobject-introspection-devel >= 1.30.0
34 BuildRequires:  gtk-doc >= 1.14
35 BuildRequires:  lcms2-devel >= 2
36 BuildRequires:  libexif-devel >= 0.6.23
37 BuildRequires:  libgsf-devel >= 1.14.31
38 BuildRequires:  libheif-devel >= 1.7.0
39 # or quantizr
40 BuildRequires:  libimagequant-devel
41 BuildRequires:  libjpeg-devel
42 BuildRequires:  libjxl-devel >= 0.7
43 BuildRequires:  libltdl-devel
44 %{!?with_libspng:BuildRequires: libpng-devel >= 2:1.2.9}
45 BuildRequires:  librsvg-devel >= 2.46
46 %{?with_libspng:BuildRequires:  libspng >= 0.7}
47 BuildRequires:  libstdc++-devel
48 BuildRequires:  libtiff-devel >= 4.0.10
49 BuildRequires:  libtool
50 BuildRequires:  libwebp-devel >= 0.6
51 BuildRequires:  libxml2-devel
52 BuildRequires:  matio-devel
53 BuildRequires:  nifticlib-devel
54 BuildRequires:  openjpeg2-devel >= 2.4
55 BuildRequires:  openslide-devel >= 3.4.0
56 BuildRequires:  orc-devel >= 0.4.31
57 BuildRequires:  pango-devel >= 1:1.32.6
58 BuildRequires:  poppler-glib-devel >= 0.16.0
59 BuildRequires:  pkgconfig
60 BuildRequires:  rpm-build >= 4.6
61 BuildRequires:  rpmbuild(find_lang) >= 1.32
62 BuildRequires:  rpmbuild(macros) >= 1.714
63 BuildRequires:  zlib-devel >= 0.4
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 libvips is a demand-driven, horizontally threaded image processing
68 library. Compared to similar libraries, libvips runs quickly and uses
69 little memory.
70
71 It has around 300 operations covering arithmetic, histograms,
72 convolution, morphological operations, frequency filtering, colour,
73 resampling, statistics and others. It supports a large range of
74 numeric formats, from 8-bit int to 128-bit complex. Images can have
75 any number of bands. It supports a good range of image formats,
76 including JPEG, TIFF, OME-TIFF, PNG, WebP, FITS, Matlab, OpenEXR, PDF,
77 SVG, HDR, PPM, CSV, GIF, Analyze, DeepZoom, and OpenSlide. It can also
78 load images via ImageMagick or GraphicsMagick, letting it load formats
79 like DICOM.
80
81 This package contains utilities based on libvips library.
82
83 %description -l pl.UTF-8
84 VIPS jest wielowątkową biblioteką przetwarzania obrazów. W porównaniu
85 do innych, działa szybko i zużywa niewiele pamięci.
86
87 Ma około 300 operacji obejmujących arytmetykę, histogramy, sploty,
88 operacje morfologiczne, filtry częstotliwościowe, kolory, resampling,
89 statystyki i inne. Obsługuje wiele formatów liczbowych, od 8-bitowych
90 do zespolonych 128-bitowych. Obrazy mogą mieć dowolną liczbę zakresów.
91 Obsługiwane jest szeroki zakres formatów, w tym JPEG, TIFF, OME-TIFF,
92 PNG, WebP, FITS, Matlab, OpenEXR, PDF, SVG, HDR, PPM, CSV, GIF,
93 Analyze, DeepZoom i OpenSlide. Biblioteka potrafi także wczytywać
94 obrazy poprzez ImageMagick lub GraphicsMagick, dzięki czemu obsługuje
95 formaty takie jak DICOM.
96
97 Ten pakiet zawiera narzędzia oparte na bibliotece libvips.
98
99 %package -n libvips
100 Summary:        VIPS image processing library
101 Summary(pl.UTF-8):      Biblioteka przetwarzania obrazów VIPS
102 Group:          Libraries
103 Requires:       ImageMagick-libs >= 1:7.0
104 Requires:       OpenEXR >= 1.2.2
105 Requires:       cairo >= 1.2
106 Requires:       cgif >= 0.2.0
107 Requires:       glib2 >= 1:2.62
108 Requires:       libexif >= 0.6.23
109 Requires:       libgsf >= 1.14.31
110 Requires:       libheif >= 1.7.0
111 Requires:       libjxl >= 0.7
112 %{!?with_libspng:Requires:      libpng >= 2:1.2.9}
113 Requires:       librsvg >= 2.46
114 %{?with_libspng:Requires:       libspng >= 0.7}
115 Requires:       libtiff >= 4.0.10
116 Requires:       libwebp >= 0.6
117 Requires:       openjpeg2 >= 2.4
118 Requires:       openslide >= 3.4.0
119 Requires:       orc >= 0.4.31
120 Requires:       pango >= 1:1.32.6
121 Requires:       poppler-glib >= 0.16.0
122 Requires:       zlib >= 0.4
123
124 %description -n libvips
125 libvips is a demand-driven, horizontally threaded image processing
126 library. Compared to similar libraries, libvips runs quickly and uses
127 little memory.
128
129 It has around 300 operations covering arithmetic, histograms,
130 convolution, morphological operations, frequency filtering, colour,
131 resampling, statistics and others. It supports a large range of
132 numeric formats, from 8-bit int to 128-bit complex. Images can have
133 any number of bands. It supports a good range of image formats,
134 including JPEG, TIFF, OME-TIFF, PNG, WebP, FITS, Matlab, OpenEXR, PDF,
135 SVG, HDR, PPM, CSV, GIF, Analyze, DeepZoom, and OpenSlide. It can also
136 load images via ImageMagick or GraphicsMagick, letting it load formats
137 like DICOM.
138
139 %description -n libvips -l pl.UTF-8
140 VIPS jest wielowątkową biblioteką przetwarzania obrazów. W porównaniu
141 do innych, działa szybko i zużywa niewiele pamięci.
142
143 Ma około 300 operacji obejmujących arytmetykę, histogramy, sploty,
144 operacje morfologiczne, filtry częstotliwościowe, kolory, resampling,
145 statystyki i inne. Obsługuje wiele formatów liczbowych, od 8-bitowych
146 do zespolonych 128-bitowych. Obrazy mogą mieć dowolną liczbę zakresów.
147 Obsługiwane jest szeroki zakres formatów, w tym JPEG, TIFF, OME-TIFF,
148 PNG, WebP, FITS, Matlab, OpenEXR, PDF, SVG, HDR, PPM, CSV, GIF,
149 Analyze, DeepZoom i OpenSlide. Biblioteka potrafi także wczytywać
150 obrazy poprzez ImageMagick lub GraphicsMagick, dzięki czemu obsługuje
151 formaty takie jak DICOM.
152
153 %package -n libvips-devel
154 Summary:        Header files for VIPS library
155 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki VIPS
156 Group:          Development/Libraries
157 Requires:       ImageMagick-devel >= 1:7.0
158 Requires:       OpenEXR-devel >= 1.2.2
159 Requires:       cairo-devel >= 1.2
160 Requires:       cfitsio-devel
161 Requires:       cgif-devel >= 0.2.0
162 Requires:       expat-devel >= 1.95
163 Requires:       fftw3-devel >= 3.0.0
164 Requires:       fontconfig-devel
165 Requires:       glib2-devel >= 1:2.62
166 Requires:       lcms2-devel >= 2
167 Requires:       libexif-devel >= 0.6.23
168 Requires:       libgsf-devel >= 1.14.31
169 Requires:       libheif-devel >= 1.7.0
170 Requires:       libimagequant-devel
171 Requires:       libjpeg-devel
172 Requires:       libjxl-devel >= 0.7
173 %{!?with_libspng:Requires:      libpng-devel >= 2:1.2.9}
174 Requires:       librsvg-devel >= 2.46
175 %{?with_libspng:Requires:       libspng-devel >= 0.7}
176 Requires:       libtiff-devel >= 4.0.10
177 Requires:       libwebp-devel >= 0.6
178 Requires:       matio-devel
179 Requires:       openjpeg2-devel >= 2.4
180 Requires:       openslide-devel >= 3.4.0
181 Requires:       orc-devel >= 0.4.31
182 Requires:       pango-devel >= 1:1.32.6
183 Requires:       poppler-glib-devel >= 0.16.0
184 Requires:       zlib-devel >= 0.4
185 Obsoletes:      vips-devel < 8.7
186
187 %description -n libvips-devel
188 Header files for VIPS library.
189
190 %description -n libvips-devel -l pl.UTF-8
191 Pliki nagłówkowe biblioteki VIPS.
192
193 %package -n libvips-static
194 Summary:        Static VIPS library
195 Summary(pl.UTF-8):      Statyczna biblioteka VIPS
196 Group:          Development/Libraries
197 Obsoletes:      vips-static < 8.7
198
199 %description -n libvips-static
200 Static VIPS library.
201
202 %description -n libvips-static -l pl.UTF-8
203 Statyczna biblioteka VIPS.
204
205 %package -n libvips-apidocs
206 Summary:        API documentation for VIPS library
207 Summary(pl.UTF-8):      Dokumentacja API biblioteki VIPS
208 Group:          Documentation
209 BuildArch:      noarch
210
211 %description -n libvips-apidocs
212 API documentation for VIPS library, together with some general VIPS
213 documentation.
214
215 %description -n libvips-apidocs -l pl.UTF-8
216 Dokumentacja API biblioteki VIPS. Zawiera także trochę ogólnej
217 dokumentacji projektu VIPS.
218
219 %package -n libvips-cpp8
220 Summary:        C++ API for VIPS 8 image processing library
221 Summary(pl.UTF-8):      API C++ do biblioteki przetwarzania obrazów VIPS 8
222 Group:          Libraries
223 Requires:       libvips = %{version}-%{release}
224
225 %description -n libvips-cpp8
226 C++ API for VIPS 8 image processing library.
227
228 %description -n libvips-cpp8 -l pl.UTF-8
229 API C++ do biblioteki przetwarzania obrazów VIPS 8.
230
231 %package -n libvips-cpp8-devel
232 Summary:        C++ API for VIPS 8 image processing library - header files
233 Summary(pl.UTF-8):      API C++ do biblioteki przetwarzania obrazów VIPS 8 - pliki nagłówkowe
234 Group:          Development/Libraries
235 Requires:       libvips-cpp8 = %{version}-%{release}
236 Requires:       libvips-devel = %{version}-%{release}
237
238 %description -n libvips-cpp8-devel
239 C++ API for VIPS 8 image processing library - header files.
240
241 %description -n libvips-cpp8-devel -l pl.UTF-8
242 API C++ do biblioteki przetwarzania obrazów VIPS 8 - pliki nagłówkowe.
243
244 %package -n libvips-cpp8-static
245 Summary:        C++ API for VIPS 8 image processing library - static library
246 Summary(pl.UTF-8):      API C++ do biblioteki przetwarzania obrazów VIPS 8 - biblioteka statyczna
247 Group:          Development/Libraries
248 Requires:       libvips-cpp8-devel = %{version}-%{release}
249
250 %description -n libvips-cpp8-static
251 C++ API for VIPS 8 image processing library - static library.
252
253 %description -n libvips-cpp8-static -l pl.UTF-8
254 API C++ do biblioteki przetwarzania obrazów VIPS 8 - biblioteka
255 statyczna.
256
257 %package -n libvips-cpp8-apidocs
258 Summary:        C++ API documentation for VIPS 8 library
259 Summary(pl.UTF-8):      Dokumentacja API C++ biblioteki VIPS 8
260 Group:          Documentation
261 BuildArch:      noarch
262
263 %description -n libvips-cpp8-apidocs
264 C++ API documentation for VIPS 8 library.
265
266 %description -n libvips-cpp8-apidocs -l pl.UTF-8
267 Dokumentacja API C++ biblioteki VIPS 8.
268
269 %prep
270 %setup -q -n libvips-%{version}
271
272 # it seems to support both python2/python3, prefer the latter
273 %{__sed} -i -e '1s,/usr/bin/python$,%{__python3},' \
274       tools/vipsprofile
275
276 %build
277 %{__gtkdocize} --docdir doc
278 %{__glib_gettextize}
279 %{__libtoolize}
280 %{__aclocal} -I m4
281 %{__autoconf}
282 %{__autoheader}
283 %{__automake}
284 %configure \
285         --enable-doxygen \
286         --enable-gtk-doc \
287         --with-html-dir=%{_gtkdocdir} \
288         %{!?with_libspng:--without-libspng}
289 %{__make}
290
291 %install
292 rm -rf $RPM_BUILD_ROOT
293
294 %{__make} install \
295         DESTDIR=$RPM_BUILD_ROOT
296
297 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvips-cpp.la
298 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvips.la
299
300 # packaged as %doc in libvips-cpp8-apidocs
301 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/vips/html
302
303 %find_lang vips8.13 -o %{name}.lang
304
305 %clean
306 rm -rf $RPM_BUILD_ROOT
307
308 %post   -n libvips -p /sbin/ldconfig
309 %postun -n libvips -p /sbin/ldconfig
310
311 %post   -n libvips-cpp8 -p /sbin/ldconfig
312 %postun -n libvips-cpp8 -p /sbin/ldconfig
313
314 %files -f %{name}.lang
315 %defattr(644,root,root,755)
316 %attr(755,root,root) %{_bindir}/batch_crop
317 %attr(755,root,root) %{_bindir}/batch_image_convert
318 %attr(755,root,root) %{_bindir}/batch_rubber_sheet
319 %attr(755,root,root) %{_bindir}/light_correct
320 %attr(755,root,root) %{_bindir}/shrink_width
321 %attr(755,root,root) %{_bindir}/vips
322 %attr(755,root,root) %{_bindir}/vips-8.13
323 %attr(755,root,root) %{_bindir}/vipsedit
324 %attr(755,root,root) %{_bindir}/vipsheader
325 %attr(755,root,root) %{_bindir}/vipsprofile
326 %attr(755,root,root) %{_bindir}/vipsthumbnail
327 %{_mandir}/man1/batch_crop.1*
328 %{_mandir}/man1/batch_image_convert.1*
329 %{_mandir}/man1/batch_rubber_sheet.1*
330 %{_mandir}/man1/light_correct.1*
331 %{_mandir}/man1/vips.1*
332 %{_mandir}/man1/vipsedit.1*
333 %{_mandir}/man1/vipsheader.1*
334 %{_mandir}/man1/vipsprofile.1*
335 %{_mandir}/man1/vipsthumbnail.1*
336
337 %files -n libvips
338 %defattr(644,root,root,755)
339 %doc AUTHORS ChangeLog NEWS README.md THANKS
340 %attr(755,root,root) %{_libdir}/libvips.so.*.*.*
341 %attr(755,root,root) %ghost %{_libdir}/libvips.so.42
342 %{_libdir}/girepository-1.0/Vips-8.0.typelib
343
344 %files -n libvips-devel
345 %defattr(644,root,root,755)
346 %attr(755,root,root) %{_libdir}/libvips.so
347 %dir %{_includedir}/vips
348 %{_includedir}/vips/almostdeprecated.h
349 %{_includedir}/vips/arithmetic.h
350 %{_includedir}/vips/basic.h
351 %{_includedir}/vips/buf.h
352 %{_includedir}/vips/colour.h
353 %{_includedir}/vips/connection.h
354 %{_includedir}/vips/conversion.h
355 %{_includedir}/vips/convolution.h
356 %{_includedir}/vips/create.h
357 %{_includedir}/vips/dbuf.h
358 %{_includedir}/vips/debug.h
359 %{_includedir}/vips/deprecated.h
360 %{_includedir}/vips/dispatch.h
361 %{_includedir}/vips/draw.h
362 %{_includedir}/vips/enumtypes.h
363 %{_includedir}/vips/error.h
364 %{_includedir}/vips/foreign.h
365 %{_includedir}/vips/format.h
366 %{_includedir}/vips/freqfilt.h
367 %{_includedir}/vips/gate.h
368 %{_includedir}/vips/generate.h
369 %{_includedir}/vips/header.h
370 %{_includedir}/vips/histogram.h
371 %{_includedir}/vips/image.h
372 %{_includedir}/vips/interpolate.h
373 %{_includedir}/vips/intl.h
374 %{_includedir}/vips/mask.h
375 %{_includedir}/vips/memory.h
376 %{_includedir}/vips/morphology.h
377 %{_includedir}/vips/mosaicing.h
378 %{_includedir}/vips/object.h
379 %{_includedir}/vips/operation.h
380 %{_includedir}/vips/private.h
381 %{_includedir}/vips/rect.h
382 %{_includedir}/vips/region.h
383 %{_includedir}/vips/resample.h
384 %{_includedir}/vips/sbuf.h
385 %{_includedir}/vips/semaphore.h
386 %{_includedir}/vips/thread.h
387 %{_includedir}/vips/threadpool.h
388 %{_includedir}/vips/transform.h
389 %{_includedir}/vips/type.h
390 %{_includedir}/vips/util.h
391 %{_includedir}/vips/vector.h
392 %{_includedir}/vips/version.h
393 %{_includedir}/vips/video.h
394 %{_includedir}/vips/vips7compat.h
395 %{_includedir}/vips/vips.h
396 %{_datadir}/gir-1.0/Vips-8.0.gir
397 %{_pkgconfigdir}/vips.pc
398
399 %files -n libvips-static
400 %defattr(644,root,root,755)
401 %{_libdir}/libvips.a
402
403 %files -n libvips-apidocs
404 %defattr(644,root,root,755)
405 %{_gtkdocdir}/libvips
406
407 %files -n libvips-cpp8
408 %defattr(644,root,root,755)
409 %attr(755,root,root) %{_libdir}/libvips-cpp.so.*.*.*
410 %attr(755,root,root) %ghost %{_libdir}/libvips-cpp.so.42
411
412 %files -n libvips-cpp8-devel
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_libdir}/libvips-cpp.so
415 %{_includedir}/vips/VConnection8.h
416 %{_includedir}/vips/VError8.h
417 %{_includedir}/vips/VImage8.h
418 %{_includedir}/vips/VInterpolate8.h
419 %{_includedir}/vips/VRegion8.h
420 %{_includedir}/vips/vips8
421 %{_pkgconfigdir}/vips-cpp.pc
422
423 %files -n libvips-cpp8-static
424 %defattr(644,root,root,755)
425 %{_libdir}/libvips-cpp.a
426
427 %files -n libvips-cpp8-apidocs
428 %defattr(644,root,root,755)
429 %doc cplusplus/html/{search,*.css,*.html,*.js,*.png}
This page took 0.064303 seconds and 2 git commands to generate.