]> git.pld-linux.org Git - packages/vim.git/blob - vim.spec
vim patches
[packages/vim.git] / vim.spec
1 Summary:        Vim static
2 Summary(pl):    Vim skompilowany statycznie
3 Name:           vim
4 Version:        5.4d
5 Release:        1d
6 #######         ftp://ftp.nl.vim.org/pub/vim/unreleased/unix
7 Source:         %{name}-%{version}-src.tar.gz
8 Source1:        %{name}-%{version}-rt.tar.gz
9 #######         ftp://ftp.nl.vim.org/pub/vim/unreleased/extra
10 Source2:        %{name}-%{version}-extra.tar.gz
11 Source3:        gvim.wmconfig
12 Patch:          %{name}-hold_gui_events.patch
13 Patch1:         %{name}-clip.patch
14 Copyright:      GPL
15 Group:          Applications/Editors/Vim
16 Group(pl):      Aplikacje/Edytory/Vim
17 URL:            http://www.vim.org/
18 Buildroot:      /tmp/%{name}-%{version}-root
19
20 %description
21 The classic Unix text editor. This version is build with minimal
22 feature and is installed in /bin as a rescue tool. The installation of
23 this package is STRONGLY recommended.
24
25 %description -l pl
26 Pakiet zawiera vim - klasyczny (unixowy) edytor tekstowy skompilowany 
27 statycznie. Instalacja tego pakietu jest MOCNO zalecana, mo¿e on pomóc
28 Tobie uratowaæ system w czasie awarii.
29
30 %package        rt 
31 Summary:        Vim runtime files
32 Summary(pl):    Pliki przydatne edytorowi vim 
33 Group:          Applications/Editors/Vim
34 Group(pl):      Aplikacje/Edytory/Vim
35
36 %description rt
37 This package contains macros, documentation, syntax configuration and
38 manual pages for vim. If you want to take advantage of vim more powerful
39 features, you should install this package.
40
41 %description rt -l pl
42 W tym pakiecie znajdziesz dokumentacjê, makra, pliki konfiguracyjne i strony
43 podrêcznika edytora vim. Je¿eli zamierzasz korzystaæ z vim-a, powiniene¶
44 zainstalowaæ ten pakiet.
45
46 #%package       slang
47 #Summary:       Vim 5.3 built with slang
48 #Summary(pl):   Vim 5.3 korzystaj±cy z bibliotek Slang
49 #Group:         Applications/Editors/Vim
50 #Group(pl):     Alikacje/Edytory/Vim
51 #Obsoletes:     vim-ncurses
52
53 #%description slang
54 #The classic Unix text editor build with slang library. It adds
55 #multiple windows, multi-level undo, block highliting, and many other
56 #features to the standard vi program.
57
58 #%description slang -l pl
59 #Wersja edytora vim skompilowana z bibliotek± slang. W porownaniu z
60 #edytorem vi, ta wersja oferuje dodatkowo pracê z wieloma plikami,
61 #wielopoziomowe operacje cofnij, bloki, pod¶wietlanie sk³adni i wiele
62 #innych usprawnieñ.
63
64 %package        ncurses 
65 Summary:        Vim built with ncurses
66 Summary(pl):    Vim korzystaj±cy z bibliotek ncurses
67 Group:          Applications/Editors/Vim
68 Group(pl):      Aplikacje/Edytory/Vim
69 Requires:       ncurses
70 Obsoletes:      vim-slang
71
72 %description ncurses
73 The classic Unix text editor build with ncurses library. It adds
74 multiple windows, multi-level undo, block highliting, and many other
75 features to the standard vi program.
76
77 %description ncurses -l pl
78 Wersja edytora vim skompilowana z bibliotek± ncurses. W porownaniu z
79 edytorem vi, ta wersja oferuje dodatkowo pracê z wieloma plikami,
80 wielopoziomowe operacje cofnij, bloki, pod¶wietlanie sk³adni i wiele
81 innych usprawnieñ.
82
83 %package        athena
84 Summary:        Vim built with X11 and athena support
85 Summary(pl):    Vim pod X-Window korzystaj±cy z Athena Widget Set
86 Group:          Applications/Editors/Vim
87 Group(pl):      Aplikacje/Edytory/Vim
88 Obsoletes:      vim-lesstif
89 Obsoletes:      vim-gtk
90
91 %description athena 
92 The classic Unix text editor now also under X Window System! 
93 This version is build with Athena Widget Set. 
94
95 %description athena -l pl
96 Wersja edytora vim pracuj±ca w graficznym ¶rodowisku X Window
97 z wykorzystaniem Athena Widget Set.
98
99 %package lesstif
100 Summary:        Vim built with X11 and LessTif support
101 Summary(pl):    Vim pod X-Window korzystaj±cy z bibliotek LessTif
102 Group:          Applications/Editors/Vim
103 Group(pl):      Aplikacje/Edytory/Vim
104 Requires:       lesstif
105 Obsoletes:      vim-athena
106 Obsoletes:      vim-gtk
107
108 %description lesstif
109 The classic Unix text editor now also under X Window System! 
110 This version is build with LessTif.
111
112 %description lesstif -l pl
113 Wersja edytora vim pracuj±ca w graficznym ¶rodowisku X Window
114 z wykorzystaniem LessTif.
115
116 %package gtk
117 Summary:        Vim built with X11 and gtk support
118 Summary(pl):    Vim pod X-Window korzystaj±cy z bibliotek gtk
119 Group:          Applications/Editors/Vim
120 Group(pl):      Aplikacje/Edytory/Vim
121 Requires:       gtk+
122 Obsoletes:      vim-athena
123 Obsoletes:      vim-lesstif
124
125 %description gtk
126 The classic Unix text editor now also under X Window System!
127 This version is build with gtk.
128
129 %description gtk -l pl
130 Wersja edytora vim pracuj±ca w graficznym ¶rodowisku X Window
131 z wykorzystaniem gtk.
132
133 %prep
134 %setup -q  -b 1 -b 2
135 %patch 
136 %patch1 -p1
137
138 %build
139 cd src
140
141 LDFLAGS=-static CFLAGS=-O ./configure --disable-gui --without-x \
142 --disable-perlinterp --disable-pythoninterp --disable-tclinterp \
143 --disable-cscope --enable-min-features \
144 --datadir=/etc --with-tlib=termcap --prefix=/usr
145 make vim
146 make xxd/xxd
147 mv vim vim.termcap
148 mv xxd/xxd xxd.termcap
149
150 #make distclean
151 #LDFLAGS=-s CFLAGS="$RPM_OPT_FLAGS" ./configure --disable-gui --without-x \
152 #--disable-perlinterp --disable-pythoninterp --disable-tclinterp \
153 #--disable-cscope --with-tlib=slang --prefix=/usr
154 #make
155 #mv src/vim src/vim.slang
156
157 make distclean
158 LDFLAGS=-s CFLAGS="$RPM_OPT_FLAGS" ./configure --disable-gui --without-x \
159 --disable-perlinterp --disable-pythoninterp --disable-tclinterp \
160 --disable-cscope --with-tlib=ncurses --prefix=/usr
161 make vim
162 mv vim vim.ncurses
163
164 make distclean
165 LDFLAGS=-s CFLAGS="$RPM_OPT_FLAGS" ./configure --enable-gui=athena --with-x \
166 --disable-perlinterp --disable-pythoninterp --disable-tclinterp \
167 --disable-cscope --with-tlib=termcap --prefix=/usr
168 make vim
169 mv vim vim.athena
170
171 make distclean
172 LDFLAGS=-s CFLAGS="$RPM_OPT_FLAGS" ./configure --enable-gui=motif --with-x \
173 --disable-perlinterp --disable-pythoninterp --disable-tclinterp \
174 --disable-cscope --with-tlib=termcap --prefix=/usr
175 make vim
176 mv vim vim.lesstif
177
178 make distclean
179 LDFLAGS=-s CFLAGS="$RPM_OPT_FLAGS" ./configure --enable-gui=gtk --with-x \
180 --disable-perlinterp --disable-pythoninterp --disable-tclinterp \
181 --disable-cscope --with-tlib=termcap --prefix=/usr
182 make vim
183 mv vim vim.gtk
184
185 cd ..
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189
190 install -d $RPM_BUILD_ROOT/etc/X11/wmconfig
191 install -d $RPM_BUILD_ROOT/bin
192 install -d $RPM_BUILD_ROOT/usr/{bin,X11R6/bin,share/vim,man/man1}
193
194 # make prefix=$RPM_BUILD_ROOT/usr install
195
196 install -s src/vim.termcap $RPM_BUILD_ROOT/bin/vi
197 install -s src/xxd.termcap $RPM_BUILD_ROOT/bin/xxd
198
199 #install -s src/vim.slang $RPM_BUILD_ROOT/usr/bin/vim.slang
200
201 install -s src/vim.ncurses $RPM_BUILD_ROOT/usr/bin/vim.ncurses
202 install -s src/vim.athena  $RPM_BUILD_ROOT/usr/X11R6/bin/gvim.athena
203 install -s src/vim.lesstif $RPM_BUILD_ROOT/usr/X11R6/bin/gvim.lesstif
204 install -s src/vim.gtk     $RPM_BUILD_ROOT/usr/X11R6/bin/gvim.gtk
205
206 rm -f $RPM_BUILD_ROOT/usr/man/man1/*.1
207
208 install runtime/doc/vim.1 $RPM_BUILD_ROOT/usr/man/man1
209 install runtime/doc/xxd.1 $RPM_BUILD_ROOT/usr/man/man1
210
211 echo ".so vim.1" > $RPM_BUILD_ROOT/usr/man/man1/vi.1
212 echo ".so vim.1" > $RPM_BUILD_ROOT/usr/man/man1/ex.1
213 echo ".so vim.1" > $RPM_BUILD_ROOT/usr/man/man1/view.1
214 echo ".so vim.1" > $RPM_BUILD_ROOT/usr/man/man1/gvim.1
215 echo ".so vim.1" > $RPM_BUILD_ROOT/usr/man/man1/gview.1
216 echo ".so vim.1" > $RPM_BUILD_ROOT/usr/man/man1/rvim.1
217 echo ".so vim.1" > $RPM_BUILD_ROOT/usr/man/man1/rview.1
218 echo ".so vim.1" > $RPM_BUILD_ROOT/usr/man/man1/rgvim.1
219 echo ".so vim.1" > $RPM_BUILD_ROOT/usr/man/man1/rgview.1
220
221 cp -a runtime/macros $RPM_BUILD_ROOT/usr/share/vim/macros
222 cp -a runtime/syntax $RPM_BUILD_ROOT/usr/share/vim/syntax
223 cp -a runtime/tutor  $RPM_BUILD_ROOT/usr/share/vim/tutor
224
225 install runtime/*.vim $RPM_BUILD_ROOT/usr/share/vim
226 install runtime/vimrc_example $RPM_BUILD_ROOT/usr/share/vim/vimrc
227 install %{SOURCE3} $RPM_BUILD_ROOT/etc/X11/wmconfig/gvim
228
229 touch $RPM_BUILD_ROOT/usr/bin/vim $RPM_BUILD_ROOT/usr/X11R6/bin/gvim
230
231 ln -sf ../../doc/%{name}-rt-%{version} $RPM_BUILD_ROOT/usr/share/vim/doc
232
233 ln -sf vi $RPM_BUILD_ROOT/bin/ex
234 ln -sf vi $RPM_BUILD_ROOT/bin/view
235 ln -sf vi $RPM_BUILD_ROOT/bin/rview
236
237 ln -sf vim $RPM_BUILD_ROOT/usr/bin/rvim
238
239 ln -sf gvim $RPM_BUILD_ROOT/usr/X11R6/bin/rgvim
240 ln -sf gvim $RPM_BUILD_ROOT/usr/X11R6/bin/gview
241 ln -sf gvim $RPM_BUILD_ROOT/usr/X11R6/bin/rgview
242
243 bzip2 -9 $RPM_BUILD_ROOT/usr/man/man1/*
244
245 %clean
246 rm -rf $RPM_BUILD_ROOT
247
248 #%post slang
249 #ln -sf /usr/bin/vim.slang /usr/bin/vim
250
251 %post ncurses
252 ln -sf /usr/bin/vim.ncurses /usr/bin/vim
253
254 %post athena
255 ln -sf /usr/X11R6/bin/gvim.athena /usr/X11R6/bin/gvim
256
257 %post lesstif 
258 ln -sf /usr/X11R6/bin/gvim.lesstif /usr/X11R6/bin/gvim
259
260 %post gtk
261 ln -sf /usr/X11R6/bin/gvim.gtk /usr/X11R6/bin/gvim
262
263 %files
264 %attr(755,root,root) /bin/*
265
266 #%files slang
267 #%attr(711,root,root) /usr/bin/vim.slang
268 #%attr(711,root,root) /usr/bin/rvim
269 #%attr(711,root,root) %ghost /usr/bin/vim
270
271 %files ncurses
272 %attr(755,root,root) /usr/bin/vim.ncurses
273 %attr(755,root,root) /usr/bin/rvim
274 %attr(755,root,root) %ghost /usr/bin/vim
275
276 %files athena
277 %attr(755,root,root) /usr/X11R6/bin/gvim.athena
278 %attr(755,root,root) /usr/X11R6/bin/rgvim
279 %attr(755,root,root) /usr/X11R6/bin/rgview
280 %attr(644,root,root) %config(missingok) /etc/X11/wmconfig/gvim
281 %attr(755,root,root) %ghost /usr/X11R6/bin/gvim
282
283 %files lesstif 
284 %attr(755,root,root) /usr/X11R6/bin/gvim.lesstif
285 %attr(755,root,root) /usr/X11R6/bin/rgvim
286 %attr(755,root,root) /usr/X11R6/bin/rgview
287 %attr(644,root,root) %config(missingok) /etc/X11/wmconfig/gvim
288 %attr(755,root,root) %ghost /usr/X11R6/bin/gvim
289
290 %files gtk
291 %attr(755,root,root) /usr/X11R6/bin/gvim.gtk
292 %attr(755,root,root) /usr/X11R6/bin/rgvim
293 %attr(755,root,root) /usr/X11R6/bin/rgview
294 %attr(644,root,root) %config(missingok) /etc/X11/wmconfig/gvim
295 %attr(755,root,root) %ghost /usr/X11R6/bin/gvim
296
297 %files rt
298 %defattr(644,root,root,755)
299 %doc runtime/doc/*.txt runtime/doc/tags
300 %attr(644,root,man) /usr/man/man1/*
301
302 %dir /usr/share/vim
303 /usr/share/vim/macros
304
305 %dir /usr/share/vim/syntax
306 /usr/share/vim/syntax/*.vim
307
308 /usr/share/vim/tutor
309 /usr/share/vim/bugreport.vim
310 /usr/share/vim/filetype.vim
311 /usr/share/vim/scripts.vim
312 /usr/share/vim/mswin.vim
313 /usr/share/vim/ftoff.vim
314 /usr/share/vim/doc
315
316 %config %verify(not size mtime md5) /usr/share/vim/menu.vim
317 %config %verify(not size mtime md5) /usr/share/vim/vimrc
318
319 %changelog
320 * Tue Feb  2 1999 Artur Frysiak <wiget@usa.net>
321 [5.4d-1d]
322 - upgraded to 5.4d
323 - now /usr/share/vim/doc is symlink to /usr/doc/%{name}-rt-%{version}
324 - added missingok option to wmconfig files
325
326 * Wed Jan 13 1999 Artur Frysiak <wiget@usa.net>
327 [5.4c-1d]
328 - upgraded to 5.4c
329 - added gtk subpackage
330 - using %%{version} makro in Summary tags
331 - some chenges in %%build section
332 - changed Group to Applications/Editors/Vim
333
334 * Sun Dec 27 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
335 [5.3-4d]
336 - fixed some errors in rt subpackage. 
337   by Ziemek Borowski <ziembor@mail.ceu.edu.pl>
338 - fixed etcdir in vim-ststic subpackage.
339
340 * Thu Nov 12 1998 Arkadiusz Mi¶kiewicz <misiek@misiek.eu.org>
341 [5.3-2d]
342 - added /usr/share/vim/doc/{help.txt,tags} to rt subpackage (was missing)
343
344 * Sun Oct 04 1998 Marcin Korzonek <mkorz@shadow.eu.org>
345 [5.3-1]
346 - completely rewritten spec, added 4 subpackages
347
348 * Thu Aug 13 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
349 [5.0-1d]
350 - build against glibc-2.1,
351 - translation modified for pl,
352 - added build-root support,
353 - added %changelog,
354 - fixed permissions fo ELF binaries.
This page took 0.122248 seconds and 3 git commands to generate.