]> git.pld-linux.org Git - packages/vice.git/blob - vice.spec
- updated gettext BR
[packages/vice.git] / vice.spec
1 # TODO
2 # - fonts-TTF-CBM subpackage:
3 #   %{_fontsdir}/TTF/CBM.ttf
4 #
5 # Conditional build:
6 %bcond_without  pulseaudio      # pulseaudio support
7 #
8 Summary:        Versatile Commodore Emulator
9 Summary(pl.UTF-8):      Uniwersalny emulator Commodore
10 Name:           vice
11 Version:        2.4
12 Release:        3
13 License:        GPL v2+
14 Group:          Applications/Emulators
15 Source0:        http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/%{name}-%{version}.tar.gz
16 # Source0-md5:  b017647a0c159bbe43cdb81762d1c577
17 Source1:        %{name}-c128.desktop
18 Source2:        %{name}-c64.desktop
19 Source3:        %{name}-cbm2.desktop
20 Source4:        %{name}-pet.desktop
21 Source5:        %{name}-plus4.desktop
22 Source6:        %{name}-vic20.desktop
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-gettext.patch
25 Patch2:         %{name}-home_etc.patch
26 Patch3:         %{name}-fonts.patch
27 Patch4:         %{name}-link.patch
28 Patch5:         %{name}-ffmpeg.patch
29 Patch6:         texinfo.patch
30 URL:            http://www.viceteam.org/
31 BuildRequires:  OpenGL-GLX-devel
32 BuildRequires:  SDL-devel >= 1.2.0
33 BuildRequires:  alsa-lib-devel
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  bison
37 BuildRequires:  ffmpeg-devel
38 BuildRequires:  flex
39 BuildRequires:  gettext-tools
40 BuildRequires:  giflib-devel
41 BuildRequires:  gtk+2-devel >= 1:2.0
42 BuildRequires:  gtkglext-devel
43 BuildRequires:  lame-libs-devel
44 BuildRequires:  libjpeg-devel
45 BuildRequires:  libpng-devel
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  perl-base
48 BuildRequires:  pkgconfig
49 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
50 BuildRequires:  readline-devel
51 BuildRequires:  texinfo
52 BuildRequires:  vte0-devel
53 BuildRequires:  xorg-app-bdftopcf
54 BuildRequires:  xorg-app-mkfontdir
55 BuildRequires:  xorg-lib-libX11-devel
56 BuildRequires:  xorg-lib-libXext-devel
57 BuildRequires:  xorg-lib-libXrandr-devel
58 BuildRequires:  xorg-lib-libXv-devel
59 BuildRequires:  xorg-lib-libXxf86dga-devel
60 BuildRequires:  xorg-lib-libXxf86vm-devel
61 Requires(post,postun):  fontpostinst >= 0.1-6
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 VICE is a Versatile Commodore Emulator, i.e. a program that runs on a
66 Unix, MS-DOS, Win95/NT, OS/2, RiscOS or BeOS machine and executes
67 programs intended for the old 8-bit Commodore computers. The current
68 version emulates the C64, the C128 (80 column screen is included now),
69 the VIC20, all the PET models (except the SuperPET 9000, which is out
70 of line anyway), CBM-II (aka C610) and the Plus4.
71
72 %description -l pl.UTF-8
73 VICE jest wszechstronnym emulatorem 8-bitowego komputera Commodore.
74 Aktualna wersja emuluje C64, C128 (wraz z trybem pracy 80 kolumnowym),
75 VIC20, wszystkie modele PET (poza SuperPET 9000, który zresztą nie
76 pasował do tej linii), CBM-II (C610) oraz Plus4.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83 %patch3 -p1
84 %patch4 -p1
85 %patch5 -p1
86 %patch6 -p1
87 %{__perl} -i -pe 's@\$\(VICEDIR\)/fonts@%{_fontsdir}/misc@' data/fonts/Makefile.am
88
89 %build
90 %{__gettextize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 cd src/resid
96 %{__autoconf}
97 cd ../..
98 %configure \
99         --libdir=%{_datadir} \
100         --enable-fullscreen \
101         --enable-gnomeui \
102         --enable-nls \
103         %{?with_pulseaudio:--with-pulse} \
104         --with-sdlsound \
105         --with-x \
106         --without-xaw3d
107
108 # contains some C++ code included as "old" library (.a), so libtool can't detect it
109 %{__make} \
110         CCLD="%{__cxx}"
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
115
116 %{__perl} -i -pe 's/SUBDIRS = html\n//' doc/Makefile
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT \
119         VICEDIR="%{_datadir}/%{name}"
120
121 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/vice/doc
122 # ?
123 #ln -sf %{_docdir}/%{name}-%{version}/html $RPM_BUILD_ROOT%{_datadir}/vice/doc
124
125 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
126 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
127 install %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
128 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
129 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
130 install %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}
131
132 cd src/arch/unix/x11
133 for i in *icon.c; do
134         install $i $RPM_BUILD_ROOT%{_pixmapsdir}/${i%.c}.xpm
135 done
136 cd ../../../..
137
138 install -d $RPM_BUILD_ROOT%{_fontsdir}/TTF
139 mv $RPM_BUILD_ROOT%{_fontsdir}/{misc,TTF}/CBM.ttf
140
141 %find_lang %{name}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 fontpostinst TTF
148 fontpostinst misc
149 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
150
151 %postun
152 fontpostinst TTF
153 fontpostinst misc
154 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
155
156 %files -f %{name}.lang
157 %defattr(644,root,root,755)
158 %doc AUTHORS ChangeLog FEEDBACK NEWS README doc/iec-bus.txt doc/html
159 %attr(755,root,root) %{_bindir}/c1541
160 %attr(755,root,root) %{_bindir}/cartconv
161 %attr(755,root,root) %{_bindir}/petcat
162 %attr(755,root,root) %{_bindir}/vsid
163 %attr(755,root,root) %{_bindir}/x128
164 %attr(755,root,root) %{_bindir}/x64
165 %attr(755,root,root) %{_bindir}/x64dtv
166 %attr(755,root,root) %{_bindir}/x64sc
167 %attr(755,root,root) %{_bindir}/xcbm2
168 %attr(755,root,root) %{_bindir}/xcbm5x0
169 %attr(755,root,root) %{_bindir}/xpet
170 %attr(755,root,root) %{_bindir}/xplus4
171 %attr(755,root,root) %{_bindir}/xvic
172 %{_datadir}/vice
173 %{_fontsdir}/misc/vice-cbm.bdf
174 %{_fontsdir}/TTF/CBM.ttf
175 %{_mandir}/man1/c1541.1*
176 %{_mandir}/man1/petcat.1*
177 %{_mandir}/man1/vice.1*
178 %{_infodir}/vice.info*
179 %{_desktopdir}/vice-*.desktop
180 %{_pixmapsdir}/c128icon.xpm
181 %{_pixmapsdir}/c64dtvicon.xpm
182 %{_pixmapsdir}/c64icon.xpm
183 %{_pixmapsdir}/cbm2icon.xpm
184 %{_pixmapsdir}/peticon.xpm
185 %{_pixmapsdir}/plus4icon.xpm
186 %{_pixmapsdir}/vic20icon.xpm
This page took 0.05984 seconds and 3 git commands to generate.