]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
use arm family macro
[packages/valgrind.git] / valgrind.spec
1 # TODO:
2 # - fix CC detection in configure, so CC=gcc won't be needed
3 #
4 # Conditional build:
5 %bcond_with     mpi     # MPI wrapper module
6 #
7 Summary:        An open-source memory debugger
8 Summary(pl.UTF-8):      Otwarty odpluskwiacz pamięci
9 Name:           valgrind
10 Version:        3.20.0
11 Release:        1
12 License:        GPL v2+
13 Group:          Development/Tools
14 Source0:        https://sourceware.org/pub/valgrind/%{name}-%{version}.tar.bz2
15 # Source0-md5:  e3ca8e03c6c527e80e7da5135a1b6beb
16 Patch0:         %{name}-native-cpuid.patch
17 Patch1:         %{name}-ld_linux_strlen.patch
18 Patch2:         %{name}-datadir.patch
19 URL:            https://www.valgrind.org/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake >= 1:1.10
22 BuildRequires:  gcc >= 5:3.0
23 %ifarch x32
24 BuildRequires:  gcc-multilib-64 >= 5:3.0
25 %endif
26 # check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
27 BuildRequires:  glibc-devel >= 6:2.2
28 BuildRequires:  libgomp-devel
29 BuildRequires:  libstdc++-devel
30 %{?with_mpi:BuildRequires:      mpi-devel}
31 BuildRequires:  rpmbuild(macros) >= 2.007
32 Obsoletes:      valgrind-callgrind < 0.11
33 Obsoletes:      valgrind-calltree < 0.10
34 ExclusiveArch:  %{ix86} %{x8664} %{armv7} ppc ppc64 s390x x32 aarch64
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautostrip    .*/vgpreload.*\\.so
38 %define         filterout_c     -fstack-protector-strong
39 # ld portion broken
40 %undefine       with_ccache
41
42 %description
43 Valgrind is a GPL'd system for debugging and profiling Linux programs.
44 With the tools that come with Valgrind, you can automatically detect
45 many memory management and threading bugs, avoiding hours of
46 frustrating bug-hunting, making your programs more stable. You can
47 also perform detailed profiling to help speed up your programs.
48
49 %description -l pl.UTF-8
50 Valgrind jest systemem służącym do odpluskwiania i profilowania
51 programów na Linuksie. Używając dostarczanych z nim narzędzi można
52 automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
53 i wątkowaniem, dzięki czemu unika się frustrującego polowania na
54 błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
55 również dokładne profilowanie, dzięki któremu programy zaczną szybciej
56 pracować.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p1
62 %patch2 -p1
63
64 %build
65 %{__aclocal}
66 %{__autoconf}
67 %{__autoheader}
68 %{__automake}
69
70 ac_cv_path_GDB=/usr/bin/gdb \
71 %configure \
72         --enable-tls \
73         %{!?with_mpi:--with-mpicc=/bin/false} \
74 %if "%{_lib}" != "lib"
75         --enable-only64bit \
76 %endif \
77         --enable-lto \
78         LDFLAGS="" # no strip!
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
89 cp -p docs/index.pdf docs/valgrind_manual.pdf
90 cp -p docs/index.ps docs/valgrind_manual.ps
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
98 %doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
99 %attr(755,root,root) %{_bindir}/callgrind_annotate
100 %attr(755,root,root) %{_bindir}/callgrind_control
101 %attr(755,root,root) %{_bindir}/cg_annotate
102 %attr(755,root,root) %{_bindir}/cg_diff
103 %attr(755,root,root) %{_bindir}/cg_merge
104 %attr(755,root,root) %{_bindir}/ms_print
105 %attr(755,root,root) %{_bindir}/valgrind
106 %attr(755,root,root) %{_bindir}/valgrind-di-server
107 %attr(755,root,root) %{_bindir}/valgrind-listener
108 %attr(755,root,root) %{_bindir}/vgdb
109 %dir %{_libdir}/%{name}
110 %{_libdir}/%{name}/lib*-linux.a
111 %if %{with mpi}
112 # TODO: subpackage?
113 %attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
114 %endif
115 %if "%{_libexecdir}" != "%{_libdir}"
116 %dir %{_libexecdir}/%{name}
117 %endif
118 %attr(755,root,root) %{_libexecdir}/%{name}/*-linux
119 %attr(755,root,root) %{_libexecdir}/%{name}/vgpreload_*-linux.so
120 %{_libexecdir}/%{name}/*.xml
121 %{_libexecdir}/%{name}/default.supp
122 %{_datadir}/%{name}
123 %{_includedir}/valgrind
124 %{_mandir}/man1/callgrind_annotate.1*
125 %{_mandir}/man1/callgrind_control.1*
126 %{_mandir}/man1/cg_annotate.1*
127 %{_mandir}/man1/cg_diff.1*
128 %{_mandir}/man1/cg_merge.1*
129 %{_mandir}/man1/ms_print.1*
130 %{_mandir}/man1/valgrind.1*
131 %{_mandir}/man1/valgrind-di-server.1*
132 %{_mandir}/man1/valgrind-listener.1*
133 %{_mandir}/man1/vgdb.1*
134 %{_pkgconfigdir}/valgrind.pc
This page took 0.057996 seconds and 4 git commands to generate.