]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
- add patch
[packages/vala.git] / vala.spec
1 Summary:        GObject-based language compiler
2 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
3 Name:           vala
4 Version:        0.5.1
5 Release:        1
6 License:        LGPL v2+
7 Group:          Applications
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.5/%{name}-%{version}.tar.bz2
9 # Source0-md5:  0051ae1f2ef967ce21e77889719daad1
10 Patch0: %{name}-0.5.1-2004.patch
11 URL:            http://www.paldo.org/vala/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  glib2-devel >= 1:2.12.0
17 BuildRequires:  gtk+2-devel >= 2:2.10.0
18 BuildRequires:  libtool
19 BuildRequires:  libxslt-progs
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Vala is a new programming language that aims to bring modern
25 programming language features to GNOME developers without imposing any
26 additional runtime requirements and without using a different ABI
27 compared to applications and libraries written in C.
28
29 valac, the Vala compiler, is a self-hosting compiler that translates
30 Vala source code into C source and header files. It uses the GObject
31 type system to create classes and interfaces declared in the Vala
32 source code. It's also planned to generate GIDL files when
33 gobject-introspection is ready.
34
35 The syntax of Vala is similar to C#, modified to better fit the
36 GObject type system.
37
38 %description -l pl.UTF-8
39 Vala to nowy język programowania, którego celem jest udostępnienie
40 cech nowoczesnych języków programowania programistom GNOME bez
41 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
42 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
43
44 valac - kompilator języka Vala - to napisany w sobie samym kompilator
45 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
46 C. Używa systemu typów GObject do tworzenia klas i interfejsów
47 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
48 generowanie plików GIDL, kiedy system gobject-introspection będzie
49 gotowy.
50
51 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
52 pasować do systemu typów GObject.
53
54 %package apidocs
55 Summary:        vala API documentation
56 Summary(pl.UTF-8):      Dokumentacja API vala
57 Group:          Documentation
58 Requires:       devhelp
59
60 %description apidocs
61 vala API documentation.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API vala.
65
66 %prep
67 %setup -q
68 %patch0 -p0
69
70 %build
71 %{__libtoolize}
72 %{__aclocal}
73 %{__autoconf}
74 %{__autoheader}
75 %{__automake}
76 %configure \
77         --enable-vapigen \
78         --enable-gen-project
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_bindir}/*
96 %attr(755,root,root) %{_libdir}/libvala.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libvala.so.0
98 %attr(755,root,root) %{_libdir}/libvala.so
99 %{_libdir}/libvala.la
100 %{_includedir}/vala-1.0
101 %{_pkgconfigdir}/vala-1.0.pc
102 %dir %{_datadir}/vala
103 %dir %{_datadir}/vala/vapi
104 %{_datadir}/vala/vapi/*.vapi
105 %{_datadir}/vala/vapi/*.deps
106 %{_mandir}/man1/valac.1*
107 %attr(755,root,root) %{_libdir}/vala/gen-introspect
108 %{_mandir}/man1/vala-gen-introspect.1
109 %{_mandir}/man1/vapigen.1
110 %dir %{_datadir}/vala/licenses
111 %{_datadir}/vala/licenses/*
112
113 %files apidocs
114 %defattr(644,root,root,755)
115 %{_datadir}/devhelp/books/vala
This page took 0.031583 seconds and 4 git commands to generate.