]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
- 0.1.2
[packages/vala.git] / vala.spec
1 Summary:        GObject-based language compiler
2 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
3 Name:           vala
4 Version:        0.1.2
5 Release:        1
6 License:        LGPL v2+
7 Group:          Applications
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.1/%{name}-%{version}.tar.bz2
9 # Source0-md5:  cfb297052d4ef83acb8e3c1c2cb57d87
10 URL:            http://www.paldo.org/vala/
11 BuildRequires:  bison
12 BuildRequires:  glib2-devel >= 1:2.10.0
13 BuildRequires:  pkgconfig
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Vala is a new programming language that aims to bring modern
18 programming language features to GNOME developers without imposing any
19 additional runtime requirements and without using a different ABI
20 compared to applications and libraries written in C.
21
22 valac, the Vala compiler, is a self-hosting compiler that translates
23 Vala source code into C source and header files. It uses the GObject
24 type system to create classes and interfaces declared in the Vala
25 source code. It's also planned to generate GIDL files when
26 gobject-introspection is ready.
27
28 The syntax of Vala is similar to C#, modified to better fit the
29 GObject type system.
30
31 %description -l pl.UTF-8
32 Vala to nowy język programowania, którego celem jest udostępnienie
33 cech nowoczesnych języków programowania programistom GNOME bez
34 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
35 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
36
37 valac - kompilator języka Vala - to napisany w sobie samym kompilator
38 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
39 C. Używa systemu typów GObject do tworzenia klas i interfejsów
40 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
41 generowanie plików GIDL, kiedy system gobject-introspection będzie
42 gotowy.
43
44 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
45 pasować do systemu typów GObject.
46
47 %prep
48 %setup -q
49
50 %build
51 %configure
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post   -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(644,root,root,755)
68 %attr(755,root,root) %{_bindir}/*
69 %attr(755,root,root) %{_libdir}/libvala.so.*.*.*
70 %attr(755,root,root) %{_libdir}/libvala.so
71 %{_libdir}/libvala.la
72 %{_includedir}/vala-1.0
73 %{_pkgconfigdir}/vala-1.0.pc
74 %dir %{_datadir}/vala
75 %dir %{_datadir}/vala/vapi
76 %{_datadir}/vala/vapi/*.vala
77 %{_datadir}/vala/vapi/*.deps
78 %{_mandir}/man1/valac.1*
This page took 0.02821 seconds and 3 git commands to generate.