]> git.pld-linux.org Git - packages/uzbl.git/blob - uzbl.spec
Release 12 (by relup.sh)
[packages/uzbl.git] / uzbl.spec
1 # TODO:
2 # - review python deps
3 #
4 Summary:        A keyboard controlled (modal vim-like bindings, or with modifier keys) browser based on Webkit
5 Summary(hu.UTF-8):      Egy billentyűzettel irányítható (vim-szerű vagy módosító kódok) böngésző Webkit alapokon
6 Summary(pl.UTF-8):      Minimalistyczna przeglądarka w całości obsługiwana przy użyciu klawiatury
7 Name:           uzbl
8 Version:        2013.12.08
9 Release:        12
10 License:        GPL v3
11 Group:          X11/Applications/Networking
12 # git://github.com/Dieterbe/uzbl.git
13 # Source0:      https://github.com/Dieterbe/uzbl/archive/%{version}.tar.gz
14 Source0:        %{name}-%{version}.tar.bz2
15 # Source0-md5:  ff21df4ce77829ec35f3632b5232069d
16 Patch0:         %{name}-build.patch
17 URL:            http://www.uzbl.org/
18 BuildRequires:  gtk+3-devel
19 BuildRequires:  gtk-webkit3-devel >= 1.2.0-4
20 BuildRequires:  libsoup-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  python3-devel
23 BuildRequires:  rpm-pythonprov
24 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
25 Requires:       dmenu
26 Requires:       socat
27 Requires:       xclip
28 Requires:       zenity
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The uzbl browser is a keyboard controlled (modal vim-like bindings, or
33 with modifier keys) browser based on Webkit.
34
35 %description -l hu.UTF-8
36 Egy billentyűzettel irányítható (vim-szerű vagy módosító kódok)
37 böngésző Webkit alapokon.
38
39 %description -l pl.UTF-8
40 uzbl jest przeglądarką, która może być w całości obsługiwana przy
41 użyciu klawiatury. Domyślne ustawienia klawiszy są wzorowane na
42 skrótach klawiszowych programu vim. uzbl wykorzystuje silnik Webkit.
43
44 uzbl sam nie obsługuje zakładek, historii, pobierania plików. Funkcje
45 te są realizowane przez zewnętrzne skrypty. Dzięki temu oraz dzięki
46 ładowanym na życzenie skryptom JavaScript przeglądarka ta jest bardzo
47 elastyczna, konfigurowalna i może być w łatwy sposób rozszerzana.
48
49 %package core
50 Summary:        Uzbl core
51 Summary(pl.UTF-8):      Jądro Uzbl
52 Group:          X11/Applications/Networking
53 Requires:       gtk-webkit >= 1.2.0-4
54 Suggests:       %{name}-event-manager = %{epoch}:%{version}-%{release}
55 Obsoletes:      uzbl-examples
56 Obsoletes:      uzbl-scripts
57
58 %description core
59 Main component of uzbl browser. You also need one of UI components
60 (uzbl or uzbl-tabbed).
61
62 %description core -l pl.UTF-8
63 Jądro przeglądarki uzbl. Aby mieć w pełni funkcjonalną przeglądarkę
64 potrzebujesz jeszcze jeden z interfejsów graficznych: uzbl lub
65 uzbl-tabbed.
66
67 %package event-manager
68 Summary:        Uzbl event manager
69 Summary(pl.UTF-8):      Zarządca zdarzeń dla uzbl
70 Group:          X11/Applications/Networking
71
72 %description event-manager
73 Uzbl event manager.
74
75 %description event-manager -l pl.UTF-8
76 Zarządca zdarzeń dla uzbl.
77
78 %package tabbed
79 Summary:        Tabs for uzbl
80 Summary(hu.UTF-8):      Tabok uzbl-hez
81 Summary(pl.UTF-8):      Taby dla uzbl
82 Group:          X11/Applications/Networking
83 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
84
85 %description tabbed
86 Wrapper for uzbl that provides firefox-style tabs.
87
88 %description tabbed -l hu.UTF-8
89 Egy uzbl-wrapper, amely firefox-stílusú tabok használatát teszi
90 lehetővé.
91
92 %description tabbed -l pl.UTF-8
93 Skrypt, który dodaje do uzbl taby podobne do tych znanych użytkownikom
94 przeglądarki firefox.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99
100 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python3}\1,' \
101       bin/uzbl-tabbed \
102       examples/data/scripts/auth.py \
103       examples/data/scripts/per-site-settings.py \
104       examples/data/scripts/scheme.py \
105       examples/data/scripts/uzblcat
106
107 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
108       uzbl/event_manager.py
109
110 %build
111 export CFLAGS="%{rpmcflags}"
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         PREFIX=%{_prefix} \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 rm -r $RPM_BUILD_ROOT%{_datadir}/uzbl/docs
122
123 ln -s %{_bindir}/uzbl-browser $RPM_BUILD_ROOT%{_bindir}/uzbl
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS README docs/*
131 %attr(755,root,root) %{_bindir}/uzbl
132 %attr(755,root,root) %{_bindir}/uzbl-browser
133
134 %files core
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/uzbl-core
137 %dir %{_datadir}/uzbl
138 %dir %{_datadir}/uzbl/examples
139 %{_datadir}/uzbl/examples/config
140 %dir %{_datadir}/uzbl/examples/data
141 %dir %{_datadir}/uzbl/examples/data/scripts
142 #%dir %{_datadir}/uzbl/examples/data/plugins
143 %attr(755,root,root) %{_datadir}/uzbl/examples/data/scripts/*
144 #%attr(755,root,root) %{_datadir}/uzbl/examples/data/plugins/*
145 %{_datadir}/uzbl/examples/data/dforms
146 %{_datadir}/uzbl/examples/data/bookmarks
147 %{_datadir}/uzbl/examples/data/per-site-settings
148 %{_datadir}/uzbl/examples/data/uzbl.png
149
150 %{py3_sitescriptdir}/uzbl*.egg-info
151 %{py3_sitescriptdir}/uzbl
152
153 %files event-manager
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/uzbl-event-manager
156
157 %files tabbed
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/uzbl-tabbed
This page took 0.114875 seconds and 4 git commands to generate.