]> git.pld-linux.org Git - packages/util-vserver.git/blob - util-vserver.spec
- update to latest syscall implementation (skiny10 patch)
[packages/util-vserver.git] / util-vserver.spec
1 # TODO
2 # - somewhy empty /var/cache/vservers is needed when building pld vserver
3 # - make build create /dev/std{in,out,err} links
4 #
5 # m68k and mips are the only not supported archs
6 #
7 # Conditional build:
8 %bcond_without  dietlibc        # don't use dietlibc (ask for troubles)
9 %bcond_without  doc             # don't build documentation which needed LaTeX
10 %bcond_without  no_dynamic_context      # disable enforcement of disabled dynamic context
11 %bcond_with     xalan           # use the xalan xslt processor
12 #
13 %define _vproc_version 0.01
14 # diet compile fails with ccache in %{__cc}
15 %undefine       with_ccache
16 #
17 Summary:        Linux virtual server utilities
18 Summary(pl):    Narzêdzia dla linuksowych serwerów wirtualnych
19 Name:           util-vserver
20 Version:        0.30.210
21 Release:        8
22 License:        GPL
23 Group:          Applications/System
24 Source0:        http://www.13thfloor.at/~ensc/util-vserver/files/alpha/%{name}-%{version}.tar.bz2
25 # Source0-md5:  1e8fff7cb6246d21ed029f082123019b
26 Source1:        vprocunhide.init
27 Source2:        vservers.init
28 Source3:        vservers-legacy.init
29 Source4:        rebootmgr.init
30 Source5:        vservers.sysconfig
31 Source6:        vservers-legacy.sysconfig
32 Source7:        vrootdevices.init
33 Source8:        vrootdevices.sysconfig
34 # A bit of documentation explaining package management
35 # http://www.paul.sladen.org/vserver/archives/200505/0078.html
36 Source9:        %{name}-pkgmgmt.txt
37 Source10:       %{name}-initpost.sh
38 Source11:       http://www.13thfloor.at/vserver/s_release/v1.2.10/vproc-%{_vproc_version}.tar.bz2
39 # Source11-md5: 1d030717bdbc958ea4b35fd2410dad85
40 Patch0:         %{name}-vsysvwrapper.patch
41 Patch1:         %{name}-pld.patch
42 Patch2:         %{name}-vrpm.patch
43 Patch3:         %{name}-include.patch
44 Patch4:         %{name}-m4-diet.patch
45 Patch5:         %{name}-cpuset.patch
46 Patch6:         %{name}-build-umask.patch
47 Patch7:         %{name}-utmpx.patch
48 Patch8:         %{name}-vprocunhide.patch
49 Patch9:         %{name}-dev.patch
50 Patch10:        %{name}-no-dynamic-ctx.patch
51 Patch11:        %{name}-more-ip.patch
52 Patch12:        http://daniel.hozac.com/vserver/util-vserver/%{name}-0.30.210-namespace-cleanup.patch
53 Patch13:        http://daniel.hozac.com/vserver/util-vserver/%{name}-0.30.210-delete.patch
54 Patch14:        http://daniel.hozac.com/vserver/util-vserver/%{name}-0.30.210-shiny10.patch
55 Patch15:        %{name}-rpm-fake-resolver-badperm-errorlogging.patch
56 URL:            http://savannah.nongnu.org/projects/util-vserver/
57 BuildRequires:  autoconf
58 BuildRequires:  automake >= 1.9
59 BuildRequires:  beecrypt-devel
60 %{?with_dietlibc:BuildRequires: dietlibc-static >= 2:0.29}
61 BuildRequires:  libstdc++-devel
62 BuildRequires:  libtool >= 1.5.14
63 %ifarch %{x8664}
64 BuildRequires:  sed >= 4.0
65 %endif
66 BuildRequires:  rpmbuild(macros) >= 1.268
67 %if %{with doc}
68 BuildRequires:  doxygen
69 BuildRequires:  graphviz
70 BuildRequires:  libxslt-progs
71 BuildRequires:  tetex-format-pdflatex
72 BuildRequires:  tetex-makeindex
73 # To be removed when tetex-format-pdflatex, tetex-pdftex...
74 # ...and graphviz packages get fixed
75 BuildRequires:  ghostscript
76 BuildRequires:  ghostscript-fonts-std
77 BuildRequires:  tetex-fonts-jknappen
78 BuildRequires:  tetex-metafont
79 %{?with_xalan:BuildRequires:    xalan-j}
80 %endif
81 Requires(post,preun):   /sbin/chkconfig
82 Requires:       %{name}-lib = %{version}-%{release}
83 Requires:       issue
84 Requires:       rc-scripts
85 Requires:       util-linux
86 Obsoletes:      util-vserver-core
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 # for adapter
90 %define         _usrbin         /usr/bin
91 %define         _usrsbin        /usr/sbin
92 %define         _usrlib         /usr/lib
93
94 %description
95 This package provides the components and a framework to setup virtual
96 servers. A virtual server runs inside a Linux server. It is
97 nevertheless highly independent. As such, you can run various services
98 with normal configuration. The various vservers can't interact with
99 each other and can't interact with services in the main server.
100
101 This requires a special kernel supporting the new new_s_context and
102 set_ipv4root system call.
103
104 This package contains utilities which are required to communicate with
105 the Linux-Vserver enabled kernel.
106
107 %description -l pl
108 Ten pakiet dostarcza sk³adniki i szkielet do tworzenia wirtualnych
109 serwerów. Wirtualny serwer dzia³a wewn±trz serwera linuksowego, lecz
110 jest od niego w du¿ym stopniu niezale¿ny. Jako taki mo¿e uruchamiaæ
111 ró¿ne us³ugi z normaln± konfiguracj±. Ró¿ne vserwery nie mog± wchodziæ
112 w interakcjê z innymi ani z us³ugami na g³ównym serwerze.
113
114 Wymaga to specjalnego j±dra obs³uguj±cego nowe wywo³ania systemowe
115 new_s_context i set_ipv4root.
116
117 Ten pakiet zawiera narzêdzia wymagane do komunikacji z j±drem z
118 w³±czonym mechanizmem Linux-Vserver.
119
120 %package devel
121 Summary:        Development files for Linux vserver libraries
122 Summary(pl):    Pliki programistyczne dla bibliotek linuksowego vserwera
123 Group:          Development/Libraries
124 Requires:       %{name}-lib = %{version}-%{release}
125
126 %description devel
127 This package contains the development files necessary for developing
128 programs which use vserver library.
129
130 %description devel -l pl
131 Ten pakiet zawiera pliki programistyczne konieczne do rozwijania
132 programów u¿ywaj±cych biblioteki vserver.
133
134 %package static
135 Summary:        Static vserver library
136 Summary(pl):    Biblioteka statyczna vservera
137 Group:          Development/Libraries
138 Requires:       %{name}-devel = %{version}-%{release}
139
140 %description static
141 This package contains the static version of vserver library.
142
143 %description static -l pl
144 Ten pakiet zawiera statyczn± wersjê biblioteki vservera.
145
146 %package lib
147 Summary:        Dynamic libraries for util-vserver
148 Summary(pl):    Biblioteki dynamiczne dla pakietu util-vserver
149 Group:          Libraries
150
151 %description lib
152 util-vserver provides the components and a framework to setup virtual
153 servers. A virtual server runs inside a linux server. It is
154 nevertheless highly independent. As such, you can run various services
155 pith normal configuration. The various vservers can't interact with
156 each other and can't interact with services in the main server.
157
158 This package contains the shared libraries needed by all other
159 'util-vserver' subpackages.
160
161 %description lib -l pl
162 util-vserver dostarcza sk³adniki i szkielet do tworzenia wirtualnych
163 serwerów. Wirtualny serwer dzia³a wewn±trz serwera linuksowego, lecz
164 jest od niego w du¿ym stopniu niezale¿ny. Jako taki mo¿e uruchamiaæ
165 ró¿ne us³ugi z normaln± konfiguracj±. Ró¿ne vserwery nie mog± wchodziæ
166 w interakcjê z innymi ani z us³ugami na g³ównym serwerze.
167
168 Ten pakiet zawiera biblioteki wspó³dzielone wymagane przez wszystkie
169 podpakiety util-vserver.
170
171 %package build
172 Summary:        Tools which can be used to build vservers
173 Summary(pl):    Narzêdzia do budowania vserverów
174 Group:          Applications/System
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       /etc/pld-release
177 Requires:       e2fsprogs
178 Requires:       which
179 Conflicts:      poldek < 0.18.8-10
180
181 %description build
182 util-vserver provides the components and a framework to setup virtual
183 servers. A virtual server runs inside a linux server. It is
184 nevertheless highly independent. As such, you can run various services
185 with normal configuration. The various vservers can't interact with
186 each other and can't interact with services in the main server.
187
188 This package contains utilities which assist in building Vservers.
189
190 %description build -l pl
191 util-vserver dostarcza sk³adniki i szkielet do tworzenia wirtualnych
192 serwerów. Wirtualny serwer dzia³a wewn±trz serwera linuksowego, lecz
193 jest od niego w du¿ym stopniu niezale¿ny. Jako taki mo¿e uruchamiaæ
194 ró¿ne us³ugi z normaln± konfiguracj±. Ró¿ne vserwery nie mog± wchodziæ
195 w interakcjê z innymi ani z us³ugami na g³ównym serwerze.
196
197 Ten pakiet zawiera narzêdzia pomagaj±ce przy budowaniu Vserwerów.
198
199 %package -n vserver-distro-fedora
200 Summary:        VServer build templates for Fedora Core
201 Summary(pl):    Szablony do tworzenia VServerów dla dystrybucji Fedora Core
202 Group:          Applications/System
203 Requires:       %{name} = %{version}-%{release}
204 Requires:       binutils
205 Requires:       e2fsprogs
206 Requires:       rpm
207 Requires:       tar
208 Requires:       wget
209
210 %description -n vserver-distro-fedora
211 VServer build templates for Fedora Core 1,2,3,4.
212
213 %description -n vserver-distro-fedora -l pl
214 Szablony do tworzenia VServerów dla dystrybucji Fedora Core 1,2,3,4.
215
216 %package -n vserver-distro-redhat
217 Summary:        VServer build template for Red Hat Linux 9
218 Summary(pl):    Szablon do tworzenia VServerów dla dystrybucji Red Hat Linux 9
219 Group:          Applications/System
220 Requires:       %{name} = %{version}-%{release}
221 Requires:       binutils
222 Requires:       e2fsprogs
223 Requires:       rpm
224 Requires:       tar
225 Requires:       wget
226
227 %description -n vserver-distro-redhat
228 VServer build template for RedHat Linux 9.
229
230 %description -n vserver-distro-redhat -l pl
231 Szablon do tworzenia VServerów dla dystrybucji Red Hat Linux 9.
232
233 %package -n vserver-distro-suse
234 Summary:        VServer build template for SuSE 9.1
235 Summary(pl):    Szablon do tworzenia VServerów dla dystrybucji SuSE 9.1
236 Group:          Applications/System
237 Requires:       %{name} = %{version}-%{release}
238 Requires:       binutils
239 Requires:       e2fsprogs
240 Requires:       rpm
241 Requires:       tar
242 Requires:       wget
243
244 %description -n vserver-distro-suse
245 VServer build template for SuSE Linux 9.1.
246
247 %description -n vserver-distro-suse -l pl
248 Szablon do tworzenia VServerów dla dystrybucji SuSE 9.1.
249
250 %package -n vserver-distro-centos
251 Summary:        VServer build template for CentOS 4.2
252 Summary(pl):    Szablon budowania VServera dla CentOS 4.2
253 Group:          Applications/System
254 Requires:       util-vserver-build
255 Requires:       yum
256
257 %description -n vserver-distro-centos
258 VServer build template for CentOS 4.2.
259
260 %description -n vserver-distro-centos -l pl
261 Szablon budowania VServera dla CentOS 4.2.
262
263 %package init
264 Summary:        initscripts for vserver
265 Summary(pl):    Skrypty inicjalizuj±ce dla vserwera
266 Group:          Applications/System
267 Requires(post,preun):   /sbin/chkconfig
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       diffutils
270 Requires:       make
271 Requires:       rc-scripts
272
273 %description init
274 util-vserver provides the components and a framework to setup virtual
275 servers. A virtual server runs inside a linux server. It is
276 nevertheless highly independent. As such, you can run various services
277 with normal configuration. The various vservers can't interact with
278 each other and can't interact with services in the main server.
279
280 This package contains the SysV initscripts which start and stop
281 Vservers and related tools.
282
283 %description init -l pl
284 util-vserver dostarcza sk³adniki i szkielet do tworzenia wirtualnych
285 serwerów. Wirtualny serwer dzia³a wewn±trz serwera linuksowego, lecz
286 jest od niego w du¿ym stopniu niezale¿ny. Jako taki mo¿e uruchamiaæ
287 ró¿ne us³ugi z normaln± konfiguracj±. Ró¿ne vserwery nie mog± wchodziæ
288 w interakcjê z innymi ani z us³ugami na g³ównym serwerze.
289
290 Ten pakiet zawiera skrypty inicjalizuj±ce SysV uruchamiaj±ce i
291 zatrzymuj±ce Vserwery oraz powi±zane narzêdzia.
292
293 %package legacy
294 Summary:        Legacy utilities for util-vserver
295 Summary(pl):    Stare narzêdzia dla util-vserver
296 Group:          Applications/System
297 Requires(post,preun):   /sbin/chkconfig
298 Requires:       %{name} = %{version}-%{release}
299 Requires:       rc-scripts
300
301 %description legacy
302 util-vserver provides the components and a framework to setup virtual
303 servers. A virtual server runs inside a linux server. It is
304 nevertheless highly independent. As such, you can run various services
305 with normal configuration. The various vservers can't interact with
306 each other and can't interact with services in the main server.
307
308 This package contains the tools which are needed to work with Vservers
309 having an old-style configuration.
310
311 %description legacy -l pl
312 util-vserver dostarcza sk³adniki i szkielet do tworzenia wirtualnych
313 serwerów. Wirtualny serwer dzia³a wewn±trz serwera linuksowego, lecz
314 jest od niego w du¿ym stopniu niezale¿ny. Jako taki mo¿e uruchamiaæ
315 ró¿ne us³ugi z normaln± konfiguracj±. Ró¿ne vserwery nie mog± wchodziæ
316 w interakcjê z innymi ani z us³ugami na g³ównym serwerze.
317
318 Ten pakiet zawiera narzêdzia potrzebne do pracy z Vserwerami maj±cymi
319 konfiguracjê w starym stylu.
320
321 %prep
322 %setup -q -a11
323 %patch0 -p1
324 %patch1 -p1
325 %patch2 -p1
326 %patch3 -p1
327 %patch4 -p1
328 %patch5 -p1
329 %patch6 -p1
330 %patch7 -p1
331 %patch8 -p1
332 %patch9 -p1
333 %{?with_no_dynamic_context:%patch10 -p1}
334 %patch11 -p1
335 %patch12 -p1
336 %patch13 -p1
337 %patch14 -p1
338 %patch15 -p1
339
340 install %{SOURCE9} package-management.txt
341
342 cp -a compat.h vserver-compat.h
343
344 %build
345 %if %{with dietlibc}
346 CFLAGS="%{rpmcflags} -D__GLIBC__"
347 %endif
348 %{__aclocal} -I m4
349 %{__automake}
350 %{__autoconf}
351 %configure \
352         --with-initrddir=/etc/rc.d/init.d \
353         --enable-release \
354         --enable-apis=NOLEGACY \
355         %{?with_dietlibc:--enable-dietlibc} \
356         %{!?with_dietlibc:--disable-dietlibc} \
357         MKTEMP=/bin/mktemp \
358         MOUNT=/bin/mount \
359         PS=/bin/ps \
360         UMOUNT=/bin/umount \
361         IP=/sbin/ip \
362         IPTABLES=%{_usrsbin}/iptables \
363         MODPROBE=/sbin/modprobe \
364         NAMEIF=/sbin/nameif \
365         RMMOD=/sbin/rmmod \
366         VCONFIG=/sbin/vconfig \
367         WGET=%{_usrbin}/wget \
368
369 %{__make} all
370 %{?with_doc:%{__make} doc}
371
372 %{__make} -C vproc-%{_vproc_version} \
373         CC="%{__cc}" \
374         CFLAGS="%{rpmcflags}"
375
376 %install
377 rm -rf $RPM_BUILD_ROOT
378 install -d $RPM_BUILD_ROOT{/vservers,/etc/{sysconfig,rc.d/init.d},/dev/pts} \
379         $RPM_BUILD_ROOT{%{_sysconfdir}/vservices,/vservers/.pkg}
380
381 %{__make} install install-distribution \
382         DESTDIR=$RPM_BUILD_ROOT
383
384 cp -a vserver-compat.h $RPM_BUILD_ROOT%{_includedir}
385
386 chmod -R +rX $RPM_BUILD_ROOT%{_libdir}/%{name}/distributions/*
387
388 ln -s /vservers $RPM_BUILD_ROOT%{_sysconfdir}/vservers/vdirbase
389 ln -s %{_localstatedir}/run/vservers.rev $RPM_BUILD_ROOT%{_sysconfdir}/vservers/run.rev
390
391 for i in $RPM_BUILD_ROOT/etc/rc.d/init.d/v_* ; do
392         s=`basename $i | sed s/v_//`
393         cat >$RPM_BUILD_ROOT%{_sysconfdir}/vservices/$s << EOF
394 # IP addresses/interfaces to bound $s service to
395 #IP=10.0.0.1
396 #IP=eth0
397 EOF
398 done
399
400 sed 's|%{_usrlib}/util-vserver|%{_libdir}/%{name}|g' %{SOURCE1} > \
401         $RPM_BUILD_ROOT/etc/rc.d/init.d/vprocunhide
402 sed 's|%{_usrlib}/util-vserver|%{_libdir}/%{name}|g' %{SOURCE2} > \
403         $RPM_BUILD_ROOT/etc/rc.d/init.d/vservers
404 sed 's|%{_usrlib}/util-vserver|%{_libdir}/%{name}|g' %{SOURCE3} > \
405         $RPM_BUILD_ROOT/etc/rc.d/init.d/vservers-legacy
406 sed 's|%{_usrlib}/util-vserver|%{_libdir}/%{name}|g' %{SOURCE4} > \
407         $RPM_BUILD_ROOT/etc/rc.d/init.d/rebootmgr
408 sed 's|%{_usrlib}/util-vserver|%{_libdir}/%{name}|g' %{SOURCE5} > \
409         $RPM_BUILD_ROOT/etc/sysconfig/vservers
410
411 install %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/vservers-legacy
412
413 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/vrootdevices
414 install %{SOURCE8} $RPM_BUILD_ROOT/etc/sysconfig/vrootdevices
415 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/%{name}/distributions/pld-ac/initpost
416 install vproc-%{_vproc_version}/vproc $RPM_BUILD_ROOT%{_sbindir}
417
418 ln -sf null $RPM_BUILD_ROOT/dev/initctl
419
420 %ifarch %{x8664}
421 sed -i 's/^glibc$/glibc64/' $RPM_BUILD_ROOT%{_libdir}/%{name}/distributions/pld-ac/pkgs/01
422 sed -i 's/glibc\-\[0\-9\]\*\.rpm/glibc64\-\[0\-9\]\*\.rpm/' $RPM_BUILD_ROOT%{_libdir}/%{name}/distributions/pld-ac/rpmlist.d/00.lst
423 %endif
424
425 # baggins check this: needed but seems unused
426 install -d $RPM_BUILD_ROOT/var/cache/vservers
427
428 %clean
429 rm -rf $RPM_BUILD_ROOT
430
431 %post
432 %{_sbindir}/setattr --barrier /vservers || :
433
434 %post   lib -p /sbin/ldconfig
435 %postun lib -p /sbin/ldconfig
436
437 %post init
438 /sbin/chkconfig --add vrootdevices
439 /sbin/chkconfig --add vprocunhide
440 /sbin/chkconfig --add vservers
441 if [ ! -f /var/lock/subsys/vrootdevices ]; then
442         echo "Type \"/sbin/service vrootdevices start\" to assign virtual root devices" 1>&2
443 fi
444 if [ ! -f /var/lock/subsys/vprocunhide ]; then
445         echo "Type \"/sbin/service vprocunhide start\" to set /proc visibility for vservers" 1>&2
446 fi
447 if [ ! -f /var/lock/subsys/vservers ]; then
448         echo "Type \"/sbin/service vservers start\" to start vservers" 1>&2
449 fi
450
451 %preun init
452 if [ "$1" = "0" ]; then
453         %service vservers stop
454         %service vprocunhide stop
455         %service vrootdevices stop
456         /sbin/chkconfig --del vservers
457         /sbin/chkconfig --del vprocunhide
458         /sbin/chkconfig --del vrootdevices
459 fi
460
461 %post legacy
462 /sbin/chkconfig --add rebootmgr
463 /sbin/chkconfig --add vservers-legacy
464 if [ ! -f /var/lock/subsys/rebootmgr ] ; then
465         echo "Type \"/sbin/service rebootmgr start\" to start reboot manager for legacy vservers" 1>&2
466 fi
467 if [ ! -f /var/lock/subsys/vservers-legacy ] ; then
468         echo "Type \"/sbin/service vservers-legacy start\" to start legacy vservers" 1>&2
469 fi
470
471 %preun legacy
472 if [ "$1" = "0" ]; then
473         %service rebootmgr stop
474         %service vservers-legacy stop
475         /sbin/chkconfig --del rebootmgr
476         /sbin/chkconfig --del vservers-legacy
477 fi
478
479 %triggerpostun build -- %{name}-build < 0.30.210-5.2
480 if [ -f /etc/vservers/.distributions/pld2.0/poldek/poldek.conf.rpmsave ]; then
481         mv -f /etc/vservers/.distributions/{pld2.0,pld-ac}/poldek/poldek.conf.rpmsave
482 fi
483
484 # kill old vserver specific package ignores which are no longer needed
485 l=`egrep '^ignore.*(basesystem|SysVinit|rc-scripts)' /etc/vservers/*/apps/pkgmgmt/base/poldek/etc/poldek.conf -l 2>/dev/null`
486 if [ "$l" ]; then
487         %{__sed} -i -e '/^ignore/s, \(basesystem\|SysVinit\|rc-scripts\),,g' $l
488 fi
489
490 %files
491 %defattr(644,root,root,755)
492 %doc AUTHORS ChangeLog NEWS THANKS doc/intro.txt
493 %{?with_doc:%doc doc/*.html}
494 %dir %{_sysconfdir}/vservers
495 %dir %{_sysconfdir}/vservers/.defaults
496 %dir %{_sysconfdir}/vservers/.defaults/apps
497 %dir %{_sysconfdir}/vservers/.defaults/files
498 %{_sysconfdir}/vservers/.defaults/vdirbase
499 %{_sysconfdir}/vservers/.defaults/run.rev
500 %{_sysconfdir}/vservers/vdirbase
501 %{_sysconfdir}/vservers/run.rev
502 /sbin/vshelper
503 %attr(755,root,root) %{_sbindir}/chbind
504 %attr(755,root,root) %{_sbindir}/chcontext
505 %attr(755,root,root) %{_sbindir}/chxid
506 %attr(755,root,root) %{_sbindir}/exec-cd
507 %attr(755,root,root) %{_sbindir}/lsxid
508 %attr(755,root,root) %{_sbindir}/reducecap
509 %attr(755,root,root) %{_sbindir}/setattr
510 %attr(755,root,root) %{_sbindir}/showattr
511 %attr(755,root,root) %{_sbindir}/vattribute
512 %attr(755,root,root) %{_sbindir}/vcontext
513 %attr(755,root,root) %{_sbindir}/vdlimit
514 %attr(755,root,root) %{_sbindir}/vnamespace
515 %attr(755,root,root) %{_sbindir}/vkill
516 %attr(755,root,root) %{_sbindir}/vlimit
517 %attr(755,root,root) %{_sbindir}/vdu
518 %attr(755,root,root) %{_sbindir}/vproc
519 %attr(755,root,root) %{_sbindir}/vps
520 %attr(755,root,root) %{_sbindir}/vpstree
521 %attr(755,root,root) %{_sbindir}/vrsetup
522 %attr(755,root,root) %{_sbindir}/vsched
523 %attr(755,root,root) %{_sbindir}/vserver
524 %attr(755,root,root) %{_sbindir}/vserver-info
525 %attr(755,root,root) %{_sbindir}/vserver-stat
526 %attr(755,root,root) %{_sbindir}/vsomething
527 %attr(755,root,root) %{_sbindir}/vtop
528 %attr(755,root,root) %{_sbindir}/vuname
529 %attr(755,root,root) %{_sbindir}/vwait
530 %dir %{_libdir}/%{name}
531 %dir %{_libdir}/%{name}/defaults
532 %{_libdir}/%{name}/FEATURES.txt
533 %{_libdir}/%{name}/util-vserver-vars
534 %{_libdir}/%{name}/defaults/*
535 %attr(755,root,root) %{_libdir}/%{name}/capchroot
536 %attr(755,root,root) %{_libdir}/%{name}/chain-echo
537 %attr(755,root,root) %{_libdir}/%{name}/check-unixfile
538 %attr(755,root,root) %{_libdir}/%{name}/chcontext-compat
539 %attr(755,root,root) %{_libdir}/%{name}/chroot-sh
540 %attr(755,root,root) %{_libdir}/%{name}/exec-ulimit
541 %attr(755,root,root) %{_libdir}/%{name}/fakerunlevel
542 %attr(755,root,root) %{_libdir}/%{name}/filetime
543 %{_libdir}/%{name}/functions
544 %attr(755,root,root) %{_libdir}/%{name}/keep-ctx-alive
545 %attr(755,root,root) %{_libdir}/%{name}/lockfile
546 %attr(755,root,root) %{_libdir}/%{name}/mask2prefix
547 %attr(755,root,root) %{_libdir}/%{name}/readlink
548 %attr(755,root,root) %{_libdir}/%{name}/save_ctxinfo
549 %attr(755,root,root) %{_libdir}/%{name}/secure-mount
550 %attr(755,root,root) %{_libdir}/%{name}/sigexec
551 %attr(755,root,root) %{_libdir}/%{name}/start-vservers
552 %attr(755,root,root) %{_libdir}/%{name}/vprocunhide
553 %{_libdir}/%{name}/vserver.*
554 %attr(755,root,root) %{_libdir}/%{name}/vservers.grabinfo.sh
555 %attr(755,root,root) %{_libdir}/%{name}/vshelper
556 %attr(755,root,root) %{_libdir}/%{name}/vshelper-sync
557 %{_mandir}/man8/chbind.8*
558 %{_mandir}/man8/chcontext.8*
559 %{_mandir}/man8/reducecap.8*
560 %{_mandir}/man8/vps.8*
561 %{_mandir}/man8/vpstree.8*
562 %{_mandir}/man8/vserver-stat.8*
563 %{_mandir}/man8/vserver.8*
564 %{_mandir}/man8/vtop.8*
565 %attr(000,root,root) %dir /vservers
566 %attr(755,root,root) %dir /vservers/.pkg
567 %dir %{_localstatedir}/run/vservers
568 %dir %{_localstatedir}/run/vservers.rev
569 %dir %{_localstatedir}/run/vshelper
570 %dir /var/cache/vservers
571
572 %files devel
573 %defattr(644,root,root,755)
574 %{?with_doc:%doc lib/apidoc/latex/refman.pdf lib/apidoc/html}
575 %attr(755,root,root) %{_libdir}/lib*.so
576 %{_libdir}/lib*.la
577 %{_includedir}/vserver*.h
578 %{_pkgconfigdir}/*.pc
579
580 %files static
581 %defattr(644,root,root,755)
582 %{_libdir}/libvserver.a
583
584 %files lib
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
587
588 %files init
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_libdir}/%{name}/vsysvwrapper
591 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vrootdevices
592 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vservers
593 %attr(754,root,root) /etc/rc.d/init.d/vprocunhide
594 %attr(754,root,root) /etc/rc.d/init.d/vrootdevices
595 %attr(754,root,root) /etc/rc.d/init.d/vservers
596
597 %files build
598 %defattr(644,root,root,755)
599 %doc contrib/yum*.patch package-management.txt
600 %dir %{_sysconfdir}/vservers/.defaults/apps/vunify
601 %dir %{_sysconfdir}/vservers/.defaults/apps/vunify/hash
602 %dir %{_sysconfdir}/vservers/.distributions
603 %dir %{_sysconfdir}/vservers/.distributions/.common
604 %dir %{_sysconfdir}/vservers/.distributions/.common/pubkeys
605 %dir %{_sysconfdir}/vservers/.distributions/pld-ac
606 %dir %{_sysconfdir}/vservers/.distributions/pld-ac/poldek
607 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vservers/.distributions/pld-ac/poldek/*.conf
608 %attr(755,root,root) %{_libdir}/%{name}/rpm-fake*
609 %dir %{_libdir}/%{name}/distributions
610 %attr(-,root,root) %{_libdir}/%{name}/distributions/defaults
611 %attr(-,root,root) %{_libdir}/%{name}/distributions/pld*
612 %dir %{_libdir}/%{name}/distributions/template
613 %attr(755,root,root) %{_libdir}/%{name}/distributions/template/init*
614 %attr(-,root,root) %{_libdir}/%{name}/distributions/redhat
615 %{_libdir}/%{name}/vserver-build.*
616 %{_libdir}/%{name}/vserver-setup.functions
617 %{_libdir}/%{name}/defaults/fstab
618 %{_libdir}/%{name}/defaults/debootstrap.uri
619 %{_libdir}/%{name}/defaults/vunify-exclude
620 %attr(755,root,root) %{_libdir}/%{name}/pkgmgmt
621 %attr(755,root,root) %{_libdir}/%{name}/vapt-get-worker
622 %attr(755,root,root) %{_libdir}/%{name}/vcopy
623 %attr(755,root,root) %{_libdir}/%{name}/vhashify
624 %attr(755,root,root) %{_libdir}/%{name}/vpkg
625 %attr(755,root,root) %{_libdir}/%{name}/vpoldek-worker
626 %attr(755,root,root) %{_libdir}/%{name}/vrpm-*
627 %attr(755,root,root) %{_libdir}/%{name}/vserver-build
628 %attr(755,root,root) %{_libdir}/%{name}/vunify
629 %attr(755,root,root) %{_libdir}/%{name}/vyum-worker
630 %attr(755,root,root) %{_sbindir}/vapt-get
631 %attr(755,root,root) %{_sbindir}/vpoldek
632 %attr(755,root,root) %{_sbindir}/vrpm
633 %attr(755,root,root) %{_sbindir}/vyum
634
635 %files -n vserver-distro-fedora
636 %defattr(644,root,root,755)
637 %dir %{_sysconfdir}/vservers/.distributions/fc*
638 %dir %{_sysconfdir}/vservers/.distributions/fc*/apt
639 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vservers/.distributions/fc*/apt/sources.list
640 %{_libdir}/%{name}/distributions/fc*
641
642 %files -n vserver-distro-redhat
643 %defattr(644,root,root,755)
644 %dir %{_sysconfdir}/vservers/.distributions/rh*
645 %dir %{_sysconfdir}/vservers/.distributions/rh*/apt
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vservers/.distributions/rh*/apt/sources.list
647 %{_libdir}/%{name}/distributions/rh*
648
649 %files -n vserver-distro-suse
650 %defattr(644,root,root,755)
651 %dir %{_sysconfdir}/vservers/.distributions/suse*
652 %dir %{_sysconfdir}/vservers/.distributions/suse*/apt
653 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vservers/.distributions/suse*/apt/sources.list
654 %{_libdir}/%{name}/distributions/suse*
655
656 %files -n vserver-distro-centos
657 %defattr(644,root,root,755)
658 %{_libdir}/util-vserver/distributions/centos42
659
660 %files legacy
661 %defattr(644,root,root,755)
662 %dir %{_sysconfdir}/vservices
663 %{_sysconfdir}/vservices/*
664 %dir %{_libdir}/%{name}/legacy
665 %attr(755,root,root) %{_libdir}/%{name}/legacy/*
666 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vservers-legacy
667 %attr(754,root,root) /etc/rc.d/init.d/v_*
668 %attr(754,root,root) /etc/rc.d/init.d/rebootmgr
669 %attr(754,root,root) /etc/rc.d/init.d/vservers-legacy
670 %attr(755,root,root) %{_sbindir}/vserver-copy
671 %{_mandir}/man8/distrib-info.8*
672 %{_mandir}/man8/rebootmgr.8*
673 %{_mandir}/man8/vserver-copy.8*
This page took 0.135086 seconds and 4 git commands to generate.