]> git.pld-linux.org Git - packages/util-vserver.git/blob - util-vserver.spec
- rel 8
[packages/util-vserver.git] / util-vserver.spec
1 # TODO
2 # - somewhy empty /var/cache/vservers is needed when building pld vserver
3 # - make build create /dev/std{in,out,err} links
4 #
5 # m68k and mips are the only not supported archs
6 #
7 # Conditional build:
8 %bcond_without  dietlibc        # don't use dietlibc (ask for troubles)
9 %bcond_without  doc             # don't build documentation which needed LaTeX
10 %bcond_without  no_dynamic_context      # disable enforcement of disabled dynamic context
11 %bcond_with     xalan           # use the xalan xslt processor
12 #
13 %define _vproc_version 0.01
14 # diet compile fails with ccache in %{__cc}
15 %undefine       with_ccache
16 #
17 Summary:        Linux virtual server utilities
18 Summary(pl):    Narzêdzia dla linuksowych serwerów wirtualnych
19 Name:           util-vserver
20 Version:        0.30.210
21 Release:        8
22 License:        GPL
23 Group:          Applications/System
24 Source0:        http://www.13thfloor.at/~ensc/util-vserver/files/alpha/%{name}-%{version}.tar.bz2
25 # Source0-md5:  1e8fff7cb6246d21ed029f082123019b
26 Source1:        vprocunhide.init
27 Source2:        vservers.init
28 Source3:        vservers-legacy.init
29 Source4:        rebootmgr.init
30 Source5:        vservers.sysconfig
31 Source6:        vservers-legacy.sysconfig
32 Source7:        vrootdevices.init
33 Source8:        vrootdevices.sysconfig
34 # A bit of documentation explaining package management
35 # http://www.paul.sladen.org/vserver/archives/200505/0078.html
36 Source9:        %{name}-pkgmgmt.txt
37 Source10:       %{name}-initpost.sh
38 Source11:       http://www.13thfloor.at/vserver/s_release/v1.2.10/vproc-%{_vproc_version}.tar.bz2
39 # Source11-md5: 1d030717bdbc958ea4b35fd2410dad85
40 Patch0:         %{name}-vsysvwrapper.patch
41 Patch1:         %{name}-pld.patch
42 Patch2:         %{name}-vrpm.patch
43 Patch3:         %{name}-include.patch
44 Patch4:         %{name}-m4-diet.patch
45 Patch5:         %{name}-cpuset.patch
46 Patch6:         %{name}-build-umask.patch
47 Patch7:         %{name}-utmpx.patch
48 Patch8:         %{name}-vprocunhide.patch
49 Patch9:         %{name}-dev.patch
50 Patch10:        %{name}-no-dynamic-ctx.patch
51 Patch11:        %{name}-more-ip.patch
52 Patch12:        http://daniel.hozac.com/vserver/util-vserver/util-vserver-0.30.210-namespace-cleanup.patch
53 Patch13:        http://daniel.hozac.com/vserver/util-vserver/util-vserver-0.30.210-delete.patch
54 URL:            http://savannah.nongnu.org/projects/util-vserver/
55 BuildRequires:  autoconf
56 BuildRequires:  automake >= 1.9
57 BuildRequires:  beecrypt-devel
58 %{?with_dietlibc:BuildRequires: dietlibc-static >= 2:0.29}
59 BuildRequires:  libstdc++-devel
60 BuildRequires:  libtool >= 1.5.14
61 %ifarch %{x8664}
62 BuildRequires:  sed >= 4.0
63 %endif
64 BuildRequires:  rpmbuild(macros) >= 1.268
65 %if %{with doc}
66 BuildRequires:  doxygen
67 BuildRequires:  graphviz
68 BuildRequires:  libxslt-progs
69 BuildRequires:  tetex-format-pdflatex
70 BuildRequires:  tetex-makeindex
71 # To be removed when tetex-format-pdflatex, tetex-pdftex...
72 # ...and graphviz packages get fixed
73 BuildRequires:  ghostscript
74 BuildRequires:  ghostscript-fonts-std
75 BuildRequires:  tetex-fonts-jknappen
76 BuildRequires:  tetex-metafont
77 %{?with_xalan:BuildRequires:    xalan-j}
78 %endif
79 Requires(post,preun):   /sbin/chkconfig
80 Requires:       %{name}-lib = %{version}-%{release}
81 Requires:       issue
82 Requires:       rc-scripts
83 Requires:       util-linux
84 Obsoletes:      util-vserver-core
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 # for adapter
88 %define         _usrbin         /usr/bin
89 %define         _usrsbin        /usr/sbin
90 %define         _usrlib         /usr/lib
91
92 %description
93 This package provides the components and a framework to setup virtual
94 servers. A virtual server runs inside a Linux server. It is
95 nevertheless highly independent. As such, you can run various services
96 with normal configuration. The various vservers can't interact with
97 each other and can't interact with services in the main server.
98
99 This requires a special kernel supporting the new new_s_context and
100 set_ipv4root system call.
101
102 This package contains utilities which are required to communicate with
103 the Linux-Vserver enabled kernel.
104
105 %description -l pl
106 Ten pakiet dostarcza sk³adniki i szkielet do tworzenia wirtualnych
107 serwerów. Wirtualny serwer dzia³a wewn±trz serwera linuksowego, lecz
108 jest od niego w du¿ym stopniu niezale¿ny. Jako taki mo¿e uruchamiaæ
109 ró¿ne us³ugi z normaln± konfiguracj±. Ró¿ne vserwery nie mog± wchodziæ
110 w interakcjê z innymi ani z us³ugami na g³ównym serwerze.
111
112 Wymaga to specjalnego j±dra obs³uguj±cego nowe wywo³ania systemowe
113 new_s_context i set_ipv4root.
114
115 Ten pakiet zawiera narzêdzia wymagane do komunikacji z j±drem z
116 w³±czonym mechanizmem Linux-Vserver.
117
118 %package devel
119 Summary:        Development files for Linux vserver libraries
120 Summary(pl):    Pliki programistyczne dla bibliotek linuksowego vserwera
121 Group:          Development/Libraries
122 Requires:       %{name}-lib = %{version}-%{release}
123
124 %description devel
125 This package contains the development files necessary for developing
126 programs which use vserver library.
127
128 %description devel -l pl
129 Ten pakiet zawiera pliki programistyczne konieczne do rozwijania
130 programów u¿ywaj±cych biblioteki vserver.
131
132 %package static
133 Summary:        Static vserver library
134 Summary(pl):    Biblioteka statyczna vservera
135 Group:          Development/Libraries
136 Requires:       %{name}-devel = %{version}-%{release}
137
138 %description static
139 This package contains the static version of vserver library.
140
141 %description static -l pl
142 Ten pakiet zawiera statyczn± wersjê biblioteki vservera.
143
144 %package lib
145 Summary:        Dynamic libraries for util-vserver
146 Summary(pl):    Biblioteki dynamiczne dla pakietu util-vserver
147 Group:          Libraries
148
149 %description lib
150 util-vserver provides the components and a framework to setup virtual
151 servers. A virtual server runs inside a linux server. It is
152 nevertheless highly independent. As such, you can run various services
153 pith normal configuration. The various vservers can't interact with
154 each other and can't interact with services in the main server.
155
156 This package contains the shared libraries needed by all other
157 'util-vserver' subpackages.
158
159 %description lib -l pl
160 util-vserver dostarcza sk³adniki i szkielet do tworzenia wirtualnych
161 serwerów. Wirtualny serwer dzia³a wewn±trz serwera linuksowego, lecz
162 jest od niego w du¿ym stopniu niezale¿ny. Jako taki mo¿e uruchamiaæ
163 ró¿ne us³ugi z normaln± konfiguracj±. Ró¿ne vserwery nie mog± wchodziæ
164 w interakcjê z innymi ani z us³ugami na g³ównym serwerze.
165
166 Ten pakiet zawiera biblioteki wspó³dzielone wymagane przez wszystkie
167 podpakiety util-vserver.
168
169 %package build
170 Summary:        Tools which can be used to build vservers
171 Summary(pl):    Narzêdzia do budowania vserverów
172 Group:          Applications/System
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       e2fsprogs
175 Requires:       which
176 Requires:       /etc/pld-release
177 Conflicts:      poldek < 0.18.8-10
178
179 %description build
180 util-vserver provides the components and a framework to setup virtual
181 servers. A virtual server runs inside a linux server. It is
182 nevertheless highly independent. As such, you can run various services
183 with normal configuration. The various vservers can't interact with
184 each other and can't interact with services in the main server.
185
186 This package contains utilities which assist in building Vservers.
187
188 %description build -l pl
189 util-vserver dostarcza sk³adniki i szkielet do tworzenia wirtualnych
190 serwerów. Wirtualny serwer dzia³a wewn±trz serwera linuksowego, lecz
191 jest od niego w du¿ym stopniu niezale¿ny. Jako taki mo¿e uruchamiaæ
192 ró¿ne us³ugi z normaln± konfiguracj±. Ró¿ne vserwery nie mog± wchodziæ
193 w interakcjê z innymi ani z us³ugami na g³ównym serwerze.
194
195 Ten pakiet zawiera narzêdzia pomagaj±ce przy budowaniu Vserwerów.
196
197 %package -n vserver-distro-fedora
198 Summary:        VServer build templates for Fedora Core
199 Summary(pl):    Szablony do tworzenia VServerów dla dystrybucji Fedora Core
200 Group:          Applications/System
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       binutils
203 Requires:       e2fsprogs
204 Requires:       rpm
205 Requires:       tar
206 Requires:       wget
207
208 %description -n vserver-distro-fedora
209 VServer build templates for Fedora Core 1,2,3,4.
210
211 %description -n vserver-distro-fedora -l pl
212 Szablony do tworzenia VServerów dla dystrybucji Fedora Core 1,2,3,4.
213
214 %package -n vserver-distro-redhat
215 Summary:        VServer build template for Red Hat Linux 9
216 Summary(pl):    Szablon do tworzenia VServerów dla dystrybucji Red Hat Linux 9
217 Group:          Applications/System
218 Requires:       %{name} = %{version}-%{release}
219 Requires:       binutils
220 Requires:       e2fsprogs
221 Requires:       rpm
222 Requires:       tar
223 Requires:       wget
224
225 %description -n vserver-distro-redhat
226 VServer build template for RedHat Linux 9.
227
228 %description -n vserver-distro-redhat -l pl
229 Szablon do tworzenia VServerów dla dystrybucji Red Hat Linux 9.
230
231 %package -n vserver-distro-suse
232 Summary:        VServer build template for SuSE 9.1
233 Summary(pl):    Szablon do tworzenia VServerów dla dystrybucji SuSE 9.1
234 Group:          Applications/System
235 Requires:       %{name} = %{version}-%{release}
236 Requires:       binutils
237 Requires:       e2fsprogs
238 Requires:       rpm
239 Requires:       tar
240 Requires:       wget
241
242 %description -n vserver-distro-suse
243 VServer build template for SuSE Linux 9.1.
244
245 %description -n vserver-distro-suse -l pl
246 Szablon do tworzenia VServerów dla dystrybucji SuSE 9.1.
247
248 %package -n vserver-distro-centos
249 Summary:        VServer build template for CentOS 4.2
250 Summary(pl):    Szablon budowania VServera dla CentOS 4.2
251 Group:          Applications/System
252 Requires:       util-vserver-build
253 Requires:       yum
254
255 %description -n vserver-distro-centos
256 VServer build template for CentOS 4.2.
257
258 %description -n vserver-distro-centos -l pl
259 Szablon budowania VServera dla CentOS 4.2.
260
261 %package init
262 Summary:        initscripts for vserver
263 Summary(pl):    Skrypty inicjalizuj±ce dla vserwera
264 Group:          Applications/System
265 Requires(post,preun):   /sbin/chkconfig
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       diffutils
268 Requires:       make
269 Requires:       rc-scripts
270
271 %description init
272 util-vserver provides the components and a framework to setup virtual
273 servers. A virtual server runs inside a linux server. It is
274 nevertheless highly independent. As such, you can run various services
275 with normal configuration. The various vservers can't interact with
276 each other and can't interact with services in the main server.
277
278 This package contains the SysV initscripts which start and stop
279 Vservers and related tools.
280
281 %description init -l pl
282 util-vserver dostarcza sk³adniki i szkielet do tworzenia wirtualnych
283 serwerów. Wirtualny serwer dzia³a wewn±trz serwera linuksowego, lecz
284 jest od niego w du¿ym stopniu niezale¿ny. Jako taki mo¿e uruchamiaæ
285 ró¿ne us³ugi z normaln± konfiguracj±. Ró¿ne vserwery nie mog± wchodziæ
286 w interakcjê z innymi ani z us³ugami na g³ównym serwerze.
287
288 Ten pakiet zawiera skrypty inicjalizuj±ce SysV uruchamiaj±ce i
289 zatrzymuj±ce Vserwery oraz powi±zane narzêdzia.
290
291 %package legacy
292 Summary:        Legacy utilities for util-vserver
293 Summary(pl):    Stare narzêdzia dla util-vserver
294 Group:          Applications/System
295 Requires(post,preun):   /sbin/chkconfig
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       rc-scripts
298
299 %description legacy
300 util-vserver provides the components and a framework to setup virtual
301 servers. A virtual server runs inside a linux server. It is
302 nevertheless highly independent. As such, you can run various services
303 with normal configuration. The various vservers can't interact with
304 each other and can't interact with services in the main server.
305
306 This package contains the tools which are needed to work with Vservers
307 having an old-style configuration.
308
309 %description legacy -l pl
310 util-vserver dostarcza sk³adniki i szkielet do tworzenia wirtualnych
311 serwerów. Wirtualny serwer dzia³a wewn±trz serwera linuksowego, lecz
312 jest od niego w du¿ym stopniu niezale¿ny. Jako taki mo¿e uruchamiaæ
313 ró¿ne us³ugi z normaln± konfiguracj±. Ró¿ne vserwery nie mog± wchodziæ
314 w interakcjê z innymi ani z us³ugami na g³ównym serwerze.
315
316 Ten pakiet zawiera narzêdzia potrzebne do pracy z Vserwerami maj±cymi
317 konfiguracjê w starym stylu.
318
319 %prep
320 %setup -q -a11
321 %patch0 -p1
322 %patch1 -p1
323 %patch2 -p1
324 %patch3 -p1
325 %patch4 -p1
326 %patch5 -p1
327 %patch6 -p1
328 %patch7 -p1
329 %patch8 -p1
330 %patch9 -p1
331 %{?with_no_dynamic_context:%patch10 -p1}
332 %patch11 -p1
333 %patch12 -p1
334 %patch13 -p1
335
336 install %{SOURCE9} package-management.txt
337
338 cp -a compat.h vserver-compat.h
339
340 %build
341 %if %{with dietlibc}
342 CFLAGS="%{rpmcflags} -D__GLIBC__"
343 %endif
344 %{__aclocal} -I m4
345 %{__automake}
346 %{__autoconf}
347 %configure \
348         --with-initrddir=/etc/rc.d/init.d \
349         --enable-release \
350         --enable-apis=NOLEGACY \
351         %{?with_dietlibc:--enable-dietlibc} \
352         %{!?with_dietlibc:--disable-dietlibc} \
353         MKTEMP=/bin/mktemp \
354         MOUNT=/bin/mount \
355         PS=/bin/ps \
356         UMOUNT=/bin/umount \
357         IP=/sbin/ip \
358         IPTABLES=%{_usrsbin}/iptables \
359         MODPROBE=/sbin/modprobe \
360         NAMEIF=/sbin/nameif \
361         RMMOD=/sbin/rmmod \
362         VCONFIG=/sbin/vconfig \
363         WGET=%{_usrbin}/wget \
364
365 %{__make} all
366 %{?with_doc:%{__make} doc}
367
368 %{__make} -C vproc-%{_vproc_version} \
369         CC="%{__cc}" \
370         CFLAGS="%{rpmcflags}"
371
372 %install
373 rm -rf $RPM_BUILD_ROOT
374 install -d $RPM_BUILD_ROOT{/vservers,/etc/{sysconfig,rc.d/init.d},/dev/pts} \
375         $RPM_BUILD_ROOT{%{_sysconfdir}/vservices,/vservers/.pkg}
376
377 %{__make} install install-distribution \
378         DESTDIR=$RPM_BUILD_ROOT
379
380 cp -a vserver-compat.h $RPM_BUILD_ROOT%{_includedir}
381
382 chmod -R +rX $RPM_BUILD_ROOT%{_libdir}/%{name}/distributions/*
383
384 ln -s /vservers $RPM_BUILD_ROOT%{_sysconfdir}/vservers/vdirbase
385 ln -s %{_localstatedir}/run/vservers.rev $RPM_BUILD_ROOT%{_sysconfdir}/vservers/run.rev
386
387 for i in $RPM_BUILD_ROOT/etc/rc.d/init.d/v_* ; do
388         s=`basename $i | sed s/v_//`
389         cat >$RPM_BUILD_ROOT%{_sysconfdir}/vservices/$s << EOF
390 # IP addresses/interfaces to bound $s service to
391 #IP=10.0.0.1
392 #IP=eth0
393 EOF
394 done
395
396 sed 's|%{_usrlib}/util-vserver|%{_libdir}/%{name}|g' %{SOURCE1} > \
397         $RPM_BUILD_ROOT/etc/rc.d/init.d/vprocunhide
398 sed 's|%{_usrlib}/util-vserver|%{_libdir}/%{name}|g' %{SOURCE2} > \
399         $RPM_BUILD_ROOT/etc/rc.d/init.d/vservers
400 sed 's|%{_usrlib}/util-vserver|%{_libdir}/%{name}|g' %{SOURCE3} > \
401         $RPM_BUILD_ROOT/etc/rc.d/init.d/vservers-legacy
402 sed 's|%{_usrlib}/util-vserver|%{_libdir}/%{name}|g' %{SOURCE4} > \
403         $RPM_BUILD_ROOT/etc/rc.d/init.d/rebootmgr
404 sed 's|%{_usrlib}/util-vserver|%{_libdir}/%{name}|g' %{SOURCE5} > \
405         $RPM_BUILD_ROOT/etc/sysconfig/vservers
406
407 install %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/vservers-legacy
408
409 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/vrootdevices
410 install %{SOURCE8} $RPM_BUILD_ROOT/etc/sysconfig/vrootdevices
411 install %{SOURCE10} $RPM_BUILD_ROOT%{_libdir}/%{name}/distributions/pld-ac/initpost
412 install vproc-%{_vproc_version}/vproc $RPM_BUILD_ROOT%{_sbindir}
413
414 ln -sf null $RPM_BUILD_ROOT/dev/initctl
415
416 %ifarch %{x8664}
417 sed -i 's/^glibc$/glibc64/' $RPM_BUILD_ROOT%{_libdir}/%{name}/distributions/pld-ac/pkgs/01
418 sed -i 's/glibc\-\[0\-9\]\*\.rpm/glibc64\-\[0\-9\]\*\.rpm/' $RPM_BUILD_ROOT%{_libdir}/%{name}/distributions/pld-ac/rpmlist.d/00.lst
419 %endif
420
421 # baggins check this: needed but seems unused
422 install -d $RPM_BUILD_ROOT/var/cache/vservers
423
424 %clean
425 rm -rf $RPM_BUILD_ROOT
426
427 %post
428 %{_sbindir}/setattr --barrier /vservers || :
429
430 %post   lib -p /sbin/ldconfig
431 %postun lib -p /sbin/ldconfig
432
433 %post init
434 /sbin/chkconfig --add vrootdevices
435 /sbin/chkconfig --add vprocunhide
436 /sbin/chkconfig --add vservers
437 if [ ! -f /var/lock/subsys/vrootdevices ]; then
438         echo "Type \"/sbin/service vrootdevices start\" to assign virtual root devices" 1>&2
439 fi
440 if [ ! -f /var/lock/subsys/vprocunhide ]; then
441         echo "Type \"/sbin/service vprocunhide start\" to set /proc visibility for vservers" 1>&2
442 fi
443 if [ ! -f /var/lock/subsys/vservers ]; then
444         echo "Type \"/sbin/service vservers start\" to start vservers" 1>&2
445 fi
446
447 %preun init
448 if [ "$1" = "0" ]; then
449         %service vservers stop
450         %service vprocunhide stop
451         %service vrootdevices stop
452         /sbin/chkconfig --del vservers
453         /sbin/chkconfig --del vprocunhide
454         /sbin/chkconfig --del vrootdevices
455 fi
456
457 %post legacy
458 /sbin/chkconfig --add rebootmgr
459 /sbin/chkconfig --add vservers-legacy
460 if [ ! -f /var/lock/subsys/rebootmgr ] ; then
461         echo "Type \"/sbin/service rebootmgr start\" to start reboot manager for legacy vservers" 1>&2
462 fi
463 if [ ! -f /var/lock/subsys/vservers-legacy ] ; then
464         echo "Type \"/sbin/service vservers-legacy start\" to start legacy vservers" 1>&2
465 fi
466
467 %preun legacy
468 if [ "$1" = "0" ]; then
469         %service rebootmgr stop
470         %service vservers-legacy stop
471         /sbin/chkconfig --del rebootmgr
472         /sbin/chkconfig --del vservers-legacy
473 fi
474
475 %triggerpostun build -- %{name}-build < 0.30.210-5.2
476 if [ -f /etc/vservers/.distributions/pld2.0/poldek/poldek.conf.rpmsave ]; then
477         mv -f /etc/vservers/.distributions/{pld2.0,pld-ac}/poldek/poldek.conf.rpmsave
478 fi
479
480 # kill old vserver specific package ignores which are no longer needed
481 l=`egrep '^ignore.*(basesystem|SysVinit|rc-scripts)' /etc/vservers/*/apps/pkgmgmt/base/poldek/etc/poldek.conf -l 2>/dev/null`
482 if [ "$l" ]; then
483         %{__sed} -i -e '/^ignore/s, \(basesystem\|SysVinit\|rc-scripts\),,g' $l
484 fi
485
486 %files
487 %defattr(644,root,root,755)
488 %doc AUTHORS ChangeLog NEWS THANKS doc/intro.txt
489 %{?with_doc:%doc doc/*.html}
490 %dir %{_sysconfdir}/vservers
491 %dir %{_sysconfdir}/vservers/.defaults
492 %dir %{_sysconfdir}/vservers/.defaults/apps
493 %dir %{_sysconfdir}/vservers/.defaults/files
494 %{_sysconfdir}/vservers/.defaults/vdirbase
495 %{_sysconfdir}/vservers/.defaults/run.rev
496 %{_sysconfdir}/vservers/vdirbase
497 %{_sysconfdir}/vservers/run.rev
498 /sbin/vshelper
499 %attr(755,root,root) %{_sbindir}/chbind
500 %attr(755,root,root) %{_sbindir}/chcontext
501 %attr(755,root,root) %{_sbindir}/chxid
502 %attr(755,root,root) %{_sbindir}/exec-cd
503 %attr(755,root,root) %{_sbindir}/lsxid
504 %attr(755,root,root) %{_sbindir}/reducecap
505 %attr(755,root,root) %{_sbindir}/setattr
506 %attr(755,root,root) %{_sbindir}/showattr
507 %attr(755,root,root) %{_sbindir}/vattribute
508 %attr(755,root,root) %{_sbindir}/vcontext
509 %attr(755,root,root) %{_sbindir}/vdlimit
510 %attr(755,root,root) %{_sbindir}/vnamespace
511 %attr(755,root,root) %{_sbindir}/vkill
512 %attr(755,root,root) %{_sbindir}/vlimit
513 %attr(755,root,root) %{_sbindir}/vdu
514 %attr(755,root,root) %{_sbindir}/vproc
515 %attr(755,root,root) %{_sbindir}/vps
516 %attr(755,root,root) %{_sbindir}/vpstree
517 %attr(755,root,root) %{_sbindir}/vrsetup
518 %attr(755,root,root) %{_sbindir}/vsched
519 %attr(755,root,root) %{_sbindir}/vserver
520 %attr(755,root,root) %{_sbindir}/vserver-info
521 %attr(755,root,root) %{_sbindir}/vserver-stat
522 %attr(755,root,root) %{_sbindir}/vsomething
523 %attr(755,root,root) %{_sbindir}/vtop
524 %attr(755,root,root) %{_sbindir}/vuname
525 %attr(755,root,root) %{_sbindir}/vwait
526 %dir %{_libdir}/%{name}
527 %dir %{_libdir}/%{name}/defaults
528 %{_libdir}/%{name}/FEATURES.txt
529 %{_libdir}/%{name}/util-vserver-vars
530 %{_libdir}/%{name}/defaults/*
531 %attr(755,root,root) %{_libdir}/%{name}/capchroot
532 %attr(755,root,root) %{_libdir}/%{name}/chain-echo
533 %attr(755,root,root) %{_libdir}/%{name}/check-unixfile
534 %attr(755,root,root) %{_libdir}/%{name}/chcontext-compat
535 %attr(755,root,root) %{_libdir}/%{name}/chroot-sh
536 %attr(755,root,root) %{_libdir}/%{name}/exec-ulimit
537 %attr(755,root,root) %{_libdir}/%{name}/fakerunlevel
538 %attr(755,root,root) %{_libdir}/%{name}/filetime
539 %{_libdir}/%{name}/functions
540 %attr(755,root,root) %{_libdir}/%{name}/keep-ctx-alive
541 %attr(755,root,root) %{_libdir}/%{name}/lockfile
542 %attr(755,root,root) %{_libdir}/%{name}/mask2prefix
543 %attr(755,root,root) %{_libdir}/%{name}/readlink
544 %attr(755,root,root) %{_libdir}/%{name}/save_ctxinfo
545 %attr(755,root,root) %{_libdir}/%{name}/secure-mount
546 %attr(755,root,root) %{_libdir}/%{name}/sigexec
547 %attr(755,root,root) %{_libdir}/%{name}/start-vservers
548 %attr(755,root,root) %{_libdir}/%{name}/vprocunhide
549 %{_libdir}/%{name}/vserver.*
550 %attr(755,root,root) %{_libdir}/%{name}/vservers.grabinfo.sh
551 %attr(755,root,root) %{_libdir}/%{name}/vshelper
552 %attr(755,root,root) %{_libdir}/%{name}/vshelper-sync
553 %{_mandir}/man8/chbind.8*
554 %{_mandir}/man8/chcontext.8*
555 %{_mandir}/man8/reducecap.8*
556 %{_mandir}/man8/vps.8*
557 %{_mandir}/man8/vpstree.8*
558 %{_mandir}/man8/vserver-stat.8*
559 %{_mandir}/man8/vserver.8*
560 %{_mandir}/man8/vtop.8*
561 %attr(000,root,root) %dir /vservers
562 %attr(755,root,root) %dir /vservers/.pkg
563 %dir %{_localstatedir}/run/vservers
564 %dir %{_localstatedir}/run/vservers.rev
565 %dir %{_localstatedir}/run/vshelper
566 %dir /var/cache/vservers
567
568 %files devel
569 %defattr(644,root,root,755)
570 %{?with_doc:%doc lib/apidoc/latex/refman.pdf lib/apidoc/html}
571 %attr(755,root,root) %{_libdir}/lib*.so
572 %{_libdir}/lib*.la
573 %{_includedir}/vserver*.h
574 %{_pkgconfigdir}/*.pc
575
576 %files static
577 %defattr(644,root,root,755)
578 %{_libdir}/libvserver.a
579
580 %files lib
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
583
584 %files init
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_libdir}/%{name}/vsysvwrapper
587 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vrootdevices
588 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vservers
589 %attr(754,root,root) /etc/rc.d/init.d/vprocunhide
590 %attr(754,root,root) /etc/rc.d/init.d/vrootdevices
591 %attr(754,root,root) /etc/rc.d/init.d/vservers
592
593 %files build
594 %defattr(644,root,root,755)
595 %doc contrib/yum*.patch package-management.txt
596 %dir %{_sysconfdir}/vservers/.defaults/apps/vunify
597 %dir %{_sysconfdir}/vservers/.defaults/apps/vunify/hash
598 %dir %{_sysconfdir}/vservers/.distributions
599 %dir %{_sysconfdir}/vservers/.distributions/.common
600 %dir %{_sysconfdir}/vservers/.distributions/.common/pubkeys
601 %dir %{_sysconfdir}/vservers/.distributions/pld-ac
602 %dir %{_sysconfdir}/vservers/.distributions/pld-ac/poldek
603 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vservers/.distributions/pld-ac/poldek/*.conf
604 %attr(755,root,root) %{_libdir}/%{name}/rpm-fake*
605 %dir %{_libdir}/%{name}/distributions
606 %attr(-,root,root) %{_libdir}/%{name}/distributions/defaults
607 %attr(-,root,root) %{_libdir}/%{name}/distributions/pld*
608 %dir %{_libdir}/%{name}/distributions/template
609 %attr(755,root,root) %{_libdir}/%{name}/distributions/template/init*
610 %attr(-,root,root) %{_libdir}/%{name}/distributions/redhat
611 %{_libdir}/%{name}/vserver-build.*
612 %{_libdir}/%{name}/vserver-setup.functions
613 %{_libdir}/%{name}/defaults/fstab
614 %{_libdir}/%{name}/defaults/debootstrap.uri
615 %{_libdir}/%{name}/defaults/vunify-exclude
616 %attr(755,root,root) %{_libdir}/%{name}/pkgmgmt
617 %attr(755,root,root) %{_libdir}/%{name}/vapt-get-worker
618 %attr(755,root,root) %{_libdir}/%{name}/vcopy
619 %attr(755,root,root) %{_libdir}/%{name}/vhashify
620 %attr(755,root,root) %{_libdir}/%{name}/vpkg
621 %attr(755,root,root) %{_libdir}/%{name}/vpoldek-worker
622 %attr(755,root,root) %{_libdir}/%{name}/vrpm-*
623 %attr(755,root,root) %{_libdir}/%{name}/vserver-build
624 %attr(755,root,root) %{_libdir}/%{name}/vunify
625 %attr(755,root,root) %{_libdir}/%{name}/vyum-worker
626 %attr(755,root,root) %{_sbindir}/vapt-get
627 %attr(755,root,root) %{_sbindir}/vpoldek
628 %attr(755,root,root) %{_sbindir}/vrpm
629 %attr(755,root,root) %{_sbindir}/vyum
630
631 %files -n vserver-distro-fedora
632 %defattr(644,root,root,755)
633 %dir %{_sysconfdir}/vservers/.distributions/fc*
634 %dir %{_sysconfdir}/vservers/.distributions/fc*/apt
635 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vservers/.distributions/fc*/apt/sources.list
636 %{_libdir}/%{name}/distributions/fc*
637
638 %files -n vserver-distro-redhat
639 %defattr(644,root,root,755)
640 %dir %{_sysconfdir}/vservers/.distributions/rh*
641 %dir %{_sysconfdir}/vservers/.distributions/rh*/apt
642 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vservers/.distributions/rh*/apt/sources.list
643 %{_libdir}/%{name}/distributions/rh*
644
645 %files -n vserver-distro-suse
646 %defattr(644,root,root,755)
647 %dir %{_sysconfdir}/vservers/.distributions/suse*
648 %dir %{_sysconfdir}/vservers/.distributions/suse*/apt
649 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vservers/.distributions/suse*/apt/sources.list
650 %{_libdir}/%{name}/distributions/suse*
651
652 %files -n vserver-distro-centos
653 %defattr(644,root,root,755)
654 %{_libdir}/util-vserver/distributions/centos42
655
656 %files legacy
657 %defattr(644,root,root,755)
658 %dir %{_sysconfdir}/vservices
659 %{_sysconfdir}/vservices/*
660 %dir %{_libdir}/%{name}/legacy
661 %attr(755,root,root) %{_libdir}/%{name}/legacy/*
662 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/vservers-legacy
663 %attr(754,root,root) /etc/rc.d/init.d/v_*
664 %attr(754,root,root) /etc/rc.d/init.d/rebootmgr
665 %attr(754,root,root) /etc/rc.d/init.d/vservers-legacy
666 %attr(755,root,root) %{_sbindir}/vserver-copy
667 %{_mandir}/man8/distrib-info.8*
668 %{_mandir}/man8/rebootmgr.8*
669 %{_mandir}/man8/vserver-copy.8*
This page took 0.101688 seconds and 3 git commands to generate.