]> git.pld-linux.org Git - packages/util-linux.git/blob - util-linux.spec
- release 2: updated kerneli-2.4 patch
[packages/util-linux.git] / util-linux.spec
1 #
2 # Conditional build:    
3 # _without_crypto       - without kerneli cryptography
4 # _with_pivot_root
5 #
6 # TODO:
7 # - move raw to /sbin (potentially can be used before mount partitions)??
8 %define         _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
9 %define         _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
10 %if %{_kernel24}
11 %define         _kernel_series  2.4
12 %else
13 %define         _kernel_series  2.2
14 %endif
15 %define         _release        2
16
17 Summary:        Collection of basic system utilities for Linux
18 Summary(de):    Sammlung von grundlegenden Systemdienstprogrammen für Linux
19 Summary(fr):    Ensemble d'utilitaires système de base pour Linux
20 Summary(pl):    Zbiór podstawowych narzêdzi systemowych dla Linuksa
21 Summary(tr):    Temel sistem araçlarý
22 Summary(pt_BR): Coletânea de utilitários básicos de sistema para Linux
23 Summary(es):    Colectánea de utilitarios básicos de sistema para Linux
24 Name:           util-linux
25 Version:        2.11l
26 Release:        %{_release}
27 License:        Distributable
28 Group:          Applications/System
29 Group(de):      Applikationen/System
30 Group(pl):      Aplikacje/System
31 Source0:        ftp://ftp.win.tue.nl/pub/linux-local/utils/util-linux/%{name}-%{version}.tar.gz
32 Source1:        %{name}-non-english-man-pages.tar.bz2
33 Source2:        login.pamd
34 Source3:        rawdevices-init
35 Source4:        rawdevices-sysconfig
36 Patch0:         %{name}-MCONFIG.patch
37 Patch1:         %{name}-fdisk.patch
38 Patch2:         %{name}-utmpx.patch
39 Patch3:         %{name}-fhs.patch
40 Patch4:         %{name}-login.patch
41 Patch5:         %{name}-kerneli.patch
42 Patch6:         %{name}-info.patch
43 Patch7:         %{name}-fdisk2.patch
44 Patch8:         ftp://ftp.linuxnfs.sourceforge.org:/pub/nfs/%{name}-2.10m-mount-compat.patch
45 Patch9:         %{name}-syscall.patch
46 Patch10:        %{name}-raw.patch
47 Patch11:        %{name}-gecos.patch
48 Patch12:        %{name}-glibc.patch
49 Patch13:        %{name}-s390.patch
50 Patch14:        %{name}-kerneli-2.4.patch
51 Patch15:        %{name}-qnx4.patch
52 Patch16:        %{name}-losetup-getpass.patch
53 Patch17:        %{name}-login-problems.patch
54 BuildRequires:  pam-devel >= 0.66
55 BuildRequires:  ncurses-devel >= 5.0
56 BuildRequires:  gettext-devel
57 BuildRequires:  texinfo
58 %if %{?BOOT:1}%{!?BOOT:0}
59 BuildRequires:  glibc-static
60 %endif
61 Requires:       pam >= 0.66
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63 Obsoletes:      util-linux-suids
64
65 %define         debugcflags     -O1 -g
66
67 %description
68 util-linux contains a large variety of low-level system utilities
69 necessary for a functional Linux system. This includes, among other
70 things, configuration tools such as fdisk and system programs such as
71 logger.
72
73 %description -l de
74 util-linux enthält eine große Anzahl an
75 low-level-Systemdienstprogrammen, die für ein funktionierendes
76 Linux-System erforderlich sind. Dazu gehören Konfigurationstools wie
77 'fdisk' und Systemprogramme wie 'logger'.
78
79 %description -l fr
80 util-linux contient une grande variété d'utilitaire système bas niveau
81 nécessaires au fonctionnement d'un système Linux. Cela comprend, entre
82 autres, les outils de configuration comme fdisk et des programmes
83 systèmes comme logger.
84
85 %description -l pl
86 Util-linux zawiera wiele ró¿nych, niskopoziomowych narzêdzi
87 systemowych niezbêdnych do prawid³owego dzia³ania Linuksa. W pakiecie
88 znajduj± siê miêdzy innymi, narzêdzia konfiguracyjne takie jak fdisk i
89 programy systemowe takie jak logger.
90
91 %description -l tr
92 þlevsel durumdaki bir Linux sistemi için gerekli birçok alt düzey
93 sistem araçlarýný içerir. Bunlar arasýnda fdisk gibi yapýlandýrma
94 uygulamalarý ve logger gibi sistem programlarý sayýlabilir.
95
96 %description -l pt_BR
97 util-Linux contém uma grande variedade de utilitários de sistema
98 de baixo-nível necessários para um sistema Linux funcional. Isso
99 inclui, entre outras coisas, ferramentas de configuração como fdisk
100 e programas de sistema como login.
101
102 %description -l es
103 util-Linux contiene una gran variedad de utilitarios de sistema de
104 bajo nivel necesarios a un sistema Linux funcional. Esto incluye,
105 entre otras cosas, herramientas de configuración como fdisk y
106 programas de sistema como login.
107
108 %package -n losetup
109 Summary:        Programs for setting up and configuring loopback devices
110 Summary(de):    Programme zum Einrichten und Konfigurieren von Loopback-Geräten
111 Summary(fr):    Programmes pour mettre en place et configurer les loopback
112 Summary(pl):    Program do konfiguracji urz±dzenia blokowego loopback
113 Summary(tr):    Yerel-çevrim aygýtlarýnýn kurulmasý ve ayarlanmasý için programlar
114 Group:          Applications/System
115 Group(de):      Applikationen/System
116 Group(pl):      Aplikacje/System
117 Release:        %{_release}@%{_kernel_series}
118 %if %{_kernel24}
119 Conflicts:      kernel < 2.3.0
120 %else
121 Conflicts:      kernel >= 2.3.0
122 %endif
123
124 %description -n losetup
125 Linux supports a special block device called the loopback device,
126 which maps a normal file onto a virtual block device. This package
127 contains programs for setting up and removing the mapping between
128 files and loopback devices.
129
130 Block loopback devices should not be confused with the networking
131 loopback device, which is configured with the normal ifconfig command.
132
133 %description -n losetup -l de
134 Linux unterstützt ein spezielles Blockgerät, das sogenannte Loopback,
135 das eine normale Datei auf ein virtuelles Blockgerät abbildet. Das
136 Paket enthält Programme zum Einrichten und Entfernen der Zuordnung
137 zwischen Dateien und Loopback-Geräten.
138
139 %description -n losetup -l fr
140 Linux gère un périphérique bloc spécial appelé « loopback », qui
141 correspond à un fichier normal sur un périphérique bloc virtuel. Ce
142 paquetage contient les programmes pour configurer et supprimer la
143 correspondance entre les fichiers et les périphériques loopback.
144
145 Les périphériques bloc loopback ne doivent pas être confondus avec le
146 périphérique loopback du réseau, configuré avec la commande ifconfig
147 normale.
148
149 %description -n losetup -l pl
150 Linux ma wsparcie dla specjalnego urz±dzenia blokowego loopback, które
151 mapuje normalny plik w wirtualne urz±dzenie blokowe. Pakiet ten
152 zawiera program przy pomocy którego bêdziesz móg³ wykorzystaæ to
153 urz±dzenie.
154
155 Urz±dzenie blokowe loopback nie powinno byæ mylone z sieciowym
156 interfejsem loopback, który jest konfigurowany przy pomocy polecenia
157 ifconfig.
158
159 %description -n losetup -l tr
160 Linux özel bir blok aygýt olan yerel-çevrim aygýtýný (loopback device)
161 destekler. Bu aygýt normal bir dosyanýn sanal bir blok aygýtý üzerine
162 haritasýný çýkarýr. Bu paket, dosyalar ve yerel-çevrim aygýtlarý
163 arasýndaki haritalama iþleminin kurulmasý ve kaldýrýlmasý için
164 programlar içerir. Blok yerel-çevrim aygýtý ifconfig komutu ile
165 yapýlandýrýlan að yerel-çevrim aygýtý ile karýþtýrýlmamalýdýr.
166
167 %package -n mount
168 Summary:        Programs for mounting and unmounting filesystems
169 Summary(de):    Programme zum Montieren und Abmontieren von Dateisystemen
170 Summary(fr):    Programme pour monter et démonter des systèmes de fichiers.
171 Summary(pl):    Programy do montowania i odmontowywania systemu plików
172 Summary(tr):    Dosya sistemlerini baðlamak ve çözmek için programlar
173 Group:          Applications/System
174 Group(de):      Applikationen/System
175 Group(pl):      Aplikacje/System
176 Release:        %{_release}@%{_kernel_series}
177 %if %{_kernel24}
178 Conflicts:      kernel < 2.3.0
179 %else
180 Conflicts:      kernel >= 2.3.0
181 %endif
182
183 %description -n mount
184 Mount is used for adding new filesystems, both local and networked, to
185 your current directory structure. The filesystems must already exist
186 for this to work. It can also be used to change the access types the
187 kernel uses for already-mounted filesystems.
188
189 This package is critical for the functionality of your system.
190
191 %description -n mount -l de
192 Mount wird zum Hinzufügen neuer Dateisysteme (lokal und im Netzwerk)
193 zu Ihrer aktuellen Verzeichnisstruktur verwendet. Die Dateisysteme
194 müssen bereits existieren. Außerdem können die Zugriffstypen geändert
195 werden, die der Kernel für bereits montierte Dateisysteme verwendet.
196
197 Dieses Paket ist für Ihr System unbedingt erforderlich.
198
199 %description -n mount -l fr
200 mount sert à ajouter de nouveaux systèmes de fichiers, locaux ou
201 réseaux, à votre structure de répertoire. Les systèmes de fichiers
202 doivent déjà exister pour que cela fonctionne. Il peut aussi servir à
203 changer les types d'accès pour les systèmes de fichiers déjà montés.
204
205 Ce paquetage est critique pour le fonctionnement de votre système.
206
207 %description -n mount -l pl
208 Program mount jest u¿ywany przez system do montowania systemu plików,
209 zarówno lokalnych jak i sieciowych (np. NFS).
210
211 Pakiet ten jest niezbêdny do prawid³owej pracy twojego Linuksa.
212
213 %description -n mount -l tr
214 mount, hem yerel hem de að dosya sistemlerinin dizin yapýsýna
215 eklenmesi için kullanýlýr. Bunun için baðlanacak dosya sisteminin
216 önceden hazýrlanmýþ olmasý gerekir. Ayný zamanda çekirdeðin baðlanmýþ
217 dosya sistemlerine eriþimini deðiþtirmek için de kullanýlýr. Bu paket
218 sisteminizin iþlevselliði açýsýndan kritiktir.
219
220 %package chkdupexe
221 Summary:        chkdupexe - find duplicate executables
222 Summary(pl):    chkdupexe odszukuje powtarzaj±ce siê pliki uruchamialne
223 Group:          Applications/System
224 Group(de):      Applikationen/System
225 Group(pl):      Aplikacje/System
226
227 %description chkdupexe
228 chkdupexe will scan the union of $PATH and a hardcoded list of common
229 locations for binaries. It will report dangling symlinks and
230 duplicately-named binaries.
231
232 %description chkdupexe -l pl
233 chkdupexe przeszukuje katalogi z $PATH oraz inne powszechnie znane
234 katalogi z plikami uruchamialnymi i informuje o powtarzaj±cych siê
235 plikach w ró¿nych katalogach.
236
237 %package -n tunelp
238 Summary:        Configures kernel parallel port driver
239 Summary(de):    Konfiguriert den Kerneltreiber für den parallelen Port
240 Summary(fr):    Configure le pilote du port parallèle dans le noyau
241 Summary(pl):    Program do konfigurowania sterownika portu równoleg³ego
242 Summary(tr):    Çekirdeðin paralel baðlantý noktasý sürücüsünü ayarlar
243 Group:          Applications/System
244 Group(de):      Applikationen/System
245 Group(pl):      Aplikacje/System
246
247 %description -n tunelp
248 `tunelp' aids in configuring the kernel parallel port driver.
249
250 %description -n tunelp -l de
251 TUNELP hilft bei der Konfiguration des Kernel-Parallelport-Treibers.
252
253 %description -n tunelp -l fr
254 « tunelp » aide à configurer le pilote du noyau pour le port
255 parallèle.
256
257 %description -n tunelp -l pl
258 Program do konfigurowania sterownika portu równoleg³ego.
259
260 %description -n tunelp -l tr
261 Paralel baðlantý noktasý sürücüsünü ayarlar.
262
263 %package -n login
264 Summary:        login is used when signing onto a system
265 Summary(pl):    login jest u¿ywany do rozpoczêcia pracy w systemie
266 Group:          Applications/System
267 Group(de):      Applikationen/System
268 Group(pl):      Aplikacje/System
269 Obsoletes:      heimdal-login
270 Requires:       pam-pld
271
272 %description -n login
273 login is used when signing onto a system. It can also be used to
274 switch from one user to another at any time (most modern shells have
275 support for this feature built into them, however).
276
277 %description -n login -l pl
278 login jest u¿ywany do rozpoczêcia pracy w systemie. Mo¿e byæ u¿ywany
279 do prze³±czania z jednego u¿ytkownika na innego w ka¿dym momencie
280 (jednak wiêkszo¶æ nowoczesnych pow³ok ma takie funkcje wbudowane).
281
282 %package -n agetty
283 Summary:        Alternative Linux getty
284 Summary(pl):    Alternatywny getty 
285 Group:          Applications/System
286 Group(de):      Applikationen/System
287 Group(pl):      Aplikacje/System
288 Requires:       login
289
290 %description -n agetty
291 agetty is simple Linux getty with serial support.
292
293 %description -n agetty -l pl
294 agetty jest prostym linuksowym getty z obs³ug± portu szeregowego.
295
296 %package -n rawdevices
297 Summary:        Support for raw-devices
298 Summary(pl):    Obs³uga raw-device'ów
299 Group:          Applications/System
300 Group(de):      Applikationen/System
301 Group(pl):      Aplikacje/System
302 Prereq:         /sbin/chkconfig
303
304 %description -n rawdevices
305 Support for raw-devices.
306
307 %description -n rawdevices -l pl
308 Obs³uga raw-device'ów.
309
310 %if %{?BOOT:1}%{!?BOOT:0}
311 %package BOOT
312 Summary:        util-linux for bootdisk
313 Group:          Applications/System
314 Group(de):      Applikationen/System
315 Group(pl):      Aplikacje/System
316
317 %description BOOT
318 %endif
319
320 %prep
321 %setup -q -a1
322 %patch0 -p1
323 %patch1 -p1
324 %patch2 -p1
325 %patch3 -p1
326 %patch4 -p1
327 %if %{_kernel24}
328 %{!?_without_crypto:%patch14 -p1}
329 %else
330 %{!?_without_crypto:%patch5 -p1}
331 %endif
332 %patch6 -p1
333 %patch7 -p1
334 %patch8 -p1
335 %patch9 -p1
336 %patch10 -p1
337 %patch11 -p1
338 %patch12 -p1
339 %patch13 -p1
340 %patch15 -p1
341 %if !%{_kernel24}
342 %{!?_without_crypto:%patch16 -p1}
343 %endif
344 %patch17 -p1
345
346 %build
347 CFLAGS="%{rpmcflags} -I%{_includedir}/ncurses -I%{_kernelsrcdir}/include"
348 %configure2_13
349
350 %if %{?BOOT:1}%{!?BOOT:0}
351 %{__make} -C fdisk fdisk OPT="%{rpmcflags}" LDFLAGS="-static"
352 mv -f fdisk/fdisk fdisk-BOOT
353 %{__make} -C fdisk clean
354 %endif
355
356 %{__make} OPT="%{rpmcflags}" \
357         MOREHELPDIR=%{_datadir}/misc \
358         ADD_RAW="yes"
359
360 (cd sys-utils; makeinfo ipc.texi)
361
362 %install
363 rm -rf $RPM_BUILD_ROOT
364
365 %if %{?BOOT:1}%{!?BOOT:0}
366 install -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/sbin
367 install fdisk-BOOT $RPM_BUILD_ROOT%{_libdir}/bootdisk/sbin/fdisk
368 %endif
369
370 install -d $RPM_BUILD_ROOT/{bin,sbin,etc/{pam.d,logrotate,rc.d/init.d,sysconfig}} \
371         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_infodir},%{_datadir}/misc} \
372         $RPM_BUILD_ROOT{%{_examplesdir},%{_mandir}/man{1,5,6,8}}
373
374 %{__make} install \
375         DESTDIR="$RPM_BUILD_ROOT" \
376         INSTALLSUID="install -m 755" \
377         MOREHELPDIR=$RPM_BUILD_ROOT%{_datadir}/misc \
378         GETOPTDIR=$RPM_BUILD_ROOT%{_examplesdir}/getopt \
379         USRGAMESDIR=$RPM_BUILD_ROOT%{_bindir} \
380         USE_TTY_GROUP=no \
381         ADD_RAW="yes"
382
383 install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/login
384 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/rawdevices
385 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rawdevices
386
387 install -d $RPM_BUILD_ROOT/{etc/security,var/lock}
388
389 touch $RPM_BUILD_ROOT/etc/security/blacklist.login
390
391 :> $RPM_BUILD_ROOT/var/lock/wtmpxlock
392
393 ln -sf hwclock $RPM_BUILD_ROOT/sbin/clock
394 echo '.so hwclock.8' > $RPM_BUILD_ROOT%{_mandir}/man8/clock.8
395
396 ln -sf swapon $RPM_BUILD_ROOT/sbin/swapoff
397
398 for d in cs de fi fr hu it ja ko pl ; do
399     for m in man1 man5 man6 man8 ; do
400         if [ -d man/$d/$m ]; then
401             install -d $RPM_BUILD_ROOT%{_mandir}/$d/$m
402             install man/$d/$m/* $RPM_BUILD_ROOT%{_mandir}/$d/$m
403         fi
404     done
405     if [ -f $RPM_BUILD_ROOT%{_mandir}/$d/man8/hwclock.8 ]; then
406         echo '.so hwclock.8' > $RPM_BUILD_ROOT%{_mandir}/$d/man8/clock.8
407     fi
408 done
409
410 gzip -9nf */README.*
411
412 %find_lang %{name}
413
414 %clean
415 rm -rf $RPM_BUILD_ROOT
416
417 %post
418 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
419
420 %postun
421 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
422
423 %post -n rawdevices
424 /sbin/chkconfig --add rawdevices
425 if [ -f /var/lock/subsys/rawdevices ]; then
426         /etc/rc.d/init.d/rawdevices restart 1>&2
427 else
428         echo "Run \"/etc/rc.d/init.d/rawdevices start\" to start rawdevices."
429 fi
430
431 %preun -n rawdevices
432 if [ -f /var/lock/subsys/rawdevices ]; then
433         /etc/rc.d/init.d/rawdevices stop 1>&2
434 fi
435 /sbin/chkconfig --del rawdevices
436
437 %files -f %{name}.lang
438 %defattr(644,root,root,755)
439 %doc */README.*
440
441 %attr(755,root,root) /sbin/clock
442 %attr(755,root,root) /sbin/hwclock
443
444 %{_mandir}/man8/clock.8*
445 %{_mandir}/man8/hwclock.8*
446 %lang(ja) %{_mandir}/ja/man8/clock.8*
447 %lang(ja) %{_mandir}/ja/man8/hwclock.8*
448
449 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/fdprm
450
451 %attr(0755,root,root) /bin/arch
452 %attr(0755,root,root) /bin/dmesg
453 %attr(0755,root,root) /bin/kill
454 %attr(0755,root,root) /bin/more
455 %attr(0755,root,root) /sbin/blockdev
456 %attr(0755,root,root) /sbin/mkfs
457 %attr(0755,root,root) /sbin/mkswap
458 %attr(0755,root,root) /sbin/ctrlaltdel
459 %attr(0755,root,root) /sbin/elvtune
460 %attr(0755,root,root) %{_bindir}/cal
461 %attr(0755,root,root) %{_bindir}/col
462 %attr(0755,root,root) %{_bindir}/colcrt
463 %attr(0755,root,root) %{_bindir}/colrm
464 %attr(0755,root,root) %{_bindir}/column
465 %attr(0755,root,root) %{_bindir}/ddate
466 %attr(0755,root,root) %{_bindir}/fdformat
467 %attr(0755,root,root) %{_bindir}/getopt
468 %attr(0755,root,root) %{_bindir}/hexdump
469 %attr(0755,root,root) %{_bindir}/ipcrm
470 %attr(0755,root,root) %{_bindir}/ipcs
471 %attr(0755,root,root) %{_bindir}/isosize
472 %attr(0755,root,root) %{_bindir}/logger
473 %attr(0755,root,root) %{_bindir}/look
474 %attr(0755,root,root) %{_bindir}/mcookie
475 %attr(0755,root,root) %{_bindir}/namei
476 %attr(0755,root,root) %{_bindir}/renice
477 %attr(0755,root,root) %{_bindir}/rev
478 %attr(0755,root,root) %{_bindir}/script
479 %attr(0755,root,root) %{_bindir}/setsid
480 %attr(0755,root,root) %{_bindir}/setfdprm
481 %attr(0755,root,root) %{_bindir}/setterm
482 %attr(0755,root,root) %{_bindir}/ul
483 %attr(0755,root,root) %{_bindir}/whereis
484 %attr(2755,root,tty) %{_bindir}/write
485 %attr(0755,root,root) %{_sbindir}/readprofile
486
487 %{_mandir}/man1/arch.1*
488 %{_mandir}/man1/cal.1*
489 %{_mandir}/man1/col.1*
490 %{_mandir}/man1/colcrt.1*
491 %{_mandir}/man1/colrm.1*
492 %{_mandir}/man1/column.1*
493 %{_mandir}/man1/ddate.1*
494 %{_mandir}/man1/getopt.1*
495 %{_mandir}/man1/hexdump.1*
496 %{_mandir}/man1/kill.1*
497 %{_mandir}/man1/logger.1*
498 %{_mandir}/man1/look.1*
499 %{_mandir}/man1/mcookie.1*
500 %{_mandir}/man1/more.1*
501 %{_mandir}/man1/namei.1*
502 %{_mandir}/man1/readprofile.1*
503 %{_mandir}/man1/rev.1*
504 %{_mandir}/man1/script.1*
505 %{_mandir}/man1/setterm.1*
506 %{_mandir}/man1/ul.1*
507 %{_mandir}/man1/whereis.1*
508 %{_mandir}/man1/write.1*
509
510 %{_mandir}/man8/blockdev.8*
511 %{_mandir}/man8/cytune.8*
512 %{_mandir}/man8/ctrlaltdel.8*
513 %{_mandir}/man8/dmesg.8*
514 %{_mandir}/man8/elvtune.8*
515 %{_mandir}/man8/fdformat.8*
516 %{_mandir}/man8/ipcrm.8*
517 %{_mandir}/man8/ipcs.8*
518 %{_mandir}/man8/isosize.8*
519 %{_mandir}/man8/mkswap.8*
520 %{_mandir}/man8/renice.8*
521 %{_mandir}/man8/setfdprm.8*
522 %{_mandir}/man8/setsid.8*
523
524 %lang(de) %{_mandir}/de/man1/kill.1*
525 %lang(de) %{_mandir}/de/man1/more.1*
526 %lang(de) %{_mandir}/de/man1/write.1*
527
528 %lang(fi) %{_mandir}/fi/man1/arch.1*
529 %lang(fi) %{_mandir}/fi/man1/cal.1*
530 %lang(fi) %{_mandir}/fi/man1/column.1*
531 %lang(fi) %{_mandir}/fi/man1/kill.1*
532 %lang(fi) %{_mandir}/fi/man1/more.1*
533 %lang(fi) %{_mandir}/fi/man1/whereis.1*
534 %lang(fi) %{_mandir}/fi/man1/write.1*
535
536 %lang(fr) %{_mandir}/fr/man1/arch.1*
537 %lang(fr) %{_mandir}/fr/man1/cal.1*
538 %lang(fr) %{_mandir}/fr/man1/col.1*
539 %lang(fr) %{_mandir}/fr/man1/kill.1*
540 %lang(fr) %{_mandir}/fr/man1/more.1*
541 %lang(fr) %{_mandir}/fr/man1/whereis.1*
542 %lang(fr) %{_mandir}/fr/man1/write.1*
543
544 %lang(fr) %{_mandir}/fr/man8/ctrlaltdel.8*
545 %lang(fr) %{_mandir}/fr/man8/dmesg.8*
546 %lang(fr) %{_mandir}/fr/man8/fdformat.8*
547 %lang(fr) %{_mandir}/fr/man8/ipcrm.8*
548 %lang(fr) %{_mandir}/fr/man8/ipcs.8*
549 %lang(fr) %{_mandir}/fr/man8/setsid.8*
550
551 %lang(hu) %{_mandir}/hu/man1/arch.1*
552 %lang(hu) %{_mandir}/hu/man1/cal.1*
553 %lang(hu) %{_mandir}/hu/man1/colrm.1*
554 %lang(hu) %{_mandir}/hu/man1/hexdump.1*
555 %lang(hu) %{_mandir}/hu/man1/kill.1*
556 %lang(hu) %{_mandir}/hu/man1/logger.1*
557 %lang(hu) %{_mandir}/hu/man1/more.1*
558 %lang(hu) %{_mandir}/hu/man1/setterm.1*
559 %lang(hu) %{_mandir}/hu/man1/whereis.1*
560 %lang(hu) %{_mandir}/hu/man1/write.1*
561
562 %lang(hu) %{_mandir}/hu/man8/ctrlaltdel.8*
563 %lang(hu) %{_mandir}/hu/man8/fdformat.8*
564 %lang(hu) %{_mandir}/hu/man8/mkswap.8*
565
566 %lang(it) %{_mandir}/it/man1/arch.1*
567 %lang(it) %{_mandir}/it/man1/kill.1*
568
569 %lang(it) %{_mandir}/it/man8/mkswap.8*
570 %lang(it) %{_mandir}/it/man8/setsid.8*
571
572 %lang(ja) %{_mandir}/ja/man1/arch.1*
573 %lang(ja) %{_mandir}/ja/man1/cal.1*
574 %lang(ja) %{_mandir}/ja/man1/col.1*
575 %lang(ja) %{_mandir}/ja/man1/colcrt.1*
576 %lang(ja) %{_mandir}/ja/man1/colrm.1*
577 %lang(ja) %{_mandir}/ja/man1/column.1*
578 %lang(ja) %{_mandir}/ja/man1/ddate.1*
579 %lang(ja) %{_mandir}/ja/man1/getopt.1*
580 %lang(ja) %{_mandir}/ja/man1/hexdump.1*
581 %lang(ja) %{_mandir}/ja/man1/kill.1*
582 %lang(ja) %{_mandir}/ja/man1/logger.1*
583 %lang(ja) %{_mandir}/ja/man1/look.1*
584 %lang(ja) %{_mandir}/ja/man1/mcookie.1*
585 %lang(ja) %{_mandir}/ja/man1/more.1*
586 %lang(ja) %{_mandir}/ja/man1/namei.1*
587 %lang(ja) %{_mandir}/ja/man1/readprofile.1*
588 %lang(ja) %{_mandir}/ja/man1/rev.1*
589 %lang(ja) %{_mandir}/ja/man1/script.1*
590 %lang(ja) %{_mandir}/ja/man1/setterm.1*
591 %lang(ja) %{_mandir}/ja/man1/ul.1*
592 %lang(ja) %{_mandir}/ja/man1/whereis.1*
593 %lang(ja) %{_mandir}/ja/man1/write.1*
594  
595 %lang(ja) %{_mandir}/ja/man8/blockdev.8*
596 %lang(ja) %{_mandir}/ja/man8/cytune.8*
597 %lang(ja) %{_mandir}/ja/man8/ctrlaltdel.8*
598 %lang(ja) %{_mandir}/ja/man8/dmesg.8*
599 %lang(ja) %{_mandir}/ja/man8/elvtune.8*
600 %lang(ja) %{_mandir}/ja/man8/fdformat.8*
601 %lang(ja) %{_mandir}/ja/man8/ipcrm.8*
602 %lang(ja) %{_mandir}/ja/man8/ipcs.8*
603 %lang(ja) %{_mandir}/ja/man8/isosize.8*
604 %lang(ja) %{_mandir}/ja/man8/mkswap.8*
605 %lang(ja) %{_mandir}/ja/man8/renice.8*
606 %lang(ja) %{_mandir}/ja/man8/setfdprm.8*
607 %lang(ja) %{_mandir}/ja/man8/setsid.8*
608
609 %lang(ko) %{_mandir}/ko/man1/arch.1*
610 %lang(ko) %{_mandir}/ko/man1/cal.1*
611 %lang(ko) %{_mandir}/ko/man1/col.1*
612 %lang(ko) %{_mandir}/ko/man1/colcrt.1*
613 %lang(ko) %{_mandir}/ko/man1/colrm.1*
614 %lang(ko) %{_mandir}/ko/man1/column.1*
615 %lang(ko) %{_mandir}/ko/man1/ddate.1*
616 %lang(ko) %{_mandir}/ko/man1/getopt.1*
617 %lang(ko) %{_mandir}/ko/man1/hexdump.1*
618 %lang(ko) %{_mandir}/ko/man1/kill.1*
619 %lang(ko) %{_mandir}/ko/man1/logger.1*
620 %lang(ko) %{_mandir}/ko/man1/look.1*
621 %lang(ko) %{_mandir}/ko/man1/mcookie.1*
622 %lang(ko) %{_mandir}/ko/man1/more.1*
623 %lang(ko) %{_mandir}/ko/man1/namei.1*
624 %lang(ko) %{_mandir}/ko/man1/readprofile.1*
625 %lang(ko) %{_mandir}/ko/man1/rev.1*
626 %lang(ko) %{_mandir}/ko/man1/script.1*
627 %lang(ko) %{_mandir}/ko/man1/setterm.1*
628 %lang(ko) %{_mandir}/ko/man1/ul.1*
629 %lang(ko) %{_mandir}/ko/man1/whereis.1*
630 %lang(ko) %{_mandir}/ko/man1/write.1*
631  
632 %lang(ko) %{_mandir}/ko/man8/ctrlaltdel.8*
633 %lang(ko) %{_mandir}/ko/man8/dmesg.8*
634 %lang(ko) %{_mandir}/ko/man8/fdformat.8*
635 %lang(ko) %{_mandir}/ko/man8/ipcrm.8*
636 %lang(ko) %{_mandir}/ko/man8/ipcs.8*
637 %lang(ko) %{_mandir}/ko/man8/mkswap.8*
638 %lang(ko) %{_mandir}/ko/man8/renice.8*
639 %lang(ko) %{_mandir}/ko/man8/setfdprm.8*
640 %lang(ko) %{_mandir}/ko/man8/setsid.8*
641
642 %lang(pl) %{_mandir}/pl/man1/arch.1*
643 %lang(pl) %{_mandir}/pl/man1/cal.1*
644 %lang(pl) %{_mandir}/pl/man1/col.1*
645 %lang(pl) %{_mandir}/pl/man1/colcrt.1*
646 %lang(pl) %{_mandir}/pl/man1/colrm.1*
647 %lang(pl) %{_mandir}/pl/man1/getopt.1*
648 %lang(pl) %{_mandir}/pl/man1/hexdump.1*
649 %lang(pl) %{_mandir}/pl/man1/kill.1*
650 %lang(pl) %{_mandir}/pl/man1/look.1*
651 %lang(pl) %{_mandir}/pl/man1/more.1*
652 %lang(pl) %{_mandir}/pl/man1/rev.1*
653 %lang(pl) %{_mandir}/pl/man1/script.1*
654 %lang(pl) %{_mandir}/pl/man1/setterm.1*
655 %lang(pl) %{_mandir}/pl/man1/ul.1*
656 %lang(pl) %{_mandir}/pl/man1/whereis.1*
657 %lang(pl) %{_mandir}/pl/man1/write.1*
658
659 %lang(pl) %{_mandir}/pl/man8/ctrlaltdel.8*
660 %lang(pl) %{_mandir}/pl/man8/dmesg.8*
661 %lang(pl) %{_mandir}/pl/man8/fdformat.8*
662 %lang(pl) %{_mandir}/pl/man8/ipcrm.8*
663 %lang(pl) %{_mandir}/pl/man8/ipcs.8*
664 %lang(pl) %{_mandir}/pl/man8/mkswap.8*
665 %lang(pl) %{_mandir}/pl/man8/renice.8*
666 %lang(pl) %{_mandir}/pl/man8/setfdprm.8*
667
668 %dir %{_examplesdir}/getopt
669 %attr(755,root,root) %{_examplesdir}/getopt/*
670 %{_datadir}/misc/more.help
671
672 %attr(755,root,root) /sbin/cfdisk
673 %attr(755,root,root) /sbin/fdisk
674 %attr(755,root,root) /sbin/fsck.minix
675 %attr(755,root,root) /sbin/mkfs.minix
676 %attr(755,root,root) /sbin/sfdisk
677
678 %{_mandir}/man8/cfdisk.8*
679 %{_mandir}/man8/fdisk.8*
680 %{_mandir}/man8/sfdisk.8*
681 %{_mandir}/man8/fsck.minix.8*
682 %{_mandir}/man8/mkfs.minix.8*
683 %{_mandir}/man8/mkfs.8*
684
685 %lang(fr) %{_mandir}/fr/man8/cfdisk.8*
686 %lang(fr) %{_mandir}/fr/man8/fdisk.8*
687 %lang(fr) %{_mandir}/fr/man8/sfdisk.8*
688 %lang(fr) %{_mandir}/fr/man8/mkfs.minix.8*
689 %lang(fr) %{_mandir}/fr/man8/mkfs.8*
690
691 %lang(hu) %{_mandir}/hu/man8/mkfs.8*
692
693 %lang(it) %{_mandir}/it/man8/cfdisk.8*
694 %lang(it) %{_mandir}/it/man8/fdisk.8*
695
696 %lang(ja) %{_mandir}/ja/man8/cfdisk.8*
697 %lang(ja) %{_mandir}/ja/man8/fdisk.8*
698 %lang(ja) %{_mandir}/ja/man8/sfdisk.8*
699 %lang(ja) %{_mandir}/ja/man8/fsck.minix.8*
700 %lang(ja) %{_mandir}/ja/man8/mkfs.minix.8*
701 %lang(ja) %{_mandir}/ja/man8/mkfs.8*
702
703 %lang(ko) %{_mandir}/ko/man8/fdisk.8*
704 %lang(ko) %{_mandir}/ko/man8/fsck.minix.8*
705 %lang(ko) %{_mandir}/ko/man8/mkfs.minix.8*
706 %lang(ko) %{_mandir}/ko/man8/mkfs.8*
707
708 %lang(pl) %{_mandir}/pl/man8/fdisk.8*
709 %lang(pl) %{_mandir}/pl/man8/fsck.minix.8*
710 %lang(pl) %{_mandir}/pl/man8/mkfs.minix.8*
711 %lang(pl) %{_mandir}/pl/man8/mkfs.8*
712
713 %attr(755,root,root) %{_bindir}/cytune
714
715 %ifarch %{ix86}
716 %attr(755,root,root) %{_sbindir}/ramsize
717 %attr(755,root,root) %{_sbindir}/rdev
718 %attr(755,root,root) %{_sbindir}/rootflags
719 %attr(755,root,root) %{_sbindir}/vidmode
720
721 %{_mandir}/man8/ramsize.8*
722 %{_mandir}/man8/rdev.8*
723 %{_mandir}/man8/rootflags.8*
724 %{_mandir}/man8/vidmode.8*
725
726 %lang(de) %{_mandir}/de/man8/rdev.8*
727
728 %lang(ja) %{_mandir}/ja/man8/ramsize.8*
729 %lang(ja) %{_mandir}/ja/man8/rdev.8*
730 %lang(ja) %{_mandir}/ja/man8/rootflags.8*
731 %lang(ja) %{_mandir}/ja/man8/vidmode.8*
732
733 %lang(ko) %{_mandir}/ko/man8/ramsize.8*
734 %lang(ko) %{_mandir}/ko/man8/rdev.8*
735 %lang(ko) %{_mandir}/ko/man8/rootflags.8*
736 %lang(ko) %{_mandir}/ko/man8/vidmode.8*
737
738 %lang(pl) %{_mandir}/pl/man8/ramsize.8*
739 %lang(pl) %{_mandir}/pl/man8/rdev.8*
740 %lang(pl) %{_mandir}/pl/man8/rootflags.8*
741 %lang(pl) %{_mandir}/pl/man8/vidmode.8*
742 %endif
743
744 %{_infodir}/ipc*
745
746 %ghost /var/lock/wtmpxlock
747
748 %files -n mount
749 %defattr(644,root,root,755)
750
751 %attr(4755,root,root) /bin/mount
752 %attr(4755,root,root) /bin/umount
753 %{?_with_pivot_root:%attr(755,root,root) /sbin/pivot_root}
754 %attr(755,root,root) /sbin/swapon
755 %attr(755,root,root) /sbin/swapoff
756
757 %{_mandir}/man5/fstab.5*
758 %{_mandir}/man5/nfs.5*
759
760 %{_mandir}/man8/mount.8*
761 %{_mandir}/man8/umount.8*
762 %{?_with_pivot_root:%{_mandir}/man8/pivot_root.8*}
763 %{_mandir}/man8/swapon.8*
764 %{_mandir}/man8/swapoff.8*
765
766 %lang(cs) %{_mandir}/cs/man5/fstab.5*
767
768 %lang(de) %{_mandir}/de/man5/fstab.5*
769 %lang(de) %{_mandir}/de/man5/nfs.5*
770
771 %lang(fr) %{_mandir}/fr/man5/fstab.5*
772 %lang(fr) %{_mandir}/fr/man5/nfs.5*
773
774 %lang(fr) %{_mandir}/fr/man8/mount.8*
775 %lang(fr) %{_mandir}/fr/man8/umount.8*
776
777 %lang(hu) %{_mandir}/hu/man5/fstab.5*
778
779 %lang(hu) %{_mandir}/hu/man8/mount.8*
780 %lang(hu) %{_mandir}/hu/man8/umount.8*
781
782 %lang(it) %{_mandir}/it/man5/fstab.5*
783 %lang(it) %{_mandir}/it/man5/nfs.5*
784
785 %lang(it) %{_mandir}/it/man8/mount.8*
786 %lang(it) %{_mandir}/it/man8/umount.8*
787 %lang(it) %{_mandir}/it/man8/swapon.8*
788 %lang(it) %{_mandir}/it/man8/swapoff.8*
789
790 %lang(ja) %{_mandir}/ja/man5/fstab.5*
791 %lang(ja) %{_mandir}/ja/man5/nfs.5*
792
793 %lang(ja) %{_mandir}/ja/man8/mount.8*
794 %lang(ja) %{_mandir}/ja/man8/umount.8*
795 %{?_with_pivot_root:%lang(ja) %{_mandir}/ja/man8/pivot_root.8*}
796 %lang(ja) %{_mandir}/ja/man8/swapon.8*
797 %lang(ja) %{_mandir}/ja/man8/swapoff.8*
798
799 %lang(ko) %{_mandir}/ko/man5/fstab.5*
800 %lang(ko) %{_mandir}/ko/man5/nfs.5*
801
802 %lang(ko) %{_mandir}/ko/man8/mount.8*
803 %lang(ko) %{_mandir}/ko/man8/umount.8*
804 %lang(ko) %{_mandir}/ko/man8/swapon.8*
805 %lang(ko) %{_mandir}/ko/man8/swapoff.8*
806
807 %lang(pl) %{_mandir}/pl/man5/fstab.5*
808 %lang(pl) %{_mandir}/pl/man5/nfs.5*
809
810 %lang(pl) %{_mandir}/pl/man8/mount.8*
811 %lang(pl) %{_mandir}/pl/man8/umount.8*
812 %lang(pl) %{_mandir}/pl/man8/swapon.8*
813 %lang(pl) %{_mandir}/pl/man8/swapoff.8*
814
815 %files -n losetup
816 %defattr(644,root,root,755)
817 %attr(755,root,root) /sbin/losetup
818
819 %{_mandir}/man8/losetup.8*
820 %lang(fr) %{_mandir}/fr/man8/losetup.8*
821 %lang(it) %{_mandir}/it/man8/losetup.8*
822 %lang(ja) %{_mandir}/ja/man8/losetup.8*
823 %lang(ko) %{_mandir}/ko/man8/losetup.8*
824 %lang(pl) %{_mandir}/pl/man8/losetup.8*
825
826 %files chkdupexe
827 %defattr(644,root,root,755)
828 %attr(755,root,root) %{_bindir}/chkdupexe
829
830 %{_mandir}/man1/chkdupexe.1*
831 %lang(ja) %{_mandir}/ja/man1/chkdupexe.1*
832 %lang(ko) %{_mandir}/ko/man1/chkdupexe.1*
833 %lang(pl) %{_mandir}/pl/man1/chkdupexe.1*
834
835 %files -n tunelp
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_sbindir}/tunelp
838
839 %{_mandir}/man8/tunelp.8*
840 %lang(ja) %{_mandir}/ja/man8/tunelp.8*
841 %lang(pl) %{_mandir}/pl/man8/tunelp.8*
842
843 %files -n login
844 %defattr(644,root,root,755)
845 %attr(640,root,root) %config(noreplace) %verify(not mtime size md5) /etc/pam.d/login
846 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.login
847 %attr(0755,root,root) /bin/login
848
849 %{_mandir}/man1/login.1*
850 %lang(de) %{_mandir}/de/man1/login.1*
851 %lang(hu) %{_mandir}/hu/man1/login.1*
852 %lang(ko) %{_mandir}/ko/man1/login.1*
853 %lang(pl) %{_mandir}/pl/man1/login.1*
854
855 %files -n agetty
856 %defattr(644,root,root,755)
857 %attr(0755,root,root) /sbin/agetty
858
859 %{_mandir}/man8/agetty.8*
860 %lang(ja) %{_mandir}/ja/man8/agetty.8*
861
862 %files -n rawdevices
863 %defattr(644,root,root,755)
864 %attr(0755,root,root) %{_bindir}/raw
865 %attr(0750,root,root) /etc/rc.d/init.d/rawdevices
866 %attr(0640,root,root) %config(noreplace) /etc/sysconfig/rawdevices
867
868 %{_mandir}/man8/raw.8*
869 %lang(ja) %{_mandir}/ja/man8/raw.8*
870
871 %if %{?BOOT:1}%{!?BOOT:0}
872 %files BOOT
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_libdir}/bootdisk/sbin/*
875 %endif
This page took 0.090276 seconds and 4 git commands to generate.