]> git.pld-linux.org Git - packages/util-linux.git/blob - util-linux.spec
- BOOT fix
[packages/util-linux.git] / util-linux.spec
1 #
2 # Conditional build:    
3 # _without_crypto       - without kerneli cryptography
4 # _with_pivot_root
5 #
6 # TODO:
7 # - move raw to /sbin (potentially can be used before mount partitions)??
8 %define         _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
9 %define         _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
10 %if %{_kernel24}
11 %define         _kernel_series  2.4
12 %else
13 %define         _kernel_series  2.2
14 %endif
15
16 %define         rel     6
17
18 Summary:        Collection of basic system utilities for Linux
19 Summary(de):    Sammlung von grundlegenden Systemdienstprogrammen für Linux
20 Summary(fr):    Ensemble d'utilitaires système de base pour Linux
21 Summary(pl):    Zbiór podstawowych narzêdzi systemowych dla Linuksa
22 Summary(tr):    Temel sistem araçlarý
23 Summary(pt_BR): Coletânea de utilitários básicos de sistema para Linux
24 Summary(es):    Colectánea de utilitarios básicos de sistema para Linux
25 Name:           util-linux
26 Version:        2.11g
27 Release:        %{rel}
28 License:        Distributable
29 Group:          Applications/System
30 Group(de):      Applikationen/System
31 Group(pl):      Aplikacje/System
32 Source0:        ftp://ftp.win.tue.nl/pub/linux-local/utils/util-linux/%{name}-%{version}.tar.gz
33 Source1:        login.pamd
34 Source2:        kill.1.pl
35 Source3:        arch.1.pl
36 Source4:        login.1.pl
37 Source5:        look.1.pl
38 Source6:        script.1.pl
39 Source7:        write.1.pl
40 Source8:        getopt.1.pl
41 Source9:        colrm.1.pl
42 Source10:       hexdump.1.pl
43 Source11:       ul.1.pl
44 Source12:       ipcrm.8.pl
45 Source13:       ipcs.8.pl
46 Source15:       fdformat.8.pl
47 Source16:       mkswap.8.pl
48 Source17:       fdisk.8.pl
49 Source18:       umount.8.pl
50 Source19:       mount.8.pl
51 Source20:       swapon.8.pl
52 Source21:       swapoff.8.pl
53 Source22:       fstab.5.pl
54 Source23:       chkdupexe.1.pl
55 Source24:       tunelp.8.pl
56 Source25:       rawdevices-init
57 Source26:       rawdevices-sysconfig
58 Patch0:         %{name}-MCONFIG.patch
59 Patch1:         %{name}-fdisk.patch
60 Patch2:         %{name}-utmpx.patch
61 Patch3:         %{name}-fhs.patch
62 Patch4:         %{name}-login.patch
63 Patch5:         %{name}-kerneli.patch
64 Patch6:         %{name}-info.patch
65 Patch7:         %{name}-fdisk2.patch
66 Patch9:         %{name}-mount-rpc.patch
67 Patch10:        ftp://ftp.linuxnfs.sourceforge.org:/pub/nfs/%{name}-2.10m-mount-compat.patch
68 Patch11:        %{name}-syscall.patch
69 Patch13:        %{name}-raw.patch
70 Patch14:        %{name}-gecos.patch
71 Patch15:        %{name}-glibc.patch
72 Patch16:        %{name}-s390.patch
73 Patch18:        %{name}-kerneli-2.4.patch
74 Patch20:        %{name}-qnx4.patch
75 Patch21:        %{name}-losetup-getpass.patch
76 Patch22:        %{name}-login-problems.patch
77 BuildRequires:  pam-devel >= 0.66
78 BuildRequires:  ncurses-devel >= 5.0
79 BuildRequires:  gettext-devel
80 BuildRequires:  texinfo
81 %if %{?BOOT:1}%{!?BOOT:0}
82 BuildRequires:  glibc-static
83 %endif
84 Requires:       pam >= 0.66
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86 Obsoletes:      util-linux-suids
87
88 %define         debugcflags     -O1 -g
89
90 %description
91 util-linux contains a large variety of low-level system utilities
92 necessary for a functional Linux system. This includes, among other
93 things, configuration tools such as fdisk and system programs such as
94 logger.
95
96 %description -l de
97 util-linux enthält eine große Anzahl an
98 low-level-Systemdienstprogrammen, die für ein funktionierendes
99 Linux-System erforderlich sind. Dazu gehören Konfigurationstools wie
100 'fdisk' und Systemprogramme wie 'logger'.
101
102 %description -l fr
103 util-linux contient une grande variété d'utilitaire système bas niveau
104 nécessaires au fonctionnement d'un système Linux. Cela comprend, entre
105 autres, les outils de configuration comme fdisk et des programmes
106 systèmes comme logger.
107
108 %description -l pl
109 Util-linux zawiera wiele ró¿nych, niskopoziomowych narzêdzi
110 systemowych niezbêdnych do prawid³owego dzia³ania Linuksa. W pakiecie
111 znajduj± siê miêdzy innymi, narzêdzia konfiguracyjne takie jak fdisk i
112 programy systemowe takie jak logger.
113
114 %description -l tr
115 þlevsel durumdaki bir Linux sistemi için gerekli birçok alt düzey
116 sistem araçlarýný içerir. Bunlar arasýnda fdisk gibi yapýlandýrma
117 uygulamalarý ve logger gibi sistem programlarý sayýlabilir.
118
119 %description -l pt_BR
120 util-Linux contém uma grande variedade de utilitários de sistema
121 de baixo-nível necessários para um sistema Linux funcional. Isso
122 inclui, entre outras coisas, ferramentas de configuração como fdisk
123 e programas de sistema como login.
124
125 %description -l es
126 util-Linux contiene una gran variedad de utilitarios de sistema de
127 bajo nivel necesarios a un sistema Linux funcional. Esto incluye,
128 entre otras cosas, herramientas de configuración como fdisk y
129 programas de sistema como login.
130
131 %package -n losetup
132 Summary:        Programs for setting up and configuring loopback devices
133 Summary(de):    Programme zum Einrichten und Konfigurieren von Loopback-Geräten
134 Summary(fr):    Programmes pour mettre en place et configurer les loopback
135 Summary(pl):    Program do konfiguracji urz±dzenia blokowego loopback
136 Summary(tr):    Yerel-çevrim aygýtlarýnýn kurulmasý ve ayarlanmasý için programlar
137 Group:          Applications/System
138 Group(de):      Applikationen/System
139 Group(pl):      Aplikacje/System
140 Release:        %{rel}@%{_kernel_series}
141 %if %{_kernel24}
142 Conflicts:      kernel < 2.3.0
143 %else
144 Conflicts:      kernel >= 2.3.0
145 %endif
146
147 %description -n losetup
148 Linux supports a special block device called the loopback device,
149 which maps a normal file onto a virtual block device. This package
150 contains programs for setting up and removing the mapping between
151 files and loopback devices.
152
153 Block loopback devices should not be confused with the networking
154 loopback device, which is configured with the normal ifconfig command.
155
156 %description -n losetup -l de
157 Linux unterstützt ein spezielles Blockgerät, das sogenannte Loopback,
158 das eine normale Datei auf ein virtuelles Blockgerät abbildet. Das
159 Paket enthält Programme zum Einrichten und Entfernen der Zuordnung
160 zwischen Dateien und Loopback-Geräten.
161
162 %description -n losetup -l fr
163 Linux gère un périphérique bloc spécial appelé « loopback », qui
164 correspond à un fichier normal sur un périphérique bloc virtuel. Ce
165 paquetage contient les programmes pour configurer et supprimer la
166 correspondance entre les fichiers et les périphériques loopback.
167
168 Les périphériques bloc loopback ne doivent pas être confondus avec le
169 périphérique loopback du réseau, configuré avec la commande ifconfig
170 normale.
171
172 %description -n losetup -l pl
173 Linux ma wsparcie dla specjalnego urz±dzenia blokowego loopback, które
174 mapuje normalny plik w wirtualne urz±dzenie blokowe. Pakiet ten
175 zawiera program przy pomocy którego bêdziesz móg³ wykorzystaæ to
176 urz±dzenie.
177
178 Urz±dzenie blokowe loopback nie powinno byæ mylone z sieciowym
179 interfejsem loopback, który jest konfigurowany przy pomocy polecenia
180 ifconfig.
181
182 %description -n losetup -l tr
183 Linux özel bir blok aygýt olan yerel-çevrim aygýtýný (loopback device)
184 destekler. Bu aygýt normal bir dosyanýn sanal bir blok aygýtý üzerine
185 haritasýný çýkarýr. Bu paket, dosyalar ve yerel-çevrim aygýtlarý
186 arasýndaki haritalama iþleminin kurulmasý ve kaldýrýlmasý için
187 programlar içerir. Blok yerel-çevrim aygýtý ifconfig komutu ile
188 yapýlandýrýlan að yerel-çevrim aygýtý ile karýþtýrýlmamalýdýr.
189
190 %package -n mount
191 Summary:        Programs for mounting and unmounting filesystems
192 Summary(de):    Programme zum Montieren und Abmontieren von Dateisystemen
193 Summary(fr):    Programme pour monter et démonter des systèmes de fichiers.
194 Summary(pl):    Programy do montowania i odmontowywania systemu plików
195 Summary(tr):    Dosya sistemlerini baðlamak ve çözmek için programlar
196 Group:          Applications/System
197 Group(de):      Applikationen/System
198 Group(pl):      Aplikacje/System
199 Release:        %{rel}@%{_kernel_series}
200 %if %{_kernel24}
201 Conflicts:      kernel < 2.3.0
202 %else
203 Conflicts:      kernel >= 2.3.0
204 %endif
205
206 %description -n mount
207 Mount is used for adding new filesystems, both local and networked, to
208 your current directory structure. The filesystems must already exist
209 for this to work. It can also be used to change the access types the
210 kernel uses for already-mounted filesystems.
211
212 This package is critical for the functionality of your system.
213
214 %description -n mount -l de
215 Mount wird zum Hinzufügen neuer Dateisysteme (lokal und im Netzwerk)
216 zu Ihrer aktuellen Verzeichnisstruktur verwendet. Die Dateisysteme
217 müssen bereits existieren. Außerdem können die Zugriffstypen geändert
218 werden, die der Kernel für bereits montierte Dateisysteme verwendet.
219
220 Dieses Paket ist für Ihr System unbedingt erforderlich .
221
222 %description -n mount -l fr
223 mount sert à ajouter de nouveaux systèmes de fichiers, locaux ou
224 réseaux, à votre structure de répertoire. Les systèmes de fichiers
225 doivent déjà exister pour que cela fonctionne. Il peut aussi servir à
226 changer les types d'accès pour les systèmes de fichiers déjà montés.
227
228 Ce paquetage est critique pour le fonctionnement de votre système.
229
230 %description -n mount -l pl
231 Program mount jest u¿ywany przez system do montowania systemu plików,
232 zarówno lokalnych jak i sieciowych (np. NFS).
233
234 Pakiet ten jest niezbêdny do prawid³owej pracy twojego Linuksa.
235
236 %description -n mount -l tr
237 mount, hem yerel hem de að dosya sistemlerinin dizin yapýsýna
238 eklenmesi için kullanýlýr. Bunun için baðlanacak dosya sisteminin
239 önceden hazýrlanmýþ olmasý gerekir. Ayný zamanda çekirdeðin baðlanmýþ
240 dosya sistemlerine eriþimini deðiþtirmek için de kullanýlýr. Bu paket
241 sisteminizin iþlevselliði açýsýndan kritiktir.
242
243 %package chkdupexe
244 Summary:        chkdupexe - find duplicate executables
245 Summary(pl):    chkdupexe odszukuje powtarzaj±ce siê pliki uruchamialne
246 Group:          Applications/System
247 Group(de):      Applikationen/System
248 Group(pl):      Aplikacje/System
249
250 %description chkdupexe
251 chkdupexe will scan the union of $PATH and a hardcoded list of common
252 locations for binaries. It will report dangling symlinks and
253 duplicately-named binaries.
254
255 %description chkdupexe -l pl
256 chkdupexe przeszukuje katalogi z $PATH oraz inne powszechnie znane
257 katalogi z plikami uruchamialnymi i informuje o powtarzaj±cych siê
258 plikach w ró¿nych katalogach.
259
260 %package -n tunelp
261 Summary:        Configures kernel parallel port driver
262 Summary(de):    Konfiguriert den Kerneltreiber für den parallelen Port
263 Summary(fr):    Configure le pilote du port parallèle dans le noyau
264 Summary(pl):    Program do konfigurowania sterownika portu równoleg³ego
265 Summary(tr):    Çekirdeðin paralel baðlantý noktasý sürücüsünü ayarlar
266 Group:          Applications/System
267 Group(de):      Applikationen/System
268 Group(pl):      Aplikacje/System
269
270 %description -n tunelp
271 `tunelp' aids in configuring the kernel parallel port driver.
272
273 %description -n tunelp -l de
274 TUNELP hilft bei der Konfiguration des Kernel-Parallelport-Treibers.
275
276 %description -n tunelp -l fr
277 « tunelp » aide à configurer le pilote du noyau pour le port
278 parallèle.
279
280 %description -n tunelp -l pl
281 Program do konfigurowania sterownika portu równoleg³ego.
282
283 %description -n tunelp -l tr
284 Paralel baðlantý noktasý sürücüsünü ayarlar.
285
286 %package -n login
287 Summary:        login is used when signing onto a system
288 Summary(pl):    login jest u¿ywany do rozpoczêcia pracy w systemie
289 Group:          Applications/System
290 Group(de):      Applikationen/System
291 Group(pl):      Aplikacje/System
292 Obsoletes:      heimdal-login
293 Requires:       pam-pld
294
295 %description -n login
296 login is used when signing onto a system. It can also be used to
297 switch from one user to another at any time (most modern shells have
298 support for this feature built into them, however).
299
300 %description -n login -l pl
301 login jest u¿ywany do rozpoczêcia pracy w systemie. Mo¿e byæ u¿ywany
302 do prze³±czania z jednego u¿ytkownika na innego w ka¿dym momencie
303 (jednak wiêkszo¶æ nowoczesnych pow³ok ma takie funkcje wbudowane).
304
305 %package -n agetty
306 Summary:        Alternative Linux getty
307 Summary(pl):    Alternatywny getty 
308 Group:          Applications/System
309 Group(de):      Applikationen/System
310 Group(pl):      Aplikacje/System
311 Requires:       login
312
313 %description -n agetty
314 agetty is simple Linux getty with serial support.
315
316 %description -n agetty -l pl
317 agetty jest prostym linuksowym getty z obs³ug± portu szeregowego.
318
319 %package -n rawdevices
320 Summary:        Support for raw-devices
321 Summary(pl):    Obs³uga raw-device'ów
322 Group:          Applications/System
323 Group(de):      Applikationen/System
324 Group(pl):      Aplikacje/System
325 Requires:       chkconfig
326
327 %description -n rawdevices
328 Support for raw-devices.
329
330 %description -n rawdevices -l pl
331 Obs³uga raw-device'ów.
332
333 %if %{?BOOT:1}%{!?BOOT:0}
334 %package BOOT
335 Summary:        util-linux for bootdisk
336 Group:          Applications/System
337 Group(de):      Applikationen/System
338 Group(pl):      Aplikacje/System
339
340 %description BOOT
341 %endif
342
343 %prep
344 %setup -q
345 %patch0 -p1
346 %patch1 -p1
347 %patch2 -p1
348 %patch3 -p1
349 %patch4 -p1
350 %if %{_kernel24}
351 %{!?_without_crypto:%patch18 -p1}
352 %else
353 %{!?_without_crypto:%patch5 -p1}
354 %endif
355 %patch6 -p1
356 %patch7 -p1
357 %patch9 -p1
358 %patch10 -p1
359 %patch11 -p1
360 %patch13 -p1
361 %patch14 -p1
362 %patch15 -p1
363 %patch16 -p1
364 %patch20 -p1
365 %if !%{_kernel24}
366 %patch21 -p1
367 %endif
368 %patch22 -p1
369
370 %build
371 CFLAGS="%{rpmcflags} -I%{_includedir}/ncurses -I%{_kernelsrcdir}/include"
372 %configure2_13
373
374 %if %{?BOOT:1}%{!?BOOT:0}
375 %{__make} -C fdisk CFLAGS="%{rpmcflags} -static"
376 mv -f fdisk/fdisk fdisk-BOOT
377 %{__make} -C fdisk clean
378 %endif
379
380 %{__make} OPT="%{rpmcflags}" \
381         MOREHELPDIR=%{_datadir}/misc \
382         ADD_RAW="yes"
383
384 (cd sys-utils; makeinfo ipc.texi)
385
386 %install
387 rm -rf $RPM_BUILD_ROOT
388
389 %if %{?BOOT:1}%{!?BOOT:0}
390 install -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/sbin
391 install fdisk-BOOT $RPM_BUILD_ROOT%{_libdir}/bootdisk/sbin/fdisk
392 %endif
393
394 install -d $RPM_BUILD_ROOT/{bin,sbin,etc/{pam.d,logrotate,rc.d/init.d,sysconfig}} \
395         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_infodir},%{_datadir}/misc} \
396         $RPM_BUILD_ROOT{%{_examplesdir},%{_mandir}/{man{1,5,6,8},pl/man{1,5,6,8}}}
397
398 %{__make} install \
399         DESTDIR="$RPM_BUILD_ROOT" \
400         INSTALLSUID="install -m 755" \
401         MOREHELPDIR=$RPM_BUILD_ROOT%{_datadir}/misc \
402         GETOPTDIR=$RPM_BUILD_ROOT%{_examplesdir}/getopt \
403         USRGAMESDIR=$RPM_BUILD_ROOT%{_bindir} \
404         USE_TTY_GROUP=no \
405         ADD_RAW="yes"
406
407 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/login
408
409 install %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/pl/man1/kill.1
410 install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1/arch.1
411 install %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/pl/man1/login.1
412 install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/pl/man1/look.1
413 install %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/pl/man1/script.1
414 install %{SOURCE7} $RPM_BUILD_ROOT%{_mandir}/pl/man1/write.1
415 install %{SOURCE8} $RPM_BUILD_ROOT%{_mandir}/pl/man1/getopt.1
416 install %{SOURCE9} $RPM_BUILD_ROOT%{_mandir}/pl/man1/colrm.1
417 install %{SOURCE10} $RPM_BUILD_ROOT%{_mandir}/pl/man1/hexdump.1
418 install %{SOURCE11} $RPM_BUILD_ROOT%{_mandir}/pl/man1/ul.1
419
420 install %{SOURCE12} $RPM_BUILD_ROOT%{_mandir}/pl/man8/ipcrm.8
421 install %{SOURCE13} $RPM_BUILD_ROOT%{_mandir}/pl/man8/ipcs.8
422 install %{SOURCE15} $RPM_BUILD_ROOT%{_mandir}/pl/man8/fdformat.8
423 install %{SOURCE16} $RPM_BUILD_ROOT%{_mandir}/pl/man8/mkswap.8
424 install %{SOURCE17} $RPM_BUILD_ROOT%{_mandir}/pl/man8/fdisk.8
425 install %{SOURCE18} $RPM_BUILD_ROOT%{_mandir}/pl/man8/umount.8
426 install %{SOURCE19} $RPM_BUILD_ROOT%{_mandir}/pl/man8/mount.8
427 install %{SOURCE20} $RPM_BUILD_ROOT%{_mandir}/pl/man8/swapon.8
428 install %{SOURCE21} $RPM_BUILD_ROOT%{_mandir}/pl/man8/swapoff.8
429
430 install %{SOURCE22} $RPM_BUILD_ROOT%{_mandir}/pl/man5/fstab.5
431
432 install %{SOURCE23} $RPM_BUILD_ROOT%{_mandir}/pl/man1/chkdupexe.1
433
434 install %{SOURCE24} $RPM_BUILD_ROOT%{_mandir}/pl/man8/tunelp.8
435
436 install %{SOURCE25} $RPM_BUILD_ROOT/etc/rc.d/init.d/rawdevices
437 install %{SOURCE26} $RPM_BUILD_ROOT/etc/sysconfig/rawdevices
438
439 install -d $RPM_BUILD_ROOT/{etc/security,var/lock}
440
441 touch $RPM_BUILD_ROOT/etc/security/blacklist.login
442
443 :> $RPM_BUILD_ROOT/var/lock/wtmpxlock
444
445 ln -sf hwclock $RPM_BUILD_ROOT/sbin/clock
446 echo '.so hwclock.8' > $RPM_BUILD_ROOT%{_mandir}/man8/clock.8
447
448 ln -sf swapon $RPM_BUILD_ROOT/sbin/swapoff
449
450 gzip -9nf */README.*
451
452 %find_lang %{name}
453
454 %post
455 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
456
457 %postun
458 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
459
460 %post -n rawdevices
461 /sbin/chkconfig --add rawdevices
462 if [ -f /var/lock/subsys/rawdevices ]; then
463         /etc/rc.d/init.d/rawdevices restart 1>&2
464 else
465         echo "Run \"/etc/rc.d/init.d/rawdevices start\" to start rawdevices."
466 fi
467
468 %preun -n rawdevices
469 if [ -f /var/lock/subsys/rawdevices ]; then
470         /etc/rc.d/init.d/rawdevices stop 1>&2
471 fi
472 /sbin/chkconfig --del rawdevices
473
474 %clean
475 rm -rf $RPM_BUILD_ROOT
476
477 %files -f %{name}.lang
478 %defattr(644,root,root,755)
479 %doc */README.*
480
481 %attr(755,root,root) /sbin/clock
482 %attr(755,root,root) /sbin/hwclock
483
484 %{_mandir}/man8/clock.8*
485 %{_mandir}/man8/hwclock.8*
486
487 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/fdprm
488
489 %attr(0755,root,root) /bin/arch
490 %attr(0755,root,root) /bin/dmesg
491 %attr(0755,root,root) /bin/kill
492 %attr(0755,root,root) /bin/more
493 %attr(0755,root,root) /sbin/blockdev
494 %attr(0755,root,root) /sbin/mkfs
495 %attr(0755,root,root) /sbin/mkswap
496 %attr(0755,root,root) /sbin/ctrlaltdel
497 %attr(0755,root,root) /sbin/elvtune
498 %attr(0755,root,root) %{_bindir}/banner
499 %attr(0755,root,root) %{_bindir}/cal
500 %attr(0755,root,root) %{_bindir}/col
501 %attr(0755,root,root) %{_bindir}/colcrt
502 %attr(0755,root,root) %{_bindir}/colrm
503 %attr(0755,root,root) %{_bindir}/column
504 %attr(0755,root,root) %{_bindir}/ddate
505 %attr(0755,root,root) %{_bindir}/fdformat
506 %attr(0755,root,root) %{_bindir}/getopt
507 %attr(0755,root,root) %{_bindir}/hexdump
508 %attr(0755,root,root) %{_bindir}/ipcrm
509 %attr(0755,root,root) %{_bindir}/ipcs
510 %attr(0755,root,root) %{_bindir}/isosize
511 %attr(0755,root,root) %{_bindir}/logger
512 %attr(0755,root,root) %{_bindir}/look
513 %attr(0755,root,root) %{_bindir}/mcookie
514 %attr(0755,root,root) %{_bindir}/namei
515 %attr(4755,root,root) %{_bindir}/newgrp
516 %attr(0755,root,root) %{_bindir}/renice
517 %attr(0755,root,root) %{_bindir}/rev
518 %attr(0755,root,root) %{_bindir}/script
519 %attr(0755,root,root) %{_bindir}/setsid
520 %attr(0755,root,root) %{_bindir}/setfdprm
521 %attr(0755,root,root) %{_bindir}/setterm
522 %attr(0755,root,root) %{_bindir}/ul
523 %attr(0755,root,root) %{_bindir}/whereis
524 %attr(2755,root,tty) %{_bindir}/write
525 %attr(0755,root,root) %{_sbindir}/readprofile
526 %attr(0755,root,root) %{_sbindir}/vigr
527 %attr(0755,root,root) %{_sbindir}/vipw
528
529 %{_mandir}/man1/arch.1*
530 %{_mandir}/man1/cal.1*
531 %{_mandir}/man1/col.1*
532 %{_mandir}/man1/colcrt.1*
533 %{_mandir}/man1/colrm.1*
534 %{_mandir}/man1/column.1*
535 %{_mandir}/man1/ddate.1*
536 %{_mandir}/man1/getopt.1*
537 %{_mandir}/man1/hexdump.1*
538 %{_mandir}/man1/kill.1*
539 %{_mandir}/man1/logger.1*
540 %{_mandir}/man1/look.1*
541 %{_mandir}/man1/mcookie.1*
542 %{_mandir}/man1/more.1*
543 %{_mandir}/man1/namei.1*
544 %{_mandir}/man1/newgrp.1*
545 %{_mandir}/man1/script.1*
546 %{_mandir}/man1/setterm.1*
547 %{_mandir}/man1/readprofile.1*
548 %{_mandir}/man1/rev.1*
549 %{_mandir}/man1/ul.1*
550 %{_mandir}/man1/whereis.1*
551 %{_mandir}/man1/write.1*
552
553 %{_mandir}/man6/banner.6*
554
555 %{_mandir}/man8/blockdev.8*
556 %{_mandir}/man8/cytune.8*
557 %{_mandir}/man8/ctrlaltdel.8*
558 %{_mandir}/man8/dmesg.8*
559 %{_mandir}/man8/elvtune.8*
560 %{_mandir}/man8/fdformat.8*
561 %{_mandir}/man8/ipcrm.8*
562 %{_mandir}/man8/ipcs.8*
563 %{_mandir}/man8/isosize.8*
564 %{_mandir}/man8/mkswap.8*
565 %{_mandir}/man8/renice.8*
566 %{_mandir}/man8/setsid.8*
567 %{_mandir}/man8/setfdprm.8*
568 %{_mandir}/man8/vipw.8*
569
570 %lang(pl) %{_mandir}/pl/man1/arch.1*
571 %lang(pl) %{_mandir}/pl/man1/colrm.1*
572 %lang(pl) %{_mandir}/pl/man1/getopt.1*
573 %lang(pl) %{_mandir}/pl/man1/hexdump.1*
574 %lang(pl) %{_mandir}/pl/man1/kill.1*
575 %lang(pl) %{_mandir}/pl/man1/look.1*
576 %lang(pl) %{_mandir}/pl/man1/script.1*
577 %lang(pl) %{_mandir}/pl/man1/ul.1*
578 %lang(pl) %{_mandir}/pl/man1/write.1*
579
580 %lang(pl) %{_mandir}/pl/man8/fdformat.8*
581 %lang(pl) %{_mandir}/pl/man8/ipcrm.8*
582 %lang(pl) %{_mandir}/pl/man8/ipcs.8*
583 %lang(pl) %{_mandir}/pl/man8/mkswap.8*
584
585 %dir %{_examplesdir}/getopt
586 %attr(755,root,root) %{_examplesdir}/getopt/*
587 %{_datadir}/misc/more.help
588
589 %attr(755,root,root) /sbin/cfdisk
590 %attr(755,root,root) /sbin/fdisk
591 %attr(755,root,root) /sbin/fsck.minix
592 %attr(755,root,root) /sbin/mkfs.minix
593 %attr(755,root,root) /sbin/sfdisk
594
595 %{_mandir}/man8/cfdisk.8*
596 %{_mandir}/man8/fdisk.8*
597 %{_mandir}/man8/sfdisk.8*
598 %{_mandir}/man8/fsck.minix.8*
599 %{_mandir}/man8/mkfs.minix.8*
600 %{_mandir}/man8/mkfs.8*
601
602 %lang(pl) %{_mandir}/pl/man8/fdisk.8*
603
604 %attr(755,root,root) %{_bindir}/cytune
605
606 %ifarch %{ix86}
607 %attr(755,root,root) %{_sbindir}/ramsize
608 %attr(755,root,root) %{_sbindir}/rdev
609 %attr(755,root,root) %{_sbindir}/rootflags
610 %attr(755,root,root) %{_sbindir}/vidmode
611
612 %{_mandir}/man8/ramsize.8*
613 %{_mandir}/man8/rdev.8*
614 %{_mandir}/man8/rootflags.8*
615 %{_mandir}/man8/vidmode.8*
616 %endif
617
618 %{_infodir}/ipc*
619
620 %ghost /var/lock/wtmpxlock
621
622 %files -n mount
623 %defattr(644,root,root,755)
624
625 %attr(4755,root,root) /bin/mount
626 %attr(4755,root,root) /bin/umount
627 %{?_with_pivot_root:%attr(755,root,root) /sbin/pivot_root}
628 %attr(755,root,root) /sbin/swapon
629 %attr(755,root,root) /sbin/swapoff
630
631 %{_mandir}/man5/fstab.5*
632 %{_mandir}/man5/nfs.5*
633
634 %{_mandir}/man8/mount.8*
635 %{_mandir}/man8/umount.8*
636 %{?_with_pivot_root:%{_mandir}/man8/pivot_root.8*}
637 %{_mandir}/man8/swapon.8*
638 %{_mandir}/man8/swapoff.8*
639
640 %lang(pl) %{_mandir}/pl/man8/mount.8*
641 %lang(pl) %{_mandir}/pl/man8/umount.8*
642 %lang(pl) %{_mandir}/pl/man8/swapon.8*
643 %lang(pl) %{_mandir}/pl/man8/swapoff.8*
644
645 %lang(pl) %{_mandir}/pl/man5/fstab.5*
646
647 %files -n losetup
648 %defattr(644,root,root,755)
649
650 %{_mandir}/man8/losetup.8*
651 %attr(755,root,root) /sbin/losetup
652
653 %files chkdupexe
654 %defattr(644,root,root,755)
655 %attr(0755,root,root) %{_bindir}/chkdupexe
656 %{_mandir}/man1/chkdupexe.1*
657
658 %lang(pl) %{_mandir}/pl/man1/chkdupexe.1*
659
660 %files -n tunelp
661 %defattr(644,root,root,755)
662 %attr(0755,root,root) %{_sbindir}/tunelp
663 %{_mandir}/man8/tunelp.8*
664 %lang(pl) %{_mandir}/pl/man8/tunelp.8*
665
666 %files -n login
667 %defattr(644,root,root,755)
668 %attr(640,root,root) %config(noreplace) %verify(not mtime size md5) /etc/pam.d/login
669 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.login
670 %attr(0755,root,root) /bin/login
671 %{_mandir}/man1/login.1*
672 %lang(pl) %{_mandir}/pl/man1/login.1*
673
674 %files -n agetty
675 %defattr(644,root,root,755)
676 %attr(0755,root,root) /sbin/agetty
677 %{_mandir}/man8/agetty.8*
678
679 %files -n rawdevices
680 %defattr(644,root,root,755)
681 %attr(0755,root,root) %{_bindir}/raw
682 %attr(0750,root,root) /etc/rc.d/init.d/rawdevices
683 %attr(0640,root,root) %config(noreplace) /etc/sysconfig/rawdevices
684 %{_mandir}/man8/raw.8*
685
686 %if %{?BOOT:1}%{!?BOOT:0}
687 %files BOOT
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/bootdisk/sbin/*
690 %endif
This page took 0.079756 seconds and 4 git commands to generate.