]> git.pld-linux.org Git - packages/umockdev.git/blob - umockdev.spec
cf0932416f3e4f1e51837678a3d1828dbb75d988
[packages/umockdev.git] / umockdev.spec
1 Summary:        Mock hardware devices for creating unit tests
2 Summary(pl.UTF-8):      Imitowanie urządzeń sprzętowych na potrzeby testów jednostkowych
3 Name:           umockdev
4 Version:        0.14.5
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Libraries
8 #Source0Download: https://github.com/martinpitt/umockdev/releases
9 Source0:        https://github.com/martinpitt/umockdev/releases/download/%{version}/%{name}-%{version}.tar.xz
10 # Source0-md5:  c06d23f24c065f7d1ba9e511ea97f0a8
11 URL:            https://github.com/martinpitt/umockdev
12 BuildRequires:  autoconf >= 2.64
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  glib2-devel >= 1:2.32.0
15 BuildRequires:  gnome-common
16 BuildRequires:  gobject-introspection-devel >= 1.32
17 BuildRequires:  gtk-doc >= 1.14
18 BuildRequires:  libgudev-devel >= 232
19 BuildRequires:  libtool >= 2:2.2
20 BuildRequires:  python3 >= 1:3
21 BuildRequires:  rpm-build >= 4.6
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  udev-devel
24 BuildRequires:  vala >= 2:0.16.1
25 BuildRequires:  xz
26 Requires:       glib2 >= 1:2.32.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 umockdev mocks Linux devices for creating integration tests for
31 hardware related libraries and programs. It also provides tools to
32 record the properties and behaviour of particular devices, and to run
33 a program or test suite under a test bed with the previously recorded
34 devices loaded. This allows developers of software like gphoto or
35 libmtp to receive these records in bug reports and recreate the
36 problem on their system without having access to the affected
37 hardware.
38
39 %description -l pl.UTF-8
40 umockdev imituje urządzenia pod Linuksem w celu tworzenia testów
41 integracyjnych dla bibliotek i programów związanych ze sprzętem.
42 Dostarcza także narzędzia do nagrywania właściwości i zachowania
43 określonych urządzeń oraz uruchamiania programów lub testów w
44 środowisku testowym z wczytanymi wcześniej nagranymi danymi
45 urządzenia. Pozwala to programistom z projektów takich jak gphoto czy
46 libmtp otrzymywać takie nagrania w zgłoszeniach błędów i odtwarzać we
47 własnym systemie bez dostępu do sprzętu dotkniętego problemem.
48
49 %package devel
50 Summary:        Header files for umockdev library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki umockdev
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       glib2-devel >= 1:2.32.0
55
56 %description devel
57 Header files for umockdev library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki umockdev.
61
62 %package static
63 Summary:        Static umockdev library
64 Summary(pl.UTF-8):      Statyczna biblioteka umockdev
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static umockdev library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka umockdev.
73
74 %package -n vala-umockdev
75 Summary:        Vala API for umockdev library
76 Summary(pl.UTF-8):      API języka Vala do biblioteki umockdev
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79 Requires:       vala >= 2:0.16.1
80 BuildArch:      noarch
81
82 %description -n vala-umockdev
83 Vala API for umockdev library.
84
85 %description -n vala-umockdev -l pl.UTF-8
86 API języka Vala do biblioteki umockdev.
87
88 %package apidocs
89 Summary:        umockdev API documentation
90 Summary(pl.UTF-8):      Dokumentacja API biblioteki umockdev
91 Group:          Documentation
92 BuildArch:      noarch
93
94 %description apidocs
95 API documentation for umockdev library.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API biblioteki umockdev.
99
100 %prep
101 %setup -q
102
103 %build
104 %{__libtoolize}
105 %{__gtkdocize} --docdir docs
106 %{__aclocal} -I m4
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         PYTHON=/usr/bin/python \
112         --enable-gtk-doc \
113         --disable-silent-rules \
114         --with-html-dir=%{_gtkdocdir}
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 # obsoleted by pkg-config
124 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
125 # packaged as %doc
126 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/umockdev
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc NEWS README.rst docs/script-format.txt
137 %attr(755,root,root) %{_bindir}/umockdev-record
138 %attr(755,root,root) %{_bindir}/umockdev-run
139 %attr(755,root,root) %{_bindir}/umockdev-wrapper
140 %attr(755,root,root) %{_libdir}/libumockdev.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libumockdev.so.0
142 %attr(755,root,root) %{_libdir}/libumockdev-preload.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libumockdev-preload.so.0
144 %{_libdir}/girepository-1.0/UMockdev-1.0.typelib
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/libumockdev.so
149 %{_datadir}/gir-1.0/UMockdev-1.0.gir
150 %{_includedir}/umockdev-1.0
151 %{_pkgconfigdir}/umockdev-1.0.pc
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libumockdev.a
156
157 %files -n vala-umockdev
158 %defattr(644,root,root,755)
159 %{_datadir}/vala/vapi/umockdev-1.0.vapi
160
161 %files apidocs
162 %defattr(644,root,root,755)
163 %{_gtkdocdir}/umockdev
This page took 0.074198 seconds and 3 git commands to generate.