]> git.pld-linux.org Git - packages/umockdev.git/blob - umockdev.spec
- updated to 0.14.1
[packages/umockdev.git] / umockdev.spec
1 Summary:        Mock hardware devices for creating unit tests
2 Summary(pl.UTF-8):      Imitowanie urządzeń sprzętowych na potrzeby testów jednostkowych
3 Name:           umockdev
4 Version:        0.14.1
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Libraries
8 #Source0Download: https://github.com/martinpitt/umockdev/releases
9 Source0:        https://github.com/martinpitt/umockdev/releases/download/%{version}/%{name}-%{version}.tar.xz
10 # Source0-md5:  6c8c200017986aba95e8ee756ccef88a
11 URL:            https://github.com/martinpitt/umockdev
12 BuildRequires:  autoconf >= 2.64
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  glib2-devel >= 1:2.32.0
15 BuildRequires:  gnome-common
16 BuildRequires:  gobject-introspection-devel >= 1.32
17 BuildRequires:  gtk-doc >= 1.14
18 BuildRequires:  libtool >= 2:2.2
19 BuildRequires:  python3 >= 1:3
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  udev-devel
22 BuildRequires:  udev-glib-devel
23 BuildRequires:  vala >= 2:0.16.1
24 BuildRequires:  xz
25 Requires:       glib2 >= 1:2.32.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 umockdev mocks Linux devices for creating integration tests for
30 hardware related libraries and programs. It also provides tools to
31 record the properties and behaviour of particular devices, and to run
32 a program or test suite under a test bed with the previously recorded
33 devices loaded. This allows developers of software like gphoto or
34 libmtp to receive these records in bug reports and recreate the
35 problem on their system without having access to the affected
36 hardware.
37
38 %description -l pl.UTF-8
39 umockdev imituje urządzenia pod Linuksem w celu tworzenia testów
40 integracyjnych dla bibliotek i programów związanych ze sprzętem.
41 Dostarcza także narzędzia do nagrywania właściwości i zachowania
42 określonych urządzeń oraz uruchamiania programów lub testów w
43 środowisku testowym z wczytanymi wcześniej nagranymi danymi
44 urządzenia. Pozwala to programistom z projektów takich jak gphoto czy
45 libmtp otrzymywać takie nagrania w zgłoszeniach błędów i odtwarzać we
46 własnym systemie bez dostępu do sprzętu dotkniętego problemem.
47
48 %package devel
49 Summary:        Header files for umockdev library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki umockdev
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       glib2-devel >= 1:2.32.0
54
55 %description devel
56 Header files for umockdev library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki umockdev.
60
61 %package static
62 Summary:        Static umockdev library
63 Summary(pl.UTF-8):      Statyczna biblioteka umockdev
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static umockdev library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka umockdev.
72
73 %package -n vala-umockdev
74 Summary:        Vala API for umockdev library
75 Summary(pl.UTF-8):      API języka Vala do biblioteki umockdev
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78 Requires:       vala >= 2:0.16.1
79 %if "%{_rpmversion}" >= "4.6"
80 BuildArch:      noarch
81 %endif
82
83 %description -n vala-umockdev
84 Vala API for umockdev library.
85
86 %description -n vala-umockdev -l pl.UTF-8
87 API języka Vala do biblioteki umockdev.
88
89 %package apidocs
90 Summary:        umockdev API documentation
91 Summary(pl.UTF-8):      Dokumentacja API biblioteki umockdev
92 Group:          Documentation
93 %if "%{_rpmversion}" >= "4.6"
94 BuildArch:      noarch
95 %endif
96
97 %description apidocs
98 API documentation for umockdev library.
99
100 %description apidocs -l pl.UTF-8
101 Dokumentacja API biblioteki umockdev.
102
103 %prep
104 %setup -q
105
106 %build
107 %{__libtoolize}
108 %{__gtkdocize} --docdir docs
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         PYTHON=/usr/bin/python \
115         --enable-gtk-doc \
116         --disable-silent-rules \
117         --with-html-dir=%{_gtkdocdir}
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 # obsoleted by pkg-config
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
128 # packaged as %doc
129 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/umockdev
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc NEWS README.rst docs/script-format.txt
140 %attr(755,root,root) %{_bindir}/umockdev-record
141 %attr(755,root,root) %{_bindir}/umockdev-run
142 %attr(755,root,root) %{_bindir}/umockdev-wrapper
143 %attr(755,root,root) %{_libdir}/libumockdev.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libumockdev.so.0
145 %attr(755,root,root) %{_libdir}/libumockdev-preload.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libumockdev-preload.so.0
147 %{_libdir}/girepository-1.0/UMockdev-1.0.typelib
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libumockdev.so
152 %{_datadir}/gir-1.0/UMockdev-1.0.gir
153 %{_includedir}/umockdev-1.0
154 %{_pkgconfigdir}/umockdev-1.0.pc
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libumockdev.a
159
160 %files -n vala-umockdev
161 %defattr(644,root,root,755)
162 %{_datadir}/vala/vapi/umockdev-1.0.vapi
163
164 %files apidocs
165 %defattr(644,root,root,755)
166 %{_gtkdocdir}/umockdev
This page took 0.094565 seconds and 3 git commands to generate.