]> git.pld-linux.org Git - packages/umockdev.git/blob - umockdev.spec
184b02a19149310bb6e6597cbe016e560f466b9a
[packages/umockdev.git] / umockdev.spec
1 Summary:        Mock hardware devices for creating unit tests
2 Summary(pl.UTF-8):      Imitowanie urządzeń sprzętowych na potrzeby testów jednostkowych
3 Name:           umockdev
4 Version:        0.9.1
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Libraries
8 # tagged snapshots at https://github.com/martinpitt/umockdev/releases
9 # release tarballs at launchpad:
10 Source0:        https://launchpad.net/umockdev/trunk/%{version}/+download/%{name}-%{version}.tar.xz
11 # Source0-md5:  c2183ae9a03623343d3344dbef259ee8
12 URL:            https://github.com/martinpitt/umockdev
13 BuildRequires:  autoconf >= 2.64
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  glib2-devel >= 1:2.32.0
16 BuildRequires:  gnome-common
17 BuildRequires:  gobject-introspection-devel >= 1.32
18 BuildRequires:  gtk-doc >= 1.14
19 BuildRequires:  libtool >= 2:2.2
20 BuildRequires:  python >= 2
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  udev-devel
23 BuildRequires:  udev-glib-devel
24 BuildRequires:  vala >= 2:0.16.1
25 BuildRequires:  xz
26 Requires:       glib2 >= 1:2.32.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 umockdev mocks Linux devices for creating integration tests for
31 hardware related libraries and programs. It also provides tools to
32 record the properties and behaviour of particular devices, and to run
33 a program or test suite under a test bed with the previously recorded
34 devices loaded. This allows developers of software like gphoto or
35 libmtp to receive these records in bug reports and recreate the
36 problem on their system without having access to the affected
37 hardware.
38
39 %description -l pl.UTF-8
40 umockdev imituje urządzenia pod Linuksem w celu tworzenia testów
41 integracyjnych dla bibliotek i programów związanych ze sprzętem.
42 Dostarcza także narzędzia do nagrywania właściwości i zachowania
43 określonych urządzeń oraz uruchamiania programów lub testów w
44 środowisku testowym z wczytanymi wcześniej nagranymi danymi
45 urządzenia. Pozwala to programistom z projektów takich jak gphoto czy
46 libmtp otrzymywać takie nagrania w zgłoszeniach błędów i odtwarzać we
47 własnym systemie bez dostępu do sprzętu dotkniętego problemem.
48
49 %package devel
50 Summary:        Header files for umockdev library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki umockdev
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       glib2-devel >= 1:2.32.0
55
56 %description devel
57 Header files for umockdev library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki umockdev.
61
62 %package static
63 Summary:        Static umockdev library
64 Summary(pl.UTF-8):      Statyczna biblioteka umockdev
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static umockdev library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka umockdev.
73
74 %package -n vala-umockdev
75 Summary:        Vala API for umockdev library
76 Summary(pl.UTF-8):      API języka Vala do biblioteki umockdev
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79 Requires:       vala >= 2:0.16.1
80 %if "%{_rpmversion}" >= "5"
81 BuildArch:      noarch
82 %endif
83
84 %description -n vala-umockdev
85 Vala API for umockdev library.
86
87 %description -n vala-umockdev -l pl.UTF-8
88 API języka Vala do biblioteki umockdev.
89
90 %package apidocs
91 Summary:        umockdev API documentation
92 Summary(pl.UTF-8):      Dokumentacja API biblioteki umockdev
93 Group:          Documentation
94 %if "%{_rpmversion}" >= "5"
95 BuildArch:      noarch
96 %endif
97
98 %description apidocs
99 API documentation for umockdev library.
100
101 %description apidocs -l pl.UTF-8
102 Dokumentacja API biblioteki umockdev.
103
104 %prep
105 %setup -q
106
107 %build
108 %{__libtoolize}
109 %{__gtkdocize} --docdir docs
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         PYTHON=/usr/bin/python \
116         --enable-gtk-doc \
117         --disable-silent-rules \
118         --with-html-dir=%{_gtkdocdir}
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 # obsoleted by pkg-config
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
129 # packaged as %doc
130 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/umockdev
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc NEWS README.rst docs/script-format.txt
141 %attr(755,root,root) %{_bindir}/umockdev-record
142 %attr(755,root,root) %{_bindir}/umockdev-run
143 %attr(755,root,root) %{_bindir}/umockdev-wrapper
144 %attr(755,root,root) %{_libdir}/libumockdev.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libumockdev.so.0
146 %attr(755,root,root) %{_libdir}/libumockdev-preload.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libumockdev-preload.so.0
148 %{_libdir}/girepository-1.0/UMockdev-1.0.typelib
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libumockdev.so
153 %{_datadir}/gir-1.0/UMockdev-1.0.gir
154 %{_includedir}/umockdev-1.0
155 %{_pkgconfigdir}/umockdev-1.0.pc
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libumockdev.a
160
161 %files -n vala-umockdev
162 %defattr(644,root,root,755)
163 %{_datadir}/vala/vapi/umockdev-1.0.vapi
164
165 %files apidocs
166 %defattr(644,root,root,755)
167 %{_gtkdocdir}/umockdev
This page took 0.049873 seconds and 2 git commands to generate.