]> git.pld-linux.org Git - packages/ufraw.git/blob - ufraw.spec
- added exiv2-0.28 patch, release 17
[packages/ufraw.git] / ufraw.spec
1 #
2 # Conditional build:
3 %bcond_without  gimp            # GIMP plugin
4 %bcond_without  openmp          # OpenMP support
5 #
6 Summary:        RAW photo loader
7 Summary(pl.UTF-8):      Narzędzie do wczytywania zdjęć w formacie RAW
8 Name:           ufraw
9 Version:        0.22
10 Release:        17
11 License:        GPL v2+
12 Group:          Applications/Graphics
13 Source0:        http://downloads.sourceforge.net/ufraw/%{name}-%{version}.tar.gz
14 # Source0-md5:  c30767cae2c44310f2a3d67d7a76f2c3
15 Patch0:         05_fix_build_due_to_unsigned_char.patch
16 Patch1:         ufraw-find_green.patch
17 Patch2:         ufraw-lf-destroy.patch
18 Patch3:         ufraw-multipliers.patch
19 Patch4:         exiv2-0.27.patch
20 Patch5:         %{name}-include.patch
21 Patch6:         %{name}-openmp.patch
22 Patch7:         %{name}-c++.patch
23 Patch8:         %{name}-exiv2-0.28.patch
24 URL:            http://ufraw.sourceforge.net/
25 BuildRequires:  automake
26 BuildRequires:  bzip2-devel
27 BuildRequires:  cfitsio-devel
28 BuildRequires:  exiv2-devel >= 0.20
29 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
30 BuildRequires:  gettext-tools
31 %{?with_gimp:BuildRequires:     gimp-devel >= 2.6.0}
32 BuildRequires:  glib2-devel >= 1:2.12
33 BuildRequires:  gtk+2-devel >= 2:2.12
34 BuildRequires:  gtkimageview-devel >= 1.6
35 BuildRequires:  jasper-devel
36 BuildRequires:  lcms2-devel >= 2
37 BuildRequires:  lensfun-devel >= 0.2.5
38 %{?with_openmp:BuildRequires:   libgomp-devel}
39 BuildRequires:  libjpeg-devel
40 BuildRequires:  libpng-devel >= 1.2
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtiff-devel >= 4
43 BuildRequires:  perl-tools-pod
44 BuildRequires:  pkgconfig >= 1:0.9.0
45 BuildRequires:  zlib-devel
46 Requires(post,postun):  desktop-file-utils
47 Requires(post,postun):  shared-mime-info >= 0.21
48 Requires(post,preun):   GConf2 >= 2.16.0
49 Requires:       exiv2-libs >= 0.20
50 Requires:       glib2 >= 1:2.12
51 Requires:       gtk+2 >= 1:2.12
52 Requires:       gtkimageview >= 1.6
53 Requires:       lcms2 >= 2
54 Requires:       lensfun >= 0.2.5
55 Obsoletes:      cinepaint-plugin-ufraw < 0.20
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %if %{with gimp}
59 %define         gimp_plugindir          %(gimptool --gimpplugindir)/plug-ins
60 %endif
61
62 %description
63 UFRaw is a utility to read and manipulate raw images from digital
64 cameras. It can be used by itself or as a GIMP plug-in. It reads raw
65 images using Dave Coffin's raw conversion utility DCRaw. And it
66 supports basic color management using Little CMS, allowing the user to
67 apply color profiles.
68
69 %description -l pl.UTF-8
70 UFRaw to narzędzie do czytania i przetwarzania zdjęć w formacie RAW
71 różnych aparatów cyfrowych. Może być używane samodzielnie lub jako
72 wtyczka programu GIMP. Zdjęcia w formacie RAW są wczytywane za pomocą
73 programu DCRaw Dave'a Coffina. Użytkownik ma możliwość stosowania
74 profili kolorów dzięki bibliotece Little CMS.
75
76 %package batch
77 Summary:        RAW photo loader batch software
78 Summary(pl.UTF-8):      Program do wsadowego przetwarzania zdjęć w formacie RAW
79 Group:          Applications/Graphics
80 Requires:       exiv2 >= 0.20
81 Requires:       glib2 >= 1:2.12
82 Requires:       lcms2 >= 2
83 Requires:       lensfun >= 0.2.5
84
85 %description batch
86 RAW photo loader batch software.
87
88 %description batch -l pl.UTF-8
89 Program do wsadowego przetwarzania zdjęć w formacie RAW.
90
91 %package -n gimp-plugin-ufraw
92 Summary:        RAW photo loader GIMP plugin
93 Summary(pl.UTF-8):      Wtyczka GIMP-a do wczytywania zdjęć w formacie RAW
94 Group:          Applications/Graphics
95 Requires:       exiv2 >= 0.20
96 Requires:       gimp >= 2.6.0
97 Requires:       glib2 >= 1:2.12
98 Requires:       gtk+2 >= 1:2.12
99 Requires:       gtkimageview >= 1.6
100 Requires:       lcms2 >= 2
101 Requires:       lensfun >= 0.2.5
102
103 %description -n gimp-plugin-ufraw
104 RAW photo loader GIMP plugin.
105
106 %description -n gimp-plugin-ufraw -l pl.UTF-8
107 Wtyczka GIMP-a do wczytywania zdjęć w formacie RAW.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p1
114 %patch3 -p1
115 %patch4 -p1
116 %patch5 -p1
117 %patch6 -p1
118 %patch7 -p1
119 %patch8 -p1
120
121 %build
122 cp -f /usr/share/automake/mkinstalldirs .
123 %configure \
124         --disable-silent-rules \
125         %{!?with_openmp:--disable-openmp} \
126         --enable-contrast \
127         --enable-dst-correction \
128         --enable-extras \
129         --enable-mime \
130         --with-gimp%{!?with_gimp:=no} \
131         --with-gtk
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT%{_desktopdir}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT \
141         schemasdir=%{_sysconfdir}/gconf/schemas
142
143 install ufraw.desktop $RPM_BUILD_ROOT%{_desktopdir}
144 %{__rm} $RPM_BUILD_ROOT%{_bindir}/dcraw
145
146 %find_lang %{name}
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post
152 %gconf_schema_install ufraw.schemas
153 %update_desktop_database_post
154
155 %preun
156 %gconf_schema_uninstall ufraw.schemas
157
158 %postun
159 %update_desktop_database_postun
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc README TODO
164 %attr(755,root,root) %{_bindir}/nikon-curve
165 %attr(755,root,root) %{_bindir}/ufraw
166 %{_desktopdir}/ufraw.desktop
167 %{_pixmapsdir}/ufraw.png
168 %{_sysconfdir}/gconf/schemas/%{name}.schemas
169 %{_datadir}/appdata/ufraw.appdata.xml
170 %{_mandir}/man1/ufraw.1*
171
172 %files batch
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/ufraw-batch
175
176 %if %{with gimp}
177 %files -n gimp-plugin-ufraw
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{gimp_plugindir}/ufraw-gimp
180 %endif
This page took 0.120831 seconds and 4 git commands to generate.