]> git.pld-linux.org Git - packages/tzdata.git/blob - tzdata.spec
686ff46b37c141cb77fc724f9ad89cd33592ca5d
[packages/tzdata.git] / tzdata.spec
1 #
2 # Conditional build
3 %bcond_without  tests           # make check
4 %bcond_with             java            # build java subpackage
5
6 %define         tzcode_ver      2010j
7 %define         tzdata_ver      2010j
8 Summary:        Timezone data
9 Summary(pl.UTF-8):      Dane o strefach czasowych
10 Name:           tzdata
11 Version:        %{tzdata_ver}
12 Release:        1
13 License:        Public Domain (database), BSD/LGPL v2.1+ (code/test suite)
14 Group:          Base
15 Source0:        %{name}-base-0.tar.bz2
16 # Source0-md5:  906a4c98cc5240f416524a256b039c42
17 Source1:        ftp://elsie.nci.nih.gov/pub/%{name}%{tzdata_ver}.tar.gz
18 # Source1-md5:  f668f66b260e14b477eac3f48bcfb5f4
19 Source2:        ftp://elsie.nci.nih.gov/pub/tzcode%{tzcode_ver}.tar.gz
20 # Source2-md5:  5ba8345720296d3a659b349b2052d139
21 Source3:        timezone.init
22 Source4:        timezone.sysconfig
23 Source5:        javazic.tar.gz
24 # Source5-md5:  6a3392cd5f1594d13c12c1a836ac8d91
25 Patch0:         %{name}-test-update.patch
26 Patch1:         javazic-fixup.patch
27 URL:            http://www.twinsun.com/tz/tz-link.htm
28 BuildRequires:  rpmbuild(macros) >= 1.228
29 Requires(post,preun):   /sbin/chkconfig
30 Requires:       /sbin/chkconfig
31 Requires:       rc-scripts >= 0.4.1.4
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This package contains data files with rules for various timezones
37 around the world.
38
39 %description -l pl.UTF-8
40 Ten pakiet zawiera pliki z danymi na temat reguł stref czasowych na
41 całym świecie.
42
43 %package java
44 Summary:        Timezone data for Java
45 Group:          Base
46
47 %description java
48 This package contains timezone information for use by Java runtimes.
49
50 %package zoneinfo_right
51 Summary:        Non-POSIX (real) time zones
52 Summary(es.UTF-8):      Zonas de tiempo reales (no de POSIX)
53 Summary(pl.UTF-8):      Nie-POSIX-owe (prawdziwe) strefy czasowe
54 Group:          Libraries
55 Obsoletes:      glibc-zoneinfo_right
56
57 %description zoneinfo_right
58 You don't want this. Details at:
59 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
60
61 %description zoneinfo_right -l es.UTF-8
62 No lo necesita. Encontrará los detalles en:
63 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
64
65 %description zoneinfo_right -l pl.UTF-8
66 Nie potrzebujesz tego. Szczegóły pod:
67 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
68
69 %package devel
70 Summary:        tzfile header file
71 Summary(pl.UTF-8):      Plik nagłówkowy tzfile
72 Group:          Development/Libraries
73
74 %description devel
75 Header file for timezone database.
76
77 %description devel -l pl.UTF-8
78 Plik nagłówkowy bazy danych stref czasowych.
79
80 %prep
81 %setup -qc
82 mv tzdata/* .
83 %{__tar} xzf %{SOURCE1} -C tzdata
84 mkdir tzcode
85 %{__tar} xzf %{SOURCE2} -C tzcode
86 %patch0 -p1
87
88 sed -e "
89 s|@objpfx@|`pwd`/obj/|
90 s|@datadir@|%{_datadir}|
91 s|@install_root@|$RPM_BUILD_ROOT|
92 " 'Makeconfig.in' > Makeconfig
93
94 grep -v tz-art.htm tzcode/tz-link.htm > tzcode/tz-link.html
95
96 %if %{with java}
97 install -d javazic
98 tar zxf %{SOURCE5} -C javazic
99 cd javazic
100 %patch1
101
102 # Hack alert! sun.tools may be defined and installed in the
103 # VM. In order to guarantee that we are using IcedTea/OpenJDK
104 # for creating the zoneinfo files, rebase all the packages
105 # from "sun." to "rht.". Unfortunately, gcj does not support
106 # any of the -Xclasspath options, so we must go this route
107 # to ensure the greatest compatibility.
108 # XXX: do we want 'pld' instead of 'rht'?
109 mv sun rht
110 find . -type f -name '*.java' -print0 \
111         | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
112                                                  -e 's:sun\.util\.:rht.util.:g'
113 cd -
114 %endif
115
116 %build
117 %{__make}
118
119 %if %{with java}
120 cd javazic
121 %javac -source 1.5 -target 1.5 -classpath . $(find -name '*.java')
122 cd ../tzdata
123 %java -classpath ../javazic/ rht.tools.javazic.Main -V %{version} \
124         -d ../zoneinfo/java \
125         africa antarctica asia australasia europe northamerica pacificnew \
126         southamerica backward etcetera solar87 solar88 solar89 systemv \
127         ../javazic/tzdata_jdk/gmt ../javazic/tzdata_jdk/jdk11_backward
128 cd ..
129 %endif
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
134 install -d $RPM_BUILD_ROOT%{_includedir}
135 install -d $RPM_BUILD_ROOT%{_mandir}/man5
136
137 %{__make} install
138
139 %if %{with tests}
140 : ====================TESTING=========================
141 %{__make} check \
142         CC="%{__cc}" \
143         CFLAGS="%{rpmcflags} %{rpmldflags}"
144 : ====================TESTING END=====================
145 %endif
146
147 # glibc.spec didn't keep it. so won't here either.
148 rm -rf $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posix
149 # behave more like glibc.spec
150 ln -sf %{_sysconfdir}/localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/localtime
151 ln -sf localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posixtime
152 ln -sf localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posixrules
153
154 > $RPM_BUILD_ROOT/etc/localtime
155
156 # header file
157 cp -a tzcode/tzfile.h $RPM_BUILD_ROOT%{_includedir}/tzfile.h
158 cp -a tzcode/tzfile.5 $RPM_BUILD_ROOT%{_mandir}/man5
159
160 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/timezone
161 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/timezone
162
163 %if %{with java}
164 cp -a zoneinfo/java $RPM_BUILD_ROOT%{_datadir}/javazi
165 %endif
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post
171 /sbin/chkconfig --add timezone
172 %service timezone restart
173
174 %preun
175 if [ "$1" = "0" ]; then
176         /sbin/chkconfig --del timezone
177
178         # save for postun
179         cp -f /etc/localtime /etc/localtime.rpmsave
180 fi
181
182 %postun
183 if [ "$1" = "0" ]; then
184         if [ ! -f /etc/localtime -a -f /etc/localtime.rpmsave ]; then
185                 mv -f /etc/localtime{.rpmsave,}
186         fi
187 fi
188
189 %triggerpostun -- rc-scripts < 0.4.1.4
190 /sbin/chkconfig --add timezone
191
192 %triggerpostun -- tzdata < 2008b-4
193 if ! grep -q '^TIMEZONE=' /etc/sysconfig/timezone; then
194         . /etc/sysconfig/timezone
195
196         if [ -z $ZONE_INFO_AREA ]; then
197                 TIMEZONE=$TIME_ZONE
198         else
199                 TIMEZONE=$ZONE_INFO_AREA/$TIME_ZONE
200         fi
201
202         echo "TIMEZONE=\"$TIMEZONE\"" >> /etc/sysconfig/timezone
203
204         %service timezone restart
205 fi
206
207 %files
208 %defattr(644,root,root,755)
209 %doc tzcode/README tzcode/Theory tzcode/tz-link.html
210 %ghost /etc/localtime
211 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/timezone
212 %attr(754,root,root) /etc/rc.d/init.d/timezone
213
214 %{_datadir}/zoneinfo
215 %exclude %{_datadir}/zoneinfo/right
216
217 %if %{with java}
218 %files java
219 %defattr(644,root,root,755)
220 %{_datadir}/javazi
221 %endif
222
223 %files zoneinfo_right
224 %defattr(644,root,root,755)
225 %{_datadir}/zoneinfo/right
226
227 %files devel
228 %defattr(644,root,root,755)
229 %doc tzcode/tzfile.5.txt
230 %{_includedir}/tzfile.h
231 %{_mandir}/man5/tzfile.5*
This page took 0.05252 seconds and 2 git commands to generate.