]> git.pld-linux.org Git - packages/tvheadend.git/blob - tvheadend.spec
cleanups; useradd/del deps
[packages/tvheadend.git] / tvheadend.spec
1 # TODO
2 Summary:        TV streaming server
3 Name:           tvheadend
4 # keep stable version announced on web page
5 %define vername 3.4patch1
6 Version:        3.4.27
7 Release:        0.1
8 License:        GPL v3
9 Group:          Applications/Multimedia
10 Source0:        https://github.com/tvheadend/tvheadend/archive/%{vername}.tar.gz
11 # Source0-md5:  86d1be0ad6e02bd2aecd3d529a026797
12 Source1:        %{name}.conf
13 Source2:        %{name}.service
14 Source3:        %{name}.sysconfig
15 Source4:        %{name}.init
16 URL:            https://tvheadend.org/projects/tvheadend
17 BuildRequires:  avahi-devel
18 BuildRequires:  curl-devel
19 BuildRequires:  python-modules
20 BuildRequires:  rpmbuild(macros) >= 1.647
21 BuildRequires:  zlib-devel
22 Requires(post): pwgen
23 Requires(post): sed >= 4.0
24 Requires(post,preun):   /sbin/chkconfig
25 Requires(post,preun,postun):    systemd-units >= 38
26 Requires(postun):       /usr/sbin/userdel
27 Requires(pre):  /bin/id
28 Requires(pre):  /usr/sbin/useradd
29 Requires:       group(video)
30 Requires:       systemd-units >= 0.38
31 Provides:       user(tvheadend)
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Tvheadend is a TV streaming server for Linux supporting DVB-S, DVB-S2,
36 DVB-C, DVB-T, ATSC, IPTV, and Analog video (V4L) as input sources.
37
38 %prep
39 %setup -q -n %{name}-%{vername}
40
41 %build
42 export CFLAGS="%{rpmcflags}"
43 export CC="%{__cc}"
44
45 # tvheadend uses a custom script, so %%configure cannot be used
46 # as not all options are supported
47 ./configure \
48         --release \
49         --prefix=%{_prefix} \
50         --libdir=%{_libdir} \
51         --mandir=%{_mandir}/man1
52
53 %{__make} V=1
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/.hts/%{name}/accesscontrol \
58         $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/Videos \
59         $RPM_BUILD_ROOT%{systemdunitdir} \
60         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/.hts/%{name}/accesscontrol/1
66 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
67 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
68 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
69
70 chmod +x $RPM_BUILD_ROOT%{_bindir}/%{name}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %pre
76 # FIXME: use registered uid!
77 %useradd -u 20 -d %{_localstatedir}/lib/%{name} -g video -G usb -c "tvheadend User" tvheadend
78
79 %post
80 /sbin/chkconfig --add tvheadend
81 %service tvheadend reload "tvheadend"
82 %systemd_post %{name}.service
83
84 # check if the access control file still has the initial dummy password, and
85 # replace the dummy password by a random, 12-character pwgen-generated password
86 if  grep -q '"password": "dummypassword"' %{_localstatedir}/lib/%{name}/.hts/%{name}/accesscontrol/1; then
87         sed -i "s,\"password\": \"dummypassword\",\"password\": \"$(pwgen -s 12 1)\"," %{_localstatedir}/lib/%{name}/.hts/%{name}/accesscontrol/1
88 fi
89
90 %preun
91 if [ "$1" = "0" ]; then
92         %service tvheadend stop
93         /sbin/chkconfig --del tvheadend
94 fi
95 %systemd_preun %{name}.service
96
97 %postun
98 if [ "$1" = "0" ]; then
99         %userremove tvheadend
100 fi
101 %systemd_reload
102
103 %files
104 %defattr(644,root,root,755)
105 %doc docs
106 %attr(755,root,root) %{_bindir}/%{name}
107 %attr(754,root,root) /etc/rc.d/init.d/tvheadend
108 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
109 %{_mandir}/man1/%{name}.1*
110 %{_datadir}/%{name}
111 %{systemdunitdir}/%{name}.service
112
113 # home directory and config file
114 %dir %attr(755,tvheadend,root) %{_localstatedir}/lib/%{name}
115 %dir %attr(755,tvheadend,video) %{_localstatedir}/lib/%{name}/Videos
116 %dir %attr(750,tvheadend,video) %{_localstatedir}/lib/%{name}/.hts
117 %dir %attr(750,tvheadend,video) %{_localstatedir}/lib/%{name}/.hts/%{name}
118 %dir %attr(750,tvheadend,video) %{_localstatedir}/lib/%{name}/.hts/%{name}/accesscontrol
119 %attr(600,tvheadend,video) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/lib/%{name}/.hts/%{name}/accesscontrol/1
This page took 0.031646 seconds and 4 git commands to generate.