]> git.pld-linux.org Git - packages/trousers.git/blob - trousers.spec
rebuild with openssl 3.0.0
[packages/trousers.git] / trousers.spec
1 # TODO: tcsd init script (see dist/fedora/fedora.initrd.tcsd)
2 #
3 # Conditional build:
4 %bcond_with     gtk     # use GTK+ popups instead of openssl
5 #
6 Summary:        TrouSerS - The open-source TCG Software Stack
7 Summary(pl.UTF-8):      TrouSerS - programowy stos TCG o otwartych źródłach
8 Name:           trousers
9 Version:        0.3.15
10 Release:        2
11 License:        BSD
12 Group:          Applications/System
13 Source0:        http://downloads.sourceforge.net/trousers/%{name}-%{version}.tar.gz
14 # Source0-md5:  eb1b02e98c7d360749b9076196db3f0f
15 Source1:        tcsd.service
16 Patch0:         no_inline.patch
17 URL:            http://trousers.sourceforge.net/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake >= 1.6
20 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.0.0}
21 BuildRequires:  libtool
22 BuildRequires:  openssl-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  rpmbuild(macros) >= 1.644
25 BuildRequires:  sed >= 4.0
26 Requires(pre):  /bin/id
27 Requires(pre):  /usr/bin/getgid
28 Requires(pre):  /usr/sbin/groupadd
29 Requires(pre):  /usr/sbin/useradd
30 Requires(postun):       /usr/sbin/groupdel
31 Requires(postun):       /usr/sbin/userdel
32 Requires:       %{name}-libs = %{version}-%{release}
33 Requires:       systemd-units >= 38
34 Provides:       group(tss)
35 Provides:       user(tss)
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 TrouSerS is an open-source TCG Software Stack (TSS), released under
40 the Common Public License. TrouSerS aims to be compliant with the 1.1b
41 and 1.2 TSS specifications available from the Trusted Computing Group
42 website: <http://www.trustedcomputinggroup.org/>.
43
44 %description -l pl.UTF-8
45 TrouSerS to programowy stos TCG (TSS, czyli TCG Software Stack) o
46 otwartych źródłach wydany na licencji Common Public License. Celem
47 projektu jest zgodność ze specyfikacjami TSS 1.1b i 1.2 dostępnymi na
48 stronie Trusted Computing Group:
49 <http://www.trustedcomputinggroup.org/>.
50
51 %package libs
52 Summary:        TrouSerS shared library
53 Summary(pl.UTF-8):      Biblioteka współdzielona TrouSerS
54 Group:          Libraries
55
56 %description libs
57 TrouSerS shared library.
58
59 %description libs -l pl.UTF-8
60 Biblioteka współdzielona TrouSerS.
61
62 %package devel
63 Summary:        Header files for TrouSerS library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TrouSerS
65 Group:          Development/Libraries
66 Requires:       %{name}-libs = %{version}-%{release}
67 %{?with_gtk:Requires:   gtk+2-devel >= 1:2.0.0}
68 Requires:       openssl-devel
69
70 %description devel
71 Header files for TrouSerS library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki TrouSerS.
75
76 %package static
77 Summary:        Static TrouSerS library
78 Summary(pl.UTF-8):      Statyczna biblioteka TrouSerS
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static TrouSerS library.
84
85 %description static -l pl.UTF-8
86 Statyczna biblioteka TrouSerS.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         --enable-static \
99         %{?with_gtk:--with-gui=gtk} \
100         --disable-usercheck
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT%{systemdunitdir}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 install %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/tcsd.service
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %pre
116 %groupadd -g 139 tss
117 %useradd -u 139 -d %{_localstatedir}/lib/tpm -s /bin/false -c "TrouSerS user" -g tss tss
118
119 %post
120 %systemd_post tcsd.service
121
122 %preun
123 %systemd_preun tcsd.service
124
125 %postun
126 if [ "$1" = "0" ]; then
127         %userremove tss
128         %groupremove tss
129 fi
130 %systemd_reload
131
132 %post   libs -p /sbin/ldconfig
133 %postun libs -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog LICENSE NICETOHAVES README README.selinux TODO
138 %attr(755,root,root) %{_sbindir}/tcsd
139 %attr(640,root,tss) %{_sysconfdir}/tcsd.conf
140 %attr(700,tss,tss) %{_localstatedir}/lib/tpm
141 %{_mandir}/man5/tcsd.conf.5*
142 %{_mandir}/man8/tcsd.8*
143 %{systemdunitdir}/tcsd.service
144
145 %files libs
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libtspi.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libtspi.so.1
149
150 %files devel
151 %defattr(644,root,root,755)
152 %doc doc/{LTC-TSS_LLD_08_r2.pdf,TSS_programming_SNAFUs.txt}
153 %attr(755,root,root) %{_libdir}/libtspi.so
154 %{_libdir}/libtspi.la
155 %{_libdir}/libtddl.a
156 %{_includedir}/trousers
157 %{_includedir}/tss
158 %{_mandir}/man3/Tspi_*.3*
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/libtspi.a
This page took 0.558643 seconds and 3 git commands to generate.