]> git.pld-linux.org Git - packages/trousers.git/blob - trousers.spec
- updated to 0.3.6
[packages/trousers.git] / trousers.spec
1 # TODO: tcsd init script (see dist/fedora/fedora.initrd.tcsd)
2 #
3 # Conditional build:
4 %bcond_with     gtk     # use GTK+ popups instead of openssl
5 #
6 Summary:        TrouSerS - The open-source TCG Software Stack
7 Summary(pl.UTF-8):      TrouSerS - programowy stos TCG o otwartych źródłach
8 Name:           trousers
9 Version:        0.3.6
10 Release:        1
11 License:        CPL v1.0
12 Group:          Applications/System
13 Source0:        http://downloads.sourceforge.net/trousers/%{name}-%{version}.tar.gz
14 # Source0-md5:  f4609e6446099e1403e23bb671df87f4
15 Patch0:         %{name}-nouser.patch
16 URL:            http://trousers.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake >= 1.6
19 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.0.0}
20 BuildRequires:  libtool
21 BuildRequires:  openssl-devel
22 BuildRequires:  pkgconfig
23 Requires(pre):  /bin/id
24 Requires(pre):  /usr/bin/getgid
25 Requires(pre):  /usr/sbin/groupadd
26 Requires(pre):  /usr/sbin/useradd
27 Requires(postun):       /usr/sbin/groupdel
28 Requires(postun):       /usr/sbin/userdel
29 Requires:       %{name}-libs = %{version}-%{release}
30 Provides:       group(tss)
31 Provides:       user(tss)
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 TrouSerS is an open-source TCG Software Stack (TSS), released under
36 the Common Public License. TrouSerS aims to be compliant with the 1.1b
37 and 1.2 TSS specifications available from the Trusted Computing Group
38 website: <http://www.trustedcomputinggroup.org/>.
39
40 %description -l pl.UTF-8
41 TrouSerS to programowy stos TCG (TSS, czyli TCG Software Stack) o
42 otwartych źródłach wydany na licencji Common Public License. Celem
43 projektu jest zgodność ze specyfikacjami TSS 1.1b i 1.2 dostępnymi na
44 stronie Trusted Computing Group:
45 <http://www.trustedcomputinggroup.org/>.
46
47 %package libs
48 Summary:        TrouSerS shared library
49 Summary(pl.UTF-8):      Biblioteka współdzielona TrouSerS
50 Group:          Libraries
51
52 %description libs
53 TrouSerS shared library.
54
55 %description libs -l pl.UTF-8
56 Biblioteka współdzielona TrouSerS.
57
58 %package devel
59 Summary:        Header files for TrouSerS library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TrouSerS
61 Group:          Development/Libraries
62 Requires:       %{name}-libs = %{version}-%{release}
63 %{?with_gtk:Requires:   gtk+2-devel >= 1:2.0.0}
64 Requires:       openssl-devel
65
66 %description devel
67 Header files for TrouSerS library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki TrouSerS.
71
72 %package static
73 Summary:        Static TrouSerS library
74 Summary(pl.UTF-8):      Statyczna biblioteka TrouSerS
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static TrouSerS library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka TrouSerS.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__automake}
93 %configure \
94         --enable-static \
95         %{?with_gtk:--with-gui=gtk}
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %pre
108 %groupadd -g 139 tss
109 %useradd -u 139 -d %{_localstatedir}/lib/tpm -s /bin/false -c "TrouSerS user" -g tss tss
110
111 %postun
112 if [ "$1" = "0" ]; then
113         %userremove tss
114         %groupremove tss
115 fi
116
117 %post   libs -p /sbin/ldconfig
118 %postun libs -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog LICENSE NICETOHAVES README README.selinux TODO
123 %attr(755,root,root) %{_sbindir}/tcsd
124 %attr(640,root,tss) %{_sysconfdir}/tcsd.conf
125 %attr(700,tss,tss) %{_localstatedir}/lib/tpm
126 %{_mandir}/man5/tcsd.conf.5*
127 %{_mandir}/man8/tcsd.8*
128
129 %files libs
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libtspi.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libtspi.so.1
133
134 %files devel
135 %defattr(644,root,root,755)
136 %doc doc/{LTC-TSS_LLD_08_r2.pdf,TSS_programming_SNAFUs.txt}
137 %attr(755,root,root) %{_libdir}/libtspi.so
138 %{_libdir}/libtspi.la
139 %{_libdir}/libtddl.a
140 %{_includedir}/trousers
141 %{_includedir}/tss
142 %{_mandir}/man3/Tspi_*.3*
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libtspi.a
This page took 0.12688 seconds and 3 git commands to generate.