]> git.pld-linux.org Git - packages/totem.git/blob - totem.spec
- up to 1.4.1
[packages/totem.git] / totem.spec
1 #
2 # TODO:
3 # - what more bowsers can be supported?
4 #
5 # Conditional build
6 %bcond_with     mozilla_firefox # build with mozilla-firefox
7 %bcond_without  gstreamer       # build with gstreamer instead xine-lib
8 %bcond_without  nvtv            # build without nvtv support
9 #
10 # nvtv only available on few archs
11 %ifnarch alpha arm %{ix86} ia64 sh %{x8664}
12 %undefine               with_nvtv
13 %endif
14 #
15 Summary:        Movie player for GNOME 2 based on the gstreamer engine
16 Summary(pl):    Odtwarzacz filmów dla GNOME 2 oparty na silniku gstreamer
17 Name:           totem
18 Version:        1.4.1
19 Release:        2
20 License:        GPL
21 Group:          Applications/Multimedia
22 Source0:        http://ftp.gnome.org/pub/gnome/sources/totem/1.4/%{name}-%{version}.tar.bz2
23 # Source0-md5:  6788b83f7889f61eef5922f4daecd859
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-idl.patch
26 Patch2:         %{name}-mozilla_includes.patch
27 Patch3:         %{name}-configure.patch
28 URL:            http://www.hadess.net/totem.php3
29 BuildRequires:  GConf2-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  dbus-glib-devel >= 0.35
33 BuildRequires:  gnome-desktop-devel
34 BuildRequires:  gnome-vfs2-devel >= 2.14.0
35 BuildRequires:  rpmbuild(macros) >= 1.236
36 %if %{with gstreamer}
37 BuildRequires:  gstreamer-plugins-base-devel >= 0.10
38 %endif
39 BuildRequires:  gtk+2-devel >= 2:2.8.3
40 BuildRequires:  intltool >= 0.34
41 BuildRequires:  iso-codes
42 BuildRequires:  libglade2-devel
43 BuildRequires:  libgnomeui-devel >= 2.14.0
44 BuildRequires:  libmusicbrainz-devel
45 %{?with_nvtv:BuildRequires:     libnvtvsimple-devel >= 0.4.5}
46 BuildRequires:  libtool
47 BuildRequires:  lirc-devel
48 %if %{with mozilla_firefox}
49 BuildRequires:  mozilla-firefox-devel
50 %else
51 BuildRequires:  mozilla-devel >= 5:1.7.12
52 %endif
53 BuildRequires:  nautilus-cd-burner-devel >= 2.14.0
54 BuildRequires:  nautilus-devel >= 2.14.0
55 BuildRequires:  pkgconfig
56 BuildRequires:  rpmbuild(macros) >= 1.197
57 BuildRequires:  scrollkeeper
58 %{!?with_gstreamer:BuildRequires:       xine-lib-devel >= 2:1.0.2-1}
59 BuildRequires:  xorg-lib-libXv-devel
60 Requires(post,postun):  scrollkeeper
61 Requires(post,preun):   GConf2
62 Requires:       %{name}-libs = %{version}-%{release}
63 %if %{with gstreamer}
64 Requires:       gstreamer-GConf >= 0.10
65 Requires:       gstreamer-audiosink >= 0.10
66 Requires:       gstreamer-videosink >= 0.10
67 %else
68 Requires:       xine-plugin-video
69 %endif
70 Requires:       gtk+2 >= 2:2.8.3
71 %if %{with mozilla_firefox}
72 %requires_eq    mozilla-firefox
73 %else
74 %endif
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         _plugindir      %{_libdir}/browser-plugins
78
79 # list of supported browsers, in free form text
80 %define         browsers        mozilla, mozilla-firefox, netscape, seamonkey
81
82 %if %{with gstreamer}
83 %description
84 Totem is simple movie player for the GNOME desktop based on gstreamer.
85 It features a simple playlist, a full-screen mode, seek and volume
86 controls, as well as a pretty complete keyboard navigation.
87
88 %description -l pl
89 Totem to prosty odtwarzacz filmów dla ¶rodowiska GNOME oparty na
90 gstreamer. Ma prost± listê odtwarzania, tryb pe³noekranowy, kontrolê
91 po³o¿enia w pliku i g³o¶no¶ci, a tak¿e w miarê kompletn± obs³ugê z
92 klawiatury.
93
94 %else
95 %description
96 Totem is simple movie player for the GNOME desktop based on xine-libs.
97 It features a simple playlist, a full-screen mode, seek and volume
98 controls, as well as a pretty complete keyboard navigation.
99
100 %description -l pl
101 Totem to prosty odtwarzacz filmów dla ¶rodowiska GNOME oparty na
102 xine-libs. Ma prost± listê odtwarzania, tryb pe³noekranowy, kontrolê
103 po³o¿enia w pliku i g³o¶no¶ci, a tak¿e w miarê kompletn± obs³ugê z
104 klawiatury.
105 %endif
106
107 %package libs
108 Summary:        Totem shared libraries
109 Summary(pl):    Wspó³dzielone biblioteki Totema
110 Group:          Libraries
111 Requires:       nautilus-libs >= 2.14.0
112
113 %description libs
114 Totem shared libraries.
115
116 %description libs -l pl
117 Wspó³dzielone biblioteki Totema.
118
119 %package devel
120 Summary:        Totem include files
121 Summary(pl):    Pliki nag³ówkowe Totema
122 Group:          Development/Libraries
123 Requires:       %{name}-libs = %{version}-%{release}
124 Requires:       gtk+2-devel >= 2:2.8.3
125
126 %description devel
127 Totem headers files.
128
129 %description devel -l pl
130 Pliki nag³ówkowe Totema.
131
132 %package static
133 Summary:        Static Totem libraries
134 Summary(pl):    Statyczne biblioteki Totema
135 Group:          Development/Libraries
136 Requires:       %{name}-devel = %{version}-%{release}
137
138 %description static
139 Static Totem libraries.
140
141 %description static -l pl
142 Statyczne biblioteki Totema.
143
144 %package -n browser-plugin-%{name}
145 Summary:        Totem's browser plugin
146 Summary(pl):    Wtyczka Totema do przegl±darek WWW
147 Group:          X11/Libraries
148 Requires:       %{name} = %{version}-%{release}
149 Requires:       browser-plugins(%{_target_base_arch})
150 Provides:       mozilla-firefox-plugin-totem
151 Provides:       mozilla-plugin-totem
152 Obsoletes:      mozilla-firefox-plugin-totem
153 Obsoletes:      mozilla-plugin-totem
154
155 %description -n browser-plugin-%{name}
156 Totem's plugin for browsers.
157
158 Supported browsers: %{browsers}.
159
160 %description -n browser-plugin-%{name} -l pl
161 Wtyczka Totem do przegl±darek WWW.
162
163 Obs³ugiwane przegl±darki: %{browsers}.
164
165 %prep
166 %setup -q
167 %patch0 -p1
168 %patch1 -p1
169 %patch2 -p1
170 %patch3 -p1
171
172 %build
173 %{__libtoolize}
174 %{__aclocal}
175 %{__autoconf}
176 %{__automake}
177 %configure \
178         --enable-lirc \
179         --enable-mozilla \
180         --enable-nautilus \
181         %{?with_nvtv:--enable-nvtv} \
182         %{?with_gstreamer:--enable-gstreamer}
183
184 %{__make} \
185         MOZILLA_IDLDIR="%{_datadir}/idl"
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189
190 %{__make} install \
191         DESTDIR=$RPM_BUILD_ROOT \
192         plugindir=%{_plugindir} \
193         typelibdir=%{_plugindir} \
194         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
195
196 rm -f $RPM_BUILD_ROOT%{_plugindir}/*.{la,a}
197 rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.{la,a}
198
199 %find_lang %{name} --all-name --with-gnome
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %post
205 %gconf_schema_install totem-handlers.schemas
206 %gconf_schema_install totem-video-thumbnail.schemas
207 %gconf_schema_install totem.schemas
208 %scrollkeeper_update_post
209 %update_desktop_database_post
210
211 %preun
212 %gconf_schema_uninstall totem-handlers.schemas
213 %gconf_schema_uninstall totem-video-thumbnail.schemas
214 %gconf_schema_uninstall totem.schemas
215
216 %postun
217 %scrollkeeper_update_postun
218 %update_desktop_database_postun
219
220 %post   libs -p /sbin/ldconfig
221 %postun libs -p /sbin/ldconfig
222
223 %triggerin -n browser-plugin-%{name} -- mozilla
224 %nsplugin_install -d %{_libdir}/mozilla/plugins libtotem_mozilla.{so,xpt}
225
226 %triggerun -n browser-plugin-%{name} -- mozilla
227 %nsplugin_uninstall -d %{_libdir}/mozilla/plugins libtotem_mozilla.{so,xpt}
228
229 %triggerin -n browser-plugin-%{name} -- mozilla-firefox
230 %nsplugin_install -d %{_libdir}/mozilla-firefox/plugins libtotem_mozilla.{so,xpt}
231
232 %triggerun -n browser-plugin-%{name} -- mozilla-forefox
233 %nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins libtotem_mozilla.{so,xpt}
234
235 %triggerin -n browser-plugin-%{name} -- netscape-common
236 %nsplugin_install -d %{_libdir}/netscape/plugins libtotem_mozilla.{so,xpt}
237
238 %triggerun -n browser-plugin-%{name} -- netscape-common
239 %nsplugin_uninstall -d %{_libdir}/netscape/plugins libtotem_mozilla.{so,xpt}
240
241 %triggerin -n browser-plugin-%{name} -- seamonkey
242 %nsplugin_install -d %{_libdir}/seamonkey/plugins libtotem_mozilla.{so,xpt}
243
244 %triggerun -n browser-plugin-%{name} -- seamonkey
245 %nsplugin_uninstall -d %{_libdir}/seamonkey/plugins libtotem_mozilla.{so,xpt}
246
247 # as rpm removes the old obsoleted package files after the triggers
248 # are ran, add another trigger to make the links there.
249 %triggerpostun -n browser-plugin-%{name} -- mozilla-plugin-%{name}
250 %nsplugin_install -f -d %{_libdir}/mozilla/plugins libtotem_mozilla.{so,xpt}
251
252 %triggerpostun -n browser-plugin-%{name} -- mozilla-firefox-plugin-%{name}
253 %nsplugin_install -f -d %{_libdir}/netscape/plugins libtotem_mozilla.{so,xpt}
254
255 %files -f %{name}.lang
256 %defattr(644,root,root,755)
257 %doc AUTHORS ChangeLog NEWS README TODO
258 %attr(755,root,root) %{_bindir}/*
259 %{_datadir}/%{name}
260 %{_desktopdir}/*.desktop
261 %{_mandir}/man1/*
262 %{_omf_dest_dir}/%{name}
263 %{_pixmapsdir}/*
264 %{_sysconfdir}/gconf/schemas/totem-handlers.schemas
265 %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas
266 %{_sysconfdir}/gconf/schemas/totem.schemas
267
268 %files libs
269 %defattr(644,root,root,755)
270 %attr(755,root,root) %{_libdir}/libtotem-plparser.so.*.*.*
271 %attr(755,root,root) %{_libdir}/nautilus/extensions-1.0/*.so
272
273 %files devel
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_libdir}/libtotem-plparser.so
276 %{_libdir}/libtotem-plparser.la
277 %{_includedir}/totem
278 %{_pkgconfigdir}/*
279
280 %files static
281 %defattr(644,root,root,755)
282 %{_libdir}/libtotem-plparser.a
283
284 %files -n browser-plugin-%{name}
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_libdir}/totem-mozilla-viewer
287 %attr(755,root,root) %{_plugindir}/*.so
288 %attr(755,root,root) %{_plugindir}/*.xpt
This page took 0.060978 seconds and 4 git commands to generate.