]> git.pld-linux.org Git - packages/totem.git/blob - totem.spec
66f8865da58124dff7999f7c1a223bdb05fa5fdb
[packages/totem.git] / totem.spec
1 #
2 # TODO:
3 # - what more bowsers can be supported?
4 #
5 # Conditional build
6 %bcond_without  gstreamer       # build with gstreamer instead xine-lib
7 %bcond_without  nvtv            # build without nvtv support
8 %bcond_without  lirc            # without lirc support
9 #
10 # nvtv only available on few archs
11 %ifnarch alpha arm %{ix86} ia64 sh %{x8664}
12 %undefine       with_nvtv
13 %endif
14 #
15 Summary:        Movie player for GNOME 2 based on the gstreamer engine
16 Summary(pl):    Odtwarzacz filmów dla GNOME 2 oparty na silniku gstreamer
17 Name:           totem
18 Version:        2.16.2
19 Release:        2
20 License:        GPL
21 Group:          Applications/Multimedia
22 Source0:        http://ftp.gnome.org/pub/gnome/sources/totem/2.16/%{name}-%{version}.tar.bz2
23 # Source0-md5:  6e98e3bc2b8531611906bd2bca73f743
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-idl.patch
26 Patch2:         %{name}-mozilla_includes.patch
27 Patch3:         %{name}-configure.patch
28 URL:            http://www.hadess.net/totem.php3
29 BuildRequires:  GConf2-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  dbus-glib-devel >= 0.71
33 BuildRequires:  gnome-desktop-devel >= 2.16.1
34 BuildRequires:  gnome-vfs2-devel >= 2.16.1
35 %if %{with gstreamer}
36 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.10
37 %endif
38 BuildRequires:  gtk+2-devel >= 2:2.10.5
39 BuildRequires:  intltool >= 0.35
40 BuildRequires:  iso-codes
41 BuildRequires:  libglade2-devel >= 1:2.6.0
42 BuildRequires:  libgnomeui-devel >= 2.16.0
43 BuildRequires:  libmusicbrainz-devel
44 %{?with_nvtv:BuildRequires:     libnvtvsimple-devel >= 0.4.5}
45 BuildRequires:  libtool
46 %{?with_lirc:BuildRequires:     lirc-devel}
47 BuildRequires:  mozilla-firefox-devel >= 1.5.0.7
48 BuildRequires:  nautilus-cd-burner-devel >= 2.16.1
49 BuildRequires:  nautilus-devel >= 2.16.1
50 BuildRequires:  pkgconfig
51 BuildRequires:  rpmbuild(macros) >= 1.311
52 BuildRequires:  scrollkeeper
53 %{!?with_gstreamer:BuildRequires:       xine-lib-devel >= 2:1.0.2-1}
54 BuildRequires:  xorg-lib-libXv-devel
55 Requires(post,preun):   GConf2 >= 2.14.0
56 Requires(post,postun):  gtk+2 >= 2:2.10.5
57 Requires(post,postun):  scrollkeeper
58 Requires:       %{name}-libs = %{version}-%{release}
59 %if %{with gstreamer}
60 Requires:       gstreamer-GConf >= 0.10.3
61 Requires:       gstreamer-audiosink >= 0.10
62 Requires:       gstreamer-videosink >= 0.10
63 %else
64 Requires:       xine-plugin-video
65 # unusable
66 Conflicts:      xine-input-gnome-vfs
67 %endif
68 Requires:       gtk+2 >= 2:2.10.5
69 Requires:       hicolor-icon-theme
70 Requires:       nautilus >= 2.16.1
71 %requires_eq    mozilla-firefox
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _plugindir      %{_libdir}/browser-plugins
75
76 # list of supported browsers, in free form text
77 %define         browsers        mozilla, mozilla-firefox, mozilla-firefox-bin, netscape, seamonkey
78
79 %if %{with gstreamer}
80 %description
81 Totem is simple movie player for the GNOME desktop based on gstreamer.
82 It features a simple playlist, a full-screen mode, seek and volume
83 controls, as well as a pretty complete keyboard navigation.
84
85 %description -l pl
86 Totem to prosty odtwarzacz filmów dla ¶rodowiska GNOME oparty na
87 gstreamer. Ma prost± listê odtwarzania, tryb pe³noekranowy, kontrolê
88 po³o¿enia w pliku i g³o¶no¶ci, a tak¿e w miarê kompletn± obs³ugê z
89 klawiatury.
90
91 %else
92 %description
93 Totem is simple movie player for the GNOME desktop based on xine-libs.
94 It features a simple playlist, a full-screen mode, seek and volume
95 controls, as well as a pretty complete keyboard navigation.
96
97 %description -l pl
98 Totem to prosty odtwarzacz filmów dla ¶rodowiska GNOME oparty na
99 xine-libs. Ma prost± listê odtwarzania, tryb pe³noekranowy, kontrolê
100 po³o¿enia w pliku i g³o¶no¶ci, a tak¿e w miarê kompletn± obs³ugê z
101 klawiatury.
102 %endif
103
104 %package libs
105 Summary:        Totem shared libraries
106 Summary(pl):    Wspó³dzielone biblioteki Totema
107 Group:          Libraries
108 Requires:       gnome-desktop-libs >= 2.16.1
109 Requires:       nautilus-libs >= 2.16.1
110
111 %description libs
112 Totem shared libraries.
113
114 %description libs -l pl
115 Wspó³dzielone biblioteki Totema.
116
117 %package devel
118 Summary:        Totem include files
119 Summary(pl):    Pliki nag³ówkowe Totema
120 Group:          Development/Libraries
121 Requires:       %{name}-libs = %{version}-%{release}
122 Requires:       gtk+2-devel >= 2:2.10.5
123
124 %description devel
125 Totem headers files.
126
127 %description devel -l pl
128 Pliki nag³ówkowe Totema.
129
130 %package static
131 Summary:        Static Totem libraries
132 Summary(pl):    Statyczne biblioteki Totema
133 Group:          Development/Libraries
134 Requires:       %{name}-devel = %{version}-%{release}
135
136 %description static
137 Static Totem libraries.
138
139 %description static -l pl
140 Statyczne biblioteki Totema.
141
142 %package -n browser-plugin-%{name}
143 Summary:        Totem's browser plugin
144 Summary(pl):    Wtyczka Totema do przegl±darek WWW
145 Group:          X11/Libraries
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       browser-plugins(%{_target_base_arch})
148 Provides:       mozilla-firefox-plugin-totem
149 Provides:       mozilla-plugin-totem
150 Obsoletes:      mozilla-firefox-plugin-totem
151 Obsoletes:      mozilla-plugin-totem
152
153 %description -n browser-plugin-%{name}
154 Totem's plugin for browsers.
155
156 Supported browsers: %{browsers}.
157
158 %description -n browser-plugin-%{name} -l pl
159 Wtyczka Totem do przegl±darek WWW.
160
161 Obs³ugiwane przegl±darki: %{browsers}.
162
163 %prep
164 %setup -q
165 %patch0 -p1
166 %patch1 -p1
167 %patch2 -p1
168 %patch3 -p1
169
170 %build
171 %{__libtoolize}
172 %{__aclocal}
173 %{__autoconf}
174 %{__automake}
175 %configure \
176         %{?with_lirc:--enable-lirc} \
177         --enable-mozilla \
178         --enable-nautilus \
179         %{?with_nvtv:--enable-nvtv} \
180         %{?with_gstreamer:--enable-gstreamer}
181
182 %{__make} \
183         MOZILLA_IDLDIR="%{_includedir}/mozilla-firefox/idl"
184
185 %install
186 rm -rf $RPM_BUILD_ROOT
187
188 %{__make} install \
189         DESTDIR=$RPM_BUILD_ROOT \
190         plugindir=%{_plugindir} \
191         typelibdir=%{_plugindir} \
192         xptdir=%{_plugindir} \
193         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
194
195 rm -f $RPM_BUILD_ROOT%{_plugindir}/*.{la,a}
196 rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.{la,a}
197
198 %find_lang %{name} --all-name --with-gnome
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post
204 %gconf_schema_install totem-handlers.schemas
205 %gconf_schema_install totem-video-thumbnail.schemas
206 %gconf_schema_install totem.schemas
207 %scrollkeeper_update_post
208 %update_desktop_database_post
209 %update_icon_cache hicolor
210
211 %preun
212 %gconf_schema_uninstall totem-handlers.schemas
213 %gconf_schema_uninstall totem-video-thumbnail.schemas
214 %gconf_schema_uninstall totem.schemas
215
216 %postun
217 %scrollkeeper_update_postun
218 %update_desktop_database_postun
219 %update_icon_cache hicolor
220
221 %post   libs -p /sbin/ldconfig
222 %postun libs -p /sbin/ldconfig
223
224 %triggerin -n browser-plugin-%{name} -- mozilla
225 %nsplugin_install -d %{_libdir}/mozilla/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
226
227 %triggerun -n browser-plugin-%{name} -- mozilla
228 %nsplugin_uninstall -d %{_libdir}/mozilla/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
229
230 %triggerin -n browser-plugin-%{name} -- mozilla-firefox
231 %nsplugin_install -d %{_libdir}/mozilla-firefox/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
232
233 %triggerun -n browser-plugin-%{name} -- mozilla-forefox
234 %nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
235
236 %triggerin -n browser-plugin-%{name} -- mozilla-firefox-bin
237 %nsplugin_install -d %{_libdir}/mozilla-firefox-bin/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
238
239 %triggerun -n browser-plugin-%{name} -- mozilla-forefox-bin
240 %nsplugin_uninstall -d %{_libdir}/mozilla-firefox-bin/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
241
242 %triggerin -n browser-plugin-%{name} -- netscape-common
243 %nsplugin_install -d %{_libdir}/netscape/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
244
245 %triggerun -n browser-plugin-%{name} -- netscape-common
246 %nsplugin_uninstall -d %{_libdir}/netscape/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
247
248 %triggerin -n browser-plugin-%{name} -- seamonkey
249 %nsplugin_install -d %{_libdir}/seamonkey/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
250
251 %triggerun -n browser-plugin-%{name} -- seamonkey
252 %nsplugin_uninstall -d %{_libdir}/seamonkey/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
253
254 # as rpm removes the old obsoleted package files after the triggers
255 # are ran, add another trigger to make the links there.
256 %triggerpostun -n browser-plugin-%{name} -- mozilla-plugin-%{name}
257 %nsplugin_install -f -d %{_libdir}/mozilla/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
258
259 %triggerpostun -n browser-plugin-%{name} -- mozilla-firefox-plugin-%{name}
260 %nsplugin_install -f -d %{_libdir}/netscape/plugins libtotem-{basic,complex,gmp,narrowspace}-plugin.{so,xpt}
261
262 %files -f %{name}.lang
263 %defattr(644,root,root,755)
264 %doc AUTHORS ChangeLog NEWS README TODO
265 %attr(755,root,root) %{_bindir}/*
266 %attr(755,root,root) %{_libdir}/nautilus/extensions-1.0/*.so
267 %{_datadir}/%{name}
268 %{_desktopdir}/*.desktop
269 %{_mandir}/man1/*
270 %{_omf_dest_dir}/%{name}
271 %{_iconsdir}/hicolor/*/*/totem.*
272 %{_pixmapsdir}/*
273 %{_sysconfdir}/gconf/schemas/totem-handlers.schemas
274 %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas
275 %{_sysconfdir}/gconf/schemas/totem.schemas
276
277 %files libs
278 %defattr(644,root,root,755)
279 %attr(755,root,root) %{_libdir}/libtotem-plparser.so.*.*.*
280
281 %files devel
282 %defattr(644,root,root,755)
283 %attr(755,root,root) %{_libdir}/libtotem-plparser.so
284 %{_libdir}/libtotem-plparser.la
285 %{_includedir}/totem
286 %{_pkgconfigdir}/*
287
288 %files static
289 %defattr(644,root,root,755)
290 %{_libdir}/libtotem-plparser.a
291
292 %files -n browser-plugin-%{name}
293 %defattr(644,root,root,755)
294 %attr(755,root,root) %{_libdir}/totem-mozilla-viewer
295 %attr(755,root,root) %{_plugindir}/*.so
296 %attr(755,root,root) %{_plugindir}/*.xpt
This page took 0.092808 seconds and 2 git commands to generate.