]> git.pld-linux.org Git - packages/tor.git/blob - tor.spec
- pl, some cleanups
[packages/tor.git] / tor.spec
1 Summary:        Anonymizing overlay network for TCP (The onion router)
2 Summary(pl):    Sieæ nak³adkowa dla TCP zapewniaj±ca anonimowo¶æ (router cebulowy)
3 Name:           tor
4 Version:        0.1.0.14
5 Release:        0.1
6 License:        BSD-like
7 Group:          Networking/Daemons
8 Source0:        http://tor.eff.org/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  a3698218371ed0e647886fef0545bb44
10 Source1:        %{name}.logrotate
11 URL:            http://tor.eff.org/
12 BuildRequires:  libevent-devel
13 BuildRequires:  openssl-devel >= 0.9.6
14 BuildRequires:  rpm-build >= 4.0
15 Requires(pre):  /bin/id
16 Requires(pre):  /usr/bin/getgid
17 Requires(pre):  /usr/sbin/groupadd
18 Requires(pre):  /usr/sbin/useradd
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Tor is a connection-based low-latency anonymous communication system.
23
24 This package provides the "tor" program, which serves as both a client
25 and a relay node. Scripts will automatically create a "tor"
26 user and group, and set tor up to run as a daemon when the system is
27 rebooted.
28
29 Applications connect to the local Tor proxy using the SOCKS protocol.
30 The local proxy chooses a path through a set of relays, in which each
31 relay knows its predecessor and successor, but no others. Traffic
32 flowing down the circuit is unwrapped by a symmetric key at each
33 relay, which reveals the downstream relay.
34
35 Warnings: Tor does no protocol cleaning. That means there is a danger
36 that application protocols and associated programs can be induced to
37 reveal information about the initiator. Tor depends on Privoxy and
38 similar protocol cleaners to solve this problem. This is alpha code,
39 and is even more likely than released code to have anonymity-spoiling
40 bugs. The present network is very small -- this further reduces the
41 strength of the anonymity provided. Tor is not presently suitable for
42 high-stakes anonymity.
43
44 %description -l pl
45 Tor to oparty na po³±czeniach system anonimowej komunikacji o ma³ych
46 opó¼nieniach.
47
48 Ten pakiet dostarcza program "tor", s³u¿±cy zarówno jako klient, jak i
49 wêze³ przeka¼nikowy. Skrypty automatycznie tworz± u¿ytkownika i grupê
50 "tor" i konfiguruj± tora do dzia³ania jako demon po uruchomieniu
51 systemu.
52
53 Aplikacje ³±cz± siê z lokalnym proxy Tor przy u¿yciu protoko³u SOCKS.
54 Lokalne proxy wybiera ¶cie¿kê poprzez zbiór przeka¼ników, z których
55 ka¿dy zna swojego poprzednika i nastêpnika, ale ¿adnego wiêcej. Ruch
56 przychodz±cy jest rozpakowywany przy u¿yciu klucza symetrycznego na
57 ka¿dym przeka¼niku, który ods³ania kolejny przeka¼nik.
58
59 Uwaga: Tor nie oczyszcza protoko³ów. Oznacza to, ¿e istnieje
60 niebezpieczeñstwo, ¿e protoko³y aplikacji i powi±zane programy mog±
61 odkryæ informacje o pochodzeniu. Tor polega na Privoxy i podobnych
62 oczyszczaczach protoko³ów w celu rozwi±zania tego problemu. To jest
63 kod alpha, wiêc mo¿e mieæ wiêcej b³êdów psuj±cych anonimowo¶æ ni¿ kod
64 wydany. Obecna sieæ jest bardzo ma³a - co w dalszym stopniu ogranicza
65 zapewnian± anonimowo¶æ. Tor aktualnie nie nadaje siê do zadañ
66 wymagaj±cych anonimowo¶ci na wysok± stawkê.
67
68 %prep
69 %setup -q
70
71 %build
72 %configure
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 mv $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/torrc{.sample,}
82 install -D contrib/tor.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
83 install -D %{SOURCE1}     $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
84
85 install -d $RPM_BUILD_ROOT/var/lib/%{name}
86 install -d $RPM_BUILD_ROOT/var/run/%{name}
87 install -d $RPM_BUILD_ROOT/var/log/{,archiv/}%{name}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %pre
93 %groupadd -g 156 tor
94 %useradd  -u 156 -r -d /var/lib/tor -s /bin/false -c "Tor" -g tor tor
95 # ???
96 /etc/rc.d/init.d/tor stop
97
98 %post
99 /sbin/chkconfig --add %{name}
100 %service %{name} restart
101
102 %preun
103 if [ "$1" = "0" ]; then
104         %service -q %{name} stop
105         /sbin/chkconfig --del %{name}
106         #%{__rm} -f ${_localstatedir}/lib/%{name}/cached-directory
107         #%{__rm} -f ${_localstatedir}/lib/%{name}/bw_accounting
108         #%{__rm} -f ${_localstatedir}/lib/%{name}/control_auth_cookie
109         #%{__rm} -f ${_localstatedir}/lib/%{name}/router.desc
110         #%{__rm} -f ${_localstatedir}/lib/%{name}/fingerprint
111 fi
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS INSTALL LICENSE README ChangeLog doc/HACKING doc/TODO doc/FAQ
116 %attr(755,root,root) %{_bindir}/*
117 %{_mandir}/man?/*
118 /etc/rc.d/init.d/%{name}
119 %dir %attr(755,root,tor) %{_sysconfdir}/%{name}
120 %attr(644,root,tor)  %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
121 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
122 %dir %attr(750,root,tor) /var/lib/%{name}
123 %dir %attr(750,root,tor) /var/run/%{name}
124 %dir %attr(750,root,tor) /var/log/{,archiv/}%{name}
This page took 0.037639 seconds and 4 git commands to generate.