]> git.pld-linux.org Git - packages/tor.git/blob - tor.spec
- release 1
[packages/tor.git] / tor.spec
1 Summary:        Anonymizing overlay network for TCP (The onion router)
2 Summary(pl):    Sieæ nak³adkowa dla TCP zapewniaj±ca anonimowo¶æ (router cebulowy)
3 Name:           tor
4 Version:        0.1.0.15
5 Release:        1
6 License:        BSD-like
7 Group:          Networking/Daemons
8 Source0:        http://tor.eff.org/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  b2f1002da96ebfbfac7edf2272733967
10 Source1:        %{name}.logrotate
11 Source2:        %{name}.init
12 Source3:        %{name}.sysconfig
13 URL:            http://tor.eff.org/
14 BuildRequires:  libevent-devel
15 BuildRequires:  openssl-devel >= 0.9.6
16 BuildRequires:  rpm-build >= 4.0
17 Requires(pre):  /bin/id
18 Requires(pre):  /usr/bin/getgid
19 Requires(pre):  /usr/sbin/groupadd
20 Requires(pre):  /usr/sbin/useradd
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Tor is a connection-based low-latency anonymous communication system.
25
26 This package provides the "tor" program, which serves as both a client
27 and a relay node. Scripts will automatically create a "tor"
28 user and group, and set tor up to run as a daemon when the system is
29 rebooted.
30
31 Applications connect to the local Tor proxy using the SOCKS protocol.
32 The local proxy chooses a path through a set of relays, in which each
33 relay knows its predecessor and successor, but no others. Traffic
34 flowing down the circuit is unwrapped by a symmetric key at each
35 relay, which reveals the downstream relay.
36
37 Warnings: Tor does no protocol cleaning. That means there is a danger
38 that application protocols and associated programs can be induced to
39 reveal information about the initiator. Tor depends on Privoxy and
40 similar protocol cleaners to solve this problem. This is alpha code,
41 and is even more likely than released code to have anonymity-spoiling
42 bugs. The present network is very small -- this further reduces the
43 strength of the anonymity provided. Tor is not presently suitable for
44 high-stakes anonymity.
45
46 %description -l pl
47 Tor to oparty na po³±czeniach system anonimowej komunikacji o ma³ych
48 opó¼nieniach.
49
50 Ten pakiet dostarcza program "tor", s³u¿±cy zarówno jako klient, jak i
51 wêze³ przeka¼nikowy. Skrypty automatycznie tworz± u¿ytkownika i grupê
52 "tor" i konfiguruj± tora do dzia³ania jako demon po uruchomieniu
53 systemu.
54
55 Aplikacje ³±cz± siê z lokalnym proxy Tor przy u¿yciu protoko³u SOCKS.
56 Lokalne proxy wybiera ¶cie¿kê poprzez zbiór przeka¼ników, z których
57 ka¿dy zna swojego poprzednika i nastêpnika, ale ¿adnego wiêcej. Ruch
58 przychodz±cy jest rozpakowywany przy u¿yciu klucza symetrycznego na
59 ka¿dym przeka¼niku, który ods³ania kolejny przeka¼nik.
60
61 Uwaga: Tor nie oczyszcza protoko³ów. Oznacza to, ¿e istnieje
62 niebezpieczeñstwo, ¿e protoko³y aplikacji i powi±zane programy mog±
63 odkryæ informacje o pochodzeniu. Tor polega na Privoxy i podobnych
64 oczyszczaczach protoko³ów w celu rozwi±zania tego problemu. To jest
65 kod alpha, wiêc mo¿e mieæ wiêcej b³êdów psuj±cych anonimowo¶æ ni¿ kod
66 wydany. Obecna sieæ jest bardzo ma³a - co w dalszym stopniu ogranicza
67 zapewnian± anonimowo¶æ. Tor aktualnie nie nadaje siê do zadañ
68 wymagaj±cych anonimowo¶ci na wysok± stawkê.
69
70 %prep
71 %setup -q
72
73 %build
74 %configure
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 mv $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/torrc{.sample,}
84 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
85 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
86 install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
87
88 install -d $RPM_BUILD_ROOT/var/lib/%{name}
89 install -d $RPM_BUILD_ROOT/var/run/%{name}
90 install -d $RPM_BUILD_ROOT/var/log/{,archiv/}%{name}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %pre
96 %groupadd -g 156 tor
97 %useradd  -u 156 -r -d /var/lib/tor -s /bin/false -c "Tor" -g tor tor
98
99 %post
100 /sbin/chkconfig --add %{name}
101 %service %{name} restart
102
103 %preun
104 if [ "$1" = "0" ]; then
105         %service -q %{name} stop
106         /sbin/chkconfig --del %{name}
107 fi
108
109 %postun
110 if [ "$1" = "0" ]; then
111         %userremove  tor
112         %groupremove tor
113 fi
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS INSTALL LICENSE README ChangeLog doc/HACKING doc/TODO doc/FAQ
118 %attr(755,root,root) %{_bindir}/*
119 %{_mandir}/man?/*
120 %attr(755,root,root) /etc/rc.d/init.d/%{name}
121 %dir %attr(750,root,tor) %{_sysconfdir}/%{name}
122 %attr(640,root,tor)  %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
123 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
124 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
125 %dir %attr(750,root,tor) /var/lib/%{name}
126 %dir %attr(750,root,tor) /var/run/%{name}
127 %dir %attr(750,root,tor) /var/log/%{name}
128 %dir %attr(750,root,tor) /var/log/archiv/%{name}
This page took 0.069176 seconds and 4 git commands to generate.