]> git.pld-linux.org Git - packages/tor.git/blob - tor.spec
- up to 0.4.6.7
[packages/tor.git] / tor.spec
1 Summary:        Anonymizing overlay network for TCP (The onion router)
2 Summary(pl.UTF-8):      Sieć nakładkowa dla TCP zapewniająca anonimowość (router cebulowy)
3 Name:           tor
4 Version:        0.4.6.7
5 Release:        1
6 License:        BSD-like
7 Group:          Networking/Daemons
8 Source0:        http://www.torproject.org/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  ff80309cfaa0719b197fdaf83f9d5443
10 Source1:        %{name}.logrotate
11 Source2:        %{name}.init
12 Source3:        %{name}.sysconfig
13 Source4:        %{name}.tmpfiles
14 URL:            http://www.torproject.org/
15 BuildRequires:  libevent-devel >= 1.1
16 BuildRequires:  openssl-devel >= 0.9.6
17 BuildRequires:  rpm-build >= 4.0
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 BuildRequires:  zlib-devel
20 Requires(post,preun):   /sbin/chkconfig
21 Requires(pre):  /bin/id
22 Requires(pre):  /usr/bin/getgid
23 Requires(pre):  /usr/sbin/groupadd
24 Requires(pre):  /usr/sbin/useradd
25 Requires:       rc-scripts
26 Provides:       group(tor)
27 Provides:       user(tor)
28 Conflicts:      logrotate < 3.7-4
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Tor is a connection-based low-latency anonymous communication system.
33
34 This package provides the "tor" program, which serves as both a client
35 and a relay node. Scripts will automatically create a "tor" user and
36 group, and set tor up to run as a daemon when the system is rebooted.
37
38 Applications connect to the local Tor proxy using the SOCKS protocol.
39 The local proxy chooses a path through a set of relays, in which each
40 relay knows its predecessor and successor, but no others. Traffic
41 flowing down the circuit is unwrapped by a symmetric key at each
42 relay, which reveals the downstream relay.
43
44 Warnings: Tor does no protocol cleaning. That means there is a danger
45 that application protocols and associated programs can be induced to
46 reveal information about the initiator. Tor depends on Privoxy and
47 similar protocol cleaners to solve this problem. This is alpha code,
48 and is even more likely than released code to have anonymity-spoiling
49 bugs. The present network is very small -- this further reduces the
50 strength of the anonymity provided. Tor is not presently suitable for
51 high-stakes anonymity.
52
53 %description -l pl.UTF-8
54 Tor to oparty na połączeniach system anonimowej komunikacji o małych
55 opóźnieniach.
56
57 Ten pakiet dostarcza program "tor", służący zarówno jako klient, jak i
58 węzeł przekaźnikowy. Skrypty automatycznie tworzą użytkownika i grupę
59 "tor" i konfigurują tora do działania jako demon po uruchomieniu
60 systemu.
61
62 Aplikacje łączą się z lokalnym proxy Tor przy użyciu protokołu SOCKS.
63 Lokalne proxy wybiera ścieżkę poprzez zbiór przekaźników, z których
64 każdy zna swojego poprzednika i następnika, ale żadnego więcej. Ruch
65 przychodzący jest rozpakowywany przy użyciu klucza symetrycznego na
66 każdym przekaźniku, który odsłania kolejny przekaźnik.
67
68 Uwaga: Tor nie oczyszcza protokołów. Oznacza to, że istnieje
69 niebezpieczeństwo, że protokoły aplikacji i powiązane programy mogą
70 odkryć informacje o pochodzeniu. Tor polega na Privoxy i podobnych
71 oczyszczaczach protokołów w celu rozwiązania tego problemu. To jest
72 kod alpha, więc może mieć więcej błędów psujących anonimowość niż kod
73 wydany. Obecna sieć jest bardzo mała - co w dalszym stopniu ogranicza
74 zapewnianą anonimowość. Tor aktualnie nie nadaje się do zadań
75 wymagających anonimowości na wysoką stawkę.
76
77 %prep
78 %setup -q
79
80 %build
81 %configure \
82         --disable-silent-rules
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT/var/{{lib,run}/%{name},log/{,archive/}%{name}} \
88         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 mv $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/torrc{.sample,}
94 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
95 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
96 install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
97 install %{SOURCE4} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %pre
103 %groupadd -g 156 tor
104 %useradd  -u 156 -r -d /var/lib/tor -s /bin/false -c "Tor" -g tor tor
105
106 %post
107 /sbin/chkconfig --add %{name}
108 %service %{name} restart
109
110 %preun
111 if [ "$1" = "0" ]; then
112         %service -q %{name} stop
113         /sbin/chkconfig --del %{name}
114 fi
115
116 %postun
117 if [ "$1" = "0" ]; then
118         %userremove  tor
119         %groupremove tor
120 fi
121
122 %files
123 %defattr(644,root,root,755)
124 %doc LICENSE README ChangeLog doc/HACKING
125 %attr(755,root,root) %{_bindir}/*
126 %{_mandir}/man1/*.1*
127 %attr(754,root,root) /etc/rc.d/init.d/%{name}
128 %dir %attr(750,root,tor) %{_sysconfdir}/%{name}
129 %attr(640,root,tor)  %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
130 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
132 /usr/lib/tmpfiles.d/%{name}.conf
133 %dir %attr(750,root,tor) /var/lib/%{name}
134 %dir %attr(750,root,tor) /var/run/%{name}
135 %dir %attr(750,root,tor) /var/log/%{name}
136 %dir %attr(750,root,tor) /var/log/archive
137 %dir %attr(750,root,tor) /var/log/archive/%{name}
138 %{_datadir}/tor
This page took 0.093455 seconds and 3 git commands to generate.