]> git.pld-linux.org Git - packages/tor.git/blob - tor.spec
- security blocker is obsolete. from ChangeLog:
[packages/tor.git] / tor.spec
1 Summary:        Anonymizing overlay network for TCP (The onion router)
2 Summary(pl.UTF-8):      Sieć nakładkowa dla TCP zapewniająca anonimowość (router cebulowy)
3 Name:           tor
4 Version:        0.2.0.34
5 Release:        1
6 License:        BSD-like
7 Group:          Networking/Daemons
8 Source0:        http://www.torproject.org/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  f20011be23d5a76988233df12c346f41
10 Source1:        %{name}.logrotate
11 Source2:        %{name}.init
12 Source3:        %{name}.sysconfig
13 URL:            http://www.torproject.org/
14 # http://archives.seul.org/or/announce/Feb-2009/msg00000.html
15 BuildRequires:  libevent-devel >= 1.1
16 BuildRequires:  openssl-devel >= 0.9.6
17 BuildRequires:  rpm-build >= 4.0
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(post,preun):   /sbin/chkconfig
20 Requires(pre):  /bin/id
21 Requires(pre):  /usr/bin/getgid
22 Requires(pre):  /usr/sbin/groupadd
23 Requires(pre):  /usr/sbin/useradd
24 Requires:       rc-scripts
25 Provides:       group(tor)
26 Provides:       user(tor)
27 Conflicts:      logrotate < 3.7-4
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Tor is a connection-based low-latency anonymous communication system.
32
33 This package provides the "tor" program, which serves as both a client
34 and a relay node. Scripts will automatically create a "tor" user and
35 group, and set tor up to run as a daemon when the system is rebooted.
36
37 Applications connect to the local Tor proxy using the SOCKS protocol.
38 The local proxy chooses a path through a set of relays, in which each
39 relay knows its predecessor and successor, but no others. Traffic
40 flowing down the circuit is unwrapped by a symmetric key at each
41 relay, which reveals the downstream relay.
42
43 Warnings: Tor does no protocol cleaning. That means there is a danger
44 that application protocols and associated programs can be induced to
45 reveal information about the initiator. Tor depends on Privoxy and
46 similar protocol cleaners to solve this problem. This is alpha code,
47 and is even more likely than released code to have anonymity-spoiling
48 bugs. The present network is very small -- this further reduces the
49 strength of the anonymity provided. Tor is not presently suitable for
50 high-stakes anonymity.
51
52 %description -l pl.UTF-8
53 Tor to oparty na połączeniach system anonimowej komunikacji o
54 małych opóźnieniach.
55
56 Ten pakiet dostarcza program "tor", służący zarówno jako klient,
57 jak i węzeł przekaźnikowy. Skrypty automatycznie tworzą
58 użytkownika i grupę "tor" i konfigurują tora do działania jako
59 demon po uruchomieniu systemu.
60
61 Aplikacje łączą się z lokalnym proxy Tor przy użyciu protokołu
62 SOCKS. Lokalne proxy wybiera ścieżkę poprzez zbiór przekaźników,
63 z których każdy zna swojego poprzednika i następnika, ale żadnego
64 więcej. Ruch przychodzący jest rozpakowywany przy użyciu klucza
65 symetrycznego na każdym przekaźniku, który odsłania kolejny
66 przekaźnik.
67
68 Uwaga: Tor nie oczyszcza protokołów. Oznacza to, że istnieje
69 niebezpieczeństwo, że protokoły aplikacji i powiązane programy
70 mogą odkryć informacje o pochodzeniu. Tor polega na Privoxy i
71 podobnych oczyszczaczach protokołów w celu rozwiązania tego
72 problemu. To jest kod alpha, więc może mieć więcej błędów
73 psujących anonimowość niż kod wydany. Obecna sieć jest bardzo
74 mała - co w dalszym stopniu ogranicza zapewnianą anonimowość. Tor
75 aktualnie nie nadaje się do zadań wymagających anonimowości na
76 wysoką stawkę.
77
78 %prep
79 %setup -q
80
81 %build
82 %configure
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 mv $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/torrc{.sample,}
92 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
93 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
94 install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
95
96 install -d $RPM_BUILD_ROOT/var/lib/%{name}
97 install -d $RPM_BUILD_ROOT/var/run/%{name}
98 install -d $RPM_BUILD_ROOT/var/log/{,archive/}%{name}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %pre
104 %groupadd -g 156 tor
105 %useradd  -u 156 -r -d /var/lib/tor -s /bin/false -c "Tor" -g tor tor
106
107 %post
108 /sbin/chkconfig --add %{name}
109 %service %{name} restart
110
111 %preun
112 if [ "$1" = "0" ]; then
113         %service -q %{name} stop
114         /sbin/chkconfig --del %{name}
115 fi
116
117 %postun
118 if [ "$1" = "0" ]; then
119         %userremove  tor
120         %groupremove tor
121 fi
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS INSTALL LICENSE README ChangeLog doc/HACKING doc/TODO
126 %attr(755,root,root) %{_bindir}/*
127 %{_mandir}/man?/*
128 %attr(754,root,root) /etc/rc.d/init.d/%{name}
129 %dir %attr(750,root,tor) %{_sysconfdir}/%{name}
130 %attr(640,root,tor)  %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
132 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
133 %dir %attr(750,root,tor) /var/lib/%{name}
134 %dir %attr(750,root,tor) /var/run/%{name}
135 %dir %attr(750,root,tor) /var/log/%{name}
136 %dir %attr(750,root,tor) /var/log/archive/%{name}
This page took 0.056505 seconds and 3 git commands to generate.