]> git.pld-linux.org Git - packages/tor.git/blob - tor.spec
- rel 2
[packages/tor.git] / tor.spec
1 Summary:        Anonymizing overlay network for TCP (The onion router)
2 Summary(pl):    Sieæ nak³adkowa dla TCP zapewniaj±ca anonimowo¶æ (router cebulowy)
3 Name:           tor
4 Version:        0.1.0.17
5 Release:        2
6 License:        BSD-like
7 Group:          Networking/Daemons
8 Source0:        http://tor.eff.org/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  83c4afe29fa82473afcb2ec7e17771b9
10 Source1:        %{name}.logrotate
11 Source2:        %{name}.init
12 Source3:        %{name}.sysconfig
13 URL:            http://tor.eff.org/
14 BuildRequires:  libevent-devel
15 BuildRequires:  openssl-devel >= 0.9.6
16 BuildRequires:  rpm-build >= 4.0
17 Provides:       group(tor)
18 Provides:       user(tor)
19 Requires(pre):  /bin/id
20 Requires(pre):  /usr/bin/getgid
21 Requires(pre):  /usr/sbin/groupadd
22 Requires(pre):  /usr/sbin/useradd
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Tor is a connection-based low-latency anonymous communication system.
27
28 This package provides the "tor" program, which serves as both a client
29 and a relay node. Scripts will automatically create a "tor"
30 user and group, and set tor up to run as a daemon when the system is
31 rebooted.
32
33 Applications connect to the local Tor proxy using the SOCKS protocol.
34 The local proxy chooses a path through a set of relays, in which each
35 relay knows its predecessor and successor, but no others. Traffic
36 flowing down the circuit is unwrapped by a symmetric key at each
37 relay, which reveals the downstream relay.
38
39 Warnings: Tor does no protocol cleaning. That means there is a danger
40 that application protocols and associated programs can be induced to
41 reveal information about the initiator. Tor depends on Privoxy and
42 similar protocol cleaners to solve this problem. This is alpha code,
43 and is even more likely than released code to have anonymity-spoiling
44 bugs. The present network is very small -- this further reduces the
45 strength of the anonymity provided. Tor is not presently suitable for
46 high-stakes anonymity.
47
48 %description -l pl
49 Tor to oparty na po³±czeniach system anonimowej komunikacji o ma³ych
50 opó¼nieniach.
51
52 Ten pakiet dostarcza program "tor", s³u¿±cy zarówno jako klient, jak i
53 wêze³ przeka¼nikowy. Skrypty automatycznie tworz± u¿ytkownika i grupê
54 "tor" i konfiguruj± tora do dzia³ania jako demon po uruchomieniu
55 systemu.
56
57 Aplikacje ³±cz± siê z lokalnym proxy Tor przy u¿yciu protoko³u SOCKS.
58 Lokalne proxy wybiera ¶cie¿kê poprzez zbiór przeka¼ników, z których
59 ka¿dy zna swojego poprzednika i nastêpnika, ale ¿adnego wiêcej. Ruch
60 przychodz±cy jest rozpakowywany przy u¿yciu klucza symetrycznego na
61 ka¿dym przeka¼niku, który ods³ania kolejny przeka¼nik.
62
63 Uwaga: Tor nie oczyszcza protoko³ów. Oznacza to, ¿e istnieje
64 niebezpieczeñstwo, ¿e protoko³y aplikacji i powi±zane programy mog±
65 odkryæ informacje o pochodzeniu. Tor polega na Privoxy i podobnych
66 oczyszczaczach protoko³ów w celu rozwi±zania tego problemu. To jest
67 kod alpha, wiêc mo¿e mieæ wiêcej b³êdów psuj±cych anonimowo¶æ ni¿ kod
68 wydany. Obecna sieæ jest bardzo ma³a - co w dalszym stopniu ogranicza
69 zapewnian± anonimowo¶æ. Tor aktualnie nie nadaje siê do zadañ
70 wymagaj±cych anonimowo¶ci na wysok± stawkê.
71
72 %prep
73 %setup -q
74
75 %build
76 %configure
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 mv $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/torrc{.sample,}
86 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
87 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
88 install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
89
90 install -d $RPM_BUILD_ROOT/var/lib/%{name}
91 install -d $RPM_BUILD_ROOT/var/run/%{name}
92 install -d $RPM_BUILD_ROOT/var/log/{,archiv/}%{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %pre
98 %groupadd -g 156 tor
99 %useradd  -u 156 -r -d /var/lib/tor -s /bin/false -c "Tor" -g tor tor
100
101 %post
102 /sbin/chkconfig --add %{name}
103 %service %{name} restart
104
105 %preun
106 if [ "$1" = "0" ]; then
107         %service -q %{name} stop
108         /sbin/chkconfig --del %{name}
109 fi
110
111 %postun
112 if [ "$1" = "0" ]; then
113         %userremove  tor
114         %groupremove tor
115 fi
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS INSTALL LICENSE README ChangeLog doc/HACKING doc/TODO doc/FAQ
120 %attr(755,root,root) %{_bindir}/*
121 %{_mandir}/man?/*
122 %attr(755,root,root) /etc/rc.d/init.d/%{name}
123 %dir %attr(750,root,tor) %{_sysconfdir}/%{name}
124 %attr(640,root,tor)  %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
125 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
126 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
127 %dir %attr(750,root,tor) /var/lib/%{name}
128 %dir %attr(750,root,tor) /var/run/%{name}
129 %dir %attr(750,root,tor) /var/log/%{name}
130 %dir %attr(750,root,tor) /var/log/archiv/%{name}
This page took 0.094063 seconds and 3 git commands to generate.